Subject: [Sip] Call fork

From: <[email-masked]>
Date: Tue, 22 Sep 2009 18:18:18 +0530

Hi 
 
 I have a scenario where  Invite is forked by a proxy and it gets
multiple 183 containing sdp and all are sending rtp packets as
anouncements.What should the b2bua do?
 As we dint know which ua is going to send 200 ok 
 
Regards
Sai

---

From: Dean Willis <[email-masked]>
Date: Tue, 22 Sep 2009 23:24:54 -0500

On Sep 22, 2009, at 7:48 AM, <[email-masked]> <[email-masked] 
 > wrote:

>  As we dint know which ua is going to send 200 ok

Congratulations. You've discovered promiscuous early media. That's why  
I think this part of the protocol spec is broken; early media (driven  
by PSTN-interworking) combined with forking produces an intractable  
problem.

Various hacks have been used to address the problem. As far as I know,  
none of them really work "right", but you might find one that works  
most of the time for your use case.

I suggest trying the sip-implementors mailing list for advice on this  
issue:

<[email-masked]>

Although personally, what I'd probably do is hunt down the developers  
of the UAs that are all sending 183 with SDP and related RTP and  
verbally abuse them. Of course, if the UAs are PSTN gateways, there  
really isn't much else they can do.

--
Dean

---

From: Paraskevopoulos Pavlos <[email-masked]>
Date: Wed, 23 Sep 2009 17:25:11 +0300

Consult the RFCs 3959 and 3960.

What about muting the RTPs except the last one and as soon as a 200 OK 
is received you re-open the valid connection. Of course you will expect 
a media clipping. I think this is the simplest one.

Pavlos

Dean Willis wrote:
>
> On Sep 22, 2009, at 7:48 AM, <[email-masked]> 
> <[email-masked]> wrote:
>
>>  Hi
>>
> _______________________________________________
> Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
>

-- 
*Paraskevopoulos Pavlos*
Software Engineer
Systems Software Development
Research & Development
----------------------------------------------- *
INTRACOM TELECOM S.A - SITRONICS*
Email: [email-masked] <mailto:[email-masked]>
TEL: +30 210 6674342, +30 210 6672267
FAX: +30 210 6671446
19,7 KM Markopoulou Ave
Peania, Attika
P.O 19002

Signature
Eco-Tip: Printing emails is usually a waste.
Please consider your environmental responsibility before printing this 
e-mail

---

From: "Dale Worley" <[email-masked]>
Date: Wed, 23 Sep 2009 10:46:58 -0400

> anouncements.What should the b2bua do?

First, you should screen the RTP streams to eliminate from consideration
any stream whose content is silence.

Assuming you have more than one stream remaining, you should mix them
together and present them to the user.  It turns out that humans can
separate and process multiple, overlapping speech streams.  This is not
an ideal solution, but it is the best that can be done.

Dale