Subject: Re: [Sipbrandy] OSRTP Question

From: Gonzalo Camarillo <[email-masked]>
Date: Fri, 7 Oct 2016 15:44:09 +0300

All,

please, note that as you all know the SIPBRANDY WG is chartered not to
produce PS specs. So, if we do not provide Ben with some arguments for
making this draft PS, it will *not* be a PS. Comments?

https://datatracker.ietf.org/wg/sipbrandy/charter/

> The working group is not expected to define new protocols or modify
> existing ones; rather it will define practices for using existing
> protocols.

Thanks,

Gonzalo

On 23/09/2016 8:58 AM, Gonzalo Camarillo wrote:
> Hi,
> 
> for context, Ben's question relates to the following paragraph in the
> minutes of the last SIPBRANDY session:
> 
> https://www.ietf.org/proceedings/96/minutes/minutes-96-sipbrandy
> 
>> The group agreed on advancing the osrtp draft as Proposed
>> Standard. However, the SIPBRANDY WG is not chartered to develop new
>> protocol mechanisms. Ben, the resposible area director for the
>> SIPBRANDY WG, will look into this and get back to the group with a
>> final plan. In the meantime, the working assumption is that the
>> intended status of the osrtp draft will be Proposed Standard.
> 
> Cheers,
> 
> Gonzalo
> 
> On 23/09/2016 3:28 AM, Ben Campbell wrote:
>> Hi,
>>
>> In the discussions about what status OSRTP should be, I was under the
>> impression that people thought that the draft modified (or violated)
>> some normative statement about using encryption with AVP rather than
>> SAVP. Can anyone point me to the specifics?
>>
>> Thanks!
>>
>> Ben.
>>
>> _______________________________________________
>> Sipbrandy mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/sipbrandy
>

---

From: Andy Hutton <[email-masked]>
Date: Tue, 11 Oct 2016 13:56:37 +0100

I am not sure what this issue is here I thought we were heading towards
consensus during IETF96 to make the OSRTP draft PS and get the AD's to fix
the charter.

We discussed the possibility of splitting the draft and taking a small
draft to MMUSIC with the normative parts but I think we had consensus that
this did not make sense and we should just fix the charter,

Regards
Andy

---

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 11 Oct 2016 16:17:52 +0300

Hi Andy,

if you do not see any issue here, then you sure won't have any trouble
responding to Ben's original question below, which is what the ADs are
actually after, right? ;-) Thanks!

Cheers,

Gonzalo

On 11/10/2016 3:56 PM, Andy Hutton wrote:
> consensus during IETF96 to make the OSRTP draft PS and get the AD's to
> fix the charter.
> 
> draft to MMUSIC with the normative parts but I think we had consensus
> that this did not make sense and we should just fix the charter,
> 
> Regards
> Andy
> 
> On Fri, Oct 7, 2016 at 1:44 PM, Gonzalo Camarillo
> <[email-masked] <mailto:[email-masked]>>
> wrote:
> 
>     All,
> 
>     <https://datatracker.ietf.org/wg/sipbrandy/charter/>
> 
>     <https://www.ietf.org/proceedings/96/minutes/minutes-96-sipbrandy>
>     >
>     >> [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/sipbrandy>
>     >
> 
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/sipbrandy>
> 
>

---

From: Andy Hutton <[email-masked]>
Date: Tue, 11 Oct 2016 19:36:45 +0100

I am not aware that the OSRTP draft violates any normative statements about
using encryption with AVP although there was a discussion at IETF96 about
whether the SDP Answer should contain SAVP if the answerer recognised and
makes use of the a=crypto.

This is why an update to the OSRTP draft has been suggested such that the
answer may contain AVP or SAVP which I think we should accept and if we had
to choose between AVP or SAVP in the answer I think I would fall on the
SAVP side.

Regards
Andy

---

From: "Asveren, Tolga" <[email-masked]>
Date: Wed, 12 Oct 2016 14:15:33 +0000

I think the concern was about the following from RFC4568 6:
“SRTP security descriptions MUST only be used with the SRTP transport (e.g., "RTP/SAVP" or "RTP/SAVPF")”

Having said that, I am completely in favor of progressing this practically very useful draft ASAP.

Thanks,
Tolga

From: Sipbrandy [mailto:[email-masked]] On Behalf Of Andy Hutton
Sent: Tuesday, October 11, 2016 2:37 PM
To: Gonzalo Camarillo <[email-masked]>
Cc: Ben Campbell <[email-masked]>; [email-masked]
Subject: Re: [Sipbrandy] OSRTP Question

I am not aware that the OSRTP draft violates any normative statements about using encryption with AVP although there was a discussion at IETF96 about whether the SDP Answer should contain SAVP if the answerer recognised and makes use of the a=crypto.

This is why an update to the OSRTP draft has been suggested such that the answer may contain AVP or SAVP which I think we should accept and if we had to choose between AVP or SAVP in the answer I think I would fall on the SAVP side.

Regards
Andy

On Tue, Oct 11, 2016 at 2:17 PM, Gonzalo Camarillo <[email-masked]<mailto:[email-masked]>> wrote:
Hi Andy,

Cheers,

Gonzalo

On 11/10/2016 3:56 PM, Andy Hutton wrote:
> <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>
> wrote:
>
>     All,
>
>     >> [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
>     [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>

---

From: "Ben Campbell" <[email-masked]>
Date: Wed, 12 Oct 2016 09:42:12 -0500

That's what I was looking for. Thanks!

Ben.

On 12 Oct 2016, at 9:15, Asveren, Tolga wrote:

> “SRTP security descriptions MUST only be used with the SRTP 
> transport (e.g., "RTP/SAVP" or "RTP/SAVPF")”
>
> I am not aware that the OSRTP draft violates any normative statements 
> about using encryption with AVP although there was a discussion at 
> IETF96 about whether the SDP Answer should contain SAVP if the 
> answerer recognised and makes use of the a=crypto.
>
> This is why an update to the OSRTP draft has been suggested such that 
> the answer may contain AVP or SAVP which I think we should accept and 
> if we had to choose between AVP or SAVP in the answer I think I would 
> fall on the SAVP side.
>
> Regards
> Andy
>
> On Tue, Oct 11, 2016 at 2:17 PM, Gonzalo Camarillo 
> <[email-masked]<mailto:[email-masked]>> 
> wrote:
> Hi Andy,
>
>> <[email-masked]<mailto:[email-masked]> 
>> <mailto:[email-masked]<mailto:[email-masked]>>>
>> wrote:
>>
>>     All,
>>
>>     >> [email-masked]<mailto:[email-masked]> 
>> <mailto:[email-masked]<mailto:[email-masked]>>
>>     [email-masked]<mailto:[email-masked]> 
>> <mailto:[email-masked]<mailto:[email-masked]>>

---

From: "Ben Campbell" <[email-masked]>
Date: Wed, 12 Oct 2016 09:44:12 -0500

(Oops, I sent that before I was finished.)

This seems to require OSRTP to update 4568. Do people agree?

Thanks!

Ben.

---

From: Andy Hutton <[email-masked]>
Date: Thu, 13 Oct 2016 10:32:52 +0100

Yes I agree.

Probably also points us further towards stating that the answer must/should
contain SAVP when OSRTP is negotiated.

Regards
Andy

On Wed, Oct 12, 2016 at 3:44 PM, Ben Campbell <[email-masked]> wrote:

> *From:* Sipbrandy [mailto:[email-masked]] *On Behalf Of *Andy
> Hutton
> *Sent:* Tuesday, October 11, 2016 2:37 PM
> *To:* Gonzalo Camarillo <[email-masked]>
> *Cc:* Ben Campbell <[email-masked]>; [email-masked]
> *Subject:* Re: [Sipbrandy] OSRTP Question
>
>
>
> about using encryption with AVP although there was a discussion at IETF96
> about whether the SDP Answer should contain SAVP if the answerer recognised
> and makes use of the a=crypto.
>
>
>