Subject: Re: [Sipbrandy] Status of our drafts

From: "Peterson, Jon" <[email-masked]>
Date: Thu, 4 May 2017 20:23:31 +0000

Hello,

Although we did not meet in Chicago, I did submit a new version of
draft-ietf-sipbrandy-rtpsec before the meeting. This incorporated the
feedback from the previous session, as well as some other points that had
come up related to Adam Roach's comments on the interaction with connected
identity.

I have had one offline discussion recently about the need to get connected
identity right for core STIR, not exclusively for use with the SIPBRANDY
profile of STIR. I think there are probably some good reasons to try to
get that properly defined. We had talked a bit here about trying to patch
RFC4916 for STIR in the context of this working group, but probably I'll
submit that as an individual and at some point we can decide where that
work should live. The RTPSEC draft here should probably reference that
patch to connected identity. But other than that, I'm not sure I have a
lot of outstanding action items for the RTPSEC document. We set out to
define a pretty simple profile, just kind of a framework document for how
you combine a bunch of things we've defined elsewhere, and at this point I
think the big ideas are in place.

Jon Peterson
Neustar, Inc.

On 3/16/17, 11:47 AM, "Sipbrandy on behalf of Gonzalo Camarillo"
<[email-masked] on behalf of [email-masked]>
wrote:

>Authors,
>
>could you please send us a status update per my email below?
>
>Thanks,
>
>Gonzalo
>
>On 16/02/2017 11:05 AM, Gonzalo Camarillo wrote:
>> Hi,
>> 
>> even if we will not have a SIPBRANDY session in Chicago, it would be
>> useful for the working group to discuss what are the next steps on the
>>list.
>> 
>> To start those discussions, we would like to ask the authors of our two
>> working group items below to let the list know what is the status of
>> their draft and what are the next steps:
>> 
>> https://datatracker.ietf.org/doc/draft-ietf-sipbrandy-osrtp/
>> https://datatracker.ietf.org/doc/draft-ietf-sipbrandy-rtpsec/
>> 
>> We would also like to ask the authors of the MMUSIC draft below, which
>> is related to the SIPBRANDY work, to give us a status update:
>> 
>> 
>>https://datatracker.ietf.org/doc/draft-hutton-mmusic-opportunistic-negoti
>>ation/
>> 
>> Thanks,
>> 
>> Gonzalo
>> 
>> _______________________________________________
>> Sipbrandy mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/sipbrandy
>> 
>
>_______________________________________________
>Sipbrandy mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/sipbrandy

---

From: Gonzalo Camarillo <[email-masked]>
Date: Mon, 8 May 2017 11:19:54 +0300

Hi Andy,

please, note that draft-ietf-sipbrandy-osrtp has expired:

What are your plans to keep it alive?

Thanks,

Gonzalo

On 20/03/2017 1:35 PM, Andy Hutton wrote:
> 
> Regarding the status
> of https://tools.ietf.org/html/draft-hutton-mmusic-opportunistic-negotiation-00.
> This draft will be discussed during the MMUSIC session at IETF98 next
> week and I am hoping that MMUSIC will agree to adopt this draft.  The
> comments received so far on the MMUSIC list have all been positive
> regarding this.  We need this draft to be adopted by MMUSIC to allow
> draft-ietf-sipbrandy-osrtp to progress since it documents the fact that
> an update to RFC 4568 is needed to allow SRTP to be negotiated using the
> RTP/AVP profile.
> 
> Please support the adoption of
> draft-hutton-mmusic-opportunistic-negotiation in MMUSIC.
> 
> Regards
> Andy
> 
> 
> 
> On Thu, Feb 16, 2017 at 9:05 AM, Gonzalo Camarillo
> <[email-masked] <mailto:[email-masked]>>
> wrote:
> 
>     Hi,
> 
>     useful for the working group to discuss what are the next steps on
>     the list.
> 
>     <https://datatracker.ietf.org/doc/draft-ietf-sipbrandy-osrtp/>
>     <https://datatracker.ietf.org/doc/draft-ietf-sipbrandy-rtpsec/>
> 
>     https://datatracker.ietf.org/doc/draft-hutton-mmusic-opportunistic-negotiation/
>     <https://datatracker.ietf.org/doc/draft-hutton-mmusic-opportunistic-negotiation/>
> 
>     Thanks,
> 
>     Gonzalo
> 
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/sipbrandy>
> 
>

---

From: "Asveren, Tolga" <[email-masked]>
Date: Mon, 8 May 2017 09:12:30 +0000

I hope this draft will proceed forward and eventually -and hopefully soon- become a RFC. It addresses a real problem with a practical solution.

Just as additional info, it seems likely that the "sister document" draft-hutton-mmusic-opportunistic-negotiation-00 will be adopted as a WG soon.

Thanks,
Tolga

-----Original Message-----
From: Sipbrandy [mailto:[email-masked]] On Behalf Of Gonzalo Camarillo
Sent: Monday, May 8, 2017 4:20 AM
To: Andy Hutton <[email-masked]>
Cc: [email-masked]
Subject: Re: [Sipbrandy] Status of our drafts

Hi Andy,

Thanks,

Gonzalo

On 20/03/2017 1:35 PM, Andy Hutton wrote:
> draft-ietf-sipbrandy-osrtp to progress since it documents the fact 
> that an update to RFC 4568 is needed to allow SRTP to be negotiated 
> using the RTP/AVP profile.
>