Subject: [sipcore] Geo URI in location-conveyance

From: "Richard L. Barnes" <[email-masked]>
Date: Mon, 19 Jul 2010 17:46:38 -0400

What do people think about having support for GEO URIs [1] in a  
Geolocation header field?  Seems like it would be kind of handy...

[1] <http://tools.ietf.org/html/rfc5870>

---

From: "Winterbottom, James" <[email-masked]>
Date: Tue, 20 Jul 2010 07:05:03 +0800

I want this, and I want to be able to support a CID in the same header.
If we can do that in the same header, then I a more than happy to restrict the number of geolocation headers to 1.

Cheers
James

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Richard L. Barnes
> Sent: Tuesday, 20 July 2010 7:47 AM
> To: [email-masked]
> Subject: [sipcore] Geo URI in location-conveyance
> 
> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore

---

From: "James M. Polk" <[email-masked]>
Date: Mon, 19 Jul 2010 20:25:06 -0500

As of now, this would be the first time I've heard that request (for 
a GEO URI), and there are currently no provisions for this (unless 
absoluteURI covers it).

James

At 06:05 PM 7/19/2010, Winterbottom, James wrote:
>If we can do that in the same header, then I a more than happy to 
>restrict the number of geolocation headers to 1.
>
>Cheers
>James
>
>

---

From: "Thomson, Martin" <[email-masked]>
Date: Tue, 20 Jul 2010 10:20:08 +0800

It's not the first time, but no matter: absoluteURI covers it.

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of James M. Polk
> Sent: Tuesday, 20 July 2010 11:25 AM
> To: Winterbottom, James; Richard L. Barnes; [email-masked]
> Subject: Re: [sipcore] Geo URI in location-conveyance
>

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 20 Jul 2010 03:16:54 -0400

Good idea; the notion of not having by-value locations in the header was always artificial and had more to do with how-do-you-stuff-XML-in-a-header than with architectural principles.

Henning

On Jul 19, 2010, at 5:46 PM, Richard L. Barnes wrote:

> What do people think about having support for GEO URIs [1] in a Geolocation header field?  Seems like it would be kind of handy...
>

---

From: "Thomson, Martin" <[email-masked]>
Date: Tue, 20 Jul 2010 10:20:08 +0800

> Behalf

---

From: "Thomson, Martin" <[email-masked]>
Date: Tue, 20 Jul 2010 10:20:08 +0800

---

From: "James M. Polk" <[email-masked]>
Date: Sun, 25 Jul 2010 06:38:16 -0500

>restrict the number of geolocation headers to 1.

this would result in exactly 2 locationValues, which is currently prohibited.

James