Subject: [sipcore] Alert-Info header field in non-100 1xx responses

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 03 Aug 2010 12:16:58 +0300

Hi,

RFC 3261 only allows Alert-Info header fields in 180 responses. The
SALUD WG would like to be able to insert this header field in any
non-100 1xx response. Formally, this change would be an update to RFC
3261. So, we would like to get feedback from the SIPCORE WG on whether
or not such a change would be OK.

Thanks,

Gonzalo

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 3 Aug 2010 11:50:13 +0200

Hi,

I think we shall allow it.

(Terminals that don't support it should simply discard it.)

Regards,

Christer

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Gonzalo Camarillo
> Sent: 3. elokuuta 2010 12:17
> To: SIPCORE
> Cc: Dale Worley
> Subject: [sipcore] Alert-Info header field in non-100 1xx responses
> 
> Hi,
> 
> RFC 3261 only allows Alert-Info header fields in 180 
> responses. The SALUD WG would like to be able to insert this 
> header field in any non-100 1xx response. Formally, this 
> change would be an update to RFC 3261. So, we would like to 
> get feedback from the SIPCORE WG on whether or not such a 
> change would be OK.
> 
> Thanks,
> 
> Gonzalo
> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore
>

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 03 Aug 2010 09:49:43 -0400

Gonzalo,

> or not such a change would be OK.

[as an individual] I think this is perfectly reasonable.

[as co-chair] There is the procedural issue of whether such a change 
must be done by SIPCORE. The following is from the SIPCORE charter:

"Extensions to SIP that add new functionality that
would not be required of all implementations will be done outside of
this WG."

Since the processing of Alert-Info is always optional according to 3261, 
defining a specific behavior for certain URNs is clearly an extension. 
And making the header allowable in additional responses also seems to be 
an extension.

So I'm ok with this.

	Thanks,
	Paul

---

From: Gonzalo Camarillo <[email-masked]>
Date: Wed, 04 Aug 2010 16:00:47 +0300

Hi Paul,

thanks for your (individual) opinion on the topic. With respect to the
process, I am well aware of the issue. That is why, first, I want to
know whether or not somebody has problems with this change. Once we
agree on a technical solution, we will easily take care of the
process-related issue. The main thing here is to make sure that this
proposal is reviewed by the relevant people in both SIPCORE and SALUD.

Thanks,

Gonalo