Subject: [Sipping] different types of transport

From: [email-masked]
Date: Fri, 10 May 2002 17:31:06 +0200

Hi all,

at line 2432 of bis09 ... 
"Request forwarded between different types of transport... MUST be forwarded transaction statefully"...

so a proxy in an EDGE between UDP and TCP connection... MUST be a statefull proxy ???
why ?

Sal

---

From: Gonzalo Camarillo <[email-masked]>
Date: Sun, 12 May 2002 11:00:31 +0300

Hi,

When a SIP entity uses unreliable ransport protocols, it needs to
implement a client transaction in order to handle retransmissions and
time outs... and this means being stateful.

However, a proxy using TCP on one side and SCTP on the other could be
stateless.

Regards,

Gonzalo

-- 
Gonzalo Camarillo         Phone :  +358  9 299 33 71
Oy L M Ericsson Ab        Mobile:  +358 40 702 35 35
Telecom R&D               Fax   :  +358  9 299 30 52
FIN-02420 Jorvas          Email :  [email-masked]
Finland                   http://www.hut.fi/~gonzalo

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP