Subject: [Sipping] New NAI draft-jennings-sipping-nai-00

From: "Cullen Jennings" <[email-masked]>
Date: Thu, 2 May 2002 02:34:34 -0700

I read Marks draft and quickly put together a possible solution to it. Until
it becomes available in the ID directory, you can find it at:

http://www.cs.ubc.ca/~jennings/draft-jennings-sipping-nai-00.txt

http://www.cs.ubc.ca/~jennings/draft-jennings-sipping-nai-00.html

The draft adds a new header, much like a From header, that specifies network
asserted identity and can be inserted by a proxy on entry of a trust domain
then removed by proxies on exit of the trust domain.

I believe it meets, at least in a marginal way, all the requirements in the
Mark's nai draft. It was put together quickly with liberal cut and paste
from others peoples drafts. It is both good and original, no doubt the parts
that are good are not original and the parts that are original are not good.
Many thanks to many unknowing and possibly unwilling contributors.

Cullen

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: [email-masked]
Date: Thu, 2 May 2002 13:29:18 +0300

cullen,

your i-d looked mostly ok to me.  in section 4 example i think you have
a typo, since the identity example doesn't have any uri scheme:

       Network-Asserted-ID: "Cullen Jennings" <[email-masked]>

what comes to the hint either in the from field or in the NAI header not
matching any of the multiple identities of the user, i would say that
the proxy MUST reject the request, since it doesn't have the required
intelligence to pick one.

-- juha

---

From: "Cullen Jennings" <[email-masked]>
Date: Fri, 3 May 2002 12:36:55 -0700

Thanks you - yes I meant for it to be sip:[email-masked] 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, May 02, 2002 3:29 AM
> To: Cullen Jennings
> Cc: [email-masked]; Jon Peterson; Rohan Mahy; Mark Watson
> Subject: [Sipping] New NAI draft-jennings-sipping-nai-00
> 
> 
> cullen,
>