Subject: RE: [Sipping] Binding published data to services

From: "Ben Campbell" <[email-masked]>
Date: Thu, 2 May 2002 16:58:34 -0500

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Sean Olson
> Sent: Thursday, April 25, 2002 12:21 PM
> To: Henning Schulzrinne; James Undery
> Cc: [email-masked]
> Subject: Re: [Sipping] Binding published data to services
>
>
> I think there are two different models for how
> this would work. One is the model where
> a server (in your example, the registrar)
> creates the binding and pushes this to the client.
>
> The other model would be where the client creates
> a binding and informs the server of the binding.
>
> I think both models are valid. Implicit in both
> is that a binding is "created" and must be
> "published" to interested parties. In other words,
> we are not talking about an algorithmic approach
> for associating one URL with another.
>
> The second model
> could be seen as an application of the content
> indirection concept (if SIP is used to push the
> binding).

Even the second model can require the first model. The URI to the indirect
content is _itself_ a form of service data. Would we then need to discover
how to tell the service the indirection URI?

>
> The first model is
> essentially provisioning and the sticky point is
> what protocol you use to do this. If SIP, how?
> If not SIP, where does this work go?
>
> A related issue
> is the time validity of this information.
> (Does it change per registration, per session,
> per device, never, etc.?)
>
> /sean
>
> --- Henning Schulzrinne <[email-masked]> wrote:
> > >
> > > This okay we pick a tag compatible with sip, http
> > and various others,
> > > this means we are at risk of interfering with
> > scheme foo.
> >
> > I suspect that we may have a different notion of how
> > this would work.
> > I'm proposing something like
> >
> > Service-Info: <http://i-am-here.com>
> > ;service=presence,
> > <http://filter.com> ;service=cpl
> >
> > being *returned* in the REGISTER response.
> >
> >
> > >
> > > > It's hard to discuss "hack quotients". Could you
> > be more specific in
> > > > your objections?
> > >
> > > It also interfers with "Contact: *, Expires: 0" as
> > we don't want those
> > > function mapped URIs to be removed just the
> > standard ones. If we don't
> > > have this we're back to the configuration problem
> > we were trying to
> > > avoid. (Or thinking about it we could fetch and
> > then restore the
> > > function mapped URIs but I'd definately describe
> > that as hackish and
> > > highly non backwardly compatible.)
> > >
> >
> > I'm assuming that these URLs are part of the
> > service. The whole point is
> > not to have the client register anything, as the
> > client only knows its
> > IP address (if it's lucky) and AOR.
> >
> > _______________________________________________
> > Sipping mailing list
> > https://www1.ietf.org/mailman/listinfo/sipping
> > This list is for NEW development of the application
> > of SIP
> > Use [email-masked] for questions
> > on current sip
> > Use [email-masked] for new developments of core SIP
>
>
> =====
> Sean Olson <[email-masked]>
>
> __________________________________________________
> Do You Yahoo!?
> Yahoo! Games - play chess, backgammon, pool and more
> http://games.yahoo.com/
>
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Sean Olson <[email-masked]>
Date: Thu, 2 May 2002 15:55:41 -0700 (PDT)

--- Ben Campbell <[email-masked]> wrote:
> > From: [email-masked]
> [mailto:[email-masked]]On Behalf Of
> > Sean Olson

No, the idea here was that in this model it is
completely up to the client which URI to use. 
Unless you are talking about communicating the
URI that server 1 gave to the client to server 2.

/sean

__________________________________________________
Do You Yahoo!?
Yahoo! Health - your guide to health and wellness
http://health.yahoo.com

---

From: "Ben Campbell" <[email-masked]>
Date: Thu, 2 May 2002 20:23:15 -0500

> From: Sean Olson [mailto:[email-masked]]
> Sent: Thursday, May 02, 2002 5:56 PM
> To: Ben Campbell; Henning Schulzrinne; James Undery
> Cc: [email-masked]
> Subject: RE: [Sipping] Binding published data to services
>

[snip]

> URI that server 1 gave to the client to server 2.

Ah, I think I missed the "If SIP is used to push the binding" part. I was
thinking of how the client tells the service where to look for the data.
This act itself is a form of service-data publication.

It seems that in the general sense, pushing a URL to a service to tell that
service where to get service data is semantically identical to the concept
of publishing using a content-indirection mechanism. One might need to
discover how to tell the service the indirection URL in the first place.