Subject: [Sipping] SIP and tel URLs

From: "Alexeitsev, D" <[email-masked]>
Date: Wed, 22 May 2002 17:00:43 +0200

Hello All,

Sorry if it was already disscused!

I can not get the whole picture from the section 8.1.1.2 

If we want to send a SIP request we need to have an IP address to send to, why one can not put this IP address behind the user part of the tel URL and make a SIP URL out of it? 

If we are transmitting a request from one domain to another why the routing is kept at the IP layer as in the case of tel URL and not at the application layer?

Thank you,

Denis Alexeitsev

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Michael Hammer <[email-masked]>
Date: Wed, 22 May 2002 14:54:05 -0400

Denis,

Could you clarify with an example?  Also, what draft is this section from?

In draft-yu-tel-url-04.txt, it gives examples of converting a tel: url to a 
sip: url.  The IP address or domain name would be behind the "@" sign in 
the url.  By using the domain name, it is more application layer oriented.

Mike

At 05:00 PM 5/22/2002 +0200, Alexeitsev, D wrote:
>If we want to send a SIP request we need to have an IP address to send to, 
>why one can not put this IP address behind the user part of the tel URL 
>and make a SIP URL out of it?
>
>If we are transmitting a request from one domain to another why the 
>routing is kept at the IP layer as in the case of tel URL and not at the 
>application layer?
>
>Thank you,
>
>Denis Alexeitsev
>

---

From: "Alexeitsev, D" <[email-masked]>
Date: Thu, 23 May 2002 10:09:51 +0200

Thank you for the reply

Yes that is the mechanism and it is ok!

My question is why it is necessary to have the tel URL at all?
The example in section 8.1.1.2 with the airport says that the request shall be processed by the airports outbound proxy - so why can not this proxy be identified in the host part of the tel URL, thus making it a SIP URL?   

Greetings,

Denis Alexeitsev

-----Ursprüngliche Nachricht-----
Von: Michael Hammer [mailto:[email-masked]]
Gesendet am: Mittwoch, 22. Mai 2002 20:54
An: Alexeitsev, D
Cc: [email-masked]
Betreff: Re: [Sipping] SIP and tel URLs

Denis,

Mike