Subject: [Sipping] RE: Session Initiation protocol and videogame consoles

From: "Christian Huitema" <[email-masked]>
Date: Thu, 16 May 2002 09:39:55 -0700

> >The idea being running processes
> >(usually games) that don't know their inside SIP.
> >
> >Would it be RTP? Ethernet tunnelling maybe?
> 
> Huh.  Well, if you've got a game that thinks it's just running over
IP, or
> over Ethernet, then you don't really need RTP's timestamps.  On the
other
> hand, you also don't need the reliability of SIP-level messages--and
those
> would be a larger problem than the timestamps, because the game's
protocol
> might include some bits that should be unreliable (e.g., if audio
> streams).

Tunneling protocol data inside SIP is generally considered a bad idea,
as it would dramatically alter the workload of the SIP servers. It is
also a bit weird. If you think about it that would be pretty much like
sending game messages as instant messages. That may work for announcing
your chess moves, but if you try that with a first person shooter
neither the IM provider not the game player are going to like the
result.

The architecturally correct way to use SIP for games is to use a SIP
exchange to initiate a game session, i.e. invite "sip:[email-masked]"
to join a game. The payload of the SIP messages (INVITE and response)
will carry the IP address and port numbers used by the game application.

-- Christian Huitema

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Henry Sinnreich <[email-masked]>
Date: Thu, 16 May 2002 12:25:39 -0500

The IM Session Mode allows the transfer of big/rich media directly
between the endpoints, once SIP has set up the session.

Henry

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Christian Huitema
> Sent: Thursday, May 16, 2002 11:40 AM
> To: John Stracke; Dan Kolis
> Cc: [email-masked]
> Subject: [Sipping] RE: Session Initiation protocol and 
> videogame consoles
> 
> 
> Tunneling protocol data inside SIP is generally considered a 
> bad idea, as it would dramatically alter the workload of the 
> SIP servers. It is also a bit weird. If you think about it 
> that would be pretty much like sending game messages as 
> instant messages. That may work for announcing your chess 
> moves, but if you try that with a first person shooter 
> neither the IM provider not the game player are going to like 
> the result.
> 
> The architecturally correct way to use SIP for games is to 
> use a SIP exchange to initiate a game session, i.e. invite 
> "sip:[email-masked]" to join a game. The payload of the 
> SIP messages (INVITE and response) will carry the IP address 
> and port numbers used by the game application.
> 
> 
> -- Christian Huitema
> 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
>