Subject: RE: [Sipping] How to indicate trunk groups in URI?

From: [email-masked]
Date: Tue, 27 Aug 2002 08:56:58 -0600

Tom hits the nail on the head.  We only need to ensure we do not preclude
the possibility of handling a single MGC with a trunk group spanning
multiple MGs.  To a carrier on the other end of the trunk group, this looks
just like a single PSTN switch.  They do not know or care that the trunks
are stripped across multiple MGs.

John Hearty
Level3

> -----Original Message-----
> From: Tom-PT Taylor [mailto:[email-masked]]
> Sent: Tuesday, August 27, 2002 7:12 AM
> To: [email-masked]'; 'Peterson, Jon'; [email-masked]
> Subject: RE: [Sipping] How to indicate trunk groups in URI?
> 
> 
> On the point of trunk groups split across gateways: it 
> depends on whether
> the gateway is analogous to a PSTN switch peripheral or to a 
> PSTN switch.
> "Gateway" in the Megaco sense corresponds to the former, 
> hence it would be
> quite reasonable according to typical PSTN practice to split 
> trunk groups
> across Megaco gateways.  In the present discussion, however, 
> I think we are
> using the term "gateway" for something which is analogous to 
> the entire PSTN
> switch.  Thus I agree with Mike's assertion that the term 
> "trunk group" is
> inappropriate for something supported by multiple gateways.  
> The closest
> PSTN term I can come up with is "route".
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, August 26, 2002 11:19 PM
> To: [email-masked]; [email-masked]
> Subject: Re: [Sipping] How to indicate trunk groups in URI?
> 
> 
> In a message dated 8/26/02 12:15:20 PM Eastern Daylight Time,
> [email-masked] writes: 
> 
> 
> This comes from the Gateway Registration work in the IPTEL group. It 
> represents resources in or beyond the gateway. Jon Peterson's 
> just expired 
> draft (draft-peterson-iptel-gwreg-arch-00.txt) describes an 
> architecture for
> 
> using trunk groups in gateway registration. 
> 
> 
> [MAP] I think the referenced Peterson draft contains the 
> correct definition
> of "trunk" and "trunk group". There was another definition 
> floating around
> that was causing trouble by relating it to what numbers were reachable
> through it. 
> 
> The thing in the Peterson draft that might cause some 
> difficulty is the
> notion of a single "Trunk Group" spanning multiple gateways. 
> It seems to
> reflect the incorrect definition by referring to a Trunk 
> Group spanning GW1
> and GW2, maybe only because a common set of phone numbers (+1202 and
> +1704...) are reachable through both parts. The question is 
> whether or not
> there is any requirement to support this case (spanning GWs). 
> It would seem
> that supporting this spanning would significantly complicate 
> any use of the
> registration function. 
> 
> There are already standardized schemes to refer to trunks and 
> trunk groups
> between PSTN switches (at least in the US). They generally 
> begin with a
> standardized identification for each entity (gateway in this 
> case). It seems
> that the task here is coding those identifiers into a 
> URL-type format, not
> defining a new scheme 
> 
> Mike Pierce 
> Artel 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Bob Penfield" <[email-masked]>
Date: Tue, 27 Aug 2002 12:00:42 -0400

----- Original Message -----
From: <[email-masked]>

> are stripped across multiple MGs.

That is true if there is an MGC with MGs. There is just one SIP element (the
MGC) to talk to. But if there are multiple SIP Gateways with ISDN or E&M
trunks to the PSTN, you have multiple SIP elements to talk to.