Subject: RE: 180 MAY ring? (was RE: [Sipping] new draft-ietf-sipping-isup- 05 ( to Mike Hammer))

From: "Francois Audet" <[email-masked]>
Date: Fri, 16 Aug 2002 14:53:02 -0700

Right, that's precisely my point: I agree with you.

This is exactly why I think this is larger than just ISUP-SIP 
interworking and should be described somewhere else than that
draft.

I'm a little worried that we don't describe in the main spec
(or somewhere applicable to SIP in general) what you are saying: 
if you want to send in-band ringing, don't send 180, and send
183 instead, etc. How is somebody not interested in ISUP suppose
to figure it out if it is only hidden in the ISUP-SIP draft?

> Hi Francois,
> 
> I think it is important to remember that the proposed 
> solution affects ALL kind of SIP nodes (no matter 
> if/what-kind-of interworking they do) wishing to generate 
> early media (remote ringback, announcement,
> whatever...) - ie they shall not send 180 if they do so.
> 
> However, since the isup-sip mapping draft is what now is to 
> get finished we have talked about ISUP, to make sure that 
> also the ISUP/SIP MAPPING fits the proposed solution (ie that 
> ISUP messages are mapped to the correct SIP response code).
> 
> Of course, the description of the qsig-sip interworking shall 
> make sure that THAT also is according to the proposed (I'll 
> call it that until I actually see it written down in the 
> draft :) solution. But again, even a normal SIP phone doing 
> early media should follow the proposed solution, because a 
> gateway probably doesn't know what kind of SIP node the 
> remote side is.
> 
> Regards,
> 
> Christer Holmberg
> Ericsson Finland

---

From: Christer Holmberg <[email-masked]>
Date: Sat, 17 Aug 2002 01:10:53 +0300

Hi Francois,

> to figure it out if it is only hidden in the ISUP-SIP draft?

I agree that it could have been more clear in the main spec, which
currently only says that 180 means the receiver "may choose to generate
local ringback". Nothing (as far as I remember) is said about 183 and
early media. But, we should remember that there are also other related
issues discussed than the how-do-I-know-if-to-generate-local-ringback
one.

However, I think what has been said by Jon, and others, is that later
this WILL be described elsewhere also, in a more generic document
However, again, since it also affects the sip-isup mapping, and that
document should be finished, it will be described there too.

But, I DO agree with your point :)

Regards,

Christer Holmberg
Ericsson Finland

> > gateway probably doesn't know what kind of SIP node the

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP