Subject: [Sipping] torture-tests-00:URI_params <-> to_params bug ?

From: [email-masked]
Date: Fri, 30 Aug 2002 17:11:28 +0200

Hi all,

Valid messages 2.36 & 2.42 of draft-ietf-sipping-torture-tests-00.txt contain
a To header of format :

To: sip:[email-masked];user=phone

Following the rules defined in Chapter 20.10 of RFC3261 (also applicable
for To and From) :

"If no "<" and ">" are present, all parameters after the URI are header parameters, not URI parameters."

the "user=phone" parameter should be interpreted as a To header parameter
but I don't think that was the intention in the above mentioned  messages.

Shouldn't it be rather

To: <sip:[email-masked];user=phone>

Ps: The expiry date from page 2 on in the body of the document is "February 2002" iso "February 2003"

Best regards,

    Ben.

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Alan Johnston <[email-masked]>
Date: Fri, 30 Aug 2002 14:40:31 -0500

Hi Ben,

Thanks for you comments on the draft.

You are right - user=phone is a URI parameter and should be inside 
<>.  I'll fix that and the other nit.

Thanks,
Alan Johnston
sip:[email-masked]