Subject: [Sipping] Remote ringing

From: "Alexeitsev, D" <[email-masked]>
Date: Mon, 19 Aug 2002 15:01:19 +0200

Hello All

A question for clarification on current remote ringing status (call flow from SIP to ISUP):

Jon said:

"I also suggested that a gateway (that supports no fully-featured early media system) should start sending backwards media before sending a 18x code when in-band information is available."

With this solution do we coming back to the 

Gonzalo said:

"About a UAC being ready to receive early media after sending the INVITE, it solves the race condition that occurs when the first RTP packet arrives before the answer (in a 1xx or 2xx response). However, it is not intended to be used to send early media without sending an answer. This creates problems with RTCP, for instance."

Or I'm misunderstanding something?

Greetings,
Denis Alexeitsev

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Peterson, Jon" <[email-masked]>
Date: Mon, 19 Aug 2002 08:41:37 -0500

We all know there are problems with 'naive' backward media. We have a whole
section in sipping-isup-05 (5.5) that outlines the need for a fully-featured
early media system, and lists that problem with RTCP as one of the reasons
why we need it.

In other words, Gonzalo and I are on the same page here. This is something
we'll return to in future iterations of this work, when the early media
problem is better understood.

Jon Peterson
NeuStar, Inc.

> -----Original Message-----
> From: Alexeitsev, D [mailto:[email-masked]]
> Sent: Monday, August 19, 2002 6:01 AM
> To: [email-masked]
> Subject: [Sipping] Remote ringing
> 
> 
> Hello All
> 
> "I also suggested that a gateway (that supports no 
> fully-featured early media system) should start sending 
> backwards media before sending a 18x code when in-band 
> information is available."
> 
> "About a UAC being ready to receive early media after sending 
> the INVITE, it solves the race condition that occurs when the 
> first RTP packet arrives before the answer (in a 1xx or 2xx 
> response). However, it is not intended to be used to send 
> early media without sending an answer. This creates problems 
> with RTCP, for instance."
>

---

From: "Alexeitsev, D" <[email-masked]>
Date: Tue, 20 Aug 2002 09:58:52 +0200

Hello Jon,

thanks for the comment. The bigger issue I can see with the 'naive' backward media is that the GW does not know where the media will come from so it would not be able to setup its policy. It might be necessary to point this out in the security section. 

Greetings,
Denis Alexeitsev