Subject: RE: [SIPPING] SUS and RES use of UPDATE method

From: Michael Hammer <[email-masked]>
Date: Mon, 12 Aug 2002 17:24:33 -0400

Adam,

Pardon me for being naive, but does last call end automatically at some 
arbitrary point in time, or if significant issues are raised, should the 
last call end when those issues have been addressed and resolved.

I thought that many of the good comments I have seen here recently were 
going to make a good document even better.  I thought that the input from 
several of the SG11 people were valuable and worth listening to.

As for complexity, I would think that not overloading the INVITE would 
reduce it.  I am not worried about an extra ACK.

Mike

At 02:51 PM 8/12/2002 -0500, Adam Roach wrote:
>I agree with Jon that this is a situation of a non-bug
>being brought up after last call -- we can address it
>when we progress the document if it seems necessary,
>but it's certainly not worth delaying publication.
>
>A quick note on the viability of using UPDATE instead
>of INVITE, though: the concept of using INVITE
>instead of, say, INFO is that normal SIP endpoints
>that render something to their users to indicate hold
>will Do The Right Thing (tm) upon receiving an INVITE.
>
>Taking into account that not all endpoints will implement
>UPDATE, you're left with the fact that any gateway that
>implements UPDATE for SUS/RES will *also* need to have
>the INVITE logic, in case the other end of the call doesn't
>understand UPDATE. It seems that a recommendation to use
>UPDATE for SUS/RES would introduce additional complexity
>in gateways for the rather dubious gain of not sending
>an ACK.
>
><thread snipped>
>
>/a

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Allison Mankin <[email-masked]>
Date: Mon, 12 Aug 2002 22:42:20 -0700

Michael,

The IETF process is that we have a IETF/community-wide Last Call
for an announced time.  The previous step of Working Group 
Last Call is expected to be more repeatable and subject to more 
flexible timings. The IETF Last Call for sipping-isup closed on
August 5.

Comments and discussion are valued, but at this point, we would
need you to be exposing a very serious flaw.  

Allison