Subject: [Sipping] selection among UDP, TCP and TLS

From: "Shu-Lin CHen" <[email-masked]>
Date: Tue, 8 Apr 2003 10:03:10 -0400

Hi:

When a proxy server needs to send a SIP msg to another proxy server, 
based on what criteria does it select a protocol among UDP/TCP/TLS?

Thanks.

shu-lin

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Brett Tate" <[email-masked]>
Date: Tue, 8 Apr 2003 18:31:17 -0400

> When a proxy server needs to send a SIP msg 
> to another proxy server, based on what criteria 
> does it select a protocol among UDP/TCP/TLS?

The basic answer is that it does a DNS query
for NAPTR records if it has not already been
limited based upon transport, address, or port.

More detailed answers can be found in RFC 3263 
and RFC 3261.