Subject: RE: [Sipping] Early media; a summary after the IETF

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Sun, 6 Apr 2003 01:36:30 +0100

See below

And yes I do remember hot, sweaty conference rooms in Geneva in 1986 and 1987 when this was all worked through.

Keith

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked] 

> -----Original Message-----
> From: Gonzalo Camarillo [mailto:[email-masked]]
> Sent: 04 April 2003 10:37
> To: Mark Watson
> Cc: Tom-PT Taylor; [email-masked]; Jon Peterson
> Subject: Re: [Sipping] Early media; a summary after the IETF
> 
<snipped> 
> 
> As far as I know, Q.931 lets you send ALERTING with no 
> indication, but I 
> do not know any example where the network uses this message. Where is 
> this used?
> 
It depends which side of the network you are on.

ISDN assumes that all ALERTING messages are accompanied by appropriate tone/announcement - at least for those "media types" where it is appropriate, e.g. voice, and in general it is even provided on 64kbit/s. 

This is generated by the destination local exchange, and possibly destination PBX as well. Therefore on the destination Q.931 interface, there is no in-band tone. On the originating Q.931 i/f there is always an in-band tone/announcement. 

In the absence of progress indicator #1, the phone has the freedom to generate either a local ringing tone, or to provide the tone that is available in-band.

The progress indicator #1 does not indicate the presence of such a tone or announcement, rather it indicates that one should listen to it and not generate a local ringing tone.
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Gonzalo Camarillo <[email-masked]>
Date: Mon, 07 Apr 2003 10:39:54 +0300

Keith,

 > In the absence of progress indicator #1, the phone has the freedom to
 > generate either a local ringing tone, or to provide the tone that is
 > available in-band.
 >
 > The progress indicator #1 does not indicate the presence of such a
 > tone or announcement, rather it indicates that one should listen to
 > it and not generate a local ringing tone.

Do you know of any particular example of a phone that generates its own 
local ringing tone? As far as I know, not even GSM phones do that.

Thanks,

Gonzalo