Subject: RE: [Sipping] New version of the early media draft

From: "Francois Audet" <[email-masked]>
Date: Mon, 7 Apr 2003 17:41:45 -0700

So your answer is that every SIP implemenation out there would need to 
include a join header in every INVITE they send if they want to be able to
receive early media using the application server approach? This
would apply even when there is no application server doing early media,
because the endpoint doesn't know in advance.

This seems to me to be very not backward compatible. Especially if
forking forces the use of this procedure.

> -----Original Message-----
> From: Gonzalo Camarillo [mailto:[email-masked]] 
> Sent: Friday, April 04, 2003 22:04
> To: Audet, Francois [SC100:4K02:EXCH]
> Cc: 'Michael Hammer'; Taylor, Tom-PT [CAR:5N00:EXCH]; 'Bob 
> Penfield'; [email-masked]'; 'Jon PETERSON 
> ([email-masked])'; 'Christer Holmberg'; Watson, 
> Mark [MOP:EP10:EXCH]
> Subject: Re: [Sipping] New version of the early media draft
> 
> 
> As I said in a separate note, the idea is not use the 
> mechanism that the 
> application interaction design team develops. Since all the 
> UACs would 
> eventually like to be able to interact with whatever is in 
> the network 
> (e.g., introduce a pin number so that your call can proceed), 
> this will 
> be a widespread feature.

---

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 08 Apr 2003 09:09:22 +0300

Francois,

the backwards compatibility issue you are talking about (current SIP UAs 
do not implement Join header) does not seem to be a big problem for 
early media specifically.

If your UA does not implement it, you will not be able to interact with 
any application server that uses that framework. Therefore, when the UAS 
is acting as an application server for the call (interacting with the 
caller using early media), it makes sense that it is not possible either.

And if the UAS intended to send optional early media, it is not a big 
deal that it cannot be sent, because it was optional.

Therefore, you should raise the backwards compatibility issue in the 
application interaction design team. We are just referencing their stuff.

Thanks,

Gonzalo

-- 
Gonzalo Camarillo         Phone :  +358  9 299 33 71
Oy L M Ericsson Ab        Mobile:  +358 40 702 35 35
Telecom R&D               Fax   :  +358  9 299 30 52
FIN-02420 Jorvas          Email :  [email-masked]
Finland                   http://www.hut.fi/~gonzalo

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP