Subject: Re: [Sipping] Early media; a summary after the IETF

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 01 Apr 2003 10:28:01 +0300

Tom,

yes, this was mentioned in the meeting.

In any event, it is important that H.248 supports this type of message 
(generate ringback until media arrives), since it is needed regardless 
of any new flags or extensions that we could come up with. It would be 
good if somebody could work on that.

Thanks,

Gonzalo

Tom Taylor wrote:
> Your charts do not reflect an important difference between MGCP and 
> Megaco/H.248. In MGCP, it is possible to tell the MG to automatically 
> terminate application of ringing tone upon detection of incoming media.  
> In Megaco/H.248, the media event is detected on one termination, but the 
> ringing tone is being applied to another.  This means that the MG has to 
> report media detection to the MGC, and then the MGC has to request that 
> ringing tone application be stopped.  It has occurred to me upon 
> reflection that there might be a way around this, but for the moment 
> that is the case.
> 
> Gonzalo Camarillo wrote:
> 
>> Folks,
>>
>> here you have a summary of what happened in the IETF regarding early
>> media.
>>
>> We planned to have an ad-hoc meeting, but since we managed to get more
>> meeting time than expected for this issue and some of the persons
>> involved in the mailing list discussions were not available for an
>> ad-hoc meeting (some of them were not even in San Francisco), we did not
>> finally have the ad-hoc.
>>
>> Regarding the discussions during the second SIPPING session, the main
>> input was slide number 3 of
>>
>> http://www.softarmor.com/sipping/meets/ietf56/slides/Gonzalo-sipping-early-media.ppt 
>>
>>
>> That slide does not discuss the encoding issue. It focuses on the
>> requirements or the gains that adding a SIP "there is media coming" (or
>> "don't generate local ringback") indication would bring.
>>
>> The conclusion of that slide is that a message with "generate local
>> ringback until media arrives" should be provided by the protocol (e.g.,
>> MGCP or H.248) between the MG and the MGC **REGARDLESS** of whether or
>> not we create a "there is media coming" flag.
>>
>> Therefore, assuming that the MG is in accept-media state as soon as the
>> INVITE is sent, the only gain that a "there is media coming" would bring
>> would be saving one message from the MGC to the MG every time a 180 with
>> a flag is received. The gain is zero for 180 responses without the flag.
>>
>> The question is: are people after this optimization (saving of one
>> message in some circumstances) or there is somebody with something else
>> in mind?
>>
>>
>> In any event, the conclusion of the meeting was that I will be gathering
>> use cases where a "there is media coming" flag would be useful. Please,
>> send any use case you have in mind and I will compile them in a
>> document. We hope that such a document help us figure out which
>> requirement is missing.
>>
>> We also may organize a conference call in some weeks to further discuss
>> the issue, if needed.
>>
>> Thanks,
>>
>> Gonzalo
>> _______________________________________________
>> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
>> This list is for NEW development of the application of SIP
>> Use [email-masked] for questions on current sip
>> Use [email-masked] for new developments of core SIP
>>
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 03 Apr 2003 12:48:23 +0300

Hi,

In Q.1950 there is a package called "Basic Call Progress Tones Generator with
Directionality", which maybe could be used for this. It allows you to specify the
direction of the tone, so basically you could play it on the RTP termination, but with the
direction towards TDM termination. Now, the RTP detection and the ringback tone generation
would take place on the same termination.

There could maybe be issues with this solution, depending on the Context model, but that's
another issue...

Regards,

Christer Holmberg
Ericsson Finland

Tom Taylor wrote:

> Your charts do not reflect an important difference between MGCP and Megaco/H.248.
> In MGCP, it is possible to tell the MG to automatically terminate application of
> ringing tone upon detection of incoming media.  In Megaco/H.248, the media event is
> detected on one termination, but the ringing tone is being applied to another.  This
> means that the MG has to report media detection to the MGC, and then the MGC has to
> request that ringing tone application be stopped.  It has occurred to me upon
> reflection that there might be a way around this, but for the moment that is the case.
>
> Gonzalo Camarillo wrote:
> > Folks,
> >

---

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 03 Apr 2003 13:04:12 +0300

Thanks Christer. This is something that is needed, so it is great that 
H.248 supports it.

Gonzalo

-- 
Gonzalo Camarillo         Phone :  +358  9 299 33 71
Oy L M Ericsson Ab        Mobile:  +358 40 702 35 35
Telecom R&D               Fax   :  +358  9 299 30 52
FIN-02420 Jorvas          Email :  [email-masked]
Finland                   http://www.hut.fi/~gonzalo