Subject: [Sipping] Geopriv and SIP current state

From: "Shane McCormack" <[email-masked]>
Date: Wed, 9 Apr 2003 10:55:34 +0100

Hi,
Could somebody please let me know how spatial location information will be
requested and returned using SIP. Will it be a new header in all messages or
can SUBSCRIBE messages request NOTIFY of geo location. Also what format will
this take, will it be similar to the presence XML format? Any help would be
much appreciated.

Regards

Shane McCormack

Research Assistant,
TSSG, Confederation House,
Waterford Business Park, Cork Road,
Waterford, Co. Waterford.

Phone: +353 51 302927     Fax: +353 51 302901
Mobile: +353 87 9955505
http://www.tssg.org
MSN: [email-masked]

---

From: "Dean Willis" <[email-masked]>
Date: Thu, 10 Apr 2003 12:49:59 -0500

I think that geolocation information could reasonably be included in
presence documents and correspondingly delivered in presence notifications
as being developed in SIMPLE. It would probably NOT be appropriat, as a
general solution, to include geoloc (as a header or otherwise) in every
message as the overhead of protecting that content could become enormous.
 
Requesting "just geoloc" when subscribing to someone's presence would
perhaps be implemented using the filtering mechanisms currently being
discussed in SIMPLE and SIPPING.
 
The actual format of geoloc data has not yet been determined. I anticipate
using the location format deliverable of the GEOPRIV working group.
 
--
Dean

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Shane McCormack
Sent: Wednesday, April 09, 2003 4:56 AM
To: Sip@Ietf. Org
Cc: Sipping@Ietf. Org
Subject: [Sipping] Geopriv and SIP current state

Hi,
 
Regards
 
Shane McCormack

Research Assistant,

Phone: +353 51 302927     Fax: +353 51 302901 
Mobile: +353 87 9955505 
 <http://www.tssg.org/> http://www.tssg.org 
MSN: [email-masked]

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 10 Apr 2003 14:05:20 -0400

Jon and I are (will be...) working on a draft for geopriv on the SIMPLE 
aspect. As is noted in Jon's current simple-for-geopriv draft, SIMPLE 
offers many of the mechanisms that are needed to satisfy the geopriv 
privacy requirements.

Dean Willis wrote:

> presence documents and correspondingly delivered in presence 
> notifications as being developed in SIMPLE. It would probably NOT be 
> appropriat, as a general solution, to include geoloc (as a header or 
> otherwise) in every message as the overhead of protecting that content 
> could become enormous.
>  
> The actual format of geoloc data has not yet been determined. I 
> anticipate using the location format deliverable of the GEOPRIV working 
> group.
>  

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Michael Hammer <[email-masked]>
Date: Tue, 15 Apr 2003 10:18:14 -0400

Henning,

There are already standard representations of geolocation and 
geo-velocity.  Do you intend to be compatible with those?

Mike

At 02:05 PM 4/10/2003 -0400, Henning Schulzrinne wrote:
>>anticipate using the location format deliverable of the GEOPRIV working group.
>>
>
>

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 17 Apr 2003 08:25:34 -0400

Yes, at least semantically. (I see no need to mimic a particular bit 
pattern to, say, encode a binary values as base64 in XML.)