Subject: [Sipping] Few questions on SIP Protocol

From: "SIP Developer" <[email-masked]>
Date: Mon, 14 Apr 2003 18:14:14 -0400

Hello,

I am new to SIP Protocol.

I am having few questions :

1) How can a SIP Gateway indicate a "Resource Availability" to SIP Proxy or SIP Redirect (similar to RAI mechanism in H.323)?
2) How can an endpoint sends DTMF in a reliable way ? Does RFC2833 provides a reliable mechanism to send DTMF ? How is RFC2833 compared to SIP INFO ?
3) Does SIP provides a mechanism for failover to backup signaling entity if the primary signaling entity fails ?

Please also give me pointers to specific documents (if any). 

Rohan Kumar

---

From: "SIP Developer" <[email-masked]>
Date: Wed, 16 Apr 2003 19:43:11 -0400

Thanks David for the answers.
I have few more questions based on your previous answers:

a) VRRP provides a 1+1 redundancy at Layer 3 and will have scaling issues.
How do you acheive n+k redundancy in SIP networks?

b) I haven't read the complete RFC2833 RFC.
But I have one generic question which you may answer directly :

I know for fact that sending inband DTMF with codecs like G.729 is having
issues.
How is that handled by RFC2833 ?
Is it still a problem with RFC2833 to send DTMF with G.729 codecs? I am
assuming that special payload type takes care of it but just need to
confirm.
When do you prefer SIP INFO method over RFC2833 ?

c) I believe SIP SRV will give you failover mechanisms for new calls.
Can you tell me how you can preserve calls in progress (signalling + media)
on SIP network ?

I know for fact that H.323 added a Annex which specifically address this
issue
for highly available H.323 networks.

d) Does SIP protocol provides a mechanism to propogate call context
information
between cluster of redundant devices ?

Thanks for your answers.

Rohan Kumar

----- Original Message -----
From: "David R. Oran" <[email-masked]>
To: "SIP Developer" <[email-masked]>
Sent: Tuesday, April 15, 2003 1:12 PM
Subject: Re: [Sipping] Few questions on SIP Protocol

>
>
> --On Monday, April 14, 2003 6:14 PM -0400 SIP Developer
> <[email-masked]> wrote:
>
> >
> >
> > Hello,
> >
> > 1) How can a SIP Gateway indicate a "Resource Availability" to SIP Proxy
> > or SIP Redirect (similar to RAI mechanism in H.323)?
> Look at TGRP.
>
> > 2) How can an
> > endpoint sends DTMF in a reliable way ? Does RFC2833 provides a reliable
> > mechanism to send DTMF ?
> Yes.
>
> > How is RFC2833 compared to SIP INFO ?
> Info loses all the timing information.
>
> > 3) Does
> > SIP provides a mechanism for failover to backup signaling entity if the
> > primary signaling entity fails ?
> No. This is the responsibility of other protocols. Look at SIP-SRV, VRRP,
> etc.
>
> ------------------------
> David R. Oran
> Cisco Systems
> 7 Ladyslipper Lane
> Acton, MA 01720
> Office: +1 978 264 2048
> VoIP: +1 408 571 4576
> Email: [email-masked]
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP