Subject: [Sipping] RE: conf=comments on draft-burger-sipping-netann-05

From: "Eric Burger" <[email-masked]>
Date: Thu, 26 Jun 2003 09:43:59 -0400

On items 1&2: you are correct; I think this is really a BCP or standard track item.

Items 3&4: that was a victim of the change to conf=conf-id parameter (see Item 5, next).

Item 5: After 4 drafts, I was persuaded to move the conf-id from the user part to a parameter.  Thanks to the work of David Rio at Alcatel, that was clearly an incorrect move.  Shame on me for giving in!

netann-06 will appear shortly, making these corrections, as well as referencing the conferencing framework document.

> -----Original Message-----
> From: Orit Levin [mailto:[email-masked]]
> Sent: Thu, May 29, 2003 6:20 PM
> To: Eric Burger
> Cc: Sipping (E-mail)
> Subject: conf=comments on draft-burger-sipping-netann-05
> 
> 
> Hi Eric!
> I have a number of questions/comments on the draft:
> 
> 1. I understand that the draft purpose is to become an 
> informational RFC.
> What stage of the process are we at?
> 2. The draft uses MUST, SHOULD, MAY, etc. Is it the right 
> language for an
> informational RFC? (Also, please, take a look at the section 
> 5.1 which says
> "This section is informative" :-)
> 3. Section 2. "Mechanism" discusses the need for 
> instantiation of a service
> and the corresponding syntax as "the concatenation of the 
> service name and
> an optional service instance identifier, separated by an 
> equal sign". It
> also brings up "multiple, separate conference sessions" as an 
> example for a
> service instantiation.
> I endorse this direction and find it completely compatible 
> and fitting the
> more general approach of the draft-sipping-cc-conferencing.
> 4. That said, in section 5 "Conference Service" a different syntax is
> defined!!! It introduces a single "conf-id" parameter to be 
> inserted as a
> global SIP URI parameter - not in the USER portion of the 
> URI... I find this
> approach dangerous (even as informational) because it doesn't add any
> functionality (to specifying a "service instance" in the USER 
> part of the
> URI) and will lead to interoperability problems (because it 
> is different
> from the approach taken by both the conferencing-framework and the
> cc-conferencing WG documents).
> 
> Any thoughts?
> 
> Thanks,
> Orit Levin
> Chief Architect
> RADVISION
> Phone: +1.201.6896330
> 
> 
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Orit Levin <[email-masked]>
Date: Thu, 26 Jun 2003 11:36:21 -0400

It seems that we are in synch here :-)

I look forward to reading the new version!
Orit.

> From: Eric Burger [mailto:[email-masked]]
> Sent: Thursday, June 26, 2003 9:44 AM
> To: Orit Levin
> Cc: Sipping (E-mail)
> Subject: RE: conf=comments on draft-burger-sipping-netann-05
> 
> Item 5: After 4 drafts, I was persuaded to move the conf-id from the user
> part to a parameter.  Thanks to the work of David Rio at Alcatel, that was
> clearly an incorrect move.  Shame on me for giving in!
> 
> 
> netann-06 will appear shortly, making these corrections, as well as
> referencing the conferencing framework document.
>