Subject: [Sipping] How to Register multiple users with a single REGISTER message

From: José Soler Lucas <[email-masked]>
Date: Thu, 19 Jun 2003 10:52:43 +0200

Hi,

Lets see if you can help me with the following issue:

Suposse there is a need to register a series of n users, with SIP URI of the
form SIP:(whatever)@hostname, so that (whatever) contains [common pattern]
for all the usser adresses to be registered. Furthermore, all the users will
have the same REGISTER´s Contact header.

Is it possible to use regular expressions in a SIP URI? This would allow for
this case to specify a SIP URI in the TO Header field of the REGISTER, using
regular expressions, that apply to an adress like: SIP:*[common
patern]*@hostname? 

In such a way, if a registrar can handle this kind of REGISTER messages, the
registration would be single and it wouldn´t need to be updated for every
new user with the [common pattern] to be added.

Well, thanks a lot in advance.
Best  regards,

josé
-------------------------------------------- 
José Soler Lucas, M.Sc.Telecom.E. 
PhD Student 
Networks Competence Area 
Research Center COM (Communications, Optics and Materials) 
Technical University of Denmark 
Building 343, DK 2800 Kgs. Lyngby, Denmark. 
Phone: +45 45 25 38 08 (direct) 
Fax:   +45 45 93 65 81 
E-mail: [email-masked] 
Web: http://www.com.dtu.dk/staff/jso/ 
---- 
Cellular: +45 22 27 48 22 
--------------------------------------------  

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Rajarshi Chakraborty" <[email-masked]>
Date: Thu, 19 Jun 2003 14:37:58 +0000

This is very interesting Jose. But the first thing that comes to my mind is 
the security concern. What if some illegitimate user (someone who has not 
subscribed to the SIP services offered) creates a user name for itself that 
matches that "common pattern"? There may be few other issues.

regards,
Rajarshi

Rajarshi Chakraborty
B-196, IIT Campus,
Kharagpur,
West Bengal, India
PIN-721302

----Original Message Follows----
From: José Soler Lucas <[email-masked]>
To: "[email-masked]'" <[email-masked]>
Subject: [Sipping] How to Register multiple users with a single REGISTER 
message
Date: Thu, 19 Jun 2003 10:52:43 +0200

Hi,

josé

_________________________________________________________________
Wedding blues? Need help? http://www.msn.co.in/Matrimony/