Subject: [Sipping] Perspective of a deaf person. Was: Text support in SIP phones

From: "A vWijk" <[email-masked]>
Date: Wed, 18 Jun 2003 15:46:09 +0200

Jon, Michael and others.
Let me bring in my experience as a deaf person. And I am then speaking for millions and millions of hearing impaired users all over the world! 

<<Personally speaking, and maybe I have ADD, but I would find watching  someone type mildly interesting in the short run, but as boring as watching  grass grow in the long run.>>

Well, as Guido said, we are looking for what the most users want. Text communication is for us hearing impaired people almost the ONLY way to use the telephone! We, the hearing impaired, want to see the other user type. Why? We will immediately know that a person is indeed answering, we can see what kind of answer the other person is formulating..and we can even interrupt and type an answer or comment.
It is then a dialog, real time interaction. IM is a very nice invetion, but as a daily user of IM. I really dislike the waiting before the other person is ready with typing. Or the other user might have missed the message. Or as sometimes desired, thinking about how to formulate a reply.
That is not interactive. 

Compare it in this way: Imagine that voice telephony works like IM.
How well can you place a call?
It would be like a radio communication with Mars, where there is a 20 seconds delay. So only one side can talk and then wait a while before getting a reply.
Is that what you want for all the hearing impaired users? 

<<I'm sure those (on both sides) that had no choice have a strong affinity to what they are used to,  but I'm not so sure which they would choose if both were available.>>

<You miss the point that hundreds of thousands of deaf people DO use IM. As they use other text based solutions in mainstream technology. And they say to us clearly that it doesn't meet their needs. So, I accept that the users are telling me what they need/want. Not the other way around.>

Exactly, we love IM and other text messaging systems since it is the ONLY way for us right now. But as soon we have a way for real-time text conversation.. I guarantee that all the hearing impaired users will immediately switch over to T.140/RTP.

Now the funny thing is that IM and T.140/RTP can be used side by side in harmony.
I think that it would be a very good idea if the SIMPLE WG really take a close look at T.140/RTP (RFC 2793). 
Jon? What do you say?

The special thing about my IETF participation is that I bring in the experience, views and wishes/needs of the hearing impaired community.
I KNOW what I am talking about and I want to help everybody here to get a better understanding how not to be able to hear. Everyday things which are normal for you, become a burden when you cannot hear. This insight should be considered when designing anything.
Making it mainstream and default in designs is the ONLY way to prevent the protocol and technology mess in the past (think for example of the different non interworking text telephone protocols OR how the designers of the cellular telephony never ever considered to allow for text telephony over their systems).

We are talking about functionality that almost all users will like and use. While it is essential for the hearing  and speech impaired to have text communication, hearing users will also benefit from this. Thus allowing for many new and exiting services for all users.

The text support that we as internet community design and implement is for EVERYBODY. And not for just a few users with specific needs.

Sincerely,

Arnoud

Drs. Arnoud A. T. van Wijk
Viataal
Research & Development
Afdeling RDS
Theerestraat 42
5271 GD Sint-Michielsgestel
The Netherlands.
Mobile: +31651921948
International text telephone: +31735588408

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Michael Hammer <[email-masked]>
Date: Wed, 18 Jun 2003 12:21:16 -0400

See below.

At 03:46 PM 6/18/2003 +0200, A vWijk wrote:
>Jon, Michael and others.
>Let me bring in my experience as a deaf person. And I am then speaking for 
>millions and millions of hearing impaired users all over the world!
>
><<Personally speaking, and maybe I have ADD, but I would find 
>watching  someone type mildly interesting in the short run, but as boring 
>as watching  grass grow in the long run.>>
>
>Well, as Guido said, we are looking for what the most users want. Text 
>communication is for us hearing impaired people almost the ONLY way to use 
>the telephone! We, the hearing impaired, want to see the other user type. 
>Why? We will immediately know that a person is indeed answering,

I hope your IM system gives an indication that the other person is responding.

>we can see what kind of answer the other person is formulating..and we can 
>even interrupt

There may be a cultural aspect here, as there are some folks who seem to 
talk over each other. (Although I find that rather rude, especially on TV 
news shows.)

But lurking in there is a requirement for more expressive presence 
information than simply the fact that I am responding.

>and type an answer or comment.
>It is then a dialog, real time interaction. IM is a very nice invetion, 
>but as a daily user of IM. I really dislike the waiting before the other 
>person is ready with typing. Or the other user might have missed the 
>message. Or as sometimes desired, thinking about how to formulate a reply.
>That is not interactive.

But, I do understand the desire to be more immediate.

>It would be like a radio communication with Mars, where there is a 20 
>seconds delay. So only one side can talk and then wait a while before 
>getting a reply.

I'm wondering if my view of IM is colored by the use of a very good 
system.  A 20 second delay seems extremely slow.  Imagine if someone told 
you email was simply not fast enough because he needed to get responses in 
less than 24 hours and that was not happening.

Should IM get a different level of QoS treatment?  I know I get frustrated 
when my on-line banking transactions take more than a couple seconds, yet 
this too is best effort.

><<I'm sure those (on both sides) that had no choice have a strong affinity 
>to what they are used to,  but I'm not so sure which they would choose if 
>both were available.>>
>
><You miss the point that hundreds of thousands of deaf people DO use IM. 
>As they use other text based solutions in mainstream technology. And they 
>say to us clearly that it doesn't meet their needs. So, I accept that the 
>users are telling me what they need/want. Not the other way around.>
>
>Exactly, we love IM and other text messaging systems since it is the ONLY 
>way for us right now. But as soon we have a way for real-time text 
>conversation.. I guarantee that all the hearing impaired users will 
>immediately switch over to T.140/RTP.
>

Agree that both methods are needed.  But, the nature of IM messaging and 
character by character transmission by be sufficiently different that I'm 
not sure what you are asking next.

>The special thing about my IETF participation is that I bring in the 
>experience, views and wishes/needs of the hearing impaired community.
>I KNOW what I am talking about and I want to help everybody here to get a 
>better understanding how not to be able to hear. Everyday things which are 
>normal for you, become a burden when you cannot hear. This insight should 
>be considered when designing anything.
>Making it mainstream and default in designs is the ONLY way to prevent the 
>protocol and technology mess in the past (think for example of the 
>different non interworking text telephone protocols OR how the designers 
>of the cellular telephony never ever considered to allow for text 
>telephony over their systems).
>
>We are talking about functionality that almost all users will like and use.

This is where my opinion diverged, then got stomped on.  While I do think 
there is a need to have a non-voice means of interacting, I would like more 
evidence that hearing users would prefer this over IM.  I appreciate the 
ability to hear.  I think the crux is that if I really needed to get the 
interactivity that you speak of, I would make a phone call.

The mobile phone carriers were simply meeting the needs of the majority of 
users of their system, which by its nature was solely hearing oriented to 
begin with.  That being said, I applaud their expansion into mutliple media 
realms, which includes IM, video, and yes it should include interactive 
text too.

I agree with the idea that this should be mainstream, not special 
equipment.  However, I do believe in modularity of design and 
packaging.  You wouldn't force everyone to buy an 8-person van if all they 
needed was a bicycle would you?  Hopefully, this feature could be 
downloaded, plugged-in, and used as needed.

I am curious to see the statistics on its use in the coming years.

Mike

>While it is essential for the hearing  and speech impaired to have text 
>communication, hearing users will also benefit from this. Thus allowing 
>for many new and exiting services for all users.
>
>The text support that we as internet community design and implement is for 
>EVERYBODY. And not for just a few users with specific needs.
>
>Sincerely,
>
>Arnoud
>
>
>
>
>

---

From: "Peterson, Jon" <[email-masked]>
Date: Wed, 18 Jun 2003 21:52:33 -0400

> I think that it would be a very good idea if the SIMPLE WG 
> really take a close look at T.140/RTP (RFC 2793). 
> Jon? What do you say?

Certainly, Arnould, I don't want to eliminate RFC2793, or suggest that it is
inappropriate for use with SIP. But this thread originated with the
supposition that RFC2793 MUST be implemented by all SIP telephone devices. I
am uncomfortable with that mandate, especially if this requirement leads to
a plurality of standards for textual communication.

Given the current dominance (right or wrong) of the instant messaging
paradigm, both on personal computers and existing cellular telephones (i.e.
SMS), by mandating RFC2793 we would be encouraging a split market. By
mandating both RFC2793 and, say, SIMPLE instant messaging sessions, we would
be requiring that telephone vendors implement two varieties of textual
communication on their devices. As you know, mobile phone vendors are
especially concerned with minimizing their baseline functionality, given the
memory and interface constraints of their devices. Frankly, I find it likely
that many vendors would elect to implement only one or the other means of
textual communications. This could lead to failures of interoperability -
and the prevention of such failures is our most important charge as a
standards body.

> The special thing about my IETF participation is that I bring 
> in the experience, views and wishes/needs of the hearing 
> impaired community.

I hope you understand that we value your contribution to the standards
process here greatly.

[snip]
> We are talking about functionality that almost all users will 
> like and use. While it is essential for the hearing  and 
> speech impaired to have text communication, hearing users 
> will also benefit from this. Thus allowing for many new and 
> exiting services for all users.

This aesthetic matter is, I think, the hardest thing for the working group
to swallow. Many readers probably haven't had much experience with real-time
text channels, and at least some users who have (myself included) found it
less accessible and useful than the instant messaging model. Ultimately,
this may come down to advocating chocolate or vanilla - we can argue about
why one or the other is better, but really it's just a matter of taste. I
imagine that some hearing-impaired users in the world might prefer instant
messaging, and some hearing users might prefer text channels, and so on.

The only real beacon of guidance we have is the existing market. And (right
or wrong) that market has favored the instant messaging model. Were the
market to be seeded with RFC2793 applications, perhaps we would see a shift.
But I'm not sure it is our prerogative to mandate that market.

Jon Peterson
NeuStar, Inc.

> The text support that we as internet community design and 
> implement is for EVERYBODY. And not for just a few users with 
> specific needs.
> 
> Sincerely,
> 
> Arnoud
> 
> 
> 
> 
>

---

From: "Guido Gybels" <[email-masked]>
Date: Thu, 19 Jun 2003 09:51:39 +0100

Jon,

<<Certainly, Arnould, I don't want to eliminate RFC2793, or suggest that it is inappropriate for use with SIP. But this thread originated with the
supposition that RFC2793 MUST be implemented by all SIP telephone devices.>>

But not for the reasons you state, but because unless you mandate it, it will not be able to use it to bring services for deaf and hard of hearing people into the mainstream. I'm also annoyed by the fact that you seem to ignore what I have suggested on multiple occasions now: make it mandatory, except for well-defined cases. Failure to do so will mean giving up on the idea of mainstream support for this important requirement.

If that is what people want, for whatever political motives, I suggest they are clear and unambiguous about that.

<<especially if this requirement leads to a plurality of standards for textual communication.>>
and
<<Given the current dominance (right or wrong) of the instant messaging paradigm, both on personal computers and existing cellular telephones (i.e. SMS), by mandating RFC2793 we would be encouraging a split market.>>

I can't believe this. The IM market is already heavily split internally. Interactive text requirements are an alternative modality, not a competing one. Many posters have acknowledged already it is not an either-or option.

<<As you know, mobile phone vendors are especially concerned with minimizing their baseline functionality, given the memory and interface constraints of their devices.>>

Yes, and most mobile manufacturers will find something light-weigt as RFC2793 quite attractive, especially if that will fulfil their legal and regulatory obligations in Europe where IM will not do so.

<<Frankly, I find it likely that many vendors would elect to implement only one or the other means of textual communications. This could lead to failures of interoperability - and the prevention of such failures is our most important charge as a standards body.>>

There is no point in heaving an interoperable system that can't fulfil the requirements. IM will not be able to provide deaf and hard of hearing people with what they need, including access to relay services. If you then don't have something like RFC2793 in mainstream, we'll be back where we are now: a plethora of proprietary solutions that don't interwork, are not widely accessible and relay on special terminals.

<<I hope you understand that we value your contribution to the standards process here greatly.>>

I hope we will do more than expressing our sympathies to deaf and hard of hearing people. As I have said in another post: we are on a point where we can either do it right, or do it wrong. We, as hearing people, won't suffer the consequences of doing it wrong, but I hope that doesn't decrease or motivation to do the right thing.

<<This aesthetic matter is, I think, the hardest thing for the working group to swallow. Many readers probably haven't had much experience with real-time text channels, and at least some users who have (myself included) found it less accessible and useful than the instant messaging model.>>

It's hardly up to hearing people to say what deaf people want. And, as so many others, you have missed the crucial point: that deaf people use text not as an *additional* or *alternative* modality, but as a substitute for voice. IM cannot deliver that and neither can it deliver relay access. You are hereby also invited to attend the TAG seminar in the qutumn in London. You can hear from deaf people what they want then and maybe you could spend a couple of days with them as well, that might shed a new light on things.

<<Ultimately, this may come down to advocating chocolate or vanilla - we can argue about why one or the other is better, but really it's just a matter of taste.>>

Oh, no, it isn't! It is no question of taste, it is a question of abilities. Deaf people have no choice but to use text rather than voice. It is not about aesthetics. Maybe if you would have been in my job, you would start to appreciate that point a bit more, I don't know, but what I see is that many people here still fail to understand what is going on and what the requirement is. That scares me, because it will lead to the wrong decisions that will impact extremely heavily on deaf and hard of hearing people.

<<I imagine that some hearing-impaired users in the world might prefer instant messaging, and some hearing users might prefer text channels, and so on.>>

I'm sorry, hearing impaired users that rely on text as a substitute to voice do not have a choice. They cannot use IM for that, and that includes the inability to use relay services in a meaningful way.

<<The only real beacon of guidance we have is the existing market.>>

Yes, and that market has steadily increased the disadvantage for deaf and hard of hearing  people in a society that is ever more dependent on access to telecommunications. You might not see it, but I am faced daily with the consequences of that. Please leave it to deaf and hard of hearing people to decide what they need and what they want. The market certainbly hasn't served them well. So I guess that means the question to you is: do you want to maintain the current discriminating situation or are you prepared to do something about it?

<<But I'm not sure it is our prerogative to mandate that market.>>

Ah, so it is our prerogative to mess up deaf and hard of hearing people instead? Is that our mandate??

Guido

Guido Gybels
Director of New Technologies

RNID, 19-23 Featherstone Street
London EC1Y 8SL, UK
Tel +44(0)20-7294 3713
Fax +44(0)20-7296 8069

************************************************************************
This email and any files transmitted with it are confidential
and intended solely for the use of the individual or entity to
whom they are addressed. Any views or opinions expressed
are solely those of the author and do not necessarily represent
RNID policy.

If you are not the intended recipient you are advised that any
use, dissemination, forwarding, printing or copying of this
email is strictly prohibited.

If you have received this email in error please notify the RNID
Helpdesk by telephone on: +44 (0) 207 296 8282.

The Royal National Institute for Deaf People  
Registered Office 19-23 Featherstone Street 
London EC1Y 8SL No. 454169 (England)
Registered Charity No. 207720
************************************************************************

---

From: "James Hamlin" <[email-masked]>
Date: Thu, 19 Jun 2003 11:56:46 +0100

Jon

<<This aesthetic matter is, I think, the hardest thing for the working group
to swallow. Many readers probably haven't had much experience with real-time
text channels, and at least some users who have (myself included) found it
less accessible and useful than the instant messaging model. >>

I think the aesthetics aren't as problematic as one might at first think.
Sending data character-by-character (RFC2793/T.140) does not imply that the
user interface needs to look like a conventional textphone screen.  The
presentation to the user can look like an IM session.  The only difference
is that as you type, the characters appear to the person at the other end.
The history of the conversation can still be presented in a line-by-line way
just as it is in existing IM clients.  I don't think that users of existing
IM will be frightened off when their conversation becomes
character-by-character.  Indeed I believe they will embrace it when they
realise that it speeds up their communication.

<<Given the current dominance (right or wrong) of the instant messaging
paradigm, both on personal computers and existing cellular telephones (i.e.
SMS), by mandating RFC2793 we would be encouraging a split market. >>

I would say that SMS is used much more like email than IM at present.  As I
said in the previous paragraph,  I don't think IM users will notice a great
change when character-by-character transport is used.  It is possible to put
"packagers" in the network so that networks that take the sensible - in our
view - step of using character-by-character systems can still provide
compatibility with others that are message based.  This does mean that
networks can provide character-by-character without risking incompatibility
with those that fail to do so.

<< The only real beacon of guidance we have is the existing market. And
(right
or wrong) that market has favored the instant messaging model. Were the
market to be seeded with RFC2793 applications, perhaps we would see a shift.
But I'm not sure it is our prerogative to mandate that market. >>

Already in the UK there is a legal requirement for the telecommunications
industry to provide a PSTN relay service (that uses human operators to
translate between voice and text).  It is most likely that such provision
will become mandatory across all networks.  While running a pilot system
that bridges between Instant Messaging and the PSTN, we have discovered that
IM introduces a delay which many users describe as unacceptable.  My
conclusion is that there will be a legal mandate for character-by-character
messaging.

RFC2793 need not be a hindrance to IM users,  fragmentation of standards can
be mitigated and there will be legal motivation that overrides the free
market.

Regards

James

-----------------------------

Message: 2
From: "Peterson, Jon" <[email-masked]>
To: "'A vWijk'" <[email-masked]>, [email-masked],
        [email-masked]
Cc: [email-masked]
Date: Wed, 18 Jun 2003 21:52:33 -0400
Subject: [Sipping] RE: Perspective of a deaf person. Was: Text support in
SIP phones

[snip]

Jon Peterson
NeuStar, Inc.