Subject: RE: [Sipping] refer and pstn

From: "Christer Holmberg (LMF)" <[email-masked]>
Date: Wed, 11 Jun 2003 07:29:26 +0200

Hi Juha,
 
I think it is important to remember that REFER is not the only way to "transfer" a call.
 
First, during the call setup the gw can receive a 3xx response, which triggers a new INVITE to a new destination.
 
Second, during the call the gw can receive a re-INVITE, with new remote IP parameters. So, even if the session from a SIP signalling point of view is still established with the initial user, the media has actually been transfered elsewhere.
 
Now, I think it's a pure implementation issue how the gw handles all these cases, ie if it decides to accept the responses/requests or not.
 
Regards,
 
Christer Holmberg
Ericsson Finland

-----Original Message-----
From: Francois Audet [mailto:[email-masked]]
Sent: 10. kesäkuuta 2003 22:26
To: Tom-PT Taylor; 'Juha Heinanen'
Cc: [email-masked]'
Subject: RE: [Sipping] refer and pstn

My take is that if you accept REFER without user acknowledgement, 
regarless of if the use is on PSTN or SIP, you need some sort 
of trusted relationship with the REFERer. It is not a PSTN 
gateway issue per se, but it is true that you typically would 
not have a built-in mechanism for getting end-user acknowledgement 
in the PSTN. 

> -----Original Message----- 
> From: Taylor, Tom-PT [CAR:5N00:EXCH] 
> Sent: Tuesday, June 10, 2003 10:45 
> To: Juha Heinanen 
> Cc: [email-masked] 
> Subject: Re: [Sipping] refer and pstn 
> 
> 
> Could I understand what difference there is between accepting 
> a REFER and call 
> transfer in the legacy network?  In both cases, the protocol 
> for gaining PSTN user 
> acceptance is for the transferor to ask -- it's not a protocol issue. 
> 
> Juha Heinanen wrote: 
> 
> > i have noticed that some sip/pstn gws on the market support refer 
> > method.  i consider this very dangerous because pstn gw has no way 
> > that i know of asking the original pstn caller to accept or 
> reject the 
> > referral.  things get even worse when these implementations do not 
> > send the resulting new request to the proxy, but directly to pstn. 
> > 
> > if any of the vendors of these gws are listening, i would like to 
> > understand what is your logic when you have implemented 
> refer method 
> > UAS or if the authors of the refer rfc are listening, how 
> you thought 
> > it could be properly used by sip UASes that are pstn gws. 
> > 
> > -- juha 
> > _______________________________________________ 
> > Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping <https://www1.ietf.org/mailman/listinfo/sipping>  
> > This list is for NEW development of the application of SIP Use 
> > [email-masked] for questions on current sip Use 
> > [email-masked] for new developments of core SIP 
> > 
> 
> _______________________________________________ 
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping <https://www1.ietf.org/mailman/listinfo/sipping>  
> This list is for NEW development of the application of SIP 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP 
>

---

From: Juha Heinanen <[email-masked]>
Date: Wed, 11 Jun 2003 09:07:12 +0300

Christer Holmberg (LMF) writes:

 > Now, I think it's a pure implementation issue how the gw handles all
 > these cases, ie if it decides to accept the responses/requests or
 > not.

yes, but the protocol must provide enough information for the gateway to
make its decision and i'm not sure if that is the case with refer.

-- juha
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP