Subject: RE: [Sipping] How to Register multiple users with a single REGIST ER message

From: José Soler Lucas <[email-masked]>
Date: Thu, 19 Jun 2003 16:58:49 +0200

Hi Rajarshi,
Thanks a lot for the response.
You are right: it represents a security problem for certain services. Anyway
it will be the service itself the one registering such numbers...what about
publicly available services that need no subscription?

Just to consider some applicable case as an example: consider a sip
application server (AS) that offers a weather information service through a
SIP proxy that proxies INVITE messages to the (AS) arriving to it with the
following To SIP URI

	[email-masked]

If the application server has to register each town´s info address into the
proxy it can be really unpractical. In the other hand, if it is allowed to
register something like $\w.[_weather]@domain.com and the proxy ´s
registrars recognises it as a request for registration of whatever contains
the common pattern [_weather] then the service is much simpler from the
communication point of view (ammount of messages).

To mention the real case I am dealing with, the application I am concerned
is with a "SIP poll colector" application that handles different polls with
a number of different options to be voted for in each poll. So to make a
registration from the application for each vote option and for each poll is
really unpractical. That´s why I needed to now wheter it is possible to
include wildcards in SIP URIS and / or is any work done on the issue. 

Again thanks a lot,

jose
--------------------------------------------
Jose Soler Lucas, M.Sc.Telecom.E.
PhD Student
Networks Competence Area
Research Center COM (Communications, Optics and Materials)
Technical University of Denmark
Building 343, DK 2800 Kgs. Lyngby, Denmark.
Phone: +45 45 25 38 08 (direct)
Fax:   +45 45 93 65 81
E-mail: [email-masked]
Web: http://www.com.dtu.dk/staff/jso/
----
Cellular: +45 22 27 48 22
--------------------------------------------

-----Original Message-----
From: Rajarshi Chakraborty [mailto:[email-masked]]
Sent: 19. juni 2003 16:38
To: [email-masked]; [email-masked]
Subject: Re: [Sipping] How to Register multiple users with a single
REGISTER message

This is very interesting Jose. But the first thing that comes to my mind is 
the security concern. What if some illegitimate user (someone who has not 
subscribed to the SIP services offered) creates a user name for itself that 
matches that "common pattern"? There may be few other issues.

regards,
Rajarshi

Rajarshi Chakraborty
B-196, IIT Campus,
Kharagpur,
West Bengal, India
PIN-721302

----Original Message Follows----
From: José Soler Lucas <[email-masked]>
To: "[email-masked]'" <[email-masked]>
Subject: [Sipping] How to Register multiple users with a single REGISTER 
message
Date: Thu, 19 Jun 2003 10:52:43 +0200

Hi,

Lets see if you can help me with the following issue:

Suposse there is a need to register a series of n users, with SIP URI of the
form SIP:(whatever)@hostname, so that (whatever) contains [common pattern]
for all the usser adresses to be registered. Furthermore, all the users will
have the same REGISTER´s Contact header.

Is it possible to use regular expressions in a SIP URI? This would allow for
this case to specify a SIP URI in the TO Header field of the REGISTER, using
regular expressions, that apply to an adress like: SIP:*[common
patern]*@hostname?

In such a way, if a registrar can handle this kind of REGISTER messages, the
registration would be single and it wouldn´t need to be updated for every
new user with the [common pattern] to be added.

Well, thanks a lot in advance.
Best  regards,

josé
--------------------------------------------
José Soler Lucas, M.Sc.Telecom.E.
PhD Student
Networks Competence Area
Research Center COM (Communications, Optics and Materials)
Technical University of Denmark
Building 343, DK 2800 Kgs. Lyngby, Denmark.
Phone: +45 45 25 38 08 (direct)
Fax:   +45 45 93 65 81
E-mail: [email-masked]
Web: http://www.com.dtu.dk/staff/jso/
----
Cellular: +45 22 27 48 22
--------------------------------------------

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

_________________________________________________________________
Wedding blues? Need help? http://www.msn.co.in/Matrimony/

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Rohan Mahy <[email-masked]>
Date: Thu, 19 Jun 2003 10:47:46 -0700

Hi Jose,

What you are describing is a service which needs to be configured.  You 
want <anything>[email-masked]  to go to your application, so you 
configure your proxy to do this (possibly using regular expressions, 
CGI scripts, or the like).  Many commercial proxies allow this.  
However I don't think you need to dynamically register this service, 
support user mobility of this service, or support multiple simultaneous 
contacts for the service.  Those are the properties of an AOR that 
needs to be registered.

Also, I'd like to point out that you could also name your service:

sip:<name-of-town>@weather.domain.com

and add an entry in DNS which points weather.domain.com to your 
application server.  then you don't even need the proxy to cooperate.

thanks,
-rohan