Subject: [Sipping] Re: I-D ACTION:draft-mahy-sipping-tones-00.txt

From: Rohan Mahy <[email-masked]>
Date: Thu, 26 Jun 2003 07:44:56 -0700

On Wednesday, June 25, 2003, at 06:25 PM, Francois Audet wrote:

> Rohan,
>
> What would be the expected behavior under this draft of a UA receing a 
> 180 with
> the audio/telephone-event or audio/tone-info+html with null data/no 
> content, or even
> a description of a "silent" tone?

no content might be interpreted differently.

> Would it mean that NO locally-generated tones shall be played to the 
> user in conjunction
> with the 180? ;^)

for a small silent tone i would expect so.

perhaps even this would be sufficient:

    SIP/2.0 180 Ringing
    ...
    Content-Type: audio/tone-info+xml
    Content-Length: 10

    <tones/>

hope this helps.  thanks,
-rohan

> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]
> > Sent: Wednesday, June 25, 2003 07:51
> > Cc: [email-masked]
> > Subject: I-D ACTION:draft-mahy-sipping-tones-00.txt
> >
> >
> > A New Internet-Draft is available from the on-line
> > Internet-Drafts directories.
> >
> >
> >       Title           : Conveying Tones in the Session
> > Initiation Protocol
> >                           (SIP)
> >       Author(s)       : R. Mahy
> >       Filename        : draft-mahy-sipping-tones-00.txt
> >       Pages           : 14
> >       Date            : 2003-6-24
>

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Francois Audet" <[email-masked]>
Date: Wed, 25 Jun 2003 18:25:32 -0700

Rohan,

What would be the expected behavior under this draft of a UA receing a 180
with
the audio/telephone-event or audio/tone-info+html with null data/no content,
or even
a description of a "silent" tone?

Would it mean that NO locally-generated tones shall be played to the user in
conjunction
with the 180? ;^)