Subject: [Sipping] Priority Promotion Scheme

From: "MORITA, Naotaka" <[email-masked]>
Date: Mon, 30 Jun 2003 14:37:18 +0900

I am Naotaka Morita working for NTT Laboratories.

I would like to draw your attention to the following new ID.
The purpose of this draft is to identify the Priority Promotion Scheme
and to define a new Measurable Forwarding Per-Hop Behavior.

Althouhg this is targeted to tsvwg,
I would like to discuss this regarding the interaction between SIP proxies and
edge routers to provide QoS guaranteed service.

Naotaka Morita
============

A New Internet-Draft is available from the on-line Internet-Drafts directories.

         Title           : Framework of Priority Promotion Scheme
         Author(s)       : N. Morita, G. Karlsson
         Filename        : draft-morita-tsvwg-pps-00.txt
         Pages           : 20
         Date            : 2003-6-25

This document describes a framework of a new scheme for traffic
control to achieve end-to-end QoS for interactive multimedia
services.  The scheme is based on end-to-end measurement of network
resources by end systems.  The network is assumed to fully support
the priority control scheme specified in the Diffserv architecture
for QoS and SIP [1]  for session control.  Since the scheme relies on
the behavior of the end systems, this document also touches on
mechanisms for monitoring end-system behavior.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-morita-tsvwg-pps-00.txt

----------------------------------
Naotaka MORITA, Senior Research Engineer, Supervisor
Network Service Systems Laboratories
Information Sharing Laboratory Group
NTT
3-9-11, Midori-Cho, Musashino-Shi, Tokyo 180-8585 JAPAN
Tel. +81-422-59-7464, ISDN-Fax +81-422-60-4012
E-mail: [email-masked]
MSN messenger: [email-masked]
NTT home page: http://www.ntt.co.jp/about/e/index.html 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Beck01, Wolfgang" <[email-masked]>
Date: Mon, 30 Jun 2003 12:49:05 +0200

Naotaka,

first of all, I am glad to see that I am not the only one
who is interested in endpoint admission control in the SIP
context. However, I don't think the proxy can derive bandwidth
requirements from the SDP body of a SIP message. To do so,
it would have to know every codec available. SDP bodies can
even be encrypted. Only the user agents know what bandwidth
they are going to use. They know about the packet size (not
included in SDP) and voice activity detection (not included
in SDP). 

Maybe the SIP User Agents could use some RSVP variant to
tell the edge router, like in RfC 3313 6.1?

Wolfgang

--
Wolfgang Beck
T-Systems Nova GmbH

---

From: "MORITA, Naotaka" <[email-masked]>
Date: Mon, 30 Jun 2003 20:36:10 +0900

Wolfgang,

Thank you for you comment.

I would like to clarify the discussion items.
1) The effectiveness of endpoint adimssion control.
This is the matter whether the measurement based approach is
valid or not.
This issue will be discussed at the TSVWG on Friday.

2) Interaction to edge routers
This is the matter of SIPPING, I believe.
I would like to hear other experts opinion,
because this is the common issue for all QoS guaranteed schemes.
Are there any way to control edge routers by SIP proxies?

Naotaka

---

From: "Beck01, Wolfgang" <[email-masked]>
Date: Mon, 30 Jun 2003 17:23:22 +0200

Hello Naotaka,

you wrote
> From: MORITA, Naotaka [mailto:[email-masked]]
> Sent: Monday, June 30, 2003 1:36 PM

> 1) The effectiveness of endpoint admission control.
> This is the matter whether the measurement based approach
> is valid or not.
At least it will prevent well behaved but unresponsive flows
from flooding hopelessly congested paths.

> This issue will be discussed at the TSVWG on Friday.
Thank for this information. 

> [..]
I don't think proxies should do that. What happens if an
application does not need SIP but wants to implement
endpoint admission control?

--
Wolfgang Beck
T-Systems Nova GmbH