Subject: RE: [Sipping] Text support in SIP phones

From: Henry Sinnreich <[email-masked]>
Date: Tue, 27 May 2003 11:17:49 -0500

Gunnar, this all seems very reasonable, and I will try to insert it
properly.

Henry

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Gunnar Hellström
> Sent: Thursday, May 22, 2003 6:54 PM
> To: 'Sipping@Ietf. Org'; Sipforum-Discussion@Lists. Su. Se
> Cc: Henry Sinnreich
> Subject: [Sipping] Text support in SIP phones
> 
> 
> Sorry, I missed out the reference to the SIP device specification.
> 
> Henry and all,
> 
> Some time ago, I suggested addition of support for real time 
> text communication to the SIP device specification 
> http://www.ietf.org/internet-drafts/draft-sinnreich-sipdev-req-00.txt
> 
> This was the simple part of the proposal:
> 
> > SIP-zz, digital text support: SIP telephone devices MUST support
> >   real time text conversation using RFC 2793 [y] for the 
> text stream.
> >   It MUST be possible to use text simultaneously with voice.
> >
> >
> >
> > ---------------------------------------------
> > In 4.11 Ringer Behaviour  : add the section below for the 
> purpose of 
> > deaf, hearing impaired, deaf-blind people and people in the 
> garden and 
> > noisy
> > locations:
> >
> > SIP Telephony devices MUST provide an external interface to an 
> > external alerting system.
> >
> >
> >
> > Add to References
> > -----------------
> > [y] G. Hellstrom: "RTP Payload for Text Conversation.", RFC 2793, 
> > IETF, May 2000.
> >
> > --------------------------------------------------------------
> 
> The reception of this proposal was very positive.
> Now, I would like to see the final formulation, and check 
> that we agree on it.
> 
> I regard this requirement to be very light. In the Interface 
> section ( e.g.
> Int-2) , there is already mentioning of mandatory text input 
> mechanisms, and assumptions that a display would be normal, 
> since handling of phone books and buddy lists are mandatory. 
> To re-use these text interface devices during the call for 
> standardised text conversation purposes seems straightforward.
> 
> It could be wise to add the T.140 text presentation protocol 
> as a codec to the codec section. The normal SDP used together 
> with RFC2793 for text could also be specified. Do you want to do that?
> 
> 
> -----
> 
> We also need to check the ideas around the other proposed 
> requirements: The requirement to include text telephone modem 
> in all designs where an RJ11 phone connector exists, and the 
> requirement to support RFC 3351. I suggest that we start with 
> the straightforward and mainstream requirement above. Is that 
> accepted as it is?
> 
> 
> Regards
> 
> Gunnar
> -------------------------------------------
> Gunnar Hellström, Omnitor, Renathvägen 2
> SE 121 37 Johanneshov, SWEDEN
> Tel: +46 8 556 002 03  Mob: +46 708204288
> e-mail: [email-masked]
> web: www.omnitor.se
> 
> 
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Guido Gybels" <[email-masked]>
Date: Wed, 11 Jun 2003 08:49:22 +0100

Keith and all,

<<I would suggest that treating these sort of things as MUST strength is best left to national regulatory requirements, along with other things like fitness for purpose and so on.>>

I'm quite surprised, since this must be the first time I see the industry actually asking for more regulation and legislation! It was my impression that free market mechanisms were preferred. I'd like to make it clear that the *current* situation with different national regulation in various countries has seriously hampered the BUSINESS case. 

If the support for a standardised mechanism for the provision of interactive text is not part of the recommendations in this document, we will end up, as has been proven time and again by history, with non-mainstream, expensive, incompatible solutions. Please note that getting regulation or legislation that imposes the obligation to provide specific services for people with disabilities is not that difficult. But you end up with a plethora of regulations and legislation and the cost of implementing solutions falls on to the service providers and network operators. Again, plenty of evidence. The new regulatory framework in the UK with regard to the provision of mobile text telephony, for example, will result in operators having to invest hundreds of thousands of pounds over the coming months, with no hope of recovering them. The operators have to bear to entire cost of this operation. The reason is that none of their mainstream services is able to support the specific require!
ment (why? because GSM/GPRS standards have no standard provision for interactive text), so you end up with these kinds of regulatory solutions. I haven't seen any of the operators in the UK being very happy about this! They would by far prefer to have one mainstream infrastructure that is able to fulfill all the requirements. Also, such solutions, being by definition not part of their standard infrastructure, require network operators to install and maintain proprietary nodes and software in their networks, which as you'll understand, is not exactly favoured by them either. It also is in the continuous danger of being broken by any mainstream developments, installation of new hard- and software on the main network etc, etc.

If, however, we are able to think out of the box this time we should be able to prevent this situation from repeating itself by providing a MAINSTREAM solution that will at the same time deal with the problems of specific requirements.

SMS on the mobile platform has proved beyond any doubt that there exists a HUGE market, NOT just for people with disabilities, but for ALL users, for texting. The popularity of texting in Europe and Japan is beyond all expectations. It is therefore reasonable to state that the ability to use text to communicate:
a) mandatory if you want to roll out next generation services since users will not accept the loss of such service
b) has to be part of the standard network and terminal provision: it is unthinkable to operate a modern mobile network that would not support SMS and I am not aware of any handsets currently on the market that do not support SMS.

Furthermore, the success of SMS is strongly linked to the fact that it is basic part of the mobile protocols. Every standard GSM supports it since it is part of the standard. Initially, operators blocked access from other providers so that SMS could not be send across network boundaries. It was only when those restrictions were lifted and users could freely send text around that SMS really took off. We should learn valuable lessons from all this. Especially in a moment in time that the telecommunication sector is suffering hard, it is mandatory to get the requirements and standards right. The cost of getting it wrong will be extremely high.
Making sure that any future networks and services offer an improved interactive texting feature therefore is extremely sound reasoning. What we are proposing as a solution is extremely light-weight, easy ti implement, readily available, cheap, does not impose any burdens on manufacturers or operators, and most importantly is the best possible solution from a purely BUSINESS point of view. It is one of these rare situations where everybody is a winner.

<<Any such MUST would surely need to be qualified anyway. If the purpose of the devise is such that it renders a textual devise irrelevant, then why require one to be fitted.>>

I have no objection against qualifying, maybe in the sense that Henry proposes. But the network MUST fully support, in a standardised way, setting up interactive sessions between any two nodes and carrying the conversation. Devices might not have a keyboard or display (although I can't imagine selling a phone without display in these days of mobile communications, except for niche markets and that is not very interesting for manufacturers anyway), but users might opt to fit one later.

In short, I strongly suggest we use the MUST. Let's agree on qualifying it if necessary.

<<Suppose we were designing a SIP phone for the totally blind, and this was designed to be worn as a headset, a text device would be irrelevant to such a user, and positioning such a device where it could be seen would require an extra box hanging out of the side of the product.>>

RNID believes that it is far better to design an off-the-shelf device in such a way that it is able to support deaf, hard of hearing, speech impaired or visually impaired people. Deaf, hard of hearing, blind,... people could then easily buy ANY off-the-shelf phone and fit it with a headset, probably connected to the phone via Bluetooth. That would:
a) give them the same freedom of choice
b) prevent them from being marginalised through the use of special equipment (just think about the link with hearing aids...)

Surveys amongst people with disabilities show that this is a major requirement: people with disabilities do not want to be considered "special" users. They want access to the same products and services as any other individual.

The provision of such headsets as you mention, BTW, is not only for the benefit of visually impaired people. These days, I see much more non-disabled people walking around with their Bluetooth handsets than visually impaired people. The use of SMS by deaf and hard of hearing people is another such example: no one would claim that SMS is only for those users. Yet, they take advantage of a MAINSTREAM provision which happens to suit their abilities and preferences. Hearing people in noisy circumstances or in situations where they cannot use voice will also revert to text in some circumstances. The whole concept of "special" equipment is well out of fashion these days.
Let's build mainstream technology so that it suits as much users as possible, regardless of their abilities and preferences. It will be to the benefit of ALL.
Best regards,

Guido

Guido Gybels
Director of New Technologies

RNID, 19-23 Featherstone Street
London EC1Y 8SL, UK
Tel +44(0)20-7294 3713
Fax +44(0)20-7296 8069

************************************************************************
This email and any files transmitted with it are confidential
and intended solely for the use of the individual or entity to
whom they are addressed. Any views or opinions expressed
are solely those of the author and do not necessarily represent
RNID policy.

If you are not the intended recipient you are advised that any
use, dissemination, forwarding, printing or copying of this
email is strictly prohibited.

If you have received this email in error please notify the RNID
Helpdesk by telephone on: +44 (0) 207 296 8282.

The Royal National Institute for Deaf People  
Registered Office 19-23 Featherstone Street 
London EC1Y 8SL No. 454169 (England)
Registered Charity No. 207720
************************************************************************

---

From: "Guido Gybels" <[email-masked]>
Date: Wed, 11 Jun 2003 12:18:29 +0100

Henry,

<<We could formulate soemthing like "SIP phones that have a text display and advertised as supporting the hearing or speech disabled MUST...">>

Surely narrowing it down to "and advertised as supporting the hearing or speech disabled" is not acceptable? How many phones (will) advertise themselves as "supporting the hearing or speech disabled"? This is just getting back to what we have today: special markets where the business case sucks and regulation imposed on operators and manufacturers that costs them loads of money, yet fails to provide an equivalent user experience in comparison to mainstream solutions. We need an inclusive mainstream solution.

Arnoud, what do you think?

Guido

Guido Gybels

---

From: "A vWijk" <[email-masked]>
Date: Wed, 11 Jun 2003 13:37:05 +0200

Keith, Henry and others.
As a deaf person myself, with experience and knowledge on what the hearing impaired users really WANT and NEED. I can only say that Guido is absolutely CORRECT! And I fully agree with him.

The requirement for real-time text conversation is a MUST.

We have to move away from special phones/devices for the handicapped people. As Guido descibed, that will only lead to expensive devices with limited functionality and lagging technology or even complete obsolete technology. With the interworking problems etc etc. This has happened time over time in the past.

By the way, when a visually impaired person is using a phone with text receiving capabilities. This user can connect a braille reader if desired and read the text. Always useful for addresses and names etc. Or his/her non handicapped partner needs to borrow the phone after the call.
And being blind does not stop such users to type any text to any other user, regardless deafness, blindness or normally hearing.

The bottomline is that this text support requirement is for ALL SIP telephony users! NOT only for the hearing impaired, but for every human being.

Think of voice menus using text so that selecting the right customer representive will be easier (press 1 for.... press 2 for..... ). Or when exchanging names and addresses, per text is so much easier. Or when calling in a bar. Not being able to hear the phone due the high background noise, you can still communicate per text.
Think of the popularity of text messaging, SMS, Instant Messaging. Think of new exiting services like translation interpreters when calling a Mexican businessman, spanish to english translation via text. (we are not like Jonathan who speaks spanish fluently :-) )

That is what we are talking about. It is not a niche market, this is a mainstream market with billions and billions of users benefitting from this text support. And having the complete FREEDOM to buy any SIP telephony device from any manufacturer with whatever functionality you like.

greetz

Arnoud

Drs. Arnoud A. T. van Wijk
Viataal
Research & Development
Afdeling RDS
Theerestraat 42
5271 GD Sint-Michielsgestel
The Netherlands.
Mobile: +31651921948

>>> "Guido Gybels" <[email-masked]> 06/11/03 09:49am >>>
Keith and all,

Guido

Guido Gybels

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Wed, 11 Jun 2003 13:43:36 +0100

First of all, my comment was in response to a comment being made on the sip devices document. I understand the scope of that document to be terminals, not network type equipment, and therefore it is axiomatic that my comment also is within that scope. My comment has nothing whatsoever to do with any requirements, or absence of requirements, for support from network type equipment, which seems to be implied by a substantial part of your response.

As regards provision of specialised terminal equipment for disabled, I do agree with you that ideally standard off the shelf equipment should be designed with the disabled in mind, thus allowing the disabled to make use of production level pricing and so on (all the reasons you have quoted). Your comments however do not eliminate the need for specialised equipment to exist, and my comment was trying to identify that writing a straight MUST could preclude some of that equipment from existing, e.g. by virtue of the mandatory provisions for one kind of disability overriding sensible design decisions for the specialised support of another kind of disability.

I have no problem with a MUST level requirement that states:

If the device supports a means of representing text, the device MUST support <list standardised text mechanisms>

I believe Gunnar has identified a number of requirements from 3GPP specifications that provide material for this.

The issue comes with what level do we represent a requirement for supporting a means of representing text. My thought process was that trying to identify all the exceptions would be too complicated to enable us to write:

IF <condition> then device MUST support means of representing text

SHOULD allows exceptions, but conveys no meaning about what those exceptions are.

This then raised in my mind as to whether this was the appropriate document to try and represent such a requirement in the first place. It is a difficult requirement to represent, and in any case, various national law will have something to say about it anyway. The conclusion I came to was as previously stated, but I have no problem coming to a different conclusion, providing we can made a sensible statement of the requirement. This however is a voluntary standard, and, to my knowledge, will not even be called up by 3GPP SIP specifications, which carry their own requirements in this area.

regards

Keith

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked] 

> From: Guido Gybels [mailto:[email-masked]]
> Sent: 11 June 2003 08:49
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: RE: Text support in SIP phones
> 
> 
> Keith and all,
> 
> <<I would suggest that treating these sort of things as MUST 
> strength is best left to national regulatory requirements, 
> along with other things like fitness for purpose and so on.>>
> 
> I'm quite surprised, since this must be the first time I see 
> the industry actually asking for more regulation and 
> legislation! It was my impression that free market mechanisms 
> were preferred. I'd like to make it clear that the *current* 
> situation with different national regulation in various 
> countries has seriously hampered the BUSINESS case. 
> 
> If the support for a standardised mechanism for the provision 
> of interactive text is not part of the recommendations in 
> this document, we will end up, as has been proven time and 
> again by history, with non-mainstream, expensive, 
> incompatible solutions. Please note that getting regulation 
> or legislation that imposes the obligation to provide 
> specific services for people with disabilities is not that 
> difficult. But you end up with a plethora of regulations and 
> legislation and the cost of implementing solutions falls on 
> to the service providers and network operators. Again, plenty 
> of evidence. The new regulatory framework in the UK with 
> regard to the provision of mobile text telephony, for 
> example, will result in operators having to invest hundreds 
> of thousands of pounds over the coming months, with no hope 
> of recovering them. The operators have to bear to entire cost 
> of this operation. The reason is that none of their 
> mainstream services is able to support the specific 
> requirement (why? because GSM/GPRS standards have no standard 
> provision for interactive text), so you end up with these 
> kinds of regulatory solutions. I haven't seen any of the 
> operators in the UK being very happy about this! They would 
> by far prefer to have one mainstream infrastructure that is 
> able to fulfill all the requirements. Also, such solutions, 
> being by definition not part of their standard 
> infrastructure, require network operators to install and 
> maintain proprietary nodes and software in their networks, 
> which as you'll understand, is not exactly favoured by them 
> either. It also is in the continuous danger of being broken 
> by any mainstream developments, installation of new hard- and 
> software on the main network etc, etc.
> 
> If, however, we are able to think out of the box this time we 
> should be able to prevent this situation from repeating 
> itself by providing a MAINSTREAM solution that will at the 
> same time deal with the problems of specific requirements.
> 
> SMS on the mobile platform has proved beyond any doubt that 
> there exists a HUGE market, NOT just for people with 
> disabilities, but for ALL users, for texting. The popularity 
> of texting in Europe and Japan is beyond all expectations. It 
> is therefore reasonable to state that the ability to use text 
> to communicate:
> a) mandatory if you want to roll out next generation services 
> since users will not accept the loss of such service
> b) has to be part of the standard network and terminal 
> provision: it is unthinkable to operate a modern mobile 
> network that would not support SMS and I am not aware of any 
> handsets currently on the market that do not support SMS.
> 
> Furthermore, the success of SMS is strongly linked to the 
> fact that it is basic part of the mobile protocols. Every 
> standard GSM supports it since it is part of the standard. 
> Initially, operators blocked access from other providers so 
> that SMS could not be send across network boundaries. It was 
> only when those restrictions were lifted and users could 
> freely send text around that SMS really took off. We should 
> learn valuable lessons from all this. Especially in a moment 
> in time that the telecommunication sector is suffering hard, 
> it is mandatory to get the requirements and standards right. 
> The cost of getting it wrong will be extremely high.
> Making sure that any future networks and services offer an 
> improved interactive texting feature therefore is extremely 
> sound reasoning. What we are proposing as a solution is 
> extremely light-weight, easy ti implement, readily available, 
> cheap, does not impose any burdens on manufacturers or 
> operators, and most importantly is the best possible solution 
> from a purely BUSINESS point of view. It is one of these rare 
> situations where everybody is a winner.
> 
> <<Any such MUST would surely need to be qualified anyway. If 
> the purpose of the devise is such that it renders a textual 
> devise irrelevant, then why require one to be fitted.>>
> 
> I have no objection against qualifying, maybe in the sense 
> that Henry proposes. But the network MUST fully support, in a 
> standardised way, setting up interactive sessions between any 
> two nodes and carrying the conversation. Devices might not 
> have a keyboard or display (although I can't imagine selling 
> a phone without display in these days of mobile 
> communications, except for niche markets and that is not very 
> interesting for manufacturers anyway), but users might opt to 
> fit one later.
> 
> <<Suppose we were designing a SIP phone for the totally 
> blind, and this was designed to be worn as a headset, a text 
> device would be irrelevant to such a user, and positioning 
> such a device where it could be seen would require an extra 
> box hanging out of the side of the product.>>
> 
> RNID believes that it is far better to design an 
> off-the-shelf device in such a way that it is able to support 
> deaf, hard of hearing, speech impaired or visually impaired 
> people. Deaf, hard of hearing, blind,... people could then 
> easily buy ANY off-the-shelf phone and fit it with a headset, 
> probably connected to the phone via Bluetooth. That would:
> b) prevent them from being marginalised through the use of 
> special equipment (just think about the link with hearing aids...)
> 
> Surveys amongst people with disabilities show that this is a 
> major requirement: people with disabilities do not want to be 
> considered "special" users. They want access to the same 
> products and services as any other individual.
> 
> The provision of such headsets as you mention, BTW, is not 
> only for the benefit of visually impaired people. These days, 
> I see much more non-disabled people walking around with their 
> Bluetooth handsets than visually impaired people. The use of 
> SMS by deaf and hard of hearing people is another such 
> example: no one would claim that SMS is only for those users. 
> Yet, they take advantage of a MAINSTREAM provision which 
> happens to suit their abilities and preferences. Hearing 
> people in noisy circumstances or in situations where they 
> cannot use voice will also revert to text in some 
> circumstances. The whole concept of "special" equipment is 
> well out of fashion these days.
> Let's build mainstream technology so that it suits as much 
> users as possible, regardless of their abilities and 
> preferences. It will be to the benefit of ALL.
> Best regards,
> 
> Guido
> 
> 
> 
> Guido Gybels

---

From: "Guido Gybels" <[email-masked]>
Date: Thu, 12 Jun 2003 10:52:24 +0100

Keith and all,

<<First of all, my comment was in response to a comment being made on the sip devices document. I understand the scope of that document to be terminals, not network type equipment, and therefore it is axiomatic that my comment also is within that scope. My comment has nothing whatsoever to do with any requirements, or absence of requirements, for support from network type equipment, which seems to be implied by a substantial part of your response.>>

The point being that one cannot dislodge the terminal considerations from the network ones, neither can you isolate them from the overal user functionality required. The famous discussions on the RTTE directive in groups like TCAM and COCOM surely have proven this point?
The ability of terminals, i.e. SIP devices to support carrying or accessing interactive text services therefore has to take that into account. Even if a device does not offer a screen or a full keyboard, it might be hooked up to one. Or might need to relay text. We cannot predict what the future will bring.

<<As regards provision of specialised terminal equipment for disabled, I do agree with you that ideally standard off the shelf equipment should be designed with the disabled in mind, thus allowing the disabled to make use of production level pricing and so on (all the reasons you have quoted). Your comments however do not eliminate the need for specialised equipment to exist, and my comment was trying to identify that writing a straight MUST could preclude some of that equipment from existing, e.g. by virtue of the mandatory provisions for one kind of disability overriding sensible design decisions for the specialised support of another kind of disability.>>

You need to differentiate between assistive devices and end user equipment. While it is certainly necessary to continue to develop assistive devices as alternatives for those users who cannot be catered for otherwise, the main focus should be on inclusive design for mainstream technology. The solution is not to design mainstream technology as minimalist as possible and then having to build assistive technology to support users with different abilities and preferences. So, I think we should state "MUST" and provide a clearly defined exception rule that could cover what you are alluding at. The rule should be to support it and provide exceptions where applicable, not the other way around IMHO.

So, to recap, I believe we should state that all devices MUST support interactive texting, EXCEPT for a clearly defined domain of exceptions.

<<This then raised in my mind as to whether this was the appropriate document to try and represent such a requirement in the first place. It is a difficult requirement to represent>>

Which is a reason for having it here as well as in other relevant places. As I said, it is not a problem that is limited to either network or terminal side. It is by definition an overall issue.

<<This however is a voluntary standard>>

IMO, standards, by default, are being based on voluntary agreement between stakeholders. Even if legislators and regulators can use them as a basis for legislation and regulations.

<<will not even be called up by 3GPP SIP specifications, which carry their own requirements in this area.>>

Yes, but GTT is not exactly an example of how things should be done. It certainly is very unsuitable for most of Europe as a solution. I don't want this document to make the same mistakes.
Best regards,

Guido

Guido Gybels

---

From: "Guido Gybels" <[email-masked]>
Date: Mon, 16 Jun 2003 08:30:50 +0100

Henry,

<<This is a very usefyl reference! It does not say "ALL" or "MUST", but "terminals offering real time text conversation should support ITU-T
Recommendation T.140". I guess in IETF language the "should" would be "SHOULD".>>

I respectfully suggest that it is not because there exist already a number of incomplete or even bad solutions today, that we should refrain from improving. Taking 3G's GTT as an example won't get us anywhere either since that is a solution that is completely unfit for the European market.
I strongly suggest we look again at my previous suggesting: make it MUST, except for well defined exceptions. That allows to harmonize interactive texting while still allowing for specific cases not to support it. It certainly is the most robust business solution and makes sense as a mainstream solution as well.
Best regards,

Guido

Guido Gybels

---

From: "Peterson, Jon" <[email-masked]>
Date: Mon, 16 Jun 2003 20:05:25 -0400

I'm uncomfortable with the suggestion that RFC2793 be mandatory as a payload
format for SIP telephone device implementations. Mr. Drage has already
articulated several of the reasons I would put forward (i.e. some telephones
need not support textual communication at all). I might add that alternative
methods of sending textual information in the PSTN today (like SMS or
similar instant messaging systems) have enjoyed profound adoption and
marketshare that has not been rivaled by T.140, in my experience anyway.

The SIP community has not been particularly enthusiastic about the RFC2793
paradigm in the past - and we have considered it for some applications. UNIX
talk does not dominate textual communication in the modern Internet for a
number of reasons - lack of an intelligible strategy for conferencing (which
IRC and its numerous descendents, including AOL, MSN, and Yahoo messengers,
easily mastered) being one obvious problem. Presumably, RFC2793 has the same
NAT traversal and security properties as baseline RTP (i.e. STUN and sRTP
are applicable), but I'm not sure if the latter is currently required for
sip devices (and note that sharing keying material for RTP is still a
somewhat controversial subject). The desired immediacy of T.140 would also,
I imagine, be somewhat compromised by the crude manner in which we are
compelled to 'dial' letters into virtually all telephones today (in which it
takes much longer to reach 's' than 'p'). If we are to mandate or even
encourage any means of textual communication in telephone devices, I think
it should more closely correspond to the irrefutable direction of the
marketplace - the instant messaging paradigm.

I would categorically oppose mandating RFC2793 to the exclusion of, say, the
outcome of SIMPLE's instant messaging sessions work.

Jon Peterson
NeuStar, Inc.

> Sent: Monday, June 16, 2003 12:31 AM
> To: [email-masked]
> Subject: RE: [Sipping] Text support in SIP phones
> 
> 
> Henry,
> 
> <<This is a very usefyl reference! It does not say "ALL" or 
> "MUST", but "terminals offering real time text conversation 
> should support ITU-T
> I respectfully suggest that it is not because there exist 
> already a number of incomplete or even bad solutions today, 
> that we should refrain from improving. Taking 3G's GTT as an 
> example won't get us anywhere either since that is a solution 
> that is completely unfit for the European market.
> I strongly suggest we look again at my previous suggesting: 
> make it MUST, except for well defined exceptions. That allows 
> to harmonize interactive texting while still allowing for 
> specific cases not to support it. It certainly is the most 
> robust business solution and makes sense as a mainstream 
> solution as well.
> Best regards,
> 
> Guido
> 
> 
> 
> Guido Gybels

---

From: "Guido Gybels" <[email-masked]>
Date: Tue, 17 Jun 2003 15:26:44 +0100

Michael,

<<Personally speaking, and maybe I have ADD, but I would find watching  someone type mildly interesting in the short run, but as boring as watching  grass grow in the long run.>>

To be quite frank about this, I was speaking about what deaf and hard of hearing people want as a group, not necessarily what you or I want as individuals or as techies. Believe me, I have argued a lot about this and talked about IM with them etc. The point is that if it doesn't suit their requirements, we have to accept that. The technology should adapt to the user, not the other way around.
Apart from that, you have however missed my most important point, namely the use of a relay service. When a deaf person wants to talk to a hearing person over the relay service, the IM model simply does not work. The operators will be speaking to the hearing party as words come through and type back to the deaf users almost simultaneously as the voice from the hearing party comes true. That is the closest deaf and hard of hearing people can get. We have done trials with our gateway and RNID Typetalk using deaf and hard of hearing people and the number 1 item was that the message style conversation didn't work for them at all in that scenario. I think we should accept that the user requirements are the predominant driving factor here, not what we would like to develop. I'll leave it to Arnoud, who is deaf, to comment on this from the user perspective, but based on our research, I'm quite sure I'm right about this.
As to finding it boring: I have actually used both systems and to be honest I find IM much more frustrating than character-by-character. I accept that my individual judgement doesn't constitute relevant data, but neither does your personal assessment of it being boring. Let's accept that user requirements drive this.

<<I would more likely turn my attention to other tasks at work and come back later when they are done typing.>>

Which misses the point about using text as an equivalent to voice altogether, I'm afraid. Deaf people are not using text as an additional medium, it is their version of talking to someone over the phone. I would respectfully suggest that we therefore allow *them* to odentify what they want as users, rather than having us tell them what they want.

<<So, I'm not so sure we can draw well-founded conclusions based on some anecdotal evidence.>>

Excuse me, the trials we have conducted recently and in the past, as well as the experience of 10 years of running RNID Typetalk constitute quite relevant expertise. That is quite different to individuals in here voicing their personal opinions and speaking on behalf of deaf and hard of hearing people.
There is currently a research project going on under the auspices of TAG in the UK, using independent researchers to verify the current assumptions and user requirements. I'm more than happy to publish those results to IETF when they become available. I take it that you all then agree to accept the outcome of that independent research? Do I have a commitment on that??

<<I'm sure those (on both sides) that had no choice have a strong affinity to what they are used to,  but I'm not so sure which they would choose if both were available.>>

You miss the point that hundreds of thousands of deaf people DO use IM. As they use other text based solutions in mainstream technology. And they say to us clearly that it doesn't meet their needs. So, I accept that the users are telling me what they need/want. Not the other way around.

Best regards,

Guido

Guido Gybels

---

From: Michael Hammer <[email-masked]>
Date: Tue, 17 Jun 2003 11:10:06 -0400

Guido,

Please don't get so defensive.

You missed the whole point of my statement, which has little to do with 
what deaf people prefer, and everything to do with what non-deaf people 
might prefer, if both parties were using text-based near-real-time 
communications.

I was responding to your suggestion that non-deaf users would also prefer 
the character-by-character mode of operation.  I was simply disagreeing 
with that assertion.  I was also up front that mine was simply an 
individual opinion.

The studies that you cite seemed to be focused on determining what the deaf 
experience, and your added comments concerning non-deaf experience appeared 
anecdotal.  I was merely suggesting that the experiences of both sides of 
the communication should be taken into account, for both the asymmetrical 
(text/voice) and symmetrical (both text) types of exchanges.

Your point about the nature of the experience when dealing with the 
situation where one party is using text and the other is using voice is a 
key distinguishing factor.

I appreciate the education I am getting by following the discussion.  But, 
please don't attack me for questioning what the studies are really saying 
based on the limited information provided thus far, or for exploring 
alternative experiences and opinions.

Mike

At 03:26 PM 6/17/2003 +0100, Guido Gybels wrote:
>Michael,
>
><<Personally speaking, and maybe I have ADD, but I would find 
>watching  someone type mildly interesting in the short run, but as boring 
>as watching  grass grow in the long run.>>
>
>To be quite frank about this, I was speaking about what deaf and hard of 
>hearing people want as a group, not necessarily what you or I want as 
>individuals or as techies. Believe me, I have argued a lot about this and 
>talked about IM with them etc. The point is that if it doesn't suit their 
>requirements, we have to accept that. The technology should adapt to the 
>user, not the other way around.
>Apart from that, you have however missed my most important point, namely 
>the use of a relay service. When a deaf person wants to talk to a hearing 
>person over the relay service, the IM model simply does not work. The 
>operators will be speaking to the hearing party as words come through and 
>type back to the deaf users almost simultaneously as the voice from the 
>hearing party comes true. That is the closest deaf and hard of hearing 
>people can get. We have done trials with our gateway and RNID Typetalk 
>using deaf and hard of hearing people and the number 1 item was that the 
>message style conversation didn't work for them at all in that scenario. I 
>think we should accept that the user requirements are the predominant 
>driving factor here, not what we would like to develop. I'll leave it to 
>Arnoud, who is deaf, to comment on this from the user perspective, but 
>based on our research, I'm quite sure I'm right about this.
>As to finding it boring: I have actually used both systems and to be 
>honest I find IM much more frustrating than character-by-character. I 
>accept that my individual judgement doesn't constitute relevant data, but 
>neither does your personal assessment of it being boring. Let's accept 
>that user requirements drive this.
>
>Which misses the point about using text as an equivalent to voice 
>altogether, I'm afraid. Deaf people are not using text as an additional 
>medium, it is their version of talking to someone over the phone. I would 
>respectfully suggest that we therefore allow *them* to odentify what they 
>want as users, rather than having us tell them what they want.
>
>Excuse me, the trials we have conducted recently and in the past, as well 
>as the experience of 10 years of running RNID Typetalk constitute quite 
>relevant expertise. That is quite different to individuals in here voicing 
>their personal opinions and speaking on behalf of deaf and hard of hearing 
>people.
>There is currently a research project going on under the auspices of TAG 
>in the UK, using independent researchers to verify the current assumptions 
>and user requirements. I'm more than happy to publish those results to 
>IETF when they become available. I take it that you all then agree to 
>accept the outcome of that independent research? Do I have a commitment on 
>that??
>
><<I'm sure those (on both sides) that had no choice have a strong affinity 
>to what they are used to,  but I'm not so sure which they would choose if 
>both were available.>>
>
>You miss the point that hundreds of thousands of deaf people DO use IM. As 
>they use other text based solutions in mainstream technology. And they say 
>to us clearly that it doesn't meet their needs. So, I accept that the 
>users are telling me what they need/want. Not the other way around.
>
>Best regards,
>
>Guido
>
>
>
>Guido Gybels

---

From: Michael Hammer <[email-masked]>
Date: Wed, 18 Jun 2003 12:28:49 -0400

Arnoud,

Are you saying that two users' characters can not cross on the wire with 
interactive text systems?

Also, I never said I hated it.  Please don't put words in my mouth.  I 
simply said that I preferred having a chance to edit my thoughts on screen 
before sending.  I also wanted to know the basis of your generalization 
from the preferences of one group to another group of people.

Even without that, I support doing interactive text because there is a need.

Mike

At 03:58 PM 6/18/2003 +0200, A vWijk wrote:
>Michael,
>
>And my point is that the real-time text conversation is for ALL users.
>Hearing users DO like to know if the other person is actually typing or 
>not. Very often IM messages cross each other. Becuase the other user was 
>taking so much more time to reply, that the original sender is already 
>adding additional stuff or even questions.
>That happens very very often between hearing IM users (or hearing /deaf 
>etc etc).
>Yahoo messenger and some other IM clients now have an indicator when the 
>other user is typing.
>Also some IM clients offer a chat mode in IRC style. Which allows for 
>quicker and more interactive conversation. But it still goes line by line 
>with the mixups.
>
>The above shows that most users will like the ability to communicate in 
>real-time using text. And those are hearing users!
>
>Hence, I URGE all IM designers/programmers to include real-time streaming 
>text. And use RFC 2793 so that any client can interwork with any other client.
>
>greetz
>
>Arnoud
>
>PS. I am so strong about this because I see how important this real-time 
>streaming text is. So any comments are not directed to the persons 
>personally. Everybody is free to have his or her own opinions. You are 
>free to hate streaming text, but realise that there is a huge user base 
>who dearly want streaming text.
>
>International text telephone: +31735588408
>
> >>> Michael Hammer <[email-masked]> 06/17/03 05:10pm >>>
>Guido,
>

---

From: "Guido Gybels" <[email-masked]>
Date: Thu, 19 Jun 2003 08:26:29 +0100

Michael,

<<Please don't get so defensive.>>

It's not a matter of getting defensive. What's happening is that we've voiced a specific requirement for character-by-character interactive text. The case for deaf people is clear, even if it seems that some of us are still trying to lecture deaf people about what they want rather than accepting that the users define their requirements. I've also argued that such a requirement should be brought into mainstream technology because that is the only way you're going to be able to move away from the current position where text telephony is cumbersome, lack interconnectivity and availability and is done using crude and overly expensive devices.
What would you hearing people say if you could only phone to someone on the same network, provided they had the same or a similar phone terminal on their desk and that thing would cost 400 quid?

I've also stated that I believe that asking for such mainstream support for interactive texting makes sense as a business case too. While it is true that muy organisation has focussed its research on deaf and hard of hearing people, and therefore our findings will reflect the needs of this group, it is untrue that these findings would not have any correlation with mainstream users. The group of deaf and hard of hearing people is a very substantial one. In the UK 1 in 7, 9 million, individuals are affected by deafness and hearing loss. These are not all profoundly deaf people, but they are, as a group, as varied as society itself.

What I do know is that the only relevant research as to what user requirements are in terms of buffered versus character-by-character comes from deaf and hard of hearing organisations. If research is lacking with regard to the whole of society, I respectfully suggest that is because you, the industry, have simply not bothered researching it. It's a shambles that my organisation, as a charity, with limited charitable resources, would have to provide relevant data for a group that does not belong to our constituancy in the first place, while the industry does not care about relevant data, except to dismiss well-founded claims from an organisation like RNID, while having failed for 20 years in collecting relevant data to back up their own claims.

In the mean time, the politics here seem to matter more than the exclusion of a big group of people who are already being severly disadvantaged in a society where the ability to communicate freely is absolutely essential in order for them to fully participate in that Information Society. I hope you won't mind me pointing to you all as being responsible for some of the barriers deaf and hard of hearing people will face in the next decade if we would fail to do this properly? I have no multi-million pound budgets, nor do I have big marketing departments and strings of lawyers to my disposal to fight you all on this. I can only ask that you open your eyes for the reality with which I have to deal on a daily basis.

The requirement we are asking for is extremely lightweight, as Henning acknowledges. It makes perfectly sense to make it a provision that is as basic as SMS on mobile phones, i.e. by default supported, unless there is a good case not to. Surely, as a group of skillled and knowledgeable people, we are able to define clearly which device categories do not require this extremely lightweight provision to be build in? 

If you maintain that you know better what that deaf and hard of hearing people want, and that these people are all wrong or have all been doing the wrong thing over the last decade, than I invite you and the others who doubt what I am stating, to attend the TAG seminar on text telephony that will take place in the Autumn in London. It will be chaired by deaf people and deaf people will speak about what they want and what they need.

I therefore repeat my question that has remained unanswered so far: is this group prepared to accept the requirements of deaf people or not?

Best regards,

Guido

Guido Gybels

---

From: "Guido Gybels" <[email-masked]>
Date: Thu, 19 Jun 2003 08:38:28 +0100

Henning,

Thanks for the comments!

<<This is a generalization of the 'is typing' status indication commonly found on commercial IM systems.>>

Indeed, my IM system does provide that. But interactivity does not end with being able to see that the user is typing. That is only 1 aspect of it. What people keep missing here is the point that deaf people use text as an equivalent to voice, with all the characteristics that this brings with it, including realtime flow of the conversation and the option to interrupt or barge in. IM simply does not offer that.

<<I have no data to back this up, but I suspect that familiarity of the two parties and text communications may influence the preference for 
message or character mode. If you do this a lot, you either become very good at typing or you don't care if things look a bit jumbled.>>

The point being that if you're deaf you don't have a choice! The request to be able to communicate using text as en *equivalent* to voice (and not as an additional modality as it is for hearing people) is crucial. It is also required for relay services.

<<I probably would find a more spontaneous mode more appropriate if 'talking' to my son.>>

Voice conversations are spontaneous when compared to written, more formal communications. In using text as a substitute for voice, the interactive and spontaneous nature of the conversation is critical in order to get the equivalent experience.

<<I'm also somewhat confused as to why this is an either-or proposition.>>

Well, it is certainly nor an either-or option in my view. I have stated clearly that I have absolutely no problems with IM. On the contrary, I personally use it a lot. I'm just stating that providing an interactive text provision as a *basic* and *standardised* feature is crucial if we want to move deaf and hard of hearing people into mainstream technology.

<<2793 is pretty light-weight, so this is hardly an undue burden to implement.>>

Which was exactly the point I have been making for a while now and I'm very happy that someone of your reputation supports that assessment. I must say that I'm puzzled as to why others are so scared of it, since it is that light-weight and easy to implement anyhow. You would think that the industry would be happy that they can deliver inclusion at such negligible cost.

All the best,

Guido

Guido Gybels

---

From: "Peterson, Jon" <[email-masked]>
Date: Thu, 19 Jun 2003 03:15:39 -0500

> I'm sorry, we're missing the point here. SMS is not a viable 
> alternative to realtime communication for deaf and hard of 
> hearing people. It is not the equivalent of voice for hearing 
> people. It is an additional modality that deaf people do use, 
> because it fits their abilities and preferences. 

I think it is important to distinguish between abilities and preferences. It
is not my preference, for example, to use G.711 for audio communications -
its fidelity is pretty poor. My preference would be to use a wideband codec,
like L16. For that matter, I have a hard time understanding why I still need
to communicate via telephones at all - I would prefer a fully immersive
virtual reality rig. Nokia folks, where is that on your release calendar?

But to return to my more modest ambition, why am I stuck with G.711 rather
than L16 in the PSTN? Because G.711 is ubiquitous and entrenched, and it is
sufficient for audio communications. Similarly, SMS is ubiquitous and
entrenched, and it is sufficient for textual communication. I don't think it
will be easy to persuade this group that any alternative to RFC2793 is not
'viable'. Instant messaging is obviously and eminently viable, even if it
isn't ideal from an aesthetic perspective.

> However, to 
> communicate interactively using text. especially with a relay 
> service, you need a character-by-character interactive 
> communication. We are running a pilot and experiments 
> comparing character-by-character conversations between deaf 
> text users and hearing people over the RNID Typetalk relay 
> service, and it is clear that message based communications do 
> not fulfil there needs at all.

The relay service is an interesting case, and one that I think highlights
some of the difficulties with these arguments for text channels. In order
for a (human or robotic) operator at a relay service to vocalize textual
communications, they need more than a single character - I don't think these
operators can plausibly sound out words on a character-by-character basis.
Some minimal number of phonemes need to be acquired by the relay before it
can vocalize - and in Indo-European languages, to provide correct inflection
to speech, several words worth of context are probably necessary.

Instant messaging users often parcel complex utterances into multiple
messages to avoid the IM equivalent of an awkward silence.

<jon> ok
<jon> wait a minute
<jon> if you think this is too long
<jon> we can divvy it up into little parts
<jon> it'll be easier to understand that way

Users could also elect to concatenate those fragments into a single message,
of course, but the point is that instant messaging admits of levels of
granularity chosen by the sender.

> With regard to T.140, there can hardly be any market 
> assessment since it is simply not commonly available, unlike 
> SMS for instance.
> 

Character-by-character network transmission is, from my persepective, not a
new idea entering the market - it is an idea that was briefly the de facto
standard for UNIX-to-UNIX communication before the rollout of EFnet and the
golden age of IRC. talk(1) had its chance at market dominance, and I believe
there are clear reasons why it was obsoleted by modern IM systems (one issue
I mentioned before, conferencing, I won't explore in further detail here).

For one thing, managing typos in these systems is always problematic. I
would often watch someone type out most of a sentence and then change their
mind and backspace over the whole thing (if backspace worked in that
terminal type - more often than not it led to patches ^H^H^H^H across the
screen). People like myself who compulsively rework what they are typing
make frustrating conversationalists in that medium. I also found that
two-way character-by-character transmission led to a lot of simultaneous
typing, balking, waiting for the other person to continue with their thought
or to defer to you - the social mechanics seemed quite awkward.

Issues with typos would be compounded, I would think, by any kind of relay
service that vocalized on a character-by-character basis. What sound would
an automaton produce in response to a backspace? Is there an audio
equivalent of ^H? 

> <<The SIP community has not been particularly enthusiastic 
> about the RFC2793 paradigm in the past - and we have 
> considered it for some applications.>>
> 
> First of all, when hearing people are being put in front of 
> an interactive text based system like the ones based on 
> T.140, they love it. The feeling of interactivity is much 
> greater than with things like IM. But if users simply have no 
> choice, sure than there is no market...
> 

The lack of supply might be credibly attributed to a lack of demand. *NIX is
far more prevalent and available to common users today than it was in the
early nineties (gratis to Mr. Torvalds & co). 'talk' has no doubt been
grandfathered into any number of modern operating systems. Somehow it
doesn't seem to have provided a real challenge to the ten of millions of
users boasted by any of the large commercial instant messaging systems.
Given the sheer diversity of start-ups targeting the instant messaging
space, if emulation of UNIX 'talk' were a positive differentiating factor,
surely someone would have offered it by now?

[snip]
> (in which it takes much longer to reach 's' than 'p').>>
> 
> We are already looking at solutions for that, like 
> (configurable) word based buffering on mobiles for instance, 
> so that you can use small keyboards and predictive texting. 
> Also, heavy text users might opt to connect larger keyboards 
> to the system and I know at least one BT foldable keyboard 
> for use with a mobile phone. SIP deskphones can have a 
> full-size keyboard added to them where required.
> 

I agree that once the device is no longer strictly a telephone (and is
effectively a personal computer with a keyboard etc), there are good
arguments for encouraging and even mandating all sorts of supported media
types. But this does not entail that RFC2793 should be mandatory for vanilla
telephone devices.

> <<If we are to mandate or even encourage any means of textual 
> communication in telephone devices, I think it should more 
> closely correspond to the irrefutable direction of the 
> marketplace - the instant messaging paradigm.>>
> 
> I'm not so sure that direction is so irrefutable as you claim 
> it to be. The truth is that IM still is hampered by the whole 
> interconnectivity issue and that users have not really had 
> any choice so far. Releasing applications that do offer an 
> alternative to IM by providing more character-by-character 
> based implementations while providing interconnectivity with 
> existing IM systems as well as legacy TTYs (like the current 
> RNID pilot which will go public early 2004 and might even be 
> offered license free) might change the current picture dramatically.
> If I would get a penny for every time someone in technology 
> has claimed something was never going to happen and was 
> proven incorrect afterwards
> 

The suggestion above that RNID, at some future time, might not be offered
'license free' rings a few additional alarm bells with me. I am even less
comfortable mandating something for all SIP telephones that will require
royalty payments.

> <<I would categorically oppose mandating RFC2793 to the 
> exclusion of, say, the outcome of SIMPLE's instant messaging 
> sessions work.>>
> 
> I don't think that is what anyone is asking for. There is no 
> reason at all why SIMPLE and RFC2793 cannot live together 
> simultaneously. They are simply separate issues. Remember 
> though that, certainly in Europe, IM will *not* fulfil the 
> legal and regulatory obligations on service providers and 
> manufacturers and that those obligations will become even 
> more strict with the implementation of the famous 4 EC 
> Directives on Communication which is now taking place in all 
> the member states and should be completed over the next 
> couple of months. RFC2793 will comply with those 
> requirements. It's up to the community to decide whether or 
> not they want to be burdened by more regulation or 
> legislation or whether they will try to fulfil those 
> requirements through mainstream solutions that will benefit 
> their business case.

I would note that it is not the philosophy of the IETF to cater to
regulations that contradict market direction and our WGs' technical
judgment.

> As ever,

---

From: "Guido Gybels" <[email-masked]>
Date: Thu, 19 Jun 2003 10:35:01 +0100

Jon,

<<I think it is important to distinguish between abilities and preferences.>>

Indeed.

<<Similarly, SMS is ubiquitous and entrenched, and it is sufficient for textual communication.>>

I find that one of the most arrogant and insulting statements to deaf people that I have seen in quite a while. Deaf people cannot use SMS as a substitute to text conversation. Your implicitly saying that they shouldn't expect any better, even if it doesn't meet their requirements. SMS is an available service. Hearing people use it. So do deaf people. But that has absolutely nothing to do with their requirements to use text as an equivalent to voice.

<<I don't think it will be easy to persuade this group that any alternative to RFC2793 is not 'viable'. Instant messaging is obviously and eminently viable, even if it isn't ideal from an aesthetic perspective.>>

I find it offensive, even as a hearing person (albeit one that works with deaf people all day) to decide on behalf of deaf people about what they want or need. I suggest strongly that you leave it to them to decide what their requirements are and I believe you are mnistaken if you think the majority of this group would support the view that it is up to hearing people to decide what deaf people need. Deaf people have already established that IM is not able to meet their needs, not in the least because of the requirement to use relay services to communicate with hearing people. If you want to discuss on mainstream markets, fine, but please refrain from patronising deaf and hard of hearing people or dictating to them what they need.

>>The relay service is an interesting case, and one that I think highlights some of the difficulties with these arguments for text channels. In order
for a (human or robotic) operator at a relay service to vocalize textual communications, they need more than a single character - I don't think these operators can plausibly sound out words on a character-by-character basis.>>

The operator will certainly type almost in RT what is being said, character by character and not word by word. The other way around is difficult enough to achieve in a transparent way with character-by-character, let alone on a sentence base. For practical reasons, it will have to be utterance based, or word or part-of-word based, depending on context. It certainly requires training. But maybe you should visit some relay operators and deaf people and use it on a daily basis for some months before making assumptions on what works and what doesn't.

I'll repeat that we have experience from the gateway pilot and that the clear and ambiguous feedback is that buffered messaging just doesn't work for relay services.

I suggest it is left to deaf people and to organisations like RNID to formulate what this group wants.

<<Some minimal number of phonemes need to be acquired by the relay before it can vocalize - and in Indo-European languages, to provide correct inflection to speech, several words worth of context are probably necessary.>>

I speak 6 Indo-European languages and I have seen relay working in most of them and they certainly don't require several words to vocalise. Relay services are certainly not perfect, but it is as close as it can get to seamless communication between text and voice. Let me suggest that you leave it to relay operators like RNID Typetalk, operating 24/24, 7/7, every day of the year. There is constant research and development done here for at least a decade now and there is also constant discussion going on with the users through user panels and research.

<<-snip- of orthogonal discussion>>
<<The lack of supply might be credibly attributed to a lack of demand.>>

LOL! Tell that to the deaf community. Seldom have I seen such a display of ignorance about how deaf people communicate and what their needs are than in the above. I'm not trying to be offending, but I simply have no better way of describing it.

<<But this does not entail that RFC2793 should be mandatory for vanilla telephone devices.>>

It does if you accept that the ability to use text as an equivalent to voice is essential for deaf people to participate fully in our information society. If you don't care about that, it probably doesn't need to be mandatory.

<<The suggestion above that RNID, at some future time, might not be offered 'license free' rings a few additional alarm bells with me. I am even less comfortable mandating something for all SIP telephones that will require royalty payments.>>

??? I have no idea what you are talking about, I was merely stating that RNID is willing to offer the result of their research and developments to the PUBLIC (in which after all charitable money is being invested) for FREE. There is no talk about royalty payments whatsoever, I don't know what you read in my words, but you could not be further of the mark. RNID is not a commercial organisation, we are a CHARITY for Christ' sake! I am not aware of RFC2793 requiring any royalties at all. It is typical that people would read something in there that was not present in what I said, neither explicitly nor implicitly.

<<I would note that it is not the philosophy of the IETF to cater to regulations that contradict market direction and our WGs' technical judgment.>>

There is nothing contradictory to the market direction. That is rubbish. We are talking plainly and simply about making sure a big user group is not being further excluded and disadvantaged in society. I'm amazed by the hostility that you have aired in this message towards such a goal of inclusion. I would have thought everybody would have benefitted from being able to bring these users in the mainstream market. How that can be perceived as being opposite to the market direction I don't know, but that is probably because I'm incompetent.

Guido

Guido Gybels

---

From: "Chris Boulton" <[email-masked]>
Date: Thu, 19 Jun 2003 12:58:27 +0100

Guido,

	Maybe it would be an idea for your research to be made available
to the group - thus allowing a range of information for members with
less experience in this area and to provide a balanced opinion.

Chris.

>Sent: 19 June 2003 10:35
>To: [email-masked]; [email-masked]
>Cc: [email-masked]
>I find that one of the most arrogant and insulting statements to deaf
>people that I have seen in quite a while. Deaf people cannot use SMS as
a
>substitute to text conversation. Your implicitly saying that they
shouldn't
>expect any better, even if it doesn't meet their requirements. SMS is
an
>available service. Hearing people use it. So do deaf people. But that
has
>absolutely nothing to do with their requirements to use text as an
>equivalent to voice.
>
><<I don't think it will be easy to persuade this group that any
alternative
>to RFC2793 is not 'viable'. Instant messaging is obviously and
eminently
>viable, even if it isn't ideal from an aesthetic perspective.>>
>
>I find it offensive, even as a hearing person (albeit one that works
with
>deaf people all day) to decide on behalf of deaf people about what they
>want or need. I suggest strongly that you leave it to them to decide
what
>their requirements are and I believe you are mnistaken if you think the
>majority of this group would support the view that it is up to hearing
>people to decide what deaf people need. Deaf people have already
>established that IM is not able to meet their needs, not in the least
>because of the requirement to use relay services to communicate with
>hearing people. If you want to discuss on mainstream markets, fine, but
>please refrain from patronising deaf and hard of hearing people or
>dictating to them what they need.
>
>communications, they need more than a single character - I don't think
>these operators can plausibly sound out words on a
character-by-character
>basis.>>
>
>The operator will certainly type almost in RT what is being said,
character
>by character and not word by word. The other way around is difficult
enough
>to achieve in a transparent way with character-by-character, let alone
on a
>sentence base. For practical reasons, it will have to be utterance
based,
>or word or part-of-word based, depending on context. It certainly
requires
>training. But maybe you should visit some relay operators and deaf
people
>and use it on a daily basis for some months before making assumptions
on
>what works and what doesn't.
>
>I'll repeat that we have experience from the gateway pilot and that the
>clear and ambiguous feedback is that buffered messaging just doesn't
work
>for relay services.
><<Some minimal number of phonemes need to be acquired by the relay
before
>it can vocalize - and in Indo-European languages, to provide correct
>inflection to speech, several words worth of context are probably
>necessary.>>
>
>I speak 6 Indo-European languages and I have seen relay working in most
of
>them and they certainly don't require several words to vocalise. Relay
>services are certainly not perfect, but it is as close as it can get to
>seamless communication between text and voice. Let me suggest that you
>leave it to relay operators like RNID Typetalk, operating 24/24, 7/7,
every
>day of the year. There is constant research and development done here
for
>at least a decade now and there is also constant discussion going on
with
>the users through user panels and research.
>
>LOL! Tell that to the deaf community. Seldom have I seen such a display
of
>ignorance about how deaf people communicate and what their needs are
than
>in the above. I'm not trying to be offending, but I simply have no
better
>way of describing it.
>It does if you accept that the ability to use text as an equivalent to
>voice is essential for deaf people to participate fully in our
information
>society. If you don't care about that, it probably doesn't need to be
>mandatory.
>
><<The suggestion above that RNID, at some future time, might not be
offered
>royalty payments.>>
>??? I have no idea what you are talking about, I was merely stating
that
>RNID is willing to offer the result of their research and developments
to
>the PUBLIC (in which after all charitable money is being invested) for
>FREE. There is no talk about royalty payments whatsoever, I don't know
what
>you read in my words, but you could not be further of the mark. RNID is
not
>a commercial organisation, we are a CHARITY for Christ' sake! I am not
>aware of RFC2793 requiring any royalties at all. It is typical that
people
>would read something in there that was not present in what I said,
neither
>explicitly nor implicitly.
>
><<I would note that it is not the philosophy of the IETF to cater to
>judgment.>>
>There is nothing contradictory to the market direction. That is
rubbish. We
>are talking plainly and simply about making sure a big user group is
not
>being further excluded and disadvantaged in society. I'm amazed by the
>hostility that you have aired in this message towards such a goal of
>inclusion. I would have thought everybody would have benefitted from
being
>able to bring these users in the mainstream market. How that can be
>perceived as being opposite to the market direction I don't know, but
that
>is probably because I'm incompetent.
>
>Guido
>
>
>
>Guido Gybels

---

From: "Guido Gybels" <[email-masked]>
Date: Thu, 19 Jun 2003 13:06:07 +0100

Chris,

<<Maybe it would be an idea for your research to be made available to the group - thus allowing a range of information for members with
less experience in this area and to provide a balanced opinion.>>

We have scheduled the writing and publishing of a number of White Papers on the issue. As we are a charity with limited resources and so many things to do, it is unlikely that will happen before Q1 or even Q2 next year. 2004 will also see the publishing of the TAG (and BT funded) research on text telephony. Apart from that. we have done a survey, sponsored by Nokia, in 2001-2002 across well over 15.000 subjects. Processing of that data is still ongoing, and as that is a massive amount of work, I don't expect publication before the end of this year either. We simply have no resources to put dozens of people on that.
Apart from that, publication of our research to the wider public has always been our intention. Apart from formal publication as and when the studies are ready, I cannot do much more at the time than share our expertise and knowledge, as a charity that operates in the field of deafness and hearing loss since 1911, including referral to feedback from user trials on some of our relevant pilots.

Guido

Guido Gybels

---

From: "Chris Boulton" <[email-masked]>
Date: Thu, 19 Jun 2003 14:51:31 +0100

Guido,

	I fully understand your frustration and passion to include such
technology as mainstream due to the results of your research BUT in
Jon's defense, until organizations like yours are able to publish the
results of such research, he will always be inclined to build a model
that 'best fits' current practice/demand.  It is up to you to deviate
this opinion with hard facts that illustrate desire for change, rather
than accusations.

Chris.

>Sent: 19 June 2003 13:06
>To: [email-masked]; [email-masked]; Chris Boulton
>Cc: [email-masked]
><<Maybe it would be an idea for your research to be made available to
the
>group - thus allowing a range of information for members with
>We have scheduled the writing and publishing of a number of White
Papers on
>the issue. As we are a charity with limited resources and so many
things to
>do, it is unlikely that will happen before Q1 or even Q2 next year.
2004
>will also see the publishing of the TAG (and BT funded) research on
text
>telephony. Apart from that. we have done a survey, sponsored by Nokia,
in
>2001-2002 across well over 15.000 subjects. Processing of that data is
>still ongoing, and as that is a massive amount of work, I don't expect
>publication before the end of this year either. We simply have no
resources
>to put dozens of people on that.
>Apart from that, publication of our research to the wider public has
always
>been our intention. Apart from formal publication as and when the
studies
>are ready, I cannot do much more at the time than share our expertise
and
>knowledge, as a charity that operates in the field of deafness and
hearing
>loss since 1911, including referral to feedback from user trials on
some of
>our relevant pilots.

---

From: "A vWijk" <[email-masked]>
Date: Mon, 23 Jun 2003 13:22:30 +0200

Hello Jon,

<<I think it is important to distinguish between abilities and preferences. It
is not my preference, for example, to use G.711 for audio communications -
its fidelity is pretty poor. My preference would be to use a wideband codec,
like L16. For that matter, I have a hard time understanding why I still need
to communicate via telephones at all - I would prefer a fully immersive
virtual reality rig. Nokia folks, where is that on your release calendar?>>

Real-time text telephony is NOT a luxery. It is a basic need for the hearing and speech impaired! IM is now used, but is a very limited system. 
Because that is equivalent to having a telephone where you wait a while before getting a voice reply.
E.g. Hi with Jon.........................................................<.hi! nice to hear from you Jon>.......................................................how are you?......................................................<fine, say, why the long pauses in our conversation?>..........................................................yeah, this is Voice IM..................................................<oh?>.......<really?>.........................................Yes, this is the only way to experience how a telephony conversation will be if we simply ignore the needs for the hearing impaired......................................<well this sucks!>.................................<hello? are you there?>..........................................<hmmm seems he logged out or so, oh well see ya then>.

This is exactly what you are trying to tell me that is acceptable????
And, what about telephony functions like forwarding a call, or redirecting a call or even putting on hold? Not possible with IM.
For the hearing impaired users like me, text telephony is the ONLY way to have a good conversation.
I know it from first hand and I am also a very experienced IM user. 

<<But to return to my more modest ambition, why am I stuck with G.711 rather
than L16 in the PSTN? Because G.711 is ubiquitous and entrenched, and it is
sufficient for audio communications. Similarly, SMS is ubiquitous and
entrenched, and it is sufficient for textual communication. I don't think it
will be easy to persuade this group that any alternative to RFC2793 is not
'viable'. Instant messaging is obviously and eminently viable, even if it
isn't ideal from an aesthetic perspective.>>

SMS is not a good alternative, we deaf are stuck to it since there is nothing better.
And by making RFC2793 mandatory for VoIP and other SIP Telephony devices does not mean we throw away IM! 
Just 2 ways for text, IM for short messages and short exchange of info that are NOT time urgent. And real-time text conversatoon T.140 for telephone conversations.

You know what? I as a deaf person simply HATE regulations. They suck bigtime. Regulations always result to fixing things to make it work and never really do that well! They just basically work. Costing a lot of money and time.

Let's just be smart and implement at protocol and design level the needs for the hearing , speech and other impairments at a neglicable cost or no cost at all! And then we never need those <beep> regulations at all!
And this work does NOT contradict market direction.

I know what I am talking about, and so does Guido Gybels.

Arnoud

---

From: "A vWijk" <[email-masked]>
Date: Mon, 23 Jun 2003 15:11:12 +0200

Hello Dean,
The price of original comments goes to you. :-)
Huffing and puffing communication.

<you imagine a real-time-text interface via a sip-and-puff controller?
Ouch! People would hyperventilate saying "hello"!) but that's probably a
little further off ;-(. Maybe ten more years . . .>

(and the likely implementation will be input via eye movements instead using your breath.)

<Question: Have we analyzed the problems of the loss-characteristics of
RFC2793 vs. the overhead of near-real-time character by character IMs?>

I have already used and seen implemenations of T140 as described in RFC2793 which was transferred over the common ordinary overloaded internet.
Gunnar Hellstrom has a lot of info about this.

But I still maintain that T140/RFC2793 has to exist besides IM. 
Because IM, even if they go near real-time character by character (how will that be done???). The interoperability remains a big issue. Zillions of IM standards.

Creating a new real-time streaming text protocol for IM is a bit useless.

RFC 2793 uses ITU and 3GPP approved text T140 protocol. So, the implementation will be easy and it should just as reliable as any other multimedia message over RTP.

Or do you feel that using RTP to send text looks like an overkill Dean? You could then define T.140 over TCP/IP and T.140 as in RFC2793
But T.140 over TCP/IP might only be useful for GPRS. UMTS and fixed lines will hardly notice the text bandwidth usage at all.
Ofcourse I am open to comments from others.

greetz

Arnoud

---

From: "Beck01, Wolfgang" <[email-masked]>
Date: Mon, 23 Jun 2003 15:45:20 +0200

some thoughts:
- UA implementors will ask how long it will take to do rfc2793.
Is T.140 encoding complicated? Are the redundancy schemes
difficult to implement? How much will it take to change
the user interface of the client? Who will pay for this?

real-time text telephony needs a better name. How many
managers know the term "instant messaging" and how many
know about T.140? Compare boring "half-duplex communication"
with the buzz word "Push To Talk".

Arnoud wrote:
> Real-time text telephony is NOT a luxery. It is a basic need 
> for the hearing and speech impaired! IM is now used, but is a 
> very limited system. 

The question of a UA manufacturer is: "How many more UAs 
will we sell if we implement this feature?" If real-time
text telephony does not sell outside the hearing and speech
impaired community, most managers will regard it as luxury.

- RfC 2793 puts far less load on SIP proxies than SIP MESSAGEs
if people are having longer text conversations.

--
Wolfgang Beck
T-Systems Nova GmbH