Subject: [Sipping] I-D ACTION:draft-sharath-sipb-requirements-00.txt

From: [email-masked]
Date: Tue, 24 Jun 2003 06:56:53 -0400

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title		: SIP-B: SIP for Business Phones Requirements for 
                          Implementing Business Telephony Features on SIP 
                          Endpoints
	Author(s)	: V. Venkataramanan, S. Rajasekar
	Filename	: draft-sharath-sipb-requirements-00.txt
	Pages		: 16
	Date		: 2003-6-23
	
This informational internet draft describes the requirements for a 
standard business telephone based on the Session Initiation Protocol 
(SIP). The objective of this document is to provide a minimum set of 
requirements for implementing business features on SIP endpoints.  
This draft is intended to serve as a requirements document for 
vendors    implementing    business    features    on    SIP    based 
devices/entities. Details of how each capability or feature is best 
implemented in SIP, is beyond the scope of this document and may be 
tracked through the working group draft submissions.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-sharath-sipb-requirements-00.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-sharath-sipb-requirements-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-sharath-sipb-requirements-00.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Christer Holmberg (LMF)" <[email-masked]>
Date: Tue, 24 Jun 2003 13:25:02 +0200

Hi,

A comment on DS-3.

I really wonder if using the topmost Via for implementing a "last call return" feature is going to work...

But, assuming it DOES work, my question is: since the Via only contains (in URI terms) a host part, where do you take the user part from? If you send a request with only a host in the Request-URI, even if allowed by the protocol, how can you be sure it will reach the same user that tried to call you?

Regards,

Christer Holmberg
Ericsson Finland

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: 24. kesäkuuta 2003 13:57
Cc: [email-masked]
Subject: [Sipping] I-D ACTION:draft-sharath-sipb-requirements-00.txt

	

Send a message to:
	[email-masked].
In the body type:

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Chris Boulton" <[email-masked]>
Date: Tue, 24 Jun 2003 16:06:48 +0100

Why is this a better response code?  Isn't 488 usually associated with
content negotiation (offer) problems.

Chris.

>From: Ranjit Avasarala [mailto:[email-masked]]
>Sent: 24 June 2003 15:16
>To: 'Rosen, Brian'; [email-masked]
>Subject: RE: [Sipping] I-D
ACTION:draft-sharath-sipb-requirements-00.txt
>
>Hi
>   I think 488 Not Acceptable Here with Retry-After: would be more
>appropriate response for a DnD feature rather than a 486 busy here
>
>Ranjit
>
>From: [email-masked] [mailto:[email-masked]] On Behalf
>Of Rosen, Brian
>Sent: Tuesday, June 24, 2003 6:31 PM
>To: [email-masked]
>Subject: RE: [Sipping] I-D
ACTION:draft-sharath-sipb-requirements-00.txt
>
>
>While there is a lot to like about this draft, I think I could spend a
>couple hours poking holes in it.  Let me give you a "for instance":
>   DS-6: All SIP business phones MUST support DND. The DND feature,
>   when activated, MUST reject any incoming call meant for the phone
>   with a 486 Busy response code or MAY redirect the call to voice
>   mail.
>
>A presence based implementation of DND might selectively reject calls
>based on who is calling.  My wife and possibly my boss might be able to
>ring through, most other callers could not.  If I implemented a phone
>this way, it would not be compliant with DS-6.
>
>Forwarding for DND might best be done at the proxy server, since you
>want it to work if the phone is "down".
>
>I also object to the language "meant for the phone".  A call to our
>phones is "meant for the user", since we require a login.  We have VERY
>little phones state, basically just IP addressing things. Everything
>else is user based, not phone based.  I wouldn't want to make it a
>requirement that DND was phone state.  I would want it to be possible
to
>have a phone that two users were logged into
>simultaneously, one of which was DND.
>
>I'll do the review work, but first I want to ask if this draft is going
>to be the basis of work in the sipping group.  I note that there are
>other efforts along similar lines, although this draft is specific to a
>"business" phone, if that actually matters. So, I guess I'm asking two
>questions:
>	Is sipping going to undertake what I would suggest is best
>		cast as a BCP on business telephones?
>	Is this draft the basis for that work?
>
>I personally think that starting from the work Henry et. al. did is a
>better path.  Adding "business" profiles to that would be one way.
>
>Brian
>
>> Sent: Tuesday, June 24, 2003 6:57 AM
>> To: @IETF-Announce.{MARCONI}
>> Cc: [email-masked]
>Internet-Drafts are also available by anonymous FTP. Login with the
>username "anonymous" and a password of your e-mail address. After
>logging in, type "cd internet-drafts" and then
>Use [email-masked] for questions on current sip Use
>[email-masked] for new developments of core SIP
>
>

---

From: "Venkatesh Venkataramanan" <[email-masked]>
Date: Tue, 24 Jun 2003 12:06:47 -0700

You are correct about the Via header. That was an error !! We had a couple
of ideas we had in mind and this was something we had thought about earlier
on but had decided against it. We will fix this. Thanks for pointing it out.

regards,
Venkatesh

-----Original Message-----
From: Christer Holmberg (LMF) [mailto:[email-masked]]
Sent: Tuesday, June 24, 2003 4:25 AM
To: [email-masked]'
Subject: RE: [Sipping] I-D ACTION:draft-sharath-sipb-requirements-00.txt

Hi,

A comment on DS-3.

I really wonder if using the topmost Via for implementing a "last call
return" feature is going to work...

But, assuming it DOES work, my question is: since the Via only contains (in
URI terms) a host part, where do you take the user part from? If you send a
request with only a host in the Request-URI, even if allowed by the
protocol, how can you be sure it will reach the same user that tried to call
you?

Regards,

Christer Holmberg
Ericsson Finland

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: 24. kesäkuuta 2003 13:57
Cc: [email-masked]
Subject: [Sipping] I-D ACTION:draft-sharath-sipb-requirements-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts
directories.

Send a message to:
	[email-masked].
In the body type:

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 24 Jun 2003 16:11:40 -0400

My problem is that if an RFC resulting from this work
requires your definition of DND, and my phone implements my
definition of DND, then I am not compliant to the RFC.
I think my definition is a "better" definition of what
phones ought to do; yours i

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 24 Jun 2003 16:53:51 -0400

The below reply somehow got mangled.  About 2/3 of it
got deleted.  I'm guessing it was operator error, since
my "sent items" folder is also mangled.

The full reply was supposed to be something like:

phones ought to do; yours simply copies what phones have done
for 20 years or more.

When creating a "best current practice", we get to ask the
question of whether doing what we have done for that long
really is the best way, or whether something more capable
is the best way.  I understand the problem - if we say
that presence based DND is the best practice, than even
inexpensive business phones have to implement it.
I also understand that current low end phones do have
a DND implementation such as you propose.

Similarly, DND that is "phone state" is what most phones
do.  In this case, I think it's pretty easy to compromise
on the issue, because we can write the document in such
a way that it says that DND is user state, but that it is 
acceptable to have a default user that is registered
automatically. 

However, before we get into all of that, we have to start
with "are we doing this at all" and "what basis to we start
with".  Need more discussion on that before we argue
DND.

Brian

> From: Rosen, Brian [mailto:[email-masked]]
> Sent: Tuesday, June 24, 2003 4:12 PM
> To: 'Venkatesh Venkataramanan'; [email-masked]
> Cc: Sharath Rajasekar