Subject: [Sipping] New Tones draft (was: "who plays the tone" or something like that)

From: Rohan Mahy <[email-masked]>
Date: Sun, 22 Jun 2003 22:49:47 -0700

Hi,

I wrote the following draft in order to provide some discussion on 
alternatives to in-band early-media ringback, and to discuss the issue 
of playing tones in general which I believe is inherently linked to 
3pcc and application interaction.

http://www.softarmor.com/sipping/drafts/draft-mahy-sipping-tones-00.html
http://www.softarmor.com/sipping/drafts/draft-mahy-sipping-tones-00.txt

comments welcome.
thx,
-r

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Vipin Palawat" <[email-masked]>
Date: Mon, 23 Jun 2003 11:17:07 -0400

Hi rohan,

Some initial comments:

1. Repeat in the schema is boolean. I would like to know how I can
specify a Repeat interval for tones like "Hold".

2. Is there a way we could indicate a UA (sort of preference) to either
play the early media tone or play the tone specified by
"audio/tone-info+xml" ? Or a UA SHOULD always play the early media when
available and stop the xml tone . 

There are some scenarios where it is desired to not have early media but
just the tones specified by "audio/tone-info+xml" .

Thanks,
Vipin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Rohan Mahy
Sent: Monday, June 23, 2003 1:50 AM
To: [email-masked]'
Subject: [Sipping] New Tones draft (was: "who plays the tone" or
something like that)

Hi,

comments welcome.
thx,
-r

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip Use
[email-masked] for new developments of core SIP

---

From: Rohan Mahy <[email-masked]>
Date: Mon, 23 Jun 2003 09:14:25 -0700

Hi Vipin,

Some very short comments, because I am very sleepy.

> specify a Repeat interval for tones like "Hold".

i think this should do the trick

<tones repeat="true">
  (first tone)
  (silence)
</tones>

> available and stop the xml tone .

IMO, you SHOULD avoid sending early media like the plague, but if you  
receive it it should take precedence over whatever ringback tones you  
were receiving.

> just the tones specified by "audio/tone-info+xml" .

yes.  that was the idea.  next rev, i'll try to make that more clear.

thx,
-r

---

From: "Vipin Palawat" <[email-masked]>
Date: Mon, 23 Jun 2003 14:44:29 -0400

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Rohan Mahy
Sent: Monday, June 23, 2003 12:14 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Sipping] New Tones draft (was: "who plays the tone" or
something like that)

Hi Vipin,

<tones repeat="true">
  (first tone)
  (silence)
</tones>

[Vipin] I am unable to understand this completely. How do I specify the
duration of silence ? Can you give me a complete example ?

> 2. Is there a way we could indicate a UA (sort of preference) to 
> either play the early media tone or play the tone specified by 
> "audio/tone-info+xml" ? Or a UA SHOULD always play the early media 
> when available and stop the xml tone .

[Vipin] Media over early media sessions may not be desired in some cases

and suppose I want to indicate that tones via "audio/tone-info+xml"
takes
precedence over media. Is there a way I can specify this ?

Few more comments:
* How do I indicate a UA to stop playing a particular or all tone ? This
is also
required for interworking with H225 Info message.

thx,
-r

> This list is for NEW development of the application of SIP Use 
> [email-masked] for questions on current sip Use

---

From: Rohan Mahy <[email-masked]>
Date: Mon, 23 Jun 2003 12:57:03 -0700

> duration of silence ? Can you give me a complete example ?

the example in the draft:

<?xml version="1.0" ?>
<tones repeat="true">
   <tone>
     <modulation hz="0"/>
     <volume db="-3"/>
     <duration ms="2000"/>
     <frequency hz="440"/>
     <frequency hz="480"/>
   </tone>
   <tone>
     <modulation hz="0"/>
     <volume db="-63"/>
     <duration ms="4000"/>
     <frequency hz="0"/>
   </tone>
</tones

says play the first tone for 2 seconds (a 440Hz and 480Hz tone 
simultaneously), then play the second tone (silence) for 4 seconds. 
Repeat ad nauseam.

> precedence over media. Is there a way I can specify this ?

my comment was only about early media.  for connected media, I imagine, 
if you send a tone you want to play during the connected state that the 
tone will take precedence over any other media.  (ex: barge-in tones).

> required for interworking with H225 Info message.

send another message (18x, UPDATE, whatever) that has no tone?

thx,
-r