Subject: [Sipping] Conference-id header?

From: "Victor A Paulsamy" <[email-masked]>
Date: Thu, 5 Jun 2003 17:45:16 -0700

Is there any proposal, from with in conference design team and/or otherwise,

for "Conference-id: header" in SIP messages? If yes, can it be cited in
other works?

Thanks in advance.

Regards,

--victor

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Arjun Roychowdhury" <[email-masked]>
Date: Thu, 5 Jun 2003 22:47:54 -0400

Victor,
doesn't the conference-uri as defined in framework-00.txt server the 
purpose of the conference-id you are looking for ? Or do you require
something else ? 
(http://www.ietf.org/internet-drafts/draft-ietf-sipping-conferencing-framework-00.txt)
To my knowledge, its been suggested that URIs would be used to uniquely 
identify conference instances.

regds
arjun

--
Arjun Roychowdhury @ Hughes Software Systems
11717 Exploration Lane, Germantown MD 20876
(O): 301 212 7860 

"Victor A Paulsamy" <[email-masked]>
Sent by: [email-masked]
06/05/2003 08:45 PM
Please respond to victor

        To:     "sipping" <[email-masked]>
        cc:     <[email-masked]>
        Subject:        [Sipping] Conference-id header?

Is there any proposal, from with in conference design team and/or 
otherwise,

Thanks in advance.

Regards,

--victor

---

From: [email-masked]
Date: Fri, 6 Jun 2003 02:29:24 -0400

Arjun,

>purpose of the conference-id you are looking for ?

Not the URI; but Conference-id header. 

This is required for identifying a specific conference that's set up on the spur of the moment; full-mesh, for instance.

Regards,

--victor

---

From: "Arjun Roychowdhury" <[email-masked]>
Date: Fri, 6 Jun 2003 08:20:36 -0400

Aha-ok,
I forgot the 'full-mesh' part. Almost all of the sipping discussion so far 
has been for centrally hosted conferences.
For centrally hosted conferences, even if they are adhoc - the conf-uri is 
the unique identifier.

I am not aware of any such SIP header, but I would assume some line in the 
SDP could be used for the same ? Again, guess
its not a standardized whay. Since any endpoint can send an INVITE to any 
other ep in a full mesh ,there is no guarantee that
any 'identifying' attributes in one leg will be retained across in the 
other leg.

regds
arjun

[email-masked]
06/06/2003 02:29 AM

        To:     [email-masked], [email-masked], [email-masked], 
[email-masked], [email-masked]
        cc:     [email-masked]
        Subject:        RE: Re: [Sipping] Conference-id header?

Arjun,

This is required for identifying a specific conference that's set up on 
the spur of the moment; full-mesh, for instance.

Regards,

--victor

---

From: [email-masked]
Date: Fri, 6 Jun 2003 12:41:01 -0400

>----- ------- Original Message ------- -----
>From: [email-masked]
>To: [email-masked]
>Sent: Fri, 6 Jun 2003 08:20:36
>
>Aha-ok,

If available information is used to compose an id, it's an easy guess for an attacker who intercepts the transaction.

On the other hand, even if it is computed in the fashion that other globally unique headers are, the attacker can still get hold of it!

>any 'identifying' attributes in one leg will be

It has to be mandated in a full-mesh conferencing.

Regards,

--victor