Subject: RE: [Sipping] refer and pstn

From: "Hearty, John" <[email-masked]>
Date: Tue, 10 Jun 2003 09:35:15 -0600

Juha,

Perhaps I missed some other reply, the below is the only reply I saw
from you on this thread, which explains nothing.  Taking apart the
paragraph from your original post:

>i have noticed that some sip/pstn gws on the market support refer
method.  >i consider this very dangerous because pstn gw has no way that
i know of >asking the original pstn caller to accept or reject the
referral.

Again, current PSTN based call forwarding services also do not ask the
original PSTN caller to accept or reject the forward.  What's different
here?

>things get even worse when these implementations do not send the
resulting new request to the proxy, but directly to pstn.

Please explain what is "worse".  You don't describe any actual problem
here.

John

> -----Original Message-----
> From: Juha Heinanen [mailto:[email-masked]]
> Sent: Tuesday, June 10, 2003 9:21 AM
> To: Hearty, John
> Cc: Pascal Dore; [email-masked]
> Subject: RE: [Sipping] refer and pstn
> 
> Hearty, John writes:
> 
>  > I don't get it.  How is that any different from call forwarding
> services
>  > already in the PSTN?  They don't ask the caller before forwarding.
> What
>  > are the problems?
> 
> see my reply to another message.
> 
> -- juha
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Francois Audet" <[email-masked]>
Date: Tue, 10 Jun 2003 12:25:51 -0700

My take is that if you accept REFER without user acknowledgement,
regarless of if the use is on PSTN or SIP, you need some sort
of trusted relationship with the REFERer. It is not a PSTN
gateway issue per se, but it is true that you typically would
not have a built-in mechanism for getting end-user acknowledgement
in the PSTN.

> From: Taylor, Tom-PT [CAR:5N00:EXCH] 
> Sent: Tuesday, June 10, 2003 10:45
> To: Juha Heinanen
> Cc: [email-masked]
> Subject: Re: [Sipping] refer and pstn
> 
> 
> Could I understand what difference there is between accepting 
> a REFER and call 
> transfer in the legacy network?  In both cases, the protocol 
> for gaining PSTN user 
> acceptance is for the transferor to ask -- it's not a protocol issue.
> 
> Juha Heinanen wrote:
> 
> > method.  i consider this very dangerous because pstn gw has no way 
> > that i know of asking the original pstn caller to accept or 
> reject the 
> > referral.  things get even worse when these implementations do not 
> > send the resulting new request to the proxy, but directly to pstn.
> > 
> > if any of the vendors of these gws are listening, i would like to 
> > understand what is your logic when you have implemented 
> refer method 
> > UAS or if the authors of the refer rfc are listening, how 
> you thought 
> > it could be properly used by sip UASes that are pstn gws.
> > 
> > -- juha
> > This list is for NEW development of the application of SIP Use 
> > [email-masked] for questions on current sip Use 
> > [email-masked] for new developments of core SIP
> > 
> 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
>