Subject: RE: [Sipping] Text support in SIP phones

From: "Guido Gybels" <[email-masked]>
Date: Tue, 17 Jun 2003 08:32:10 +0100

Jon,

Thanks for your clear comments.

<<I'm uncomfortable with the suggestion that RFC2793 be mandatory as a payload format for SIP telephone device implementations. Mr. Drage has already articulated several of the reasons I would put forward (i.e. some telephones need not support textual communication at all).>>

I do appreciate that there might be a need to exclude certain devices or device categories from providing such text support, but surely the best way to achieve a harmonized and mainstream solution is to do it by specifying those categories that do not support it?

<<I might add that alternative methods of sending textual information in the PSTN today (like SMS or similar instant messaging systems) have enjoyed profound adoption and marketshare that has not been rivaled by T.140, in my experience anyway.>>

I'm sorry, we're missing the point here. SMS is not a viable alternative to realtime communication for deaf and hard of hearing people. It is not the equivalent of voice for hearing people. It is an additional modality that deaf people do use, because it fits their abilities and preferences. However, to communicate interactively using text. especially with a relay service, you need a character-by-character interactive communication. We are running a pilot and experiments comparing character-by-character conversations between deaf text users and hearing people over the RNID Typetalk relay service, and it is clear that message based communications do not fulfil there needs at all.
With regard to T.140, there can hardly be any market assessment since it is simply not commonly available, unlike SMS for instance.

<<The SIP community has not been particularly enthusiastic about the RFC2793 paradigm in the past - and we have considered it for some applications.>>

First of all, when hearing people are being put in front of an interactive text based system like the ones based on T.140, they love it. The feeling of interactivity is much greater than with things like IM. But if users simply have no choice, sure than there is no market...

<<lack of an intelligible strategy for conferencing (which IRC and its numerous descendents, including AOL, MSN, and Yahoo messengers,
easily mastered) being one obvious problem.>>

Good point. But surely it is up to us in the technology community to define solutions, rather than avoid dealing with them?

<<Presumably, RFC2793 has the same NAT traversal and security properties as baseline RTP (i.e. STUN and sRTP
are applicable), but I'm not sure if the latter is currently required for sip devices (and note that sharing keying material for RTP is still a
somewhat controversial subject).>>

The way we have dealt with it in the RNID pilot is to use a proxy server to connect both ends, so that both user agents only make outbound connections, which obviously solves the firewall traversal and NAT problem.
Also, IM systems like MSN etc, are not entirely immune to FW traversal and natting issues either when you start using their extended feature set. I won't even mention netmeeting.

<<The desired immediacy of T.140 would also, I imagine, be somewhat compromised by the crude manner in which we are compelled to 'dial' letters into virtually all telephones today (in which it takes much longer to reach 's' than 'p').>>

We are already looking at solutions for that, like (configurable) word based buffering on mobiles for instance, so that you can use small keyboards and predictive texting. Also, heavy text users might opt to connect larger keyboards to the system and I know at least one BT foldable keyboard for use with a mobile phone. SIP deskphones can have a full-size keyboard added to them where required.

<<If we are to mandate or even encourage any means of textual communication in telephone devices, I think it should more closely correspond to the irrefutable direction of the marketplace - the instant messaging paradigm.>>

I'm not so sure that direction is so irrefutable as you claim it to be. The truth is that IM still is hampered by the whole interconnectivity issue and that users have not really had any choice so far. Releasing applications that do offer an alternative to IM by providing more character-by-character based implementations while providing interconnectivity with existing IM systems as well as legacy TTYs (like the current RNID pilot which will go public early 2004 and might even be offered license free) might change the current picture dramatically.
If I would get a penny for every time someone in technology has claimed something was never going to happen and was proven incorrect afterwards

<<I would categorically oppose mandating RFC2793 to the exclusion of, say, the outcome of SIMPLE's instant messaging sessions work.>>

I don't think that is what anyone is asking for. There is no reason at all why SIMPLE and RFC2793 cannot live together simultaneously. They are simply separate issues. Remember though that, certainly in Europe, IM will *not* fulfil the legal and regulatory obligations on service providers and manufacturers and that those obligations will become even more strict with the implementation of the famous 4 EC Directives on Communication which is now taking place in all the member states and should be completed over the next couple of months. RFC2793 will comply with those requirements. It's up to the community to decide whether or not they want to be burdened by more regulation or legislation or whether they will try to fulfil those requirements through mainstream solutions that will benefit their business case.
As ever,

Guido

Guido Gybels
Director of New Technologies

RNID, 19-23 Featherstone Street
London EC1Y 8SL, UK
Tel +44(0)20-7294 3713
Fax +44(0)20-7296 8069

************************************************************************
This email and any files transmitted with it are confidential
and intended solely for the use of the individual or entity to
whom they are addressed. Any views or opinions expressed
are solely those of the author and do not necessarily represent
RNID policy.

If you are not the intended recipient you are advised that any
use, dissemination, forwarding, printing or copying of this
email is strictly prohibited.

If you have received this email in error please notify the RNID
Helpdesk by telephone on: +44 (0) 207 296 8282.

The Royal National Institute for Deaf People  
Registered Office 19-23 Featherstone Street 
London EC1Y 8SL No. 454169 (England)
Registered Charity No. 207720
************************************************************************

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Michael Hammer <[email-masked]>
Date: Tue, 17 Jun 2003 10:02:19 -0400

At 08:32 AM 6/17/2003 +0100, Guido Gybels wrote:
>First of all, when hearing people are being put in front of an interactive 
>text based system like the ones based on T.140, they love it. The feeling 
>of interactivity is much greater than with things like IM. But if users 
>simply have no choice, sure than there is no market...

Guido,

Personally speaking, and maybe I have ADD, but I would find watching 
someone type mildly interesting in the short run, but as boring as watching 
grass grow in the long run.  I would more likely turn my attention to other 
tasks at work and come back later when they are done typing.  Frankly, I 
don't see that this is so different from IM.  Also, as a sender, I would 
prefer to have my thoughts laid out before me before hitting the send 
button.  So, I'm not so sure we can draw well-founded conclusions based on 
some anecdotal evidence.

That is not to say that we can't offer both modes.  I'm sure those (on both 
sides) that had no choice have a strong affinity to what they are used to, 
but I'm not so sure which they would choose if both were available.

Mike