Subject: [Sipping] Crossing message between ACK and INFO

From: [email-masked]
Date: Mon, 1 Mar 2004 18:20:27 +0100

Dear sipping members,

My media server (UDP transport) receives a INFO request 
before ACK because there is a crossing message :

Application Server       Media Server
(Shangai)                  (France)
--------------------------> INVITE
<-------------------------- 180
<-------------------------- 200
-----------
           \
----------  \  -----------> INFO
             \------------> ACK

The INFO message must be send within a dialog. So I was supposed
that I could only be accept after ACK.

What should be the behaviour of media server in this case?
1 - discard the message in order that AS resend INFO request
or
2 - reject the INFO message with 603 response in order that AS resend
an other request after a timer defined in Retry-After header of response
or
3 - accept INFO. But in the case, the remote sequence number of ACK request 
is less that the remote sequence number. 
.../...

Thanks you for you help.

Regards

Christophe Bourny
Alcatel CIT - Rennes - France

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Michael Hammer <[email-masked]>
Date: Tue, 16 Mar 2004 14:41:05 -0500

Please correct me if I am wrong, but my understanding was that the sending 
of the 200 OK INVITE creates the dialog at the UAS and the receipt of it 
creates the dialog at the UAC.  If you have both From and To tags, you have 
the dialog identity.  Recalling previous discussion, if you try and wait 
for the ACK, you fall into the Byzantine General dilemma.

Seems you should be able to process the INFO.

In your example below, why do you say the remote sequence number is out of 
order, was it not in order when sent?

Mike

---

From: Ajay Gupta <[email-masked]>
Date: Tue, 16 Mar 2004 16:24:36 -0800 (PST)

You are right, since the ACK message contains the CSeq of the INVITE for which it is generated. So, there should not be any CSeq issues
 
Ajay

Michael Hammer <[email-masked]> wrote:

Mike

Do you Yahoo!?
Yahoo! Mail - More reliable, more storage, less spam