Subject: RE: [Sipping] refer to PSTN

From: "Christer Holmberg (JO/LMF)" <[email-masked]>
Date: Wed, 17 Mar 2004 22:42:18 +0100

Hi,

Does this solution require that the redirection proxy, inserting the "pstn indicator", knows that the call is initiated from PSTN in the first place? What would a normal SIP UA do if it received a 3xx response with the indicator?

Also, if I have a SIP phone, and wants to divert my call to PSTN, the phone would have to support the indicator too, to tell the redirection proxy (or whatever database it uses) that the phone is in the PSTN network...?

Regards,

Christer Holmberg
Ericsson Finland

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> Stastny Richard
> Sent: 17. maaliskuuta 2004 10:59
> To: Juha Heinanen
> Cc: Arunachalam Venkatraman; [email-masked]
> Subject: RE: [Sipping] refer to PSTN
> 
> 
> Juha
> 
> I have an order to write an ID regarding the enum dip 
> indicator for the
> tel: URI
> in iptel
> 
> I could try to include the pstn indicator for tel: in this draft and
> lets see how the reactions are ;-)
> 
> Richard
> 
> > -----Original Message-----
> > From: Juha Heinanen [mailto:[email-masked]] 
> > Sent: Tuesday, March 16, 2004 12:37 PM
> > To: Stastny Richard
> > Cc: Arunachalam Venkatraman; [email-masked]
> > Subject: RE: [Sipping] refer to PSTN
> > 
> > 
> > Stastny Richard writes:
> > 
> >  > If an indicator is required to force a call to the PSTN, 
> > it should be  > independent from enum: eg tel:+xxx;pstn
> > 
> > this would be fine with me.  is someone writing an internet 
> > draft describing the pstn uri parameter or does someone have 
> > a better idea on how to solve the problem?
> > 
> > -- juha
> > 
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 

This communication is confidential and intended solely for the addressee(s). Any unauthorized review, use, disclosure or distribution is prohibited. If you believe this message has been sent to you in error, please notify the sender by replying to this transmission and delete the message without disclosing it. Thank you.

E-mail including attachments is susceptible to data corruption, interruption, unauthorized amendment, tampering and viruses, and we only send and receive e-mails on the basis that we are not liable for any such corruption, interception, amendment, tampering or viruses or any consequences thereof.

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Juha Heinanen <[email-masked]>
Date: Thu, 18 Mar 2004 08:06:21 +0200

Christer Holmberg (JO/LMF) writes:

 > Does this solution require that the redirection proxy, inserting the
 > "pstn indicator", knows that the call is initiated from PSTN in the
 > first place? 

the call does not need to be initiated from the pstn.

What would a normal SIP UA do if it received a 3xx response with the
indicator?  it would ask the user, would you like to try this other
destination and then send out the invite normally.

 > Also, if I have a SIP phone, and wants to divert my call to PSTN, the
 > phone would have to support the indicator too, to tell the
 > redirection proxy (or whatever database it uses) that the phone is in
 > the PSTN network...?

you would need to configure in the phone the redirection uri and that
would thus need to contain the ;pstn parameter.  i don't know what you
refer to by "phone" in the last sentence.

-- juha