Subject: Re: [Sipping] Netann user name

From: "Qiru Zhou" <[email-masked]>
Date: Tue, 9 Mar 2004 14:38:12 -0500

Eric,

I prefer __sip-* (or other prefix) than "master" postfix since it is
more clear than the other. We have prototype implementation now using
"annc", "dialog", and "conf". I hope this is the one time change to
adapt the new names.

BTW, why we need "__sip-ivr" here? I thought it is covered by
"__sip-dialog".

-- Qiru

Eric Burger wrote:
>
> One of the Application's Area AD's suggested that we ask the URI folks at
the W3C about the use of the user part of a URI as a service indicator.
>
> The feedback we got was that while they trust that the URI is actually a
URL
at a given host, we should not rely on that being the case forever.
>
> There were two suggestions on what to do.  Both relate to obscuring the
user
part.
>
> The first suggestion is to prepend the user name with something "special",
like "sip" or "sip-".
>
> The second suggestion is to postfix the user name with "master".  The idea
is that people already have an expectation that individuals will not take a
mumblemaster name.  Common uses are postmaster, listmaster, webmaster, and
so
on.
>
> My proposal is to change the existing user names as follows:
>
>   OLD         NEW
>  annc       __sip-annc
>  dialog     __sip-dialog
>  conf       __sip-conf
>  ivr        __sip-ivr
>
> Comments?
>
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Eric Burger" <[email-masked]>
Date: Tue, 9 Mar 2004 14:41:42 -0500

__sip-ivr is MSCML outside the context of a conference.

> -----Original Message-----
> From: Qiru Zhou [mailto:[email-masked]]
> Sent: Tuesday, March 09, 2004 2:38 PM
> To: Eric Burger
> Cc: [email-masked]
> Subject: Re: [Sipping] Netann user name
> 
> 
> Eric,
>

---

From: "Eric Burger" <[email-masked]>
Date: Thu, 11 Mar 2004 11:29:36 -0500

Frankly, I think that I haven't been too clear on the issue.  My last missive pointed out that a user name at a device is just that, a user name at a device.  In my last posting to the URI list I pointed out that the user name at a device does not impose any restrictions whatsoever on that user's e-mail AOR (a.k.a. domain address).  It is like saying that I should not be able to be [email-masked], because there may another [email-masked]!

I am declaring defeat and will most likely go for __sip-mumble.  The proof of the silliness is that any argument against mumble is identical for __sip-mumble.  That said, people with objections to mumble begrudgingly accept __sip-mumble, so I am going for the path of least resistance to get this done with.

> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Thursday, March 11, 2004 12:39 AM
> To: Eric Burger
> Cc: Sipping (E-mail)
> > One of the Application's Area AD's suggested that we ask the URI
> > folks at the W3C about the use of the user part of a URI as 
> a service
> > indicator.
> > 
> > The feedback we got was that while they trust that the URI is
> > actually a URL at a given host, we should not rely on that being the
> > case forever.
> 
> I don't understand this comment. What can't you rely on? The 
> user part 
> of a URI is always interpreted only by the server 
> authoritative for the 
> domain in the domain part. Are they saying that this wont 
> always be true?
> 
> -Jonathan R.
> 
> 
> -- 
> Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
> Chief Technology Officer                    Parsippany, NJ 07054-2711
> dynamicsoft
> [email-masked]                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 
>