Subject: [Sipping] Once again: AAA and Billing for SIP

From: "Harry Behrens" <[email-masked]>
Date: Wed, 3 Mar 2004 07:33:24 +0100

Well I guess today was not the right time to bring up the topic...
what with all the REFER discussions...;-)

but: I would still suggest a "AAA and Billing" group within the SIPPING
WG.
Basically work from RFC3702 and the relevant drafts (OSP token etc.) to
come up with a common view on how AAA and Billing should be tackled
within SIP/VoIP.

I sorely miss the focus on this - to my mind - extremely important
facilitating technology.
We are seeing a lot of ITSPs entering the field, a lot of traditional
telcos as well, not to mention the 3GPP with its IMS.
We do need to clarify how we plan to enable people to be able to charge
for whatever services they plan to deliver over SIP. The telcos are
squarely betting on OSP and all we have is one draft
(draft-johnston-sip-osp-token-05.txt) which addresses only a minuscule
portion of the whole picture.
3GPP seems to assume Diameter, everybody else is using RADIUS etc....

I would volunteer for any helping role needed within the WG.
I am still in town (Seoul) until Saturday, so if any of you would find
the time for a brief discussion on this, I would be very grateful.

Best regards,

	Harry Behrens

> -----Ursprüngliche Nachricht-----
> Von: Harry Behrens [mailto:[email-masked]] 
> Gesendet: Freitag, 27. Februar 2004 18:23
> An: 'Dean Willis'
> Cc: 'Gonzalo Camarillo'; 'Henning Schulzrinne'; 'James M. 
> Polk'; [email-masked]'; 'Rohan Mahy'
> Betreff: AW: AW: AW: AW: [Sipping] SIPPING Agenda, IETF 59
> 
> 
> Dear Dean,
> 
> understood. Thank you for the explanation.
> 
> See you in Seoul.
> 
> 	Harry
> 
> > -----Ursprüngliche Nachricht-----
> > Von: [email-masked] [mailto:[email-masked]]
> > Im Auftrag von Dean Willis
> > Gesendet: Freitag, 27. Februar 2004 17:57
> > An: Harry Behrens
> > Cc: 'Gonzalo Camarillo'; 'Henning Schulzrinne'; 'James M. 
> > Polk'; [email-masked]; 'Rohan Mahy'; [email-masked]
> > Betreff: Re: AW: AW: AW: [Sipping] SIPPING Agenda, IETF 59
> > 
> > 
> > Harry Behrens wrote:
> > > Gonzalo,
> > > 
> > > understood. Regarding "Additional requests will be
> > > 
> > >>accomodated
> > >>if time allows"
> > > 
> > > 
> > > how would that work?
> > 
> > It means if we get to the end of the agenda and still have 
> time left,
> > the chairs ask "Ok, we're at the end of the agenda. Anybody have 
> > anything else to talk about?", and you and other folks can 
> pop up and 
> > say "I want to talk about . . .", and we judge the consensus 
> > of the room 
> > on what topic to talk about by priority.
> > 
> > --
> > Dean
> > 
> > _______________________________________________
> > Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> > This list is for NEW development of the application of SIP Use 
> > [email-masked] for questions on current sip Use 
> > [email-masked] for new developments of core SIP
> > 
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Harry Behrens" <[email-masked]>
Date: Wed, 3 Mar 2004 12:08:08 +0100

Dear Dean,

thank you for your frank response.
Anything that can help to clarify how to account for resource management
in SIP and the underlying media streams (is that politically correct
enough ;-?) in an open and standard-conform manner is of interest to me
and I would be glad to contribute in that direction.
And at least from the interoperability standpoint (with PSTN) I would
hope that it should be of interest to a number of people who wants to
see SIP-based VoIP enter the mainstream.
Pls. note that while signalling provides identification of the involved
parties, it lacks in granularity and relevance when it comes to actual
consumption and charging thereof.
In essence what I´m saying is "account media/PSTN consumption to the
counterparties identified by signalling (SIP) and/or session description
(SDP)".

What would the next step be in the direction of moving forward on this?

Regards,

	Harry Behrens

P.S.:
I should clarify that my company provides SIP solutions and is not
affiliated to any telco or billing institution - maybe that can
alleviate some concerns. 

> Von: Dean Willis [mailto:[email-masked]] 
> Gesendet: Mittwoch, 3. März 2004 09:14
> An: Harry Behrens
> Polk'; [email-masked]; 'Rohan Mahy'
> Betreff: Re: Once again: AAA and Billing for SIP
> 
> 
> 
> Here's the deal. If we say "billing", a lynch mob is likely 
> to descend 
> and try to hang us from high places by the necks. It's a classis IETF 
> "anathema" word, assured to receive a visceral response.
> 
> We MIGHT be able to get away with something like "accounting 
> methodology", perhaps "Best Practices for Accounting in SIP 
> Environments" or something like that. This might be a good place to 
> document things like "Financial accounting for media 
> utilization based 
> on SIP transactions is a Bad Idea" and so on. Have to 
> indicate what can 
> and cannot be efectively accounted for from the SIP traffic 
> itself, as 
> opposed to being in the media path. Might talk about generation of 
> accounting records for SIP and DIAMETER, and bring in 
> relevant elements 
> from the SIP MIB and explain how they can be used.
> 
> Does this sound like what you want to work on?
> 
> Incidentally, Brian Rosen has been making noises about using session 
> liveness to provide some sort of accounting input, so he might be 
> interested in the work.
> 
> --
> Dean
> 
> Harry Behrens wrote:
> 
> > but: I would still suggest a "AAA and Billing" group within the 
> > SIPPING WG. Basically work from RFC3702 and the relevant 
> drafts (OSP 
> > token etc.) to come up with a common view on how AAA and Billing 
> > should be tackled within SIP/VoIP.
> > 
> > facilitating technology. We are seeing a lot of ITSPs entering the 
> > field, a lot of traditional telcos as well, not to mention the 3GPP 
> > with its IMS. We do need to clarify how we plan to enable 
> people to be 
> > able to charge for whatever services they plan to deliver over SIP. 
> > The telcos are squarely betting on OSP and all we have is one draft
> > I would volunteer for any helping role needed within the WG. I am 
> > still in town (Seoul) until Saturday, so if any of you 
> would find the 
> > time for a brief discussion on this, I would be very grateful.
> > 
>

---

From: Dean Willis <[email-masked]>
Date: Wed, 03 Mar 2004 02:13:58 -0600

Here's the deal. If we say "billing", a lynch mob is likely to descend 
and try to hang us from high places by the necks. It's a classis IETF 
"anathema" word, assured to receive a visceral response.

We MIGHT be able to get away with something like "accounting 
methodology", perhaps "Best Practices for Accounting in SIP 
Environments" or something like that. This might be a good place to 
document things like "Financial accounting for media utilization based 
on SIP transactions is a Bad Idea" and so on. Have to indicate what can 
and cannot be efectively accounted for from the SIP traffic itself, as 
opposed to being in the media path. Might talk about generation of 
accounting records for SIP and DIAMETER, and bring in relevant elements 
from the SIP MIB and explain how they can be used.

--
Dean