Subject: [Sipping] Netann user name

From: "Eric Burger" <[email-masked]>
Date: Sat, 6 Mar 2004 18:51:36 -0500

One of the Application's Area AD's suggested that we ask the URI folks at the W3C about the use of the user part of a URI as a service indicator.

The feedback we got was that while they trust that the URI is actually a URL at a given host, we should not rely on that being the case forever.

There were two suggestions on what to do.  Both relate to obscuring the user part.

The first suggestion is to prepend the user name with something "special", like "sip" or "sip-".

The second suggestion is to postfix the user name with "master".  The idea is that people already have an expectation that individuals will not take a mumblemaster name.  Common uses are postmaster, listmaster, webmaster, and so on.

My proposal is to change the existing user names as follows:

  OLD         NEW
 annc       __sip-annc
 dialog     __sip-dialog
 conf       __sip-conf
 ivr        __sip-ivr

Comments?

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Tim Melanchuk <[email-masked]>
Date: Wed, 10 Mar 2004 03:02:21 +0900

this is fine with me. i think it's important to get get this
work concluded. we already have many implementations using the
existing set of names, and the longer this takes to finalize,
the more entrenched those names will become.

the prefix "__sip-" seems preferable over appending "master"
and seems to align with other work.

timm

Eric Burger wrote:

> One of the Application's Area AD's suggested that we ask the URI folks 
> at the W3C about the use of the user part of a URI as a service indicator.
> 
> The feedback we got was that while they trust that the URI is actually 
> a URL at a given host, we should not rely on that being the case forever.
> 
> The second suggestion is to postfix the user name with "master".  
> The idea is that people already have an expectation that individuals 
> will not take a mumblemaster name.  Common uses are postmaster, 
> listmaster, webmaster, and so on.
>

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 11 Mar 2004 00:38:41 -0500

Eric Burger wrote:

> One of the Application's Area AD's suggested that we ask the URI
> folks at the W3C about the use of the user part of a URI as a service
> indicator.
> 
> The feedback we got was that while they trust that the URI is
> actually a URL at a given host, we should not rely on that being the
> case forever.

I don't understand this comment. What can't you rely on? The user part 
of a URI is always interpreted only by the server authoritative for the 
domain in the domain part. Are they saying that this wont always be true?

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: Qiru Zhou <[email-masked]>
Date: Tue, 09 Mar 2004 14:34:43 -0500

Eric,

I prefer __sip-* (or other prefix) than "master" postfix since it is
more clear than the other. We have prototype implementation now using
"annc", "dialog", and "conf". I hope this is the one time change to
adapt the new names.

BTW, why we need "__sip-ivr" here? I thought it is covered by
"__sip-dialog".

-- Qiru