Subject: RE: [Sipping] GRUU in KPML

From: "Eric Burger" <[email-masked]>
Date: Thu, 11 Mar 2004 09:18:12 -0500

I guess I'm missing something.

The device that does KPML is a server.

What normative text can we put in?  The client will always use the Contact:, whether it is a GRUU or not (e.g., no normative text there).

We can say that the server should populate the Contact: with a GRUU (so the client can use it).  That's what I'm trying to say below.

> -----Original Message-----
> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Thursday, March 11, 2004 12:29 AM
> To: Eric Burger
> Cc: Sipping (E-mail)
> Subject: Re: [Sipping] GRUU in KPML
> 
> 
> 
> 
> Eric Burger wrote:
> 
> > How is this for text in KPML:
> > 
> > In Section 2.1 (Model): <t>In all cases, the Requesting Application
> > (or UA) uses a <xref target="I-D.ietf-sip-gruu">GRUU</xref> to
> > address the End Point.  Discovery of the GRUU can be from the
> > original INVITE or 200 OK message, from a subscription to the <xref
> > target="I-D.ietf-sipping-dialog-package">dialog package</xref>, from
> > an all-knowing service broker, or other means.  GRUU discovery is
> > beyond the scope of this specification.</t>
> 
> I dont see why its that complicated. We are always talking about 
> subscriptions associated with dialogs. Dialogs always have contacts. 
> Contacts will always have gruu if the client supports it. Thus, an 
> application server would always subscribe to the gruu found in the 
> contact URI.
> 
> A client which supports KPML MUST also support gruu.
> 
> Thats it.
> 
> Am I missing something?
> 
> -Jonathan R.
> 
> 
> -- 
> Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
> Chief Technology Officer                    Parsippany, NJ 07054-2711
> dynamicsoft
> [email-masked]                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Ben Campbell <[email-masked]>
Date: Mon, 22 Mar 2004 13:02:23 -0600

Jonathan Rosenberg wrote:
> "do" KPML? What does that mean?
> 
> Let me explain using the terminology in the app-interaction framework. 
> We have a user device, such as a standalone IP phone, and an application 
> in the network. When the user device makes a call, it includes a Contact 
> in the INVITE. That Contact has to be a gruu. THis way, when the 
> application wants to get keypad notifications, it can send a SUBSCRIBE 
> to the gruu generated by the user device.
> 
> My point was that, we need normative text that says a user device that 
> supports the application interaction framework and/or kpml, MUST also 
> support GRUU, and include a GRUU in the Contact in any dialog creating 
> requests and responses it sends.

If I understand you correctly, this means the subscription target URI is 
always the dialog contact URI. Is that what you have in mind?

I can imagine a use case where my call is signaled by a device with a 
minimal user interface, but KPML interaction is handled by a separate 
device with a richer interface, such as my PDA or PC. This would be much 
more simple to accomplish if I could specify a KPML target that was 
distinct from my dialog contact.

(I'm OK if we consider this sort of thing out-of-scope. I just wanted to 
make sure we had thought about it.)

Ben.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 12 Mar 2004 16:18:57 -0500

-Jonathan R.