Subject: [Sipping] Re: [Sip-implementors] Call Transfer through B2BUA..

From: Paul Kyzivat <[email-masked]>
Date: Mon, 19 Apr 2004 09:38:41 -0400

[email-masked] wrote:
> Hi All,
> 
> The 3pcc RFC 3725 depicts call flows that are best current practices for
> B2BUAs...
> In all the Call Flows the signalling initiates from the B2BUA i.e the INVITE
> is sent from the B2BUA that then puts the 2 UAs into a Call.
> But in the real life scenario like Call Transfer, the Call originates from
> an End Point A that then reaches a IP-PBX (B2BUA) that then tranfers the
> Call to End Point B. Pl. find below the flows equivalent to those given in
> the RFC 3725 where the Call originates from an End Point.

[snip]

> Flow 4 in RFC 3725 sends out an INVITE from the B2BUA without any media line
> in the Sdp.
> This flow is not possible for an INVITE that comes from an external enppoint
> that will always have an SDP with some media line.

It may be improbable, but it isn't impossible.

For instance, suppose A was yet another B2BUA that is itself carrying 
out flow 4.

> I am in the process of coming up with a test Suite for B2BUA. I am assumuing
> that a B2BUA that implements Call Transfer functionality will use any one of
> the above flows to achieve Call transfer. Am I correct in assuming this. 

A B2BUA is a very general concept. There are many uses for them. You 
cannot infer very much about the behavior of a B2BUA *in general*, so it 
is nearly impossible to test that one is acting correctly, except that 
both sides of it adhere to the rules for a UA.

I suggest you abandon any attempt to generically test a B2BUA. Instead, 
decide on the behavior you require of the kind of B2BUA you are 
interested in and test that. If you are interested in a B2BUA that acts 
as a control point in the middle of calls handled by an IP-PBX, then 
test for that. You will have to figure out the requirements that need 
testing, because there are no standards for such a beast.

> Also in general in any B2BUA call flow, in a real life situation the Call
> originates from an Endpoint and reaches the B2BUA that then ends & initiates
> the Call and controls it. Is that correct..?

Not in general. For instance it isn't true for a "click to dial" 
application. Maybe it is true for the kind of B2BUA you are interested in.

	Paul

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: [email-masked]
Date: Mon, 19 Apr 2004 14:36:30 +0530

Hi All,

Equivalent to Flow 1

	A			B2BUA		B
	 INV (Sdp A)	
	------------>
	100 Trying			INV (Sdp A)
	<------------		------------>
	 				200 (Sdp B)
					<--------------
					 ACK
	200 (Sdp B)			----------->
	<-------------
	ACK
	------------>
			RTP
	<----------------------------------->

Equivalent to Flow 2

	A			B2BUA		B
	 INV (Sdp A)
	-------------->
	200 ( blackhole Sdp)
	<--------------
				INV (Sdp A)
	   ACK		------------->
	<---------------
				200 (Sdp B)
				<-------------
				ACK
				-------------->
	ReINV (Sdp B)
	<-------------- 
	200
	-------------->
	ACK
	<--------------
			RTP
	<-------------------------------->

Equivalent to Flow 3

	A			B2BUA		B
	INV (Sdp A)
	-------------->
	200 (black hole Sdp)
	<--------------
	ACK
	--------------->		INV (No Sdp)
				  --------------->
					200 (Sdp B)
				   <--------------
	ReINV (Sdp B)
	<---------------
	200 (Sdp C)
	--------------->		ACK (Sdp C)
				  ---------------->
	ACK
	<---------------
			RTP
	<--------------------------------->

Thanks,
Badri

Badri Srinivasan S
Networking Technology Labs,
HCL Technologies,
Plot No:66 South Phase
Ambattur Industrial Estate
Chennai-58
Phone:91 44 26521077, 26521270  Xtn: 2243
Fax 52060485

----------------------------------------------------------------------------
-----------
"After much research, Polycom selected HCL's SIP protocol tester to ensure
our products deliver the carrier-grade reliability our conferencing service
providers demand. In addition, HCL's tools provide the in-depth testing we
need to speed the certification of our Voice over IP solutions and guarantee
interoperability," said Matt Taylor, Staff Engineer for Polycom
----------------------------------------------------------------------------
------------

visit us @ http://www.hcltechnologies.com/voip