Subject: RE: [Sipping] Re:draft-camarillo-sipping-uri-list-02.txt

From: [email-masked]
Date: Thu, 15 Apr 2004 13:53:38 +0300

I think this paragraph can be entirely removed.

/Hisham

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> ext Paul Kyzivat
> Sent: 10.April.2004 01:06
> To: [email-masked]
> Subject: [Sipping] Re:draft-camarillo-sipping-uri-list-02.txt
> 
> 
> Section 4 says:
> 
>     As for any other SIP request, the size of requests 
> carrying URI lists
>     MUST NOT exceed 1300 bytes, unless the user agent client 
> has positive
>     knowledge that the message will not traverse a 
> congestion-unsafe link
>     at any hop, or that the message size is at least 200 
> bytes less than
>     the lowest MTU value found en route to the server.
> 
> I was curious about the implications of this, so I did some 
> counting. I 
> took the example in section 9 and stripped out all the 
> leading blanks to 
> get a plausible size estimate. The number I got was 1242, 
> with four urls 
> in the list. Each additional URL (of the size in the example) adds 37 
> bytes. So a list with more than 5 urls exceeds the 1300 byte limit.
> 
> That says to me that this technique is pretty much useless except in 
> carefully controlled networks, or when compression is used. 
> Seems pretty 
> limiting. So it seems likely that in practice content 
> indirection will 
> have to be used.
> 
> 	Paul
> 
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Gonzalo Camarillo <[email-masked]>
Date: Fri, 16 Apr 2004 09:51:17 +0300

Hi,

yes, I had already got this comment before, and I had logged a bug 
against it. The next revision of the draft will not have this paragraph.

Thanks,

Gonzalo

-- 
Gonzalo Camarillo         Phone :  +358  9 299 33 71
Oy L M Ericsson Ab        Mobile:  +358 40 702 35 35
Telecom R&D               Fax   :  +358  9 299 30 52
FIN-02420 Jorvas          Email :  [email-masked]
Finland                   http://www.hut.fi/~gonzalo

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 16 Apr 2004 10:11:34 -0400

Why can this be removed? Isn't it still a real issue?

Or is this assumed to be fixed by the 3261 requirement that large 
messages be delivered over TCP?

	Paul

Gonzalo Camarillo wrote:
>>> From: [email-masked] [mailto:[email-masked]]On Behalf Of
>>> ext Paul Kyzivat
>>>    As for any other SIP request, the size of requests carrying URI lists
>>>    MUST NOT exceed 1300 bytes, unless the user agent client has positive
>>>    knowledge that the message will not traverse a congestion-unsafe link
>>>    at any hop, or that the message size is at least 200 bytes less than
>>> I was curious about the implications of this, so I did some counting. 
>>> I took the example in section 9 and stripped out all the leading 
>>> blanks to get a plausible size estimate. The number I got was 1242, 
>>> with four urls in the list. Each additional URL (of the size in the 
>>> example) adds 37 bytes. So a list with more than 5 urls exceeds the 
>>> 1300 byte limit.
>>>
>>> carefully controlled networks, or when compression is used. Seems 
>>> pretty limiting. So it seems likely that in practice content 
>>> indirection will have to be used.
>>>
>>>     Paul
>>>
>>>

---

From: Alex Audu <[email-masked]>
Date: Fri, 16 Apr 2004 10:16:33 -0500

UDP induced message size limitation should be transparent to the user.  
3261 has
already specified proper handling for large messages. I think that 
should be enough
to allow the client side deal with the problem transparently.

Regards,
Alex.

Paul Kyzivat wrote:

>>>> counting. I took the example in section 9 and stripped out all the 
>>>> leading blanks to get a plausible size estimate. The number I got 
>>>> was 1242, with four urls in the list. Each additional URL (of the 
>>>> size in the example) adds 37 bytes. So a list with more than 5 urls 
>>>> exceeds the 1300 byte limit.
>>>>
>>>> That says to me that this technique is pretty much useless except 
>>>> in carefully controlled networks, or when compression is used. 
>>>> Seems pretty limiting. So it seems likely that in practice content

---

From: Gonzalo Camarillo <[email-masked]>
Date: Fri, 16 Apr 2004 18:23:27 +0300

Hi,

yes, the idea is to reference RFC 3261. That is, we will not define any 
special handling for large messages in the uri list draft.

Thanks,

Gonzalo