Subject: [Sipping] Service Discovery Mechanism using SIP

From: De Leo Walter <[email-masked]>
Date: Wed, 5 May 2004 11:53:41 -0300

Is there some work or plan to define a Service Discovery mechanismo using
SIP?
 
I elaborate:
 
Suppose there is some AS providing a set of services. Is there a mechanism
for:
 
a) The AS publicize the services it provides.
b) The UA access to a list of AS providing the service its user need.
 
I find it very like a Presence Service but where the resource is not a user
but a Service.
That is a Service "Presence" Server would maintain a list of Service-AS
presence status to which a user could subscribe.
 
Is any work in this line of thought or interest in developing that
mechanism?
 
Or is there some other approach for this task?
 
Regards.

______________________________________________________

Walter D. De Leo

Defensa 390 Piso 1 (C1065AAF) Buenos Aires. Argentina

Tel: 54 11 4332-5027  Fax: 54 11 4303-5586 Int 2302
email: [email-masked]

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 12 May 2004 02:26:21 -0400

SIP isn't in the business of service discovery. The service location 
protocol (SLP), RFC 2608, is an ietf protocol for this function. There 
are also many proprietary protocols.

-Jonathan R.

De Leo Walter wrote:

> Is there some work or plan to define a Service Discovery mechanismo 
> using SIP?
>  
> I elaborate:
>  
> Suppose there is some AS providing a set of services. Is there a 
> mechanism for:
>  
> I find it very like a Presence Service but where the resource is not a 
> user but a Service.
> email: [email-masked]
> 
>  

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Xiaotao Wu <[email-masked]>
Date: Wed, 12 May 2004 09:31:18 -0400 (EDT)

> protocol (SLP), RFC 2608, is an ietf protocol for this function. There

There are some SLP templates for SIP services. You may take a look at
ftp://ftp.isi.edu/in-notes/iana/assignments/svrloc-templates/

sip.1.0.en
sipproxy.1.0.en
sipregistrar.1.0.en

-Xiaotao