Subject: RE: [Sipping] RE: [Sip] SIP Forward, Who pays the bill ?

From: "Mary Barnes" <[email-masked]>
Date: Fri, 21 May 2004 08:38:22 -0400

I've trimmed the receiver list and kept this on sipping only.  I think folks
should take a look at:
http://www.ietf.org/internet-drafts/draft-elwell-sipping-redirection-reason-
00.txt
and see if this doesn't help fill the gap.  

This could be used in conjunction with History-Info:
http://www.ietf.org/internet-drafts/draft-ietf-sip-history-info-02.txt
to achieve the functionality of knowing when a a call has been forwarded
(obviously, not all addressing any billing requirements, but I think all the
information you would need would be available). 

Regards,
Mary. 

-----Original Message-----
From: Juha Heinanen [mailto:[email-masked]] 
Sent: Friday, May 21, 2004 3:55 AM
To: Diego B
Cc: Jonathan Rosenberg; Roy, Radhika R, ALABS; [email-masked]; Chowdhury,
Sayan [Business:WBNG:7Q23]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Sipping] RE: [Sip] SIP Forward, Who pays the bill ?

Diego B writes:

 > In a close environment, I can use whatever method to  recognize a 
 > forward situation. But SIP is about inter operability and integration 
 > and AFAIK there are some drafts but nothing specific to inform of a call 
 > forward situation, I don't know the status of Diversion header, but this 
 > can be a solution if standardized.

both rpid and diversion headers have become de-facto industry ways to
achieve that you want.  may be one day some ietf standardized way to do the
same becomes widely implemented, at which point you can support this new
thing too.

-- juha

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip Use
[email-masked] for new developments on the application of sip

---

From: Takuya Sawada <[email-masked]>
Date: Mon, 24 May 2004 18:48:23 +0900

Hi,

Do you have a plan to include the proposal in Johon's draft into
History-Info draft?

Regards,
Takuya

> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP

--------
Takuya Sawada
KDDI Corporation (KDDI)
Garden Air Tower, 3-10-10, Iidabashi, 
Chiyoda-ku, Tokyo 102-8460, Japan
Tel: +81-3-6678-2997
Fax: +81-3-6678-0286
[email-masked]

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Takuya Sawada <[email-masked]>
Date: Mon, 24 May 2004 18:50:54 +0900

Hi,

In draft-elwell-sipping-redirection-reason-07, two solutions
are proposed. Solution 1 proposes new Reason header protocol value
and Solution 2 proposes new Contact URI parameter.

As discussed in the draft, the main difference between two 
solutions is that redirect reason is associated with the original
URI in the solution 1, whereas it is associated with the new URI
in the solution 2.

In ISUP, redirect reason is associated with the original
called number. So, as far as ISUP interworking is concerned,
solution 1 can be a suitable solution.
But I think we need more pros and cons discussion on this topic.

----
As shown below, indexes of redirection-to and redirected-from
are not necessarily adjacent to each other in the indexes tree.
In the solution 1, History-Info of index=1.3 can not express
where it is redirected from. In the solution 2, History-Info
of index=1.1 can not express where it is redirected to.
If we need complete information about from-to redirection,
we need another field to be included.
For example, redirect-to field for the soltuion 1 or redirected-from
parameter for the solution 2.
This is messy, though.

                           1.1
               ---------------->o A: Redirect to C
              /
     index=1 /  (Fork)     1.2
----------->o------------------>o B
             \
              \            1.3
               ---------------->o C
----

Regards,
Takuya

--------
Takuya Sawada
KDDI Corporation (KDDI)

---

From: Juha Heinanen <[email-masked]>
Date: Mon, 24 May 2004 13:37:43 +0300

takuya,

i'm not sure if people want the caller to know why redirection
happened.

to which category would redirection by enum query fit?

-- juha