Subject: RE: [Sipping] Poll: Consensus on adoption of the URI-list work

From: [email-masked]
Date: Mon, 17 May 2004 15:51:24 +0300

Hi,

Has there been a resolution for this or for the other poll about MESSAGE exploder? There were a few persons in favour (it seems you never get much more activity on these lists), and I did not see anyone objecting, so I guess this should be clear? At least to me it seems that people working on this have done a lot of work with quite rapid progress, so I don't think there is a risk that this would be one of those almost-never-finishing activities that SIP/SIPPING/SIMPLE are quite full of.

Markus

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> ext Dean Willis
> Sent: 04 May, 2004 21:14
> To: [email-masked]
> Cc: Gonzalo Camarillo; Rohan Mahy; Allison Mankin
> Subject: [Sipping] Poll: Consensus on adoption of the URI-list work
> 
> 
> 
> See: draft-camarillo-sipping-uri-list-02.txt
> 
> It seems that the URI-list stuff is becoming important for its use in 
> ad-hoc list requests. I've heard of several other groups that are 
> referring to it in their specifications, and wish for us to 
> conclude on 
> the specification ASAP.
> 
> The current draft is fairly mature, and we seem to have a 
> constituency 
> for the specification.
> 
> Consequently, I'd like to suggest that the SIPPING group consider 
> adopting this draft as a working group effort, targeted for 
> informational RFC, with an estimated delivery date to IESG of 
> June, 2004.
> 
> Please respond, aye or nay, if you care. The chairs will, as usual, 
> judge consensus and report the recommendation (for or 
> against) to the AD 
> for consideration.
> 
> Thanks,
> 
> --
> Dean Willis
> SIPPING co-chair
> 
> 
> 
> 
> 
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Gonzalo Camarillo <[email-masked]>
Date: Mon, 17 May 2004 18:24:47 +0300

Hi,

as an individual, I also believe that this work has raised enough 
interest and that the technical solution is quite estable at this point. 
So, I would support making those documents WG items.

In addition, I would like to see discussions on the only important open 
issue we have: security. The security considerations section of the 
requirements and framework for SIP exploders talks about the security 
implications of this work. It would be great if the community, including 
chairs and ADs, had a look at it and express their opinions.

Thanks,

Gonzalo

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 17 May 2004 12:10:02 -0400

> So, I would support making those documents WG items.

I agree with making this a WG item.

> chairs and ADs, had a look at it and express their opinions.

I don't agree this is the only issue we have.

I think how the list is specified is still an issue. Use of a uri 
parameter is still potentially a problem. (See the ongoing discussion on 
uri parameters and proxy translation of the request uri.)

But these are solvable issues, and I think it is clear that as a group 
we need this capability.

	Paul

---

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 18 May 2004 18:20:22 +0300

Paul,

> I agree with making this a WG item.

Good.

> 
>> In addition, I would like to see discussions on the only important 
>> open issue we have: security. The security considerations section of 
>> the requirements and framework for SIP exploders talks about the 
>> security implications of this work. It would be great if the 
>> community, including chairs and ADs, had a look at it and express 
>> their opinions.
> 
> 

Yes, I agree that this is a solvable issue. Based on several 
conversations during the last two IETF meetings, I believe that we have 
rough consensus on going ahead with the URI parameter, but we can 
definitively discuss this in the interim during the exploders' time slot.

Thanks,

Gonzalo

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 18 May 2004 13:58:49 -0400

Gonzalo Camarillo wrote:
>> parameter is still potentially a problem. (See the ongoing discussion 
>> on uri parameters and proxy translation of the request uri.)
>>

I think we may have had rough concensus, but it may not have been 
informed consent. Based on the recent discussions around uri parameters, 
I don't know how many people realized that they aren't automatically 
passed along when an address is translated by a proxy.

I personally was grudgingly going along on the assumption that you just 
couldn't use addresses that are subject to proxy translation when you 
want to use a list. I don't consider that ideal, but have been trying to 
ignore that. But I would like to be confident that everybody understands 
that limitation.

Alternatively, the draft may need to have language that ammends the 
functioning of proxies so that the 'list' parameter is passed in 
translation. But I don't think that is a good idea.

	Paul