Subject: [Sipping] RE: [Sip] SIP Forward, Who pays the bill ?

From: [email-masked]
Date: Wed, 19 May 2004 10:29:54 +0530

Also , Alice might be sending the re-invite to on receipt of a 302 from Bob. So the set of proxies invloved in the first leg of the call may not be involved in the second ?
Solutuion to this will be on the PSTN gateway side.
The PSTN gateway should look for and bill from Diversion/Request History/remote Part Header information in preference to the from header which is unreliable any way.
However , I do not know of any standards which explicitly mentions that ..
 
Regards ,
Sayan

	-----Original Message----- 
	From: [email-masked] on behalf of Diego B 
	Sent: Tue 5/18/2004 7:44 PM 
	To: [email-masked] 
	Cc: [email-masked]; 'sipping'; 'Cullen Jennings' 
	Subject: Re: [Sip] SIP Forward, Who pays the bill ?

	Hi Baruch;
	Thanks for your answer.
	I belive that you are implementing a proprietary solution to deal with it.
	I'm looking more to a standarize way to deal with the second-leg issue.
	
	I'm agree that Alice has to pay for the first leg and Bob for the
	second, but if the Proxy that is doing the forward is not a biling
	entity ( local calls are free, outbound call are not free and billed by
	an external real-time billing system connected to the GW using RADIUS or
	similar), the PSTN gateway will have to know that this call may be
	billed to Bob and not to Alice ( she apears in the From header ).
	
	Thanks
	
	Baruch Sterman wrote:
	
	> In the systems that we implemented, two cdrs are created: the first for
	> the incoming leg (Alice to Bob's non-forwarded location) and a second
	> for the forward to Bob's forwarded location.
	>
	> Alice would pay for the first leg, and Bob pays for the second.
	>
	> Furthermore, it may be the case that Bob pays for the first leg as well.
	> If, for example, Bob has a toll free number where he pays per minute
	> charges for the inbound leg (in this case, Alice is on the PSTN).
	>
	> Either way, multiple CDRs is the way we came up with to handle this.
	> Care has to be taken that the key to any CDR database is NOT the
	> call-ID, because this is the same across the two CDRs.
	>
	> Baruch
	>
	> -----Original Message-----
	> From: [email-masked] [mailto:[email-masked]] On Behalf Of Diego
	> B
	> Sent: Tuesday, May 18, 2004 7:42 AM
	> To: [email-masked]; sipping
	> Cc: Cullen Jennings
	> Subject: [Sip] SIP Forward, Who pays the bill ?
	>
	> Hi;
	> My question is regarding billing a forwarded sip call.
	>
	> Lets take the exmple from draft-ietf-sipping-service-examples
	> 2.7
	>
	> Alice calls Bob, and Bob has all his incomming calls forwarded to the
	> PSTN.
	>
	> Let say that calls from ALice to Bob in the same domain are free (same
	> office, or same ITSP), but calls to the PSTN are not free.
	>
	> Who pays for Alice call to Bob ??
	> In a normal situacion, Alice knows that the call is for free becuase she
	>
	> is calling Bob's sip number. But the gateweay may create CDR from the
	>  From header of the SIP message and at the end of the month Alice may
	> have to pay for the call.
	>
	> I see this kind of examples in several other drafts/RFC related to SIP
	> services and call forward.
	>
	> I belive forward is a very important feature, but this issue may be
	> resolved. The question is if it is a standard way to make Bob pays for
	> the second leg of the call like in PSTN forward.
	>
	> Maybe changing the From header where applicable and adding a new one to
	> "remember" that the call is from, in my example, Alice.
	>
	> The diversion header (Diversion Indication in SIP
	> draft-levy-sip-diversion-07.txt)" may be a solution if the PSTN gateway
	> or the SIP Billing server support it and knows that they have to bill
	> the sip-uri in the diversion header ( this is right ??? ).
	>
	> Regards;
	>
	>
	>
	>
	>
	
	--
	Diego B
	MailVision Ltd.
	Tel.  : 4-8500505 ext 13
	e-mail: [email-masked]
	web   : http://www.mailvision.com <https://gateway-india.wipro.com/,DanaInfo=www.mailvision.com> 

	_______________________________________________
	Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip <https://gateway-india.wipro.com/mailman/listinfo/sip,DanaInfo=www1.ietf.org,SSL> 
	This list is for NEW development of the core SIP Protocol
	Use [email-masked] for questions on current sip
	Use [email-masked] for new developments on the application of sip

---

From: "Baruch Sterman" <[email-masked]>
Date: Wed, 19 May 2004 05:47:07 -0400

Another avenue that can be explored is an explicit header to deal with this and other accounting issues. I think that the AAA group has suggested an ACCOUNTING header. We were thinking of a BILLING header. In that header you would have a username and type. So as the call progresses you could add to that header. This would also allow to charge for various services along the way. Imagine the following. Alice calls Bob, Bob forwards to Charlie who requires an ENUM lookup to find his IP – and you are dealing with a psychotic ITSP that *Charges* for ENUM listing.
Inbound Alice -> Bob         Billing: Alice, inbound
Forward Bob -> Charlie      Billing: Alice, inbound; Bob, outbound
ITSP looks up Charlie        Billing: Alice, inbound; Bob, outbound; Charlie, serviceX
 
So when the CDR gets written, the rating engine looks through the Billing header and applies all the relevant charges to the relevant accounts. Some may be per minute, some may be fixed charges.
 
The problems are first and foremost, security. No one can add to the billing header unless they are trusted entities within your system, because money will be charged based on the information there. Second, care has to be taken to strip off the header when it leaves the trusted domain – out to the UA’s for example. You don’t want people knowing what is going on in your billing system. 
 
But the idea here is very flexible and can take into account many things that we aren’t thinking about now. For example, we may charge differently one day calls that require NAT treatment on the RTP level (where the bandwidth cost to the hosting ITSP is not negligible). When you find that to be the case, just add it to the Billing header. What about if calls are forwarded multiple times? Keep adding each leg to the billing header.
 
What does everyone think about this?
 
Baruch
 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, May 19, 2004 1:00 AM
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [Sip] SIP Forward, Who pays the bill ?

Regards ,
Sayan
 
-----Original Message----- 
From: [email-masked] on behalf of Diego B 
Sent: Tue 5/18/2004 7:44 PM 
To: [email-masked] 
Cc: [email-masked]; 'sipping'; 'Cullen Jennings' 
Subject: Re: [Sip] SIP Forward, Who pays the bill ?
Hi Baruch;
Thanks for your answer.

Thanks

---

From: "Michael Herman \(Parallelspace/Office\)" <[email-masked]>
Date: Wed, 19 May 2004 22:31:20 -0400

Apologies for possibly sending this to the wrong email distribution lists
...
 
Q: Does anyone know where I can find information about ECMA 232 and
tunneling it over SIP?

Thank you in advance (and my apologies if these are the wrong lists or if
the list memberships are extraordinarily large),
----------
Michael Herman
Parallelspace Corporation
Developers of Advanced Business Collaboration Solutions for Microsoft
SharePoint, Microsoft Live Communications Server and Groove Workspace
Portal and Content Migration Solution Specialists:
<http://www.parallelspace.net/sharepoint>
http://www.parallelspace.net/sharepoint
SharePoint Migration Knowledge Center:
http://groups.yahoo.com/group/sharepointmigration