Subject: RE: [Sipping] instance-ID for SIP UA

From: Simonetti Gabrielle <[email-masked]>
Date: Wed, 22 Sep 2004 11:54:29 +0200

Hi,
One more question, see below.
Gabrielle

> -----Original Message-----
> From: Paul Kyzivat [mailto:[email-masked]]
> Sent: martedì 21 settembre 2004 16.32
> To: Simonetti Gabrielle
> Cc: [email-masked]
> Subject: Re: [Sipping] instance-ID for SIP UA
> 
> 
> Simonetti Gabrielle wrote:
> >  
> > My questions relate to the Instance-ID: to my 
> understanding, in the case of the Profile Delivery Framework, 
> the instance-ID itself may be used in the URI to retrieve the 
> "device" profile, if it identifies a specific UA instance 
> with a SIP URI.
> > 
> >    First issue - What is the format of the instance-ID?
> > We would like a standardized instance-ID for all UA. 
> Jennings draft suggests the format "RANID-" followed by a 16 
> digit representation of a random 64 bit number. Couldn't this 
> number be associated with the local domain to obtain a unique 
> URI identifying the UA instance to be used for the 
> subscription to the "device" profile? 
> 
> In the GRUU spec we tried not to be too specific about this - 
> it is only 
> important that there be a mechanism for comparing instance 
> IDs and that 
> each be unique. For this purpose it is sufficient that the id 
> be a URN.
> 
> However, we did have in mind a particular form of URN as especially 
> suitable: the UUID URN as defined in 
> draft-mealling-uuid-urn-03. But we 
> didn't want to reference it normatively because it would impose a 
> dependency on the order in which they become RFCs.
 
The one thing that tickled me about using the GRUU to retrieve the device profile is that it involves an AOR. Yet the "device" profile is only concerned with the device itself and there is no user involved in the process at this point. So should the URN alone be used as the request URI and in the From/To Header fields? Or should it be escaped and associated to the local domain?

Thank you.
Gabrielle

Gruppo Telecom Italia - Direzione e coordinamento di Telecom Italia S.p.A.

====================================================================
CONFIDENTIALITY NOTICE
This message and its attachments are addressed solely to the persons
above and may contain confidential information. If you have received
the message in error, be informed that any use of the content hereof
is prohibited. Please return it immediately to the sender and delete
the message. Should you have any questions, please send an e_mail to
[email-masked]. Thank you
====================================================================

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 22 Sep 2004 09:32:44 -0400

> The one thing that tickled me about using the GRUU to retrieve the device profile is that it involves an AOR. Yet the "device" profile is only concerned with the device itself and there is no user…

I don't think anyone is suggesting that you use the gruu to retrieve the 
device profile.

What is being suggested is that the gruu mechanism now uses an instance 
ID to identify the specific UA that is requesting the gruu, and that 
that same instance ID could be used to retrieve the "device" profile.

I believe the identity and uniqueness properties required by the two 
applications are the same, so the same id seems appropriate.

	Paul