Subject: AW: [Sipping] New draft on media handling feature for seamless session mobility

From: "Kellerer, Wolfgang" <[email-masked]>
Date: Mon, 23 May 2005 14:20:37 +0200

Hello,

This draft touches an important issue in session transfer.

I have some concerns regarding the approach as there is quite some
complexity in setting up a PAN. Especially for real-time media services
(VoIP, video telephony), which we target in the referenced draft that
specifies the underlying transfer method
(http://www.ietf.org/internet-drafts/draft-shacham-sipping-session-mobil
ity-00.txt)
it is unclear to see how this media handling approach would make a
difference. In VoIP, videotelephony, etc. buffering times are on the
order of 1-2 packets only. 

Furthermore, our measurements on actual session transfers based on our
draft (draft-shacham-sipping-session-mobility-00.txt) show that the
transfer delay even for long links is still below one second.

Regards,

Wolfgang

------------------------------------------
Dr.-Ing. Wolfgang Kellerer
Manager
Service Platform and Middleware Technology Group
Future Networking Lab
 
DoCoMo Communications Laboratories Europe GmbH
Landsberger Str. 312
80687 Munich, Germany
 
Tel. +49-89-56824-222
Fax. +49-89-56824-300
E-mail: [email-masked]
i-mode: [email-masked]
http://www.docomolab-euro.com
------------------------------------------

> From: "Xu Ming Qiang \(Jo\)" <xu.mingqiang at jp.panasonic.com>
> Date: Mon, 16 May 2005 19:44:27 +0900
> 
> We have submitted a draft on the indication of media handling 
> feature in SIP for realizing seamless session mobility. 
> Suggestions and comments would be appreciated.
> 
> http://www.ietf.org/internet-drafts/draft-mingqiang-sipping-se
ssion-mobility-media-00.txt
> 
> >From the abstract:
>    Session mobility allows a user to transfer an ongoing communication
>    session from one device to another device. Seamless 
> session mobility
>    is  very  important  for  real  time  multimedia  
> applications. This
>    document defines a new option tag in SIP to indicate media handling
>    feature during the transfer of communication session from 
> one device
>    to another device to achieve seamless session transfer without
>    disruption of media streams. The new media handling option 
> tag is to be
>    used in the Require SIP header. This document also defines 
> a new media
>    feature tag, which can be used in the Contact header field 
> (instead of the
>    new option tag) to enable seamless session transfer 
> without disruption of media.
> 
> Best regards
> 
> Xu
> 
> 
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Xu Ming Qiang \(Jo\)" <[email-masked]>
Date: Wed, 25 May 2005 19:52:06 +0900

Hello, Wolfgang

Thank you very much for your comment. It is a good point.

Actually, our draft mainly targets for streaming application. For this
kind of application, as we wrote in the draft, streaming clients such as
Windows Media Player usually have a receiver buffer that is capable
of storing a relatively large amount of data for a short duration to
maintain
continuous playback in case of occasional increased transmission delays
or network throughput drops.

So, in our solution, we start creating the necessary playback buffer at
the target device to eliminate the pre-roll delay during the process of
selecting
the transfer target device. (Pre-roll delay means the time that it takes for
the
receiver buffer to fill to a desired level so that playback can begin
instantly.)

Just as you pointed out, as for telephony such as VoIP, compared with
streaming application, buffering time is devised to be very short in order
to
decrease the media delay. For this kind of application, it is out of the
scope
of our solution.

Thanks and regards

Xu

----- Original Message ----- 
From: "Kellerer, Wolfgang" <[email-masked]>
To: <[email-masked]>
Sent: Monday, May 23, 2005 9:20 PM
Subject: AW: [Sipping] New draft on media handling feature for
seamlesssession mobility

Hello,

Regards,

Wolfgang

Tel. +49-89-56824-222
Fax. +49-89-56824-300