Subject: RE: [Sipping] Re: draft-elwell-sipping-service-retargeting-00.txt

From: "Elwell, John" <[email-masked]>
Date: Tue, 11 Oct 2005 16:59:08 +0100

Paul,

> -----Original Message-----
> From: Paul Kyzivat [mailto:[email-masked]] 
> Sent: 11 October 2005 16:32
> To: Dolly, Martin C, ALABS
> Cc: Elwell, John; GARCIN Sebastien RD-CORE-ISS; sipping
> Subject: Re: [Sipping] Re: 
> draft-elwell-sipping-service-retargeting-00.txt
> 
> I think the choices of where to carry the reason (header, or uri 
> parameter), and how reasons are named, are independent decisions.
> 
> I think I understand why the uri parameter approach is being 
> suggested, 
> and it does have some benefits. But it has some drawbacks as 
> well. I'm 
> not yet settled on my final conclusion about them.
> 
> One issue with the uri parameter approach is: what if the new 
> target is 
> not a sip-uri? It could easily be a tel: uri - there are quite 
> reasonable use cases for that. It could also potentially be an IM: or 
> PRES: uri. And in the case of 3xx responses it can be any 
> kind of URI - 
> even http. At best the rules for affixing parameters can vary by URI 
> scheme, and at worst some schemes may not allow it.
[JRE] Tel URI excepted, this limitation applies also to the Reason header
approach, since that relies on the header being placed in a History-Info
header in the retargeted or recursed SIP request. But your point about the
tel: URI is valid.

John

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Dean Willis <[email-masked]>
Date: Tue, 11 Oct 2005 14:15:50 -0500

This item from the thread on retargeting and Reason header usage just  
caught my eye:

On Oct 11, 2005, at 10:59 AM, Elwell, John wrote:

> Paul said:
> URI excepted, this limitation applies also to the Reason header

I'm thinking that the generalized usage of the History-Info header  
for telephone services (like some of the TISPAN discussion usage)  
depends on using tel: URIs in requests.

But if I read this right, we really can't put the Reason header into  
a History-Info which uses a tel: URI.

Do we have a major problem here? Or am I just missing something?

Thanks,

--
Dean