Subject: [Sipping] Multiple REFERs in the same dialog

From: Kapil Nayar <[email-masked]>
Date: Thu, 13 Oct 2005 22:55:24 +0100 (BST)

Hi

Although, the protocol allows this - is there any
practical scenario where multiple REFERs need to be
sent/ handled in the same existing dialog.
Any info would be appreciated.

thanks,
-kapil nayar

___________________________________________________________ 
To help you stay safe and secure online, we've developed the all new Yahoo! Security Centre. http://uk.security.yahoo.com

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 13 Oct 2005 18:40:22 -0400

> sent/ handled in the same existing dialog.

Case 1:

- A calls B,
- A wants to forward B to C.
- A sends REFER to B in dialog
- the refer fails (e.g. bad address for C)
- A sends another REFER to B in same dialog
   (with a revised address.)

Case 2:
- A is in dialog with conference focus F
- A sends REFER in dialog to F, asking F
   to INVITE B as another conference member
- A sends REFER in dialog to F, asking F
   to INVITE C as another conference member

I believe these are both practical scenarios. Both cases can be done 
with REFER outside the dialog if the contacts are known to have the gruu 
property. But until gruu is much more widely implemented I think the 
in-dialog approach will be of interest.

	Paul

---

From: Dean Willis <[email-masked]>
Date: Thu, 13 Oct 2005 18:32:15 -0500

> Any info would be appreciated.

The OMA PoC "Pre-Established Dialog" model makes use of this  
characteristic.  The user's UA initially establishes a long-lived  
dialog with an in-network UA, called a "PF" or "Participating  
Function". The user's UA then uses in-dialog REFER transactions to  
ask the PF to connect or disconnect third parties. In essence, the PF  
acts as a conference focus for a long-lived conference that never  
contains more than two members (unless the PF is promoted to a "CF",  
or "Controlling Function", but that's a whole 'nother story).

--
Dean