Subject: RE: [Sipping] Reason header in Responses

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Wed, 19 Oct 2005 13:43:52 -0400

Dean,

Reason header already includes the protocol value "Q.850" and
cause=1*DIGIT, but the earlier discussion was about extending it to also
include Q.732 values.

Mike 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Dean Willis
> Sent: Tuesday, October 18, 2005 4:10 PM
> To: Jesske, R
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Sipping] Reason header in Responses
> 
> 
> On Oct 18, 2005, at 4:24 AM, Jesske, R wrote:
> 
> > Dear all,
> > Still the use of the Reason header confuses me.
> > With regard to the discussion of the retargeting draft the 
> inclusion 
> > of a 486 in a 302 is discussed as possible.
> > But on the other side the inclusion of a Q.850 reason header in a 
> > response is not allowed.
> > Could I have some Guidance How I have to understand the following 
> > phrase written in RFC 3326 Reason Header:
> >
> >    Initially, the Reason header field defined here appears 
> to be most
> >    useful for BYE and CANCEL requests, but it can appear in any 
> > request
> >    within a dialog, in any CANCEL request and in any response whose
> >    status code explicitly allows the presence of this header field.
> >
> >    Note that the Reason header field is usually not needed in 
> > responses
> >    because the status code and the reason phrase already provide
> >    sufficient information.
> >
> > Does this mean that if I specify the use of SIP Reason in a 
> response 
> > (e.G in a IETF RFC, ITU-T or ETSI Specification) it is 
> allowed to use 
> > this now or do I need a special IETF draft to allow the use 
> of Q.850 
> > Reasons in responses?
> 
> I'm sorry, Roland, but use of Q.850 codes in SIP responses 
> would be "unreasonable" ;-), at least without an RFC that 
> revises the response code to allow it to carry a Reason 
> header. John submitted a draft that proposed extending 302 to 
> carry a Reason header, and we haven't resolved on that 
> approach. Even with such a draft, we'd also I believe need 
> additional RFCs defining use of Q.850 codes in Reason 
> headers, along with appropriate IANA actions.
> 
> --
> Dean
> 
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Dean Willis <[email-masked]>
Date: Thu, 20 Oct 2005 00:57:30 -0500

> cause=1*DIGIT, but the earlier discussion was about extending it to  
Ah. Thanks, Mike. I believe you're right.

I think we'd still need the "Reason in response" to do what I think  
Roland was suggesting.

--
Dean