Subject: RE: [Sipping] Redirection on busy and History Info

From: "Elwell, John" <[email-masked]>
Date: Mon, 31 Oct 2005 09:41:26 +0000

Gonzalo,

> -----Original Message-----
> From: Gonzalo Camarillo [mailto:[email-masked]] 
> Sent: 30 October 2005 09:39
> To: sipping
> Subject: [Sipping] Redirection on busy and History Info
> 
> Hi,
> 
> this is a strawman on how to encode the redirection reason in a 302 
> response using History-Info.
> 
> A UAS that needs to send a 302 response because its user is 
> busy could 
> act as a virtual proxy and return the following History-Info header 
> field in the 302 response:
> 
> History-Info: <sip:[email-masked]; index=1,
>                <sip:[email-masked]?Reason=SIP;cause=486;\
>                   text="Busy Here">;index=1.1
> 
> The URI would be the same in both entries because the UAS acts as a 
> virtual proxy.
> 
> The entity receiving the 302 would generate an INVITE with 
> the following 
> History-Info header field:
> 
> History-Info: <sip:[email-masked]?Reason=SIP;cause=302;\
>                    text="Moved Temporarily">; index=1,
>                 <sip:[email-masked]?Reason=SIP;cause=486;\
>                    text="Busy Here">;index=1.1
> 
[JRE] So presumably, if the UAC (or proxy) does indeed recurse based on the
contents of the Contact URI in the 302 response, then it will generate a
third H-I entry to represent that? 

My comments on your proposal would be:

1. This is not how UACs / proxies would work at present according to the
History-Info draft. When building a recursed INVITE request they would take
existing History-Info entries from the original INVITE request, not from the
3xx response.

2. We have two entries with the same URI but different indices, which is not
recognised in the History-Info draft at present but might be harmless.

John

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Gonzalo Camarillo <[email-masked]>
Date: Mon, 31 Oct 2005 12:50:04 +0200

Hi John,

> existing History-Info entries from the original INVITE request, not from the

Message F4 and F5 from page 29/30 in the History Info draft do just what 
I described. F4 is a 302 response, and Proxy1 includes that information 
in the F5 INVITE:

History-Info: <sip:[email-masked]?Reason=SIP;\
       cause=302; text="Moved Temporarily">; index=1,
       <sip:[email-masked]>;index=2

http://www.ietf.org/internet-drafts/draft-ietf-sip-history-info-06.txt

> recognised in the History-Info draft at present but might be harmless.

Coming up with a new user part for the URI would be trivial for the UAC, 
if somebody really thinks that having two identical URIs with different 
indexes is a problem.

Cheers,

Gonzalo