Subject: [Sipping] Use cases of multi-transcoding

From: "Kang Tae-Gyu" <[email-masked]>
Date: Tue, 21 Feb 2006 11:12:56 +0900

Hello,

I would like to discuss about the use case of multi-transcoding. First of all, I am sorry for that I could not answer about its use case when I received the question from the floor, IETF 64 Vancouver meeting, because of poor English. Also, thank you for the minutes(chairmen and note takers).

There are three kinds of use cases of multi-transcoding.

-    one or two more heterogeneous networks

-    one or two more ITSPs

-    one or two more wideband speech codecs

There are one or two more heterogeneous networks: enterprise networks using IP-PBX, ITSP(Internet Telephony Service Provider), IMS in 3GPP2, PacketCable, and Wibro. They will not use a common codec. So, they need multi transcoding such as;

-    use case 1: A(a) - IP PBX T1(a-b) - ITSP T2(b-c, b-d) - IMS T3(a-d, d-e) - D(d)

-    use case 2: A(a) - IP PBX T1(a-b) - ITSP T2(b-c, b-d) - PacketCable T4(c-d) - F(d)

-    use case 3: E(e) - IMS T3(a-d, e-d) - ITSP T2(b-c, b-d) - Wibro T4(a-d, d-c) - G(c)

There are one or two more ITSPs or SBC because all of internet telephony subscribers will not subscribe only one ITSP. There are a lot of domestic ITSPs and international ITSPs or ITXP. Internet telephony should be supported any kind of terminal vendor even though it supports any specific codec. It also supports multi call forwarding service. So, they need multi transcoding such as;

-    use case 4: C(c) - ITSP T2(c-b, b-d) - ITSP T6(b-a, b-d) - ITSP7 T7(a-d, d-e) - G(d)

There are one or two more wideband speech codecs. There has been developing one or two more wideband speech codecs for internet telephony: AMR-WB in 3GPP, VMR-WB in 3GPP2, G.729EV in ITU-T SG 16 Question 10, a wideband codec in ITU-T SG 16 Question 9, and AAC in ISO/IEC. In this convention, Capital letter means a node and lowercase(a, b, c, d, and e) means a codec.

A wideband codec encodes voice using 16,000 samples per second (50 ~ 7,000Hz), as opposed to the 8,000 samples per second (300 ~ 3,400Hz) by narrowband codec. A voice quality of wideband codec is better than one of narrowband codec due to support wider band. A tandem transcoding means to encode narrowband codec such as G.711. So, it makes down sampling and worse the voice quality. If two parties(calling party and called party) have two different wideband codecs, transcoders should transcode a wideband codec to another wideband codec without tandem transcoding. If we use a common codec with G.711(tandem), there is no more need multi-transcoding. But, we need a multi-transcoding for supplying a wideband speech high quality to each sides.

-    use case 5: wideband codec to wideband codec without tandem transcoding

Multi transcoding signaling can be useful for internet telephony environments supported by standard; an example VoIP network in quality of service for next generation Voice over IP networks, MSF-TR-QoS-001.final, 2003 Feb, and Telecommunications and Internet Protocol Harmonization over Networks (TIPHON) Release 3; End-to-End Quality of Service in TIPHON Systems; Part 3: Signalling and Control of End-to-End Quality of Service (QoS)-V2.1.2, 2002.

Multi trascoder can cover the use case using one or two more conference bridge transcoding model.

We would like to discuss open these use cases or another use case. Comments are welcome.

Thanks,

Kang

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: [email-masked]
Date: Tue, 21 Feb 2006 08:29:12 +0100

Hi Kang,

just a comment to the transcoding scenario between two different WB codecs
(WB1<->WB2).

Transcoding as such should be avoided because it is inherently decreasing
the audio/speech quality ("adds e.g., delay impairments and Ie, equipment
impairment factors") and an "expensive" network function.
There must be therefore an agreed justifaction, particularly for WB1<->WB2
transcoding scenarios!

Transcoding between two different NB codecs (NB1<->NB2) is often
inevitable.

The difference with WB codecs is that terminals "should support a fallback
mode to a NB codec" in my opinion. There are two possibilities:
      NB mode is part of the WB codec modes of operation (e.g., G.729EV
      with G.729A as NB mode), or
      separate NB codec (e.g., terminal concept according G.725).

The inconsistent "WB1<->WB2" E2E scenario might then lead to fallbacks to
(default) NB codecs. In case of a then "NB1<->NB2" inconsistency to NB
transcoding in the network.

Comments?

Albrecht

                      "Kang Tae-Gyu"                                                                                               
                      <[email-masked].         To:      <[email-masked]>                                                         
                      kr>                      cc:      [email-masked], [email-masked], [email-masked],      
                                               [email-masked]                                                           
                      21.02.2006 03:12         Subject: [Sipping] Use cases of multi-transcoding                                   
                      Please respond                                                                                               
                      to Kang Tae-Gyu                                                                                              

Hello,

I would like to discuss about the use case of multi-transcoding. First of
all, I am sorry for that I could not answer about its use case when I
received the question from the floor, IETF 64 Vancouver meeting, because of
poor English. Also, thank you for the minutes(chairmen and note takers).

There are one or two more heterogeneous networks: enterprise networks using
IP-PBX, ITSP(Internet Telephony Service Provider), IMS in 3GPP2,
PacketCable, and Wibro. They will not use a common codec. So, they need
multi transcoding such as;
 -    use case 1: A(a) - IP PBX T1(a-b) - ITSP T2(b-c, b-d) - IMS T3(a-d,
d-e) - D(d)
 -    use case 2: A(a) - IP PBX T1(a-b) - ITSP T2(b-c, b-d) - PacketCable
T4(c-d) - F(d)
 -    use case 3: E(e) - IMS T3(a-d, e-d) - ITSP T2(b-c, b-d) - Wibro
T4(a-d, d-c) - G(c)

There are one or two more ITSPs or SBC because all of internet telephony
subscribers will not subscribe only one ITSP. There are a lot of domestic
ITSPs and international ITSPs or ITXP. Internet telephony should be
supported any kind of terminal vendor even though it supports any specific
codec. It also supports multi call forwarding service. So, they need multi
transcoding such as;
 -    use case 4: C(c) - ITSP T2(c-b, b-d) - ITSP T6(b-a, b-d) - ITSP7
T7(a-d, d-e) - G(d)

There are one or two more wideband speech codecs. There has been developing
one or two more wideband speech codecs for internet telephony: AMR-WB in
3GPP, VMR-WB in 3GPP2, G.729EV in ITU-T SG 16 Question 10, a wideband codec
in ITU-T SG 16 Question 9, and AAC in ISO/IEC. In this convention, Capital
letter means a node and lowercase(a, b, c, d, and e) means a codec.

A wideband codec encodes voice using 16,000 samples per second (50 ~
7,000Hz), as opposed to the 8,000 samples per second (300 ~ 3,400Hz) by
narrowband codec. A voice quality of wideband codec is better than one of
narrowband codec due to support wider band. A tandem transcoding means to
encode narrowband codec such as G.711. So, it makes down sampling and worse
the voice quality. If two parties(calling party and called party) have two
different wideband codecs, transcoders should transcode a wideband codec to
another wideband codec without tandem transcoding. If we use a common codec
with G.711(tandem), there is no more need multi-transcoding. But, we need a
multi-transcoding for supplying a wideband speech high quality to each
sides.
 -    use case 5: wideband codec to wideband codec without tandem
transcoding

Multi transcoding signaling can be useful for internet telephony
environments supported by standard; an example VoIP network in quality of
service for next generation Voice over IP networks, MSF-TR-QoS-001.final,
2003 Feb, and Telecommunications and Internet Protocol Harmonization over
Networks (TIPHON) Release 3; End-to-End Quality of Service in TIPHON
Systems; Part 3: Signalling and Control of End-to-End Quality of Service
(QoS)-V2.1.2, 2002.

Multi trascoder can cover the use case using one or two more conference
bridge transcoding model.

We would like to discuss open these use cases or another use case. Comments
are welcome.

Thanks,
Kang

---

From: "Henry Sinnreich" <[email-masked]>
Date: Tue, 21 Feb 2006 10:34:32 +0100

> the audio/speech quality

Correct!

> Comments?

The numerous wireline legacy ITU-T G.7xx codecs and other countless codecs
deployed for mobile phones are a disgrace IMHO.

The industry would be better off adopting "Internet codecs":

The iLBC RFC 3951 and RFC 3952 as the default codec and SPEEX for variable
rate wideband
(ftp://ftp.rfc-editor.org/in-notes/internet-drafts/draft-ietf-avt-rtp-speex-
00.txt).

Thanks, Henry

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, February 21, 2006 8:29 AM
To: Kang Tae-Gyu
Cc: [email-masked]
Subject: Re: [Sipping] Use cases of multi-transcoding

Hi Kang,

Comments?

Albrecht

                      "Kang Tae-Gyu"

                      kr>                      cc:      [email-masked],
[email-masked], [email-masked],      
                                               [email-masked]

                      21.02.2006 03:12         Subject: [Sipping] Use cases
of multi-transcoding                                   
                      Please respond

                      to Kang Tae-Gyu

Hello,

Thanks,
Kang

---

From: Nathan Allen Stratton <[email-masked]>
Date: Tue, 21 Feb 2006 09:24:44 -0500 (EST)

> deployed for mobile phones are a disgrace IMHO.

Tell me about it, I have been working for 2 years to get CPE manufactures
to support some updated CODECs. The big problem has always been that the
manufactures sell CPE to service providers with a PSTN leg in over 90% of
there calls. As a service provider you have two options to connect to the
PSTN, you can go out and buy some trunking gateways and do it yourself or
use a GLBX, XO, BWING of the world and hand them SIP and let them deal
with that. So the issue is that even if you support Speex at the edge,
there is no way your going to had that off to a Sonus or other gateway.

> The industry would be better off adopting "Internet codecs":

We have started to see some light at the end of the tunnel on this, some
of the SBC vendors are now supporting transcoding. This would let a
service provider support say Speex at the edge of their network and then
hand off G.711 to origination/termination partners. If a call was CPE to
CPE you could just use wideband.

> (ftp://ftp.rfc-editor.org/in-notes/internet-drafts/draft-ietf-avt-rtp-speex-

I have been very disappointed in iLBC, all my testing puts it just below
G.729 in quality. If you look at that night graph from the guys are GIPS
it shows that it does much better with packet loss, but rumor is that they
got that data by using very sub optimal G.729 settings. Speex however has
shown to be a great CODEC along the full range of bit rates. I think the
best way to deal with packet loss with CODECs that take up small amounts
of bandwidth is to send duplicate frames.

><>
Nathan Stratton
nathan at robotics.net
http://www.robotics.net