Subject: RE: [Sipping] Question on do not disturb indication

From: "Elwell, John" <[email-masked]>
Date: Sun, 06 Aug 2006 14:54:01 +0100

Francois,

See below.

John 

> -----Original Message-----
> From: Francois Audet [mailto:[email-masked]] 
> Sent: 04 August 2006 21:01
> To: Henry Sinnreich; Jonathan Rosenberg; Dean Willis
> Cc: Dolly, Martin C, ALABS; Paul Kyzivat; Elwell, John; 
> [email-masked]; Scott Lawrence
> Subject: RE: [Sipping] Question on do not disturb indication
> 
> Actually, this is a very good point.
> 
> There are really 2 aspects to "Do Not Disturb":
> 
> 1 - On aspect for the terminating side to "reject" a session. 
> That's the
> one I was
>     focussing on. That's the one where many of us are not 
> convinced that
> we need
>     something beyond what is already allowed with SIP (480, 486, 6XX,
> etc.).
[JRE]But extending this, there is the aspect of how the indication given by
the terminating side can be used by its proxy to take appropriate action. I
think this is the most important aspect, perhaps more important than aspect
2 below.

> 
> 2 - The other aspect is conveying a DND indication to the other end. I
> guess
>     John was thinking about that. Henry is right that this aspect is
> definitively 
>     something appropriate for presence...
[JRE] In the very first message in the thread I acknowledged that presence
is an alternative. Presence, if availabe and authorised, can give you status
independently of any call attempt. But I still feel it would be good to have
a proper indication of why a call fails.

> 
> > -----Original Message-----
> > From: Henry Sinnreich [mailto:[email-masked]] 
> > Sent: Friday, August 04, 2006 10:54 AM
> > To: Jonathan Rosenberg; Dean Willis
> > Cc: Dolly, Martin C, ALABS; Paul Kyzivat; Elwell, John; 
> > [email-masked]; Scott Lawrence
> > Subject: RE: [Sipping] Question on do not disturb indication
> > 
> > This is also a good time to remember once more there is in a 
> > SIP a capability called PRESENCE that is much more useful 
> > than DND and many other legacy telephony features.  :-)
> > 
> > Why ignore Presence and just stick with the "old proven way"?
> > 
> > Thanks, Henry
> > 
> > -----Original Message-----
> > From: Jonathan Rosenberg [mailto:[email-masked]]
> > Sent: Friday, August 04, 2006 8:12 AM
> > To: Dean Willis
> > Cc: Dolly, Martin C, ALABS; Paul Kyzivat; Elwell,John; 
> > [email-masked]; Scott Lawrence
> > Subject: Re: [Sipping] Question on do not disturb indication
> > 
> > I agree with Dean here.
> > 
> > Why do you want to know, at the calling UA side, that the 
> > call was busy because of DND? Whether you need a new code 
> > depends on the answer:
> > 
> > 1. if you want the human user to know that this was DND so 
> > they can do something appropriate, a reason phrase is exactly 
> > the right thing
> > 
> > 2. if you want to have the calling UA to do something 
> > different, what would it do differently on a 'your call was 
> > rejected by DND' vs. 'your call was rejected because the user 
> > is on another call'? If the answer is
> > 
> > nothing, then you don't need a new response code.
> > 
> > I'm also leary about defining new response codes to do a 
> > specific terminating application that is running. Saying that 
> > this was rejected due to 'DND' requiers you to have a 
> > standard definition for DND. I don't
> > 
> > want to do that. As others have pointed out, a reasonable 
> > implementation
> > 
> > for DND is that the termianting network simply lets the phone 
> > ring and eventually responds with a 480. That should be allowed.
> > 
> > Thanks,
> > Jonathan R.
> > 
> > Dean Willis wrote:
> > 
> > > 
> > > On Aug 3, 2006, at 1:28 AM, Elwell, John wrote:
> > > 
> > >> Dean,
> > >>
> > >> So what would you like the IETF to recommend? Do you believe 480
> > mostly
> > >> works, or do you think something new is needed?
> > >>
> > >> John
> > > 
> > > 
> > > 
> > > Hey, I'm just a consumer. I don't want to know the 
> > technical details.
> > I 
> > > just want it to work, mostly.
> > > 
> > > If it were up to me, I'd be asking the question:
> > > 
> > > What part of DND is important for a calling human to 
> understand, vs.
> > a 
> > > calling automata? Is there a distinction needed?
> > > 
> > > If we believe that we'd like to convey a distinction between 
> > > "Temporarily unavailable" and "Temporarily unavailable due to 
> > > subscriber choice" to a human, perhaps a reason phrase on a 
> > 480 would
> > 
> > > be adequate? Like "480 Do Not Disturb", maybe.
> > > 
> > > 
> > > An automata is just likely to retry the call periodically 
> > anyhow, but
> > a 
> > > human might stop and think "Oh yeah, it IS the middle of 
> > the night  in
> > 
> > > Singapore . . .".
> > > 
> > > Question: How beneficial would a Retry-After value be in rate-
> > limiting 
> > > the retries of automata?
> > > 
> > > Now, I will say that Martin is right in that there might be many 
> > > reasons to reject a call, that DND is just the tip of the iceberg,
> > and 
> > > that there's no way we can define them all.
> > > 
> > > 
> > > Now, here's an interesting thought. If I use a reason 
> > phrase on 480, 
> > > and couple it to the right software, I can use SIP INVITE 
> > requests as
> > a 
> > > covert-channel replacement for HTTP GET operations (or file 
> >  transfer,
> > 
> > > or whatever) , but peer-to-peer using the SIP  
> infrastructure as a 
> > > rendezvous service.  Don't try this at home, kids.
> > > 
> > > --
> > > Dean
> > > 
> > > _______________________________________________
> > > Sipping mailing list  
> https://www1.ietf.org/mailman/listinfo/sipping
> > > This list is for NEW development of the application of SIP Use 
> > > [email-masked] for questions on current sip Use 
> > > [email-masked] for new developments of core SIP
> > > 
> > 
> > -- 
> > Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
> > Cisco Fellow                                   Parsippany, NJ 
> > 07054-2711
> > Cisco Systems
> > [email-masked]                              FAX:   (973) 952-5050
> > http://www.jdrosen.net                         PHONE: (973) 952-5000
> > http://www.cisco.com
> > 
> > _______________________________________________
> > Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> > This list is for NEW development of the application of SIP 
> > Use [email-masked] for questions on current 
> > sip Use [email-masked] for new developments of core SIP
> > 
> > _______________________________________________
> > Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> > This list is for NEW development of the application of SIP 
> > Use [email-masked] for questions on current 
> > sip Use [email-masked] for new developments of core SIP
> > 
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Francois Audet" <[email-masked]>
Date: Mon, 7 Aug 2006 13:12:38 -0500

John,

I guess the reason for the different opinions we are seeing is that some
products (even
in PSTN-land) do not care about the reason for an "unvailable" (except
for 'busy').

Many, for example, don't treat things differently if DND was the result
of the user
pressing a DND key, or if there is a temporary reason why the user not
available (network
issue for example).

In other words, while I believe that the concept of "busy" is
quasi-universal, I do not 
believe that the concept of "explicit DND" is necessarily universal. 

That may explain why some of us don't believe that we need to
distinguish between "Temporarily
Unavailable" versus "Do not Disturb".

> From: Elwell, John [mailto:[email-masked]] 
> Sent: Sunday, August 06, 2006 6:54 AM
> To: Audet, Francois (SC100:3055); Henry Sinnreich; Jonathan 
> Rosenberg; Dean Willis
> Cc: Dolly, Martin C, ALABS; Paul Kyzivat; [email-masked]; 
> Scott Lawrence
> >     focussing on. That's the one where many of us are not convinced 
> > that we need
> [JRE]But extending this, there is the aspect of how the 
> indication given by the terminating side can be used by its 
> proxy to take appropriate action. I think this is the most 
> important aspect, perhaps more important than aspect
> 2 below.
> 
> > 
> [JRE] In the very first message in the thread I acknowledged 
> that presence is an alternative. Presence, if availabe and 
> authorised, can give you status independently of any call 
> attempt. But I still feel it would be good to have a proper 
> indication of why a call fails.
> 
> > 
> > > This is also a good time to remember once more there is 
> in a SIP a 
> > > capability called PRESENCE that is much more useful than DND and 
> > > many other legacy telephony features.  :-)
> > > 
> call was 
> > > busy because of DND? Whether you need a new code depends on the 
> > > answer:
> > > 
> > > 1. if you want the human user to know that this was DND 
> so they can 
> > > do something appropriate, a reason phrase is exactly the 
> right thing
> > > 
> > > 2. if you want to have the calling UA to do something different, 
> > > what would it do differently on a 'your call was rejected by DND' 
> > > vs. 'your call was rejected because the user is on 
> another call'? If 
> > > the answer is
> > > 
> > > I'm also leary about defining new response codes to do a specific 
> > > terminating application that is running. Saying that this was 
> > > rejected due to 'DND' requiers you to have a standard 
> definition for 
> > > DND. I don't
> > > 
> > > for DND is that the termianting network simply lets the 
> phone ring 
> > > and eventually responds with a 480. That should be allowed.
> > > 
> > > Thanks,
> > > Jonathan R.
> > > 
> > > Dean Willis wrote:
> > > 
> > > >