Subject: RE: [Sipping] Question on do not disturb indication

From: "Elwell, John" <[email-masked]>
Date: Thu, 03 Aug 2006 07:26:38 +0100

Francois,

See below.

John 

> -----Original Message-----
> From: Francois Audet [mailto:[email-masked]] 
> Sent: 03 August 2006 00:24
> To: Paul Kyzivat; Scott Lawrence
> Cc: [email-masked]; Elwell, John
> Subject: RE: [Sipping] Question on do not disturb indication
> 
> I agree: I don't see a need for a special code for this, as 
> it seems to
> make
> pretty much exactly to existing practice.
> 
> In fact, even in the "old days" you had different features 
> corresponding
> to
> the two codes.
> - Do-not-Disturb is pretty much like 480
> - Make-busy is pretty much like 486
[JRE] I agree that "make busy" is a separate feature and is best dealt with
by 486. But where I explicitly want the caller to know that I am in DND
(possibly with a retry-after time), do you think that 480 is sufficient,
bearing in mind that it gets used for other purposes too, e.g., in RFC3398?

> 
> Some vendors have "make busy", others have "do not disturb", some may
> have
> both.
> 
> On the 603 issue, I'd like to disagree with everybody else...
> Sometimes being able to decline the call everywhere is 
> actually what you
> want.
> As an example, I have multiple forked device. If I send a 603, it
> triggers the proxy to
> use whatever alternate routing is sees fit (e.g., voicemail, 
> attendant,
> etc.). That's
> the desired behavior.
[JRE] I tend to agree that 603 is useful, but I find the other 6xx codes
less useful. 603 is saying I reject this call, period. That is quite
different from DND, where I don't want to be disturbed on my present device
but might be quite happy for my call to another device, where an assistant
perhaps could answer, or voicemail.

> 
> Problem with a 480/486 with that scenario is that it won't trigger the
> alternate routing
> and will keep on ringing the other fork. That may not be the desired
> behavior.
> 
> My 2 cents. 
> 
> > -----Original Message-----
> > From: Paul Kyzivat [mailto:[email-masked]] 
> > Sent: Wednesday, August 02, 2006 3:31 PM
> > To: Scott Lawrence
> > Cc: [email-masked]; Elwell, John
> > Subject: Re: [Sipping] Question on do not disturb indication
> > 
> > I pretty much agree with Scott. In many/most cases I won't 
> > want the caller to know why his call is going unanswered. 
> > Both 480 and 486 are in effect "white lies". Which one to use 
> > may depend on which impression you want to give to the 
> > caller. Another one - if you want to be more rude - is 403 
> Forbidden.
> > 
> > I don't see a need for a *special* code that is unique to 
> > this service.
> > 
> > 	Paul
> > 
> > Scott Lawrence wrote:
> > > On Wed, 2006-08-02 at 21:09 +0100, Elwell, John wrote:
> > >> RFC 3261 suggests the use of response code 480 Temporarily 
> > >> Unavailable for indicating do not disturb (DND), but it is 
> > not used 
> > >> exclusively for this purpose. There are other documents 
> (e.g., RFC 
> > >> 4504) that suggest the use of 486 Busy Here, but again 
> this is not 
> > >> helpful if the receiver wants to distinguish between DND 
> > and ordinary 
> > >> busy. Presence can be used to indicate this condition 
> through the 
> > >> RPID note element, but that does not say why a 
> particular session 
> > >> establishment attempt has failed. What are the best 
> practices for 
> > >> indicating the DND condition? Does anyone see a need for 
> > an explicit 
> > >> indicator for this purpose, e.g., a new SIP response code?
> > > 
> > > Personally, I like 480 for this.  
> > > 
> > > If the phone wanted to be sneaky, it could just mute the 
> > ringing and 
> > > allow the transaction to time out without explicitly 
> rejecting it.  
> > > That prevents the caller from being able to tell they are being 
> > > disregarded, but some users might prefer that forwarding 
> > take effect 
> > > sooner and not like that.
> > > 
> > > The one thing that I _don't_ like to see is a 603 being 
> > used for this; 
> > > that messes up any upstream forking.
> > > 
> > > 
> > 
> > _______________________________________________
> > Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> > This list is for NEW development of the application of SIP 
> > Use [email-masked] for questions on current 
> > sip Use [email-masked] for new developments of core SIP
> > 
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Francois Audet" <[email-masked]>
Date: Thu, 3 Aug 2006 13:10:08 -0500

> [JRE] I agree that "make busy" is a separate feature and is 
> best dealt with by 486. But where I explicitly want the 
> caller to know that I am in DND (possibly with a retry-after 
> time), do you think that 480 is sufficient, bearing in mind 
> that it gets used for other purposes too, e.g., in RFC3398?

Personally, I think it is sufficient, and I also think that 
mapping DND to 480 is pretty much established by now.

My perspective is Enterprise-centric however: there might be
some Service Provider services that need a more precise indication.
I could be convinced that it is needed...