Subject: RE: [Sipping] bug in rfc-3261

From: "B, Nataraju" <[email-masked]>
Date: Thu, 17 Aug 2006 14:19:38 +0530

Hi All, 

I did not get many replies. 

Should this be logged as bug against 3261 or not ? 

Thanks, 
Nataraju A B 

  _____  

From: Manjunath Warad [mailto:[email-masked]] 
Sent: Monday, August 14, 2006 3:17 PM
To: B, Nataraju; [email-masked]
Subject: RE: [Sipping] bug in rfc-3261

Hi,

    Please see inline...

Rgds,

Manju

	-----Original Message-----
	From: B, Nataraju [mailto:[email-masked]] 
	Sent: Monday, August 14, 2006 5:22 PM
	To: [email-masked]
	Subject: [Sipping] bug in rfc-3261

	Header field              where       proxy ACK BYE CAN INV OPT
REG

	WWW-Authenticate           401         ar    -   m   -   m   m
m

	WWW-Authenticate           407         ar    -   o   -   o   o
o

	Contact                     3xx         d    -   o   -   o   o
o

	Why proxy column is mentioned as "ar" for WWW-Authenticate in
401/407. It should have been mentioned as "r" only. In no case proxy
would add the WWW-Authenticate header for responses 401/407 ?. Does the
proxy aggregation considered for this case ? 

	Yes you are right! Proxy aggregation is considered here. 

	Why proxy is allowed to "delete only" for contact in 3xx
response? Even it should be allowed to read the contacts in 3xx replies.
BTW, in which scenario it can delete a contact in 3xx response. This
option should have been either "dr" or "r" only depending on answer to
my previous question.  

	Here again, proxy can remove the contact, for which it has
already tried, so that upstream proxies need not try on those contacts
again. This technique is used when proxy chose 3xx as best response to
be forwarded for upstream proxies. So, I think "adr" need to be used
here as this header can be aggregated to form the final 3xx response if
more than 1 is present.

	[ABN] this one should be considered bug against rfc-3261. 

	Please let me know, if my interpretation is wrong.

	Thanks,

	Nataraju A B

	Sonus Networks Ind Pvt Ltd

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Dean Willis <[email-masked]>
Date: Thu, 17 Aug 2006 12:28:03 -0500

Personally, I think that whole misbegotten table should be logged as  
a bug in 3261. It confuses more people than Hilbert's Paradox.

But I've not yet seem a better way to render that information. If  
anybody has an idea, please bring it to the table.

--
dean

On Aug 17, 2006, at 3:49 AM, B, Nataraju wrote:

> Header field              where       proxy ACK BYE CAN INV OPT REG
>
> WWW-Authenticate           401         ar    -   m   -   m   m   m
>
> WWW-Authenticate           407         ar    -   o   -   o   o   o
>
> Contact                     3xx         d    -   o   -   o   o   o
>
> Why proxy column is mentioned as “ar” for WWW-Authenticate in  
> 401/407. It should have been mentioned as “r” only. In no case  
> proxy would add the WWW-Authenticate header for responses  
> 401/407 ?. Does the proxy aggregation considered for this case ?
>
> Why proxy is allowed to “delete only” for contact in 3xx response?  
> Even it should be allowed to read the contacts in 3xx replies. BTW,  
> in which scenario it can delete a contact in 3xx response. This  
> option should have been either “dr” or “r” only depending on answer  
> to my previous question.
>
> Here again, proxy can remove the contact, for which it has already  
> tried, so that upstream proxies need not try on those contacts  
> again. This technique is used when proxy chose 3xx as best response  
> to be forwarded for upstream proxies. So, I think "adr" need to be  
> used here as this header can be aggregated to form the final 3xx  
> response if more than 1 is present.
>