Subject: [Sipping] Q about draft-poetzl-sipping-call-completion-01

From: "James M. Polk" <[email-masked]>
Date: Thu, 24 Aug 2006 13:55:16 -0500

Isn't this call-completion performing the same function of how we now 
subscribe to to someone's (rather their UA's) presence state, to be 
notified when the UA becomes available?

If so, why is this necessary?

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Huelsemann, Martin" <[email-masked]>
Date: Fri, 25 Aug 2006 14:52:01 +0200

Hi James, all,

although you could in principle use presence information to inform a user about a the call-completion condition, basically the meaning of the two events is a littlebit different. With presence information the remote user can be informed that you are ready to accept Instant Messages, or multimedia communication sessions in general, so that you are basically available, but it doesn't mean that a communication session establishment will be successfull, because there might be other call-completion requests active.

And as the presence server wouldn't know if the presence subscription is really for receiving presence information or more for receiving call-completion information, it wouldn't know whether to inform the subscribing user in every case of a change in the presence state or, if there are other subscribers, only to inform him when his position in the call-completion queue allows it.

So, to make it short, presence and call-completion events can provide different information, and to have the possibility to receive this information independent from each other, the two packages are needed.

Hope this clarifies.

Best regards, Martin