Subject: [Sipping] Scope of b2bua and draft-marjou-sipping-b2bua-00

From: Cullen Jennings <[email-masked]>
Date: Sat, 10 Mar 2007 15:26:48 -0800

One thing that I want to make sure stays clear with any work about  
B2BUAs, the specification must not have a B2BUA violating any of the  
things that a UA is required to do. If we need to change how SIP UAs  
work, that can be done but has to be done extremely carefully to not  
fully break SIP - in this way, B2BUA are no different than any other UA.

Cullen <with my AD hat on>

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Xavier Marjou" <[email-masked]>
Date: Mon, 12 Mar 2007 15:09:13 +0100

> things that a UA is required to do.

I agree that we must not end-up with a new SIP UA. Otherwise this
would mean that every SIP-related RFC would need to be updated to take
into account this element.

> If we need to change how SIP UAs work, that can be done but has
> to be done extremely carefully to not fully break SIP
> - in this way, B2BUA are no different than any other UA.

Agreed.

---

From: Peili Xu <[email-masked]>
Date: Tue, 13 Mar 2007 13:29:12 +0800

Hi Xavier,

My understanding for the purpose of this draft is to
give a best current practice for how to develop and
deploy B2BUAs without loosing transparency as much as
possible. Considering B2BUAs are commonly used in many
senarios like: SBC and Application Server, this kind of
guidance is definitely valuable. 

Peili

-----Original Message-----
From: Xavier Marjou
[mailto:[email-masked]] 
Sent: Monday, March 12, 2007 10:09 PM
To: Cullen Jennings
Cc: [email-masked]
Subject: Re: [Sipping] Scope of b2bua and
draft-marjou-sipping-b2bua-00

> things that a UA is required to do.

I agree that we must not end-up with a new SIP UA.
Otherwise this would mean that every SIP-related RFC
would need to be updated to take into account this
element.

> If we need to change how SIP UAs work, that can be
done but has to be 
> done extremely carefully to not fully break SIP

Agreed.

_______________________________________________
Sipping mailing list
https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of
SIP Use [email-masked] for questions
on current sip Use [email-masked] for new developments of
core SIP