Subject: [Sipping] Updates to xml2rfc

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 08 Mar 2007 20:28:11 +0200

Hi,

we would like to encourage editors to try and use the latest stable
version of xml2rfc to build their documents. This can be done by either
building the document online or by downloading the latest version of the
tool before building the document.

This time, a lot of draft submissions have been initially rejected
because the xml2rfc version used to build the document was too old and
did not use the new Internet Draft boilerplate that talks about the IETF
Trust.

Cheers,

Gonzalo

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Thu, 08 Mar 2007 14:03:43 -0600

> did not use the new Internet Draft boilerplate that talks about the IETF

Gonzalo: What happens to the rejected drafts because of the
boilerplate issue?  Since a couple of my drafts were caught up in
this, I have resubmitted these with the new boilerplate (I was
using an older version of xml2rfc.)

The resubmitted drafts have not yet made it to the IETF archives.
One of these drafts is a SIPPING milestone draft.

Would it be possible to have the chairs request the I-D editor to
okay the drafts that made the submission deadline but were
rejected because of the boilerplate issues?

I have also sent an email to the tools list to see if they can
put a notification feature in xml2rfc.tcl that automatically
notifies you of a new release of the software.  This way people
who do not subscribe to the tools mailing list will know when
to upgrade.

Thanks,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
2701 Lucent Lane, Rm. 9F-546, Lisle, Illinois 60532 (USA)
Email: vkg@{alcatel-lucent.com,bell-labs.com,acm.org}
WWW:   http://www.alcatel-lucent.com/bell-labs

---

From: "Brian Stucker" <[email-masked]>
Date: Thu, 8 Mar 2007 14:11:14 -0600

Even using the online-tool isn't 100% fool-proof. I had one draft get
rejected because the boilerplate used 2006 instead of 2007 in the
copyright statement. Apparently the boilerplate didn't get updated until
sometime in February to acknowledge the change in year.

Luckily, had more than enough time to resubmit.

Regards,
Brian 

> -----Original Message-----
> From: Vijay K. Gurbani [mailto:[email-masked]] 
> Sent: Thursday, March 08, 2007 2:04 PM
> To: Gonzalo Camarillo
> Cc: SIPPING LIST; Barnes, Mary (RICH2:AR00)
> Subject: Re: [Sipping] Updates to xml2rfc
> 
> Gonzalo Camarillo wrote:
> > did not use the new Internet Draft boilerplate that talks about the 
> > IETF Trust.
> 
> boilerplate issue?  Since a couple of my drafts were caught 
> up in this, I have resubmitted these with the new boilerplate 
> (I was using an older version of xml2rfc.)
> 
> Would it be possible to have the chairs request the I-D 
> editor to okay the drafts that made the submission deadline 
> but were rejected because of the boilerplate issues?
> 
> I have also sent an email to the tools list to see if they 
> can put a notification feature in xml2rfc.tcl that 
> automatically notifies you of a new release of the software.  
> This way people who do not subscribe to the tools mailing 
> list will know when to upgrade.
> 
> Thanks,
> 
> - vijay
> --
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
>

---

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 08 Mar 2007 22:11:37 +0200

Typically these drafts are still processed by the editors. It just takes 
a bit longer.
No reason to worry.

---

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 08 Mar 2007 22:16:07 +0200

Hi,

yes, as Hannes points out, the editor typically accepts drafts that are 
submitted before the deadline but need to be resubmitted because of this 
type of error.

Cheers,

Gonzalo

---

From: Richard Barnes <[email-masked]>
Date: Fri, 09 Mar 2007 15:43:37 -0500

Also, I think the idnits checker catches most of these things, so you 
can find them before you send it in:
<http://tools.ietf.org/tools/idnits/>

--Richard

Gonzalo Camarillo wrote:
>> Typically these drafts are still processed by the editors. It just 
>> takes a bit longer.
>> No reason to worry.
>>
>> Vijay K. Gurbani wrote:
>>> Gonzalo Camarillo wrote:
>>>> IETF