Subject: RE: [Sipping] Session Establishment Efficiency Rate

From: "Marian Delkinov \(LN/EAB\)" <[email-masked]>
Date: Thu, 29 Mar 2007 10:06:45 +0200

Hi Daryl,

I haven't got your opinion about my comments on the SEER definition.
Have you considered them? 
Would also be interested to know when a finalized document on the
performance metrics can be released. 

Thanks!

Best regards!
Mario.

-----Original Message-----
From: Marian Delkinov (LN/EAB) 
Sent: Monday, 05 March, 2007 17:06
To: 'Daryl Malas'
Subject: RE: [Sipping] Session Establishment Efficiency Rate

Hi Daryl,

In principle, I agree with you in case we considered this from a user
perspective - then 3xx is not final. However my idea behind including
the 3xx codes was based on the involvement of "#Invite" in the formula.
If a 3xx code would result in sending a new Invite, then it sounds
logical to me to add the 3xx codes in the numerator. (NB: RFC3261
defines 3xx responses as "final" for the SIP transaction, ref. to page
21, Final Response).

Best regards!
Mario.

-----Original Message-----
From: Daryl Malas [mailto:[email-masked]]
Sent: Friday, 23 February, 2007 17:00
To: Marian Delkinov (LN/EAB)
Cc: [email-masked]
Subject: RE: [Sipping] Session Establishment Efficiency Rate

I don't think 3xx codes should be included, since they would not be
considered a "Final" release cause code.  --Daryl

On Fri, 2007-02-23 at 12:22 +0100, Marian Delkinov (LN/EAB) wrote:
> Hi,
> 
> If the Network Efficiency Rate is designed to express the ability of 
> the network to deliver calls (in SIP terms one should perhaps say 
> "establish sessions"), I think that it might be reasonable to include 
> few more cases (cause codes) in the numerator: e.g. all redirection 
> 3xx codes, all 4xx except 408 codes and all 6xx codes. (If you agree 
> that those are the ones that exclude network failures, congestion and 
> any other network malfunction).
> 
> Actually it sounds fair to me if it's the opposite of the Ineffective 
> Session Attempts (ISA):
> SEER% =
> 	   Total # of Invite Requests - # of ISA 
> ---------------------------------------------------- x 100
> 	   Total # of Invite Requests
> 
> What do you think?
> 
> Best regards!
> Mario.
> 
> -----Original Message-----
> From: Daryl Malas [mailto:[email-masked]]
> Sent: Friday, 23 February, 2007 01:14
> To: [email-masked]
> Subject: [Sipping] Session Establishment Efficiency Rate
> 
> A couple more people have expressed to me that this adaptation of the 
> ITU-T E.411 Network Efficiency Rate metric is very valuable.  The 
> snapshot of the metric from the draft is:
> 
> "This metric is similar to Session Establishment Rate, but it is 
> intended to exclude the effects of customer behavior and user agent 
> behavior.  Essentially, the attempts resulting with a final cause code

> of 480, 486, and 600 would be added to the SER numerator."
> 
> Does anyone else want to see this metric in the draft?  I personally 
> think it is an interesting metric.
> 
> Thanks...
> 
> --Daryl
> 
> 
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP Use 
> [email-masked] for questions on current sip Use 
> [email-masked] for new developments of core SIP

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Fardid, Reza" <[email-masked]>
Date: Fri, 30 Mar 2007 13:02:18 -0700

Mario,

What I had in mind when I proposed inclusion of SEER in this draft was
a SIP performance metric analogous to NER in the PSTN, within the
framework defined by Daryl:

Telephony Metric/Standard (ITU-T, BellCore, etc.) ==> SIP ETE Metric

Clearly some SIP metrics defined in this draft do not have a telephony
counterpart.  For the rest, IMO, it is good to stay within the above
framework and leave exclusion/inclusion of specific release codes from
defined metrics to implementation.

Regards,
Reza Fardid
Covad Communications

-----Original Message-----
From: Marian Delkinov (LN/EAB) [mailto:[email-masked]] 
Sent: Thursday, March 29, 2007 1:07 AM
To: Daryl Malas
Cc: [email-masked]
Subject: RE: [Sipping] Session Establishment Efficiency Rate

Hi Daryl,

Thanks!

Best regards!
Mario.

-----Original Message-----
From: Marian Delkinov (LN/EAB) 
Sent: Monday, 05 March, 2007 17:06
To: 'Daryl Malas'
Subject: RE: [Sipping] Session Establishment Efficiency Rate

Hi Daryl,

Best regards!
Mario.

---

From: "Fardid, Reza" <[email-masked]>
Date: Fri, 30 Mar 2007 13:02:18 -0700

Mario,

Regards,
Reza Fardid
Covad Communications

-----Original Message-----
From: Marian Delkinov (LN/EAB) [mailto:[email-masked]] 
Sent: Thursday, March 29, 2007 1:07 AM
To: Daryl Malas
Cc: [email-masked]
Subject: RE: [Sipping] Session Establishment Efficiency Rate

Hi Daryl,

Thanks!

Best regards!
Mario.

-----Original Message-----
From: Marian Delkinov (LN/EAB) 
Sent: Monday, 05 March, 2007 17:06
To: 'Daryl Malas'
Subject: RE: [Sipping] Session Establishment Efficiency Rate

Hi Daryl,

Best regards!
Mario.