Subject: [Sipping] Re: I-D ACTION:draft-ietf-sipping-sip-offeranswer-04.txt

From: Takuya Sawada <[email-masked]>
Date: Fri, 26 Oct 2007 20:30:28 +0900

Hi,

As you may notice that, I post the new version of sip-offeranswer
draft. You can take it at;
http://www.ietf.org/internet-drafts/draft-ietf-sipping-sip-offeranswer-04.txt

There are many changes since the previous version to incorporate
the comments from WGLC reviews.
Many of them are just for clarification. But they are important because
the primary purpose of this document is clarification.

Below is the summary of the changes. Please have a look.

----
Addition/Modification:
- Add 'Introduction' section. (1)
- Remove 'preview of offer' (3.1.2)
- Add the section for 'Behavior on receiving SDP with c=IN
  IP4 0.0.0.0' (5.4)
- Add 'IANA Considerations' section (8)
- Add 'Acknowledgement' section (10)

Clarification:
- Add a note on UPDATE w/o SDP for clarification (2.1)
- Clarification on 'only one offer/answer negotiation in progress'
  (2.1)
- Clarification on the recommended behavior for UAS to send SDP
  answer. (3.1)
- Add a considertion on user interaction at UAC when using INVITE
  request w/o offer. (3.1.2)
- Add a considertion on user interaction at UAS when using UPDATE
  request. (3.2)
- Add a considertion on user interaction at UAS when using PRACK
  request w/o offer. (3.2)
- Add Table and Figures to explain 'Message Crossing Case Handling'
  for clarification. (4.1)
- Clarification on how to build an SDP offer to offerless re-INVITE
  (5.2.5)
- Clarification on how to build an SDP answer to the offer to resume.
  (5.3)
- Simplify the first paragraph of 'Add New Offer/Answer Usage in SIP'
  (7)

And many other editorial changes.

---

Regards,
Takuya

> 
> A New Internet-Draft is available from the on-line Internet-Drafts 
> directories.
> This draft is a work item of the Session Initiation Proposal Investigation Working Group of the IETF.
> 
> 	Title		: SIP (Session Initiation Protocol) Usage of the Offer/Answer Model
> 	Author(s)	: T. Sawada, P. Kyzivat
> 	Filename	: draft-ietf-sipping-sip-offeranswer-04.txt
> 	Pages		: 25
> 	Date		: 2007-10-25
> 	
> SIP utilizes the offer/answer model to establish and update 
>    multimedia sessions. The descriptions on how to use offer/answer in 
>    SIP are dispersed in the multiple RFCs. This document summarizes all 
>    the current usage of the offer/answer model in SIP communication.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-sipping-sip-offeranswer-04.txt
> 
> To remove yourself from the I-D Announcement list, send a message to 
> [email-masked] with the word unsubscribe in the body of 
> the message. 
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
> to change your subscription settings.
> 
> Internet-Drafts are also available by anonymous FTP. Login with the 
> username "anonymous" and a password of your e-mail address. After 
> logging in, type "cd internet-drafts" and then 
> "get draft-ietf-sipping-sip-offeranswer-04.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-ietf-sipping-sip-offeranswer-04.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 
> 

--------
Takuya Sawada
KDDI Corporation (KDDI)
Garden Air Tower, 3-10-10, Iidabashi, 
Chiyoda-ku, Tokyo 102-8460, Japan
Tel: +81-3-6678-2997
Fax: +81-3-6678-0286
[email-masked]

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Mary Barnes" <[email-masked]>
Date: Tue, 30 Oct 2007 12:00:19 -0500

Hi all,

This email is to announce a three week post-WGLC review of the changes
made to this document. The diff is available at:
http://tools.ietf.org/wg/sipping/draft-ietf-sipping-sip-offeranswer/draf
t-ietf-sipping-sip-offeranswer-04-from-03.diff.html

Please review the changes and post any comments on those changes to the
list on or before November 20th, 2007.  If you think the doc is "Ready",
please post a comment to the list as well.  

We are allowing additional time for this re-review since the review
overlaps with the configuration framework re-review and the document
deadlines for IETF-70 (Nov 12th for -00, Nov 19th for -01+). 

Regards,
Mary.
SIPPING WG co-chair

-----Original Message-----
From: Takuya Sawada [mailto:[email-masked]] 
Sent: Friday, October 26, 2007 6:30 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; Barnes, Mary
(RICH2:AR00)
Subject: Re: I-D ACTION:draft-ietf-sipping-sip-offeranswer-04.txt

Hi,

As you may notice that, I post the new version of sip-offeranswer draft.
You can take it at;
http://www.ietf.org/internet-drafts/draft-ietf-sipping-sip-offeranswer-0
4.txt

There are many changes since the previous version to incorporate the
comments from WGLC reviews.
Many of them are just for clarification. But they are important because
the primary purpose of this document is clarification.

----
Addition/Modification:

Clarification:

---

Regards,
Takuya

> logging in, type "cd internet-drafts" and then "get 
> draft-ietf-sipping-sip-offeranswer-04.txt".
> 
> http://www.ietf.org/shadow.html or 
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 	"FILE
/internet-drafts/draft-ietf-sipping-sip-offeranswer-04.txt".

--------
Takuya Sawada
KDDI Corporation (KDDI)