Subject: Re: [Sipping] PRACK: Change MUST requirement to include SDP offerin first reliable provisional response

From: "Christer Holmberg" <[email-masked]>
Date: Thu, 2 Apr 2009 13:57:58 +0200

Hi,
 
I guess it depends on whether sending an early-session SDP offer
"fulfills" the requirement to send an SDP offer in the first reliable
response. 
 
If it does, is it then allowed to complete the whole INVITE transaction
with only an early-session SDP offer/answer?
 
Regards,
 
Christer

________________________________

From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, April 02, 2009 9:25 AM
To: Christer Holmberg
Cc: Hisham Khartabil; Sanjay Sinha (sanjsinh); [email-masked];
[email-masked]
Subject: Re: [Sipping] PRACK: Change MUST requirement to include SDP
offerin first reliable provisional response

Hi, 

  Considering early-session, if the UAS receives an INVITE without SDP, 
before transmit it,the UAS wants to play a tone with early-session in
order 
to inform the caller the call is ongoing.The UAS may have no rule to 
generate a normal session SDP.Unless UAS creates a fake one e.g with ip
0.0.0.0. 

UAC                 UAS 
|--------INVITE----->| 
|<-----183(early)----|-----INVITE--> 
|-----PRACK(early)-->| 
|<--------200--------| 

Regards 
Eric

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail
is solely property of the sender's organization. This mail communication
is confidential. Recipients named above are obligated to maintain
secrecy and are not permitted to disclose the contents of this
communication to others.
This email and any files transmitted with it are confidential and
intended solely for the use of the individual or entity to whom they are
addressed. If you have received this email in error please notify the
originator of the message. Any views expressed in this message are those
of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam
system.

---

From: [email-masked]
Date: Fri, 3 Apr 2009 08:36:54 +0800

Hi,
> "fulfills" the requirement to send an SDP offer in the first 
> reliable response. 

It's OK if the first reliable 18x with early media fulfill the 
requirement.

> 
> If it does, is it then allowed to complete the whole INVITE 
> transaction with only an early-session SDP offer/answer?

I think there must be normal session offer/answer exchange if the final 
response
is 2xx, but if the final response is 3xx-6xx as INVITE fails, an 
early-session
SDP offer/answer on the purpose of failure-notice is enough.

Then, if the INVITE carrys NO SDP ,the first reliable response generator 
must 
fill the response with at least one SDP(early-session, or normal session, 
or both).
There must be at least one normal session offer/answer exchange if the 
final response
is 2xx.

Regards,
Eric

order 
> generate a normal session SDP.Unless UAS creates a fake one e.g with
> ip 0.0.0.0. 
> 
> UAC                 UAS 
> |--------INVITE----->| 
> ZTE Information Security Notice: The information contained in this 
> mail is solely property of the sender's organization. This mail 
> communication is confidential. Recipients named above are obligated 
> to maintain secrecy and are not permitted to disclose the contents 
> of this communication to others.
> intended solely for the use of the individual or entity to whom they
> are addressed. If you have received this email in error please 
> notify the originator of the message. Any views expressed in this 
> message are those of the individual sender.
system.

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.