Subject: [siprec] Thoughts on draft-ram-siprec-metadata-00

From: "Elwell, John" <[email-masked]>
Date: Fri, 27 Aug 2010 11:52:59 +0200

(as chair)
Thanks to the authors for posting this, following Paul's presentation in Maastricht and consensus in the room that people would like to see a separate draft on this.

(as individual)
This seems to be a good first pass at identifying the data objects involved in the subject of session recording. I am not sure that it all should be considered as "metadata". In my opinion, metadata is information the SRS needs to accompany recorded media. In particular, anything to do with the Recording Session (RS) is just a temporary artefact of the SIPREC delivery mechanism, and doesn't need to be retained as metadata. For example, whether a single RS is used to record one CS or several CSs is irrelevant after the event. So I think the Recording Session Group and Recording Session objects are not part of metadata.

John

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 27 Aug 2010 09:41:43 -0400

Elwell, John wrote:
> This seems to be a good first pass at identifying the data objects involved in the subject of session recording. I am not sure that it all should be considered as "metadata". In my opinion, metadata is information the SRS needs to accompany recorded media.

> In particular, anything to do with the Recording Session (RS) is just a temporary artefact of the SIPREC delivery mechanism, and doesn't need to be retained as metadata. For example, whether a single RS is used to record one CS or several CSs is irrelevant after the event. So I think the Recording Session Group and Recording Session objects are not part of metadata.

This is a good discussion to have.

I don't have an opinion one way or the other on the specific piece of 
info that John is calling out. I can imagine somebody would indeed like 
to have that information about the recording session (for tracability or 
whatever.) Others might consider it irrelevant.

I'm happy to go either way on that.

The piece that I think is least likely to be needed long term, but which 
is needed by the SRS short term, is the address and port on the SRS at 
which it is receiving a particular media stream. I think it very 
unlikely that anyone will find that important to keep in the historical 
record. That at least establishes the point that we probably need to 
distinguish between that which is needed transiently and that which is 
needed permanently. So maybe we need a documentation convention for that.

	Thanks,
	Paul

---

From: Leon Portman <[email-masked]>
Date: Fri, 27 Aug 2010 19:41:11 +0300

Yes, I agree as well regarding RS metadata. However, there are some exceptions for that. For example, if SRC is mixing some medias together and reports the mix via RS metadata, then off course this info will be stored and used by SRS.

Leon

Sent from my iPad

On Aug 27, 2010, at 4:41 PM, Paul Kyzivat <[email-masked]> wrote:

> I don't have an opinion one way or the other on the specific piece of info that John is calling out. I can imagine somebody would indeed like to have that information about the recording session (for tracability or whatever.) Others might consider it irrelevant.
> 
> The piece that I think is least likely to be needed long term, but which is needed by the SRS short term, is the address and port on the SRS at which it is receiving a particular media stream. I think it very unlikely that anyone will find that important to keep in the historical record. That at least establishes the point that we probably need to distinguish between that which is needed transiently and that which is needed permanently. So maybe we need a documentation convention for that.
> 
> 	Thanks,
> 	Paul
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec