Subject: Re: [siprec] I-D Action: draft-portman-siprec-protocol-04.txt

From: "Elwell, John" <[email-masked]>
Date: Thu, 5 May 2011 11:37:26 +0200

Leon, Henry and others,

Thanks for doing this revision. One question:
In 5.4.1 it states:
"The format of the metadata snapshot request
   is described in [I-D.ietf-siprec-metadata]."
I searched for this in the metadata draft (and also in the metadata-format draft, which contains candidate material for merging into the metadata draft) and could find nothing, so I assume it is your intent that something should be added to the metadata draft. However, although the metadata model and its format should be specified in the metadata draft, a snapshot request sounds to me like something more appropriate for the protocol draft.

John

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> [email-masked]
> Sent: 04 May 2011 16:24
> To: [email-masked]
> Subject: I-D Action: draft-portman-siprec-protocol-04.txt
> 
> A New Internet-Draft is available from the on-line 
> Internet-Drafts directories.
> 
> 	Title           : Session Recording Protocol
> 	Author(s)       : Leon Portman
>                           Henry Lum
>                           Alan Johnston
>                           Andrew Hutton
> 	Filename        : draft-portman-siprec-protocol-04.txt
> 	Pages           : 20
> 	Date            : 2011-05-04
> 
>    The Session Recording Protocol is used for establishing recording
>    session and reporting of the metadata of the communication session.
> 
>    This document specifies the Session Recording Protocol.  
> The protocol
>    is used between Session Recording Client (SRC) and Session 
> Recording
>    Server (SRS).
> 
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-portman-siprec-proto
> col-04.txt
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> This Internet-Draft can be retrieved at:
> ftp://ftp.ietf.org/internet-drafts/draft-portman-siprec-protoc
> ol-04.txt
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

---

From: "Henry Lum" <[email-masked]>
Date: Fri, 6 May 2011 09:09:28 -0700

I originally thought it would be useful consolidate all metadata-related
formats in the metadata/metadata-format drafts, but the snapshot request
does sound like a protocol issue rather than a metadata issue since the
request itself does not need to contain any metadata. In fact, the
snapshot request content does not even need to be XML at all.

Henry

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Elwell, John
> Sent: Thursday, May 05, 2011 5:37 AM
> To: [email-masked]
> Subject: Re: [siprec] I-D Action: draft-portman-siprec-protocol-04.txt
> 
> Leon, Henry and others,
> 
> I searched for this in the metadata draft (and also in the metadata-
> format draft, which contains candidate material for merging into the
> metadata draft) and could find nothing, so I assume it is your intent
> that something should be added to the metadata draft. However,
although
> the metadata model and its format should be specified in the metadata
> draft, a snapshot request sounds to me like something more appropriate
> for the protocol draft.
> 
> John
> 
> 
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec

-------------------------------------------------------------------------------------------------------------------
CONFIDENTIALITY NOTICE: This e-mail and any files attached may contain confidential and proprietary information of Alcatel-Lucent and/or its affiliated entities. Access by the intended recipient only is authorized. Any liability arising from any party acting, or refraining from acting, on any information contained in this e-mail is hereby excluded. If you are not the intended recipient, please notify the sender immediately, destroy the original transmission and its attachments and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Copyright in this e-mail and any attachments belongs to Alcatel-Lucent and/or its affiliated entities.