Subject: [siprec] Modelling current speaker video.

From: "Elwell, John" <[email-masked]>
Date: Fri, 20 May 2011 09:10:57 +0200

This may already be covered, but how do we envisage modelling the following? There are n participants, all participating in 3 media: audio, main video and current speaker video. Audio and main video are mixed/combined by the mixer. But with current speaker video, the mixer switches between different sources, according to voice activity detection. At any one time, only one Participant is contributing to that MS, but switching is dynamic, much faster than we would envisage doing metadata updates. I guess the simple solution would be to model it as all Participants are contributing to that MS, even though at any instant there will be only one contributor.

John (as individual)

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 20 May 2011 08:39:03 -0400

> This may already be covered, but how do we envisage modelling the following? There are n participants, all participating in 3 media: audio, main video and current speaker video. Audio and main vide…

I think I agree.

*If* the SRC can signal the participant changes then it is free to do 
so, If not, doing as you say seems appropriate.

	Thanks,
	Paul

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Sun, 22 May 2011 09:07:44 -0700

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
Behalf Of Paul Kyzivat (pkyzivat)
> Sent: Friday, May 20, 2011 5:39 AM
> To: [email-masked]
> Subject: Re: [siprec] Modelling current speaker video.
> 
> 
> 
> > This may already be covered, but how do we envisage modelling the
following? There are n
> participants, all participating in 3 media: audio, main video and
current speaker video. Audio and
> main video are mixed/combined by the mixer. But with current speaker
video, the mixer switches between
> different sources, according to voice activity detection. At any one
time, only one Participant is
> contributing to that MS, but switching is dynamic, much faster than we
would envisage doing metadata
> updates. I guess the simple solution would be to model it as all
Participants are contributing to that
> MS, even though at any instant there will be only one contributor.
> 
> I think I agree.
> 

This is where I think SSRC or CSRC would be a good way to indicate the
participant responsible for the stream. Either one may be appropriate
depending on the exact scenario.

Cheers,
Charles

> 
> 	Thanks,
> 	Paul
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec