Subject: [siprec] Agenda slots and slides

From: "Elwell, John" <[email-masked]>
Date: Wed, 20 Jul 2011 11:48:28 +0200

I really need to finalise the agenda - I have had little feedback on times required or whether indeed a topic needs to be on the agenda. Would all authors please respond. Also, please let me have your initial slides by Sunday - they can always be updated later in the week, up to the day before the meeting.

Thanks,

John

John Elwell
Tel: +44 1908 817801 (office and mobile)
Email: [email-masked]
http://www.siemens-enterprise.com/uk/

Siemens Enterprise Communications Limited.
Registered office: Brickhill Street, Willen Lake, Milton Keynes, MK15 0DJ.
Registered No: 5903714, England.

Siemens Enterprise Communications Limited is a Trademark Licensee of Siemens AG.

---

From: "Elwell, John" <[email-masked]>
Date: Sun, 24 Jul 2011 21:18:58 +0200

(added the mailing list)

It is a question of when something can be removed from complete updates. If a conference has been going on for days, with lots of people joining and leaving, a complete XML (snapshot) containing all past participants could  be huge, so I thought we wanted to avoid transmitting all that history.

John (as individual)

> -----Original Message-----
> From: Paul Kyzivat [mailto:[email-masked]] 
> Sent: 24 July 2011 19:50
> To: Elwell, John
> Cc: Ram Mohan R (rmohanr); Parthasarathi R (partr)
> Subject: Re: [siprec] Agenda slots and slides
> 
> On 7/24/11 7:24 AM, Elwell, John wrote:
> > Thanks, Ram, I will post the slides.
> >
> > One possible addition might be a slide on how you delete an 
> object, particularly when using partial updates. We had some 
> discussion on that, and I think the conclusion was to you 
> could add a stop time and that implicitly meant the object 
> had finished would no longer appear in the complete XML. 
> Might be worth getting confirmation of this at the meeting.
> 
> This probably warrants further discussion.
> 
> For one thing, I think we should state that there is no such thing as 
> deletion of anything. Deletion is comparable to changing 
> history, which 
> we shouldn't be doing.
> 
> Rather, we have things that "end". And even that is a little 
> bit elusive 
> to define. I'm uncomfortable with the concept that a thing becomes 
> immutable at the SRS once the SRC sends a stop time for it. 
> It makes me 
> uncomfortable because it introduces nasty error conditions. 
> Specifically, if additional updates are sent for a thing 
> after the stop 
> time has been sent. I think the SRS is obligated to capture the added 
> info even if it thinks this is bad behavior.
> 
> Identifying those things that would not be reported in a 
> "complete" xml 
> is an interesting criterion. I'm not sure if we can/should guarantee 
> that the SRS can predict things like that.
> 
> 	Thanks,
> 	Paul
> 
> > John
> >
> >> -----Original Message-----
> >> From: Ram Mohan R (rmohanr) [mailto:[email-masked]]
> >> Sent: 24 July 2011 03:34
> >> To: Elwell, John
> >> Cc: Paul Kyzivat; Parthasarathi R (partr)
> >> Subject: RE: [siprec] Agenda slots and slides
> >>
> >> John,
> >>
> >> Please find the initial version of slide deck for metadata. Please
> >> review and provide your opinion on if you would like to 
> see anything
> >> added/modified/removed in the slide deck which will help in making
> >> metadata draft move forward.
> >>
> >> Regards,
> >> Ram
> >>
> >>> -----Original Message-----
> >>> From: [email-masked] [mailto:[email-masked]] On
> >>> Behalf Of Elwell, John
> >>> Sent: Wednesday, July 20, 2011 5:48 AM
> >>> To: [email-masked]
> >>> Subject: [siprec] Agenda slots and slides
> >>>
> >>> I really need to finalise the agenda - I have had little 
> feedback on
> >>> times required or whether indeed a topic needs to be on 
> the agenda.
> >>> Would all authors please respond. Also, please let me have your
> >> initial
> >>> slides by Sunday - they can always be updated later in the
> >> week, up to
> >>> the day before the meeting.
> >>>
> >>> Thanks,
> >>>
> >>> John
> >>>
> >>>
> >>>
> >>> John Elwell
> >>> Registered office: Brickhill Street, Willen Lake, Milton
> >> Keynes, MK15
> >>> 0DJ.
> >>> Siemens Enterprise Communications Limited is a Trademark 
> Licensee of
> >>> Siemens AG.
> >>> _______________________________________________
> >>> siprec mailing list
> >>> [email-masked]
> >>> https://www.ietf.org/mailman/listinfo/siprec
> >>
> 
>