Subject: [siprec] start/stop times

From: Michael Baj <[email-masked]>
Date: Mon, 25 Jul 2011 12:34:40 +0000

The RS start/stop times are defined by the lifetime of the Recording dialog (when doing selective recording). If a CS is on-going prior to the initiation of the RD (as would be the case when the CS is not initially recorded, but then a policy decision on the SRC causes the CS to be recorded), should the 
start times precede the RS start time? Should the participant and media stream start times also precede the RS?  What is the recommended behavior in this case?

Thanks,
Mike

---

From: Leon Portman <[email-masked]>
Date: Mon, 25 Jul 2011 09:35:05 -0400

This is one of the main issue with defining MS in the metadata as RS MS and not CS MS. Because the expectation is that times in MS will represent original CS times.

Leon

On Jul 25, 2011, at 8:34 AM, Michael Baj wrote:

> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Tue, 26 Jul 2011 02:25:48 +0530

The current metadata is left flexible to allow the same.
CS has start/stop times which represents the start/stop of CS as seen by
SRC. These  are optional attributes as not all SRC may store the
start/stop time. Refer to section 6.3.1. Hope this is sufficient.

Regards,
Ram

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Leon Portman
> Sent: Monday, July 25, 2011 9:35 AM
> To: Michael Baj
> Cc: [email-masked]
> Subject: Re: [siprec] start/stop times
> 
> This is one of the main issue with defining MS in the metadata as RS
MS
> and not CS MS. Because the expectation is that times in MS will
> represent original CS times.
> 
> Leon
> 
> > The RS start/stop times are defined by the lifetime of the Recording
> dialog (when doing selective recording). If a CS is on-going prior to
> the initiation of the RD (as would be the case when the CS is not
> initially recorded, but then a policy decision on the SRC causes the
CS
> to be recorded), should the
> > start times precede the RS start time? Should the participant and
> media stream start times also precede the RS?  What is the recommended
> behavior in this case?
> >
> > Thanks,
> > Mike
> >