Subject: [siprec] Handling of end times

From: "Elwell, John" <[email-masked]>
Date: Thu, 14 Jul 2011 15:20:22 +0200

One thing that is not clear to me in the metadata draft is the handling of stop times.

For example, suppose there is a CS being recorded with a number of participants and a number of media streams. During recording the XML document will show these various objects as XML elements with start times and no stop times. What happens when the CS ends? Possibilities include:

1. Updating the XML to show removal of the elements concerned. But in this case there is no opportunity to show stop times for any of the elements.

2. Updating the XML to add stop times to the various elements. But in this case the elements concerned remain in existence, even though the objects they are modelling have disappeared.

3. Do 2 followed almost immediately by 1.

Any opinions?

John

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Thu, 14 Jul 2011 21:10:49 +0530

Hi John,

Please see inline

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Elwell, John
> Sent: Thursday, July 14, 2011 6:50 PM
> To: [email-masked]
> Subject: [siprec] Handling of end times
> 
> One thing that is not clear to me in the metadata draft is the
handling
> of stop times.
> 
> For example, suppose there is a CS being recorded with a number of
> participants and a number of media streams. During recording the XML
> document will show these various objects as XML elements with start
> times and no stop times. What happens when the CS ends? Possibilities
> include:
> 
> 1. Updating the XML to show removal of the elements concerned. But in
> this case there is no opportunity to show stop times for any of the
> elements.
> 
> 2. Updating the XML to add stop times to the various elements. But in
> this case the elements concerned remain in existence, even though the
> objects they are modelling have disappeared.

If CS has ended an updated XML schema with stop-time attribute added
shall be sent for each of the deleted element.

Regards,
Ram

> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec