Subject: [siprec] Caller preference information in Metadata

From: "Parthasarathi R (partr)" <[email-masked]>
Date: Thu, 7 Jul 2011 17:36:41 +0530

Hi all,
 
Caller preference (RFC 3841) information about CS is possible to be
passed in extension data of participant. The caller preference like
"automata" shall be passed in SIPREC metadata itself in case folks are
interested. Please let me know whether "caller preference" attribute
shall be added under participant block.
 
Thanks
Partha

---

From: Leon Portman <[email-masked]>
Date: Thu, 7 Jul 2011 16:44:42 +0300

Partha Hi

Today we are not receive and store  this information. Is it widely accepted?

Leon

From: [email-masked] [mailto:[email-masked]] On Behalf Of Parthasarathi R (partr)
Sent: Thursday, July 07, 2011 3:07 PM
To: [email-masked]
Subject: [siprec] Caller preference information in Metadata

Hi all,

Caller preference (RFC 3841) information about CS is possible to be passed in extension data of participant. The caller preference like "automata" shall be passed in SIPREC metadata itself in case folks are interested. Please let me know whether "caller preference" attribute shall be added under participant block.

Thanks
Partha

---

From: "Parthasarathi R (partr)" <[email-masked]>
Date: Thu, 7 Jul 2011 19:34:49 +0530

Leon,
 
I agree with you that it is not stored currently. I asked this question
because there was an earlier discussion wherein participant has to be
identified as normal user or media server. Paul, Ram and myself
discussed internally and thought that it would be better to have generic
caller preference rather than specific single "automata" parameter. I
forget to continue the mail thread in SIPREC alias, so initiated after a
long time. 
 
This attribute shall be added as an optional which helps for better
interop in case future application uses this attribute.
 
In case everyone feels that this attribute will never be used, I'm fine
with it.
 
Thanks
Partha

________________________________

	From: Leon Portman [mailto:[email-masked]] 
	Sent: Thursday, July 07, 2011 7:15 PM
	To: Parthasarathi R (partr); [email-masked]
	Subject: RE: Caller preference information in Metadata

	Partha Hi

	Today we are not receive and store  this information. Is it
widely accepted? 

	Leon

	From: [email-masked] [mailto:[email-masked]]
On Behalf Of Parthasarathi R (partr)
	Sent: Thursday, July 07, 2011 3:07 PM
	To: [email-masked]
	Subject: [siprec] Caller preference information in Metadata

	Hi all,

	Caller preference (RFC 3841) information about CS is possible to
be passed in extension data of participant. The caller preference like
"automata" shall be passed in SIPREC metadata itself in case folks are
interested. Please let me know whether "caller preference" attribute
shall be added under participant block.

	Thanks

	Partha

---

From: Leon Portman <[email-masked]>
Date: Thu, 7 Jul 2011 17:06:30 +0300

It is important distinction (talking to IVR vs person). We should have a way to relay this info to SRS

Leon

From: Parthasarathi R (partr) [mailto:[email-masked]]
Sent: Thursday, July 07, 2011 5:05 PM
To: Leon Portman; [email-masked]
Subject: RE: Caller preference information in Metadata

Leon,

I agree with you that it is not stored currently. I asked this question because there was an earlier discussion wherein participant has to be identified as normal user or media server. Paul, Ram and myself discussed internally and thought that it would be better to have generic caller preference rather than specific single "automata" parameter. I forget to continue the mail thread in SIPREC alias, so initiated after a long time.

This attribute shall be added as an optional which helps for better interop in case future application uses this attribute.

In case everyone feels that this attribute will never be used, I'm fine with it.

Thanks
Partha

________________________________
From: Leon Portman [mailto:[email-masked]]<mailto:[mailto:[email-masked]]>
Sent: Thursday, July 07, 2011 7:15 PM
To: Parthasarathi R (partr); [email-masked]<mailto:[email-masked]>
Subject: RE: Caller preference information in Metadata
Partha Hi

Leon

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]<mailto:[mailto:[email-masked]]> On Behalf Of Parthasarathi R (partr)
Sent: Thursday, July 07, 2011 3:07 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [siprec] Caller preference information in Metadata

Hi all,

Thanks
Partha

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 07 Jul 2011 11:20:11 -0400

Presumably we are really talking about "callee" capabilities, not 
preferences. Namely, the feature tags present as header parameters on 
the contact URI from each signaling participant.

That is info that belongs to the association of the participant to a CS.

We might just want to include the entire Contact header, or all of its 
header parameters.

	Thanks,
	Paul

On 7/7/11 10:06 AM, Leon Portman wrote:
> *From:*Parthasarathi R (partr) [mailto:[email-masked]]
> *Sent:* Thursday, July 07, 2011 5:05 PM
> *To:* Leon Portman; [email-masked]
> *Subject:* RE: Caller preference information in Metadata
>
> Leon,
>
>     ------------------------------------------------------------------------
>
>     *From:*Leon Portman [mailto:[email-masked]]
>     <mailto:[mailto:[email-masked]]>
>     *Sent:* Thursday, July 07, 2011 7:15 PM
>     *To:* Parthasarathi R (partr); [email-masked] <mailto:[email-masked]>
>     *Subject:* RE: Caller preference information in Metadata
>
>     Partha Hi
>
>     *From:[email-masked] <mailto:[email-masked]>
>     [mailto:[email-masked]]
>     <mailto:[mailto:[email-masked]]> *On Behalf Of
>     *Parthasarathi R (partr)
>     *Sent:* Thursday, July 07, 2011 3:07 PM
>     *To:* [email-masked] <mailto:[email-masked]>
>     *Subject:* [siprec] Caller preference information in Metadata
>
>     Hi all,
>
>     "automata" shall be passed in SIPREC metadata itself in case folks
>     are interested. Please let me know whether "caller preference"
>     attribute shall be added under participant block.
>
>     Thanks
>
>     Partha
>
>
>
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec

---

From: "Henry Lum" <[email-masked]>
Date: Mon, 11 Jul 2011 14:12:29 -0700

+1, it would be useful to relay this information to SRS.

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Leon Portman
Sent: Thursday, July 07, 2011 10:06 AM
To: Parthasarathi R (partr); [email-masked]
Subject: Re: [siprec] Caller preference information in Metadata

It is important distinction (talking to IVR vs person). We should have a
way to relay this info to SRS

Leon

Leon,

Thanks

Partha

	Partha Hi

	Leon

	Hi all,

	Thanks

	Partha

-------------------------------------------------------------------------------------------------------------------
CONFIDENTIALITY NOTICE: This e-mail and any files attached may contain confidential and proprietary information of Alcatel-Lucent and/or its affiliated entities. Access by the intended recipient only is authorized. Any liability arising from any party acting, or refraining from acting, on any information contained in this e-mail is hereby excluded. If you are not the intended recipient, please notify the sender immediately, destroy the original transmission and its attachments and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Copyright in this e-mail and any attachments belongs to Alcatel-Lucent and/or its affiliated entities.

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 12 Jul 2011 12:35:29 -0400

> Today we are not receive and store this information. Is it widely accepted?

As I noted earlier, there is a difference between callee-capability info 
(rfc3840) and caller-preference info (rfc3841), though they are often 
talked about as one thing.

Its not evident to me that caller preference info is very relevant. It 
could influence what UAS ends up in a call, but that isn't so relevant 
to recording.

The callee caps stuff goes two places: in registered contacts, and in 
contacts used to establish dialogs. Again, the registered contacts 
probably aren't of interest, and aren't available in any case.

The callee caps in dialog contacts can be significant. For instance, the 
isFocus capability/tag can be quite interesting. I think we ought to 
make them available.

	Thanks,
	Paul

> Leon
>
> *From:[email-masked] [mailto:[email-masked]] *On
> Behalf Of *Parthasarathi R (partr)
> *To:* [email-masked]

---

From: "Parthasarathi R (partr)" <[email-masked]>
Date: Tue, 12 Jul 2011 22:52:24 +0530

Paul,

I'm not very sure whether we need both callee capability and caller
preference or callee capability will serve the purpose. The reason for
my doubt is that Caller participant information may end up as "automata"
in contact header which has to be passed across to  from SRC to SRS and
caller "automata" information to SRS is considered as callee capability
or caller preference. 

Thanks
Partha  

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Paul Kyzivat
> Sent: Tuesday, July 12, 2011 10:05 PM
> To: [email-masked]
> (rfc3840) and caller-preference info (rfc3841), though they 
> are often talked about as one thing.
> 
> Its not evident to me that caller preference info is very 
> relevant. It could influence what UAS ends up in a call, but 
> that isn't so relevant to recording.
> 
> The callee caps stuff goes two places: in registered 
> contacts, and in contacts used to establish dialogs. Again, 
> the registered contacts probably aren't of interest, and 
> aren't available in any case.
> 
> The callee caps in dialog contacts can be significant. For 
> instance, the isFocus capability/tag can be quite 
> interesting. I think we ought to make them available.
> 
> 	Thanks,
> 	Paul
> 
> > Leon
> >

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 12 Jul 2011 13:47:43 -0400

> caller "automata" information to SRS is considered as callee capability

Its a capability.

The preferences are selection "expressions" applied to capabilities to 
compute which contact to prefer.

	Thanks,
	Paul

---

From: "Parthasarathi R (partr)" <[email-masked]>
Date: Wed, 13 Jul 2011 11:07:37 +0530

Paul,

I agree that participant capability (RFC 3840) has to passed across in
metadata XML. Please let me know whether adding <capability> element
within <participant> element will serve the purpose. The example
metadata xml element structure is as follows:

        <participant id="..." parent="..">
             <capability> automata </capability>
        </participant>

Thanks
Partha 

> From: Paul Kyzivat [mailto:[email-masked]] 
> Sent: Tuesday, July 12, 2011 11:18 PM
> To: Parthasarathi R (partr)
> Cc: [email-masked]
> > in contact header which has to be passed across to  from SRC to SRS 
> > and caller "automata" information to SRS is considered as callee 
> > capability or caller preference.
> 
> Its a capability.
> 
> The preferences are selection "expressions" applied to 
> capabilities to compute which contact to prefer.
> 
> 	Thanks,
> 	Paul
> 
> > Thanks
> > Partha
> >
> >> As I noted earlier, there is a difference between 
> callee-capability 
> >> info
> relevant. 
> >> It could influence what UAS ends up in a call, but that isn't so 
> >> relevant to recording.
> >>
> contacts, and in 
> instance, 
> >> the isFocus capability/tag can be quite interesting. I 
> think we ought 
> >> to make them available.
> >>
> >> 	Thanks,
> >> 	Paul
> >>
> >>> Leon
> >>>

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Wed, 13 Jul 2011 15:32:15 +0530

Paul / Partha,

Would it better to use "characteristic" as the XML element name instead
of "capability". As per 3840 definition one difference between
capability and characteristic is capability is something that can be
negotiated where as characteristic cannot be.
IMO since "automata" is a characteristic of a device it is better to
have XML element as the "characteristic"

Ram

> Sent: Wednesday, July 13, 2011 11:08 AM
> To: Paul Kyzivat
> Cc: [email-masked]

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 13 Jul 2011 08:57:56 -0400

On 7/13/11 1:37 AM, Parthasarathi R (partr) wrote:
> metadata XML. Please let me know whether adding<capability>  element
> within<participant>  element will serve the purpose. The example
>               <capability>  automata</capability>
>          </participant>

That would work. Then need to decide whether to pass the arguments "as 
is" from the sip, or re-encode them in some way. (When no value is given 
for the tag, do we include the default value? Preserve quoting?)

I expect it will be necessary to match up characters used and 
quoting/escaping conventions in the sip syntax with those in xml and do 
some mapping.

	Thanks,
	Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 13 Jul 2011 09:17:25 -0400

> have XML element as the "characteristic"

How about "feature-tag" ?

	Thanks,
	Paul

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Wed, 13 Jul 2011 19:05:17 +0530

Hi Paul,

feature-tag sounds fine to me

Regards,
Ram

> Sent: Wednesday, July 13, 2011 6:47 PM
> To: Ram Mohan R (rmohanr)
> Cc: Parthasarathi R (partr); [email-masked]