Subject: [siprec] Participant "recv" attribute

From: Michael Baj <[email-masked]>
Date: Mon, 25 Jul 2011 03:09:06 +0000

The default behavior is for all participants in a CS to receive all media streams.  If a participant has a "recv" element, it is unclear what other
streams the participant receives.  Assume a conference video/audio stream and a private audio stream between two (or more) participants.  Should there be some indication about which media streams are being received by which participants?

---

From: "Parthasarathi R (partr)" <[email-masked]>
Date: Mon, 25 Jul 2011 17:07:07 +0530

Mike,

The default behavior is introduced for the simplification wherein <recv>
element is not required for two party basic call. ISTM, it confuses for
the complicated scenario rather than providing the clarity. John raised
the same issue as part of his review comment on the draft. 

The authors of the draft discussed about this issue. We are fine with
removing the default behavior in the next revision. IOW, each
participant has to add <recv> element for each media stream. Let us look
for others comment on the same.

Thanks
Partha  

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Michael Baj
> Sent: Monday, July 25, 2011 8:39 AM
> To: [email-masked]
> Subject: [siprec] Participant "recv" attribute
> 
> The default behavior is for all participants in a CS to 
> receive all media streams.  If a participant has a "recv" 
> element, it is unclear what other streams the participant 
> receives.  Assume a conference video/audio stream and a 
> private audio stream between two (or more) participants.  
> Should there be some indication about which media streams are 
> being received by which participants?
> 
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec
>

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Mon, 25 Jul 2011 19:58:49 +0530

Given the complexities in assuming default behavior of all participants
receiving a MS when <recv> tag is not present, I would go for having
explicitly adding <recv> tag for each participant to give the list of
streams that participant is receiving.
The downside though is the XML would be slightly bloated when we have
several participants in a session. 

If anyone has a better way to represent this I am all open to hear,
otherwise we would go with the approach of having <recv> tag explicitly
added to each participant.

Regards,
Ram

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Parthasarathi R (partr)
> Sent: Monday, July 25, 2011 7:37 AM
> To: Michael Baj; [email-masked]
> Subject: Re: [siprec] Participant "recv" attribute
> 
> Mike,
>