Subject: [siprec] I-D Action: draft-ietf-siprec-protocol-09.txt

From: [email-masked]
Date: Fri, 07 Dec 2012 15:32:28 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the SIP Recording Working Group of the IETF.

	Title           : Session Recording Protocol
	Author(s)       : Leon Portman
                          Henry Lum
                          Charles Eckel
                          Alan Johnston
                          Andrew Hutton
	Filename        : draft-ietf-siprec-protocol-09.txt
	Pages           : 42
	Date            : 2012-12-07

Abstract:
   This document specifies the use of the Session Initiation Protocol
   (SIP), the Session Description Protocol (SDP), and the Real Time
   Protocol (RTP) for delivering real-time media and metadata from a
   Communication Session (CS) to a recording device.  The Session
   Recording Protocol specifies the use of SIP, SDP, and RTP to
   establish a Recording Session (RS) between the Session Recording
   Client (SRC), which is on the path of the CS, and a Session Recording
   Server (SRS) at the recording device.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-siprec-protocol

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-siprec-protocol-09

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-siprec-protocol-09

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 7 Dec 2012 23:34:28 +0000

Changes in this update of the protocol draft:

Updated section 8.3, "RTP Session Usage by SRC". Removed section 8.3.2, " SRC using SSRC Multiplexing". The workgroup reached consensus at IETF 85 that SSRC multiplexing is out of scope. The definition of it is left for CLUE/RTCWEB.

Added section 8.4, "RTP Session Usage by SRS". This section places requirements on the SRS to support a minimum level of RTP session usages. The text is based on that posted by Hadriel (http://www.ietf.org/mail-archive/web/siprec/current/msg03508.html), with some modifications as discussed on the list.

Reworked  section 12, "Security Consideration", clarifying some text as discussed on the list (http://www.ietf.org/mail-archive/web/siprec/current/msg03597.html), and also adding a note about the potential for the SRC to use EKT.

Cheers,
Charles

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of [email-masked]
> Sent: Friday, December 07, 2012 3:32 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [siprec] I-D Action: draft-ietf-siprec-protocol-09.txt
> 
> 
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 7 Dec 2012 23:39:04 +0000

Removing the internet-drafts and i-d-announce lists that I unintentionally spammed.

> Of Charles Eckel (eckelcu)
> Sent: Friday, December 07, 2012 3:34 PM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: Re: [siprec] I-D Action: draft-ietf-siprec-protocol-09.txt
> 
> Updated section 8.3, "RTP Session Usage by SRC". Removed section 8.3.2, "
> SRC using SSRC Multiplexing". The workgroup reached consensus at IETF 85
> that SSRC multiplexing is out of scope. The definition of it is left for
> CLUE/RTCWEB.
> 
> Added section 8.4, "RTP Session Usage by SRS". This section places
> requirements on the SRS to support a minimum level of RTP session usages.
> The text is based on that posted by Hadriel (http://www.ietf.org/mail-
> archive/web/siprec/current/msg03508.html), with some modifications as
> discussed on the list.
> 
> Reworked  section 12, "Security Consideration", clarifying some text as
> discussed on the list (http://www.ietf.org/mail-
> archive/web/siprec/current/msg03597.html), and also adding a note about
> the potential for the SRC to use EKT.
> 
> Cheers,
> Charles
>