Subject: Re: Correct definition of ContentInfo in CMS-10

From: [email-masked] (Peter Gutmann)
Date: Tue, 23 Feb 1999 03:46:28 (NZDT)

>>Within the body of CMS 10 ContentInfo is defined as : -
>>
>>ContentInfo ::= SEQUENCE {
>>        contentType ContentType,
>>        content [0] EXPLICIT ANY DEFINED BY contentType }
>>
>>However, in the appendix ContentInfo is defined as : -
>>
>>ContentInfo ::= SEQUENCE {
>>     contentType ContentType,
>>     content [0] EXPLICIT ANY DEFINED BY contentType OPTIONAL }
>>
>>I assume the one within the body (i.e. content not optional) is correct.
 
>I assume that content is not optional
 
The content is optional.  Think about how detached sigs work.
 
Peter.

---

From: Russ Housley <[email-masked]>
Date: Mon, 08 Mar 1999 04:37:29 -0500

Peter:

Thanks for pointing out the error in the Appendix.  You are correct,
content is NOT OPTIONAL.

Russ