Subject: Re: Correct definition of ContentInfo in CMS-10

From: "Ross demon" <[email-masked]>
Date: Mon, 22 Feb 1999 13:45:08 -0000

I assume that content is not optional
-----Original Message-----
From: William Ottaway <[email-masked]>
To: [email-masked]' <[email-masked]>
Date: Monday, February 22, 1999 1:27 PM
Subject: Correct definition of ContentInfo in CMS-10

>Within the body of CMS 10 ContentInfo is defined as : -
>
>ContentInfo ::= SEQUENCE {
>        contentType ContentType,
>        content [0] EXPLICIT ANY DEFINED BY contentType }
>
>However, in the appendix ContentInfo is defined as : -
>
>ContentInfo ::= SEQUENCE {
>     contentType ContentType,
>     content [0] EXPLICIT ANY DEFINED BY contentType OPTIONAL }
>
>I assume the one within the body (i.e. content not optional) is correct.
>
>Bill.
>
>
>"The Information contained in this E-Mail and any subsequent
>correspondence is private and is intended solely for the intended
>recipient(s).  For those other than the intended recipient any
>disclosure, copying, distribution, or any action taken or omitted to
>be taken in reliance on such information is prohibited and may be
>unlawful."
>____________________________________________________
>William Ottaway BSc Hons CEng MBCS,
>L323,                        Tel: +44 (0) 1684 894079
>DERA Malvern,                Fax: +44 (0) 1684 896113
>St. Andrews Road,            email: [email-masked]
>Malvern,
>Worcs,
>WR14 3PS
>
>All opinions are my own.
>

---

From: "John Ross" <[email-masked]>
Date: Mon, 22 Feb 1999 14:17:13 -0800

---

From: "Ross demon" <[email-masked]>
Date: Mon, 22 Feb 1999 15:37:26 -0000

Peter,

When using detached signatures, I agree that the eContent is absent, but the
content is still required to convey the SignedData and hence the signature.
-----Original Message-----
From: Peter Gutmann <[email-masked]>
To: [email-masked] <[email-masked]>; [email-masked]
<[email-masked]>
Date: Monday, February 22, 1999 3:04 PM
Subject: Re: Correct definition of ContentInfo in CMS-10

>The content is optional.  Think about how detached sigs work.
>
>Peter.
>

---

From: Darren Harter <[email-masked]>
Date: Tue, 23 Feb 1999 08:41:07 -0000

Peter,

You would be correct if we were talking about PKCS#7 where ContentInfo was used within SignedData to carry the content.  This would clearly have to be optional in the detached signature case.  But, in CMS we now only use ContentInfo for carrying SignedData, EnvelopedData etc., so even when detached signatures are being used the Content field of ContentInfo must be present to carry your SignedData.

I agree with John and other posters that the definition in the main body of the document is correct.  Content is not optional.

Regards,

Darren

--------------------------------------------------------------------------------
Darren Harter BSc (Hons) CEng MBCS
Entegrity Solutions
E-Mail:	[email-masked]
Tel:	+44 (0) 1452 371 383, or +44 (0) 181 876 8666
Fax:	+44 (0) 1452 371 384, or +44 (0) 181 876 8660
Cell:	+44 (0) 7801 812 850

-----Original Message-----
From:	Peter Gutmann [SMTP:[email-masked]]
Sent:	Tuesday, February 23, 1999 3:46 AM
To:	[email-masked]; [email-masked]
Subject:	Re: Correct definition of ContentInfo in CMS-10

Peter.

---

From: William Ottaway <[email-masked]>
Date: Wed, 24 Feb 1999 14:08:36 -0000

Russ:

To draw this thread to a close, the content within ContentInfo is not 
optional. Therefore, the ASN.1 in the appendix to CMS defining ContentInfo 
needs to have optional removed..

Bill.

-----Original Message-----
From:	Russ Housley [SMTP:[email-masked]]
Sent:	Wednesday, February 24, 1999 12:08 PM
To:	Bonatti, Chris
Cc:	SMIME
Subject:	RE: Correct definition of ContentInfo in CMS-10

Chris:

In PKCS#7 v1.5, ContentInfo was used as the outer wrapper (around
SignedData, EnvelopedData, etc) as well as the wrapper around the content
being protected.  In CMS, two different ASN.1 types are used for the two
different wrappers.  ContentInfo remains the outer wrapper.  There is no
need for such a wrapper without a protecting content such as SignedData,
EnvelopedData, etc., therefore the ContentInfo content should not be
optional.  The EncapsulatedContentInfo is the wrapper for the content being
protected.  To support a SignedData for distribution of certificates and
CRLs without any content (this approach is used in many products for
certificate user enrollment), EncapsulatedContentInfo has an OPTIONAL
content.

Russ

-----Original Message-----
From:	[email-masked] [mailto:[email-masked]] On Behalf
Of Bonatti, Chris
Sent:	Monday, February 22, 1999 9:42 AM
To:	William Ottaway; [email-masked]'; Russ Housley
Subject:	Re: Correct definition of ContentInfo in CMS-10

    I would submit that the 'content' field in the General Syntax section 
is
correct.  The instance of OPTIONAL in the appendix must be a copy artifact
from the 'EncapsulatedContentInfo', in which the 'content' field is
correctly optional.  I can see no legitimate use of CMS in which you would
send only a 'contentType' OID.  Even if someone were sending a "detached
content" in a separate body part, either MIME or X.400 mail systems are
perfectly capable of attaching a content types for that information without
utilizing this structure.

Russ,

    Browsing through my historical archive of now "non-existent" I-Ds, I 
see
that the OPTIONAL tag seems to have fallen out of the General Syntax
starting in version 3 of CMS.  Do you remember the reasoning behind the
change?

Chris

 ---------------------------------------------------------------
 |  International Electronic Communication Analysts, Inc.      |
 |  Christopher D. Bonatti             15309 Turkey Foot Road  |
 |  Principal Engineer              Darnestown, Md 20878-3640  |
 |  [email-masked]   Tel: 301-208-2349   Fax: 301-208-2379  |
 ---------------------------------------------------------------

____________________