Subject: RE: RE: Last Call: 'S/MIME Version 3.1 Message Specification' to Proposed Standard

From: "Blake Ramsdell" <[email-masked]>
Date: Thu, 22 Apr 2004 20:34:02 -0700

> -----Original Message-----
> From: Blake Ramsdell [mailto:[email-masked]] 
> Sent: Thursday, April 22, 2004 8:21 PM
> To: 'Peter Hesse'; 'Russ Housley'; [email-masked]'
> Subject: RE: RE: Last Call: 'S/MIME Version 3.1 Message 
> Specification' to Proposed Standard 
> 
> In any case, the current path is a non-normative paragraph as 
> Paul suggested, which covers MTA munging in general.

You know what? From section 3.1:

<verbatim>
A single procedure is used for creating MIME entities that are to have
any combination of signing, enveloping and compressing applied. Some
additional steps are recommended to defend against known corruptions
that can occur during mail transport that are of particular importance
for clear- signing using the multipart/signed format. It is
recommended that these additional steps be performed on enveloped
messages, or signed and enveloped messages in order that the message
can be forwarded to any environment without modification.
</verbatim>

I think this is completely adequate and exactly covers the case we're
discussing here.

Blake

---

From: "Tony Capel" <[email-masked]>
Date: Fri, 23 Apr 2004 10:08:11 -0400

I agree with Blake, section 3.1 already notes this problem,
and (as noted by Peter originally) the example in section
3.1.4 already explicitly notes the "From" problem
(and others) as well.

There are two problems with inserting a general recommendation
to solve this problem by making transfer encoding a "should":
1) This is only a problem with clear-signed text (not for opaque or any
encrypted); so if this were a general "should" we may be unnecessarily forcing
transfer encoding (and message expanding) ALL messages.
2) I have found that clear-signing often fails with messages going from one
organization to another and it has not always been clear why.  A better solution
in MHO is to use opaque signing.  Trying to make a list of all the potential
corruption cases and specifying transfer encoding for each case may be a
formative task - and I am not sure we would get every case - that is, I don't
think MSG is the place to be definitive about this (leaving it as an example as
per 3.1.4 is fine).

So I would suggest leaving MSG as is.

tony

| -----Original Message-----
| From: [email-masked] 
| [mailto:[email-masked]] On Behalf Of Blake Ramsdell
| Sent: April 22, 2004 11:34 PM
| To: 'Peter Hesse'; 'Russ Housley'; [email-masked]
| Subject: RE: RE: Last Call: 'S/MIME Version 3.1 Message 
| Specification' to Proposed Standard 
| 
| 
| 
| > -----Original Message-----
| > From: Blake Ramsdell [mailto:[email-masked]]
| > Sent: Thursday, April 22, 2004 8:21 PM
| > To: 'Peter Hesse'; 'Russ Housley'; [email-masked]'
| > Subject: RE: RE: Last Call: 'S/MIME Version 3.1 Message 
| > Specification' to Proposed Standard 
| > 
| > In any case, the current path is a non-normative paragraph as
| > Paul suggested, which covers MTA munging in general.
| 
| You know what? From section 3.1:
| 
| <verbatim>
| A single procedure is used for creating MIME entities that 
| are to have any combination of signing, enveloping and 
| compressing applied. Some additional steps are recommended to 
| defend against known corruptions that can occur during mail 
| transport that are of particular importance for clear- 
| signing using the multipart/signed format. It is recommended 
| that these additional steps be performed on enveloped 
| messages, or signed and enveloped messages in order that the 
| message can be forwarded to any environment without 
| modification. </verbatim>
| 
| I think this is completely adequate and exactly covers the 
| case we're discussing here.
| 
| Blake
|

---

From: "Sean P. Turner" <[email-masked]>
Date: Fri, 23 Apr 2004 10:28:26 -0400

I agree if it's already covered then we ought to leave MSG alone.

spt

---

From: "Peter Hesse" <[email-masked]>
Date: Fri, 23 Apr 2004 11:01:24 -0400

Tony Capel wrote:
> 2) I have found that clear-signing often fails with messages going from
> one organization to another and it has not always been clear why.

I can give you a good reason why: certain Microsoft mail applications (i.e.
Outlook) make no effort to escape "From" if it appears on the beginning of a
line.  However, when that message leaves the organization and lands at a
*NIX mail server, the mail server is inserting the ">" because of settings
in Sendmail or Exim.

My experience has been that non-MS mail applications (Netscape Messenger,
Thunderbird, Eudora) do a good job of escaping "From" when sending.  MS
Exchange has no option to escape "From" upon receipt.

I agree with Blake that there is already a recommendation in the document
that "additional steps are recommended to defend against known corruptions
that can occur during mail transport that are of particular importance
for clear- signing using the multipart/signed format."  I also
want people to understand that this is a prevalent problem, and anything we
can add to reduce the likelihood of occurence is a good thing.  The
suggestion to use quoted-printable encoding for messages which have "From"
in the beginning of the line appears nowhere other than the sample message
in 3.1.4--which is easily ignored.

Thanks,

--Peter

+---------------------------------------------------------------+
| Peter Hesse                    [email-masked]     |
| Phone: (703)934-2031         Gemini Security Solutions, Inc.  |
| ICQ: 1942828                     www.geminisecurity.com       |
+---------------------------------------------------------------+
"Pay no attention to what the critics say; there has never been
a statue set up in honor of a critic." --Jean Sibelius

---

From: Eric Norman <[email-masked]>
Date: Fri, 23 Apr 2004 16:56:48 -0500 (CDT)

> in 3.1.4--which is easily ignored.

While I can't argue against the idea of escaping mechanisms to prevent
clear-signed messages from being mangled, I do wonder how the authors
of such non-compliant software will get an incentive to repair their
code.  Actually, I also wonder if they would even be made aware that
there's a problem since a symptom of the problem (signature failure)
is being hidden from all parties.

Anyway, I'll also add two more examples of mangling that some of us
have discovered.

(1) When Microsoft software prepares a message for clear signing,
the MIME header on the text part is a continued line that starts
with a tab character.  Some mailing list software thinks it's OK
to change that tab to 8 spaces.

(2) We have also found mailing list software that thinks it's OK
to insert a third part in a multipart/signed message as a footer
for the message.

Eric Norman

	"Congress shall make no law restricting the size of integers
	that may be multiplied together, or the number of times that
	an integer may be multiplied by itself, or the modulus by
	which an integer may be reduced".