Subject: [smime] [Editorial Errata Reported] RFC3394 (3358)

From: RFC Errata System <[email-masked]>
Date: Mon, 17 Sep 2012 20:24:27 -0700 (PDT)

The following errata report has been submitted for RFC3394,
"Advanced Encryption Standard (AES) Key Wrap Algorithm".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=3394&eid=3358

--------------------------------------
Type: Editorial
Reported by: Dwayne Litzenberger <[email-masked]>

Section: 2.2.1

Original Text
-------------
   3) Output the results.

       Set C[0] = A[t]
       For i = 1 to n
           C[i] = R[t][i]

Corrected Text
--------------
   3) Output the results.

       Set C[0] = A[t]
       For i = 1 to n
           C[i] = R[s][i], where s = 6n

Notes
-----

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC3394 (draft-ietf-smime-aes-keywrap-00)
--------------------------------------
Title               : Advanced Encryption Standard (AES) Key Wrap Algorithm
Publication Date    : September 2002
Author(s)           : J. Schaad, R. Housley
Category            : INFORMATIONAL
Source              : S/MIME Mail Security
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: "Jim Schaad" <[email-masked]>
Date: Wed, 19 Sep 2012 08:41:31 -0700

As it stands I would say that this errata needs to be rejected.

I accept the basic premise of the errata, that when you start step 3 the
value of t might not be well defined, however

1.  the value of s is well defined and therefore does not need to be
redefined, and 
2. the value of t needs to be replaced with s in both locations that it
occurs.

Jim

> -----Original Message-----
> From: RFC Errata System [mailto:[email-masked]]
> Sent: Monday, September 17, 2012 8:24 PM
> To: [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: [Editorial Errata Reported] RFC3394 (3358)
> 
>

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 19 Sep 2012 11:10:49 -0700

> 2. the value of t needs to be replaced with s in both locations that it

So, you have an alternate errata to propose?

--Paul Hoffman

---

From: "Jim Schaad" <[email-masked]>
Date: Wed, 19 Sep 2012 20:29:47 -0700

I would make it

Corrected Text
--------------
   3) Output the results.

       Set C[0] = A[s]
       For i = 1 to n
           C[i] = R[s][i]

> From: Paul Hoffman [mailto:[email-masked]]
> Sent: Wednesday, September 19, 2012 11:11 AM
> To: Jim Schaad
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [Editorial Errata Reported] RFC3394 (3358)
> 
> > I accept the basic premise of the errata, that when you start step 3
> > the value of t might not be well defined, however
> >
> > redefined, and 2. the value of t needs to be replaced with s in both
> > locations that it occurs.
>

---

From: Dwayne Litzenberger <[email-masked]>
Date: Wed, 19 Sep 2012 23:25:45 -0700

Oh, good catch.  I saw R[t] but missed A[t].  Sorry about that.

-- 
Dwayne C. Litzenberger <[email-masked]>
  OpenPGP: 19E1 1FE8 B3CF F273 ED17  4A24 928C EC13 39C2 5CF7