Subject: [smime] [Technical Errata Reported] RFC2631 (5897)

From: RFC Errata System <[email-masked]>
Date: Thu, 7 Nov 2019 14:04:01 -0800 (PST)

The following errata report has been submitted for RFC2631,
"Diffie-Hellman Key Agreement Method".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid5897

--------------------------------------
Type: Technical
Reported by: Russ Housley <[email-masked]>

Section: 2.1.2

Original Text
-------------
     KeySpecificInfo ::= SEQUENCE {
       algorithm OBJECT IDENTIFIER,
       counter OCTET STRING SIZE (4..4) }

Corrected Text
--------------
     KeySpecificInfo ::= SEQUENCE {
       algorithm OBJECT IDENTIFIER,
       counter OCTET STRING (SIZE (4..4)) }

Notes
-----
The addition of '(' and ')' are needed for an ASN.1 compiler to accept the syntax without raising an error.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC2631 (draft-ietf-smime-x942-07)
--------------------------------------
Title               : Diffie-Hellman Key Agreement Method
Publication Date    : June 1999
Author(s)           : E. Rescorla
Category            : PROPOSED STANDARD
Source              : S/MIME Mail Security
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Cullen Jennings <[email-masked]>
Date: Thu, 7 Nov 2019 14:21:22 -0800

I reviewed this and believe this errata is correct and should be approved. 

> On Nov 7, 2019, at 2:04 PM, RFC Errata System <[email-masked]> wrote:
> 
> _______________________________________________
> smime mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/smime

---

From: Sean Turner <[email-masked]>
Date: Tue, 19 Nov 2019 13:36:36 +0800

+1

> On Nov 8, 2019, at 06:21, Cullen Jennings <[email-masked]> wrote:
> 
>