Subject: [smime] [Editorial Errata Reported] RFC3058 (5913)

From: RFC Errata System <[email-masked]>
Date: Mon, 18 Nov 2019 19:47:59 -0800 (PST)

The following errata report has been submitted for RFC3058,
"Use of the IDEA Encryption Algorithm in CMS".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid5913

--------------------------------------
Type: Editorial
Reported by: Russ Housley <[email-masked]>

Section: 2

Original Text
-------------
     IDEA-CBC OBJECT IDENTIFIER
       ::= { iso(1) identified-organization(3)
           usdod(6) oid(1) private(4) enterprises(1)
           ascom(188) systec(7) security(1) algorithms(1) 2 }

Corrected Text
--------------
     id-IDEA-CBC OBJECT IDENTIFIER
       ::= { iso(1) identified-organization(3)
           usdod(6) oid(1) private(4) enterprises(1)
           ascom(188) systec(7) security(1) algorithms(1) 2 }

Notes
-----
ASN.1 requires that such an identifier begin with a lower case letter.  The prefix of "id-" is a common approach to meeting this requirement for an OBJECT IDENTIFIER.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC3058 (draft-ietf-smime-idea-08)
--------------------------------------
Title               : Use of the IDEA Encryption Algorithm in CMS
Publication Date    : February 2001
Author(s)           : S. Teiwes, P. Hartmann, D. Kuenzi
Category            : INFORMATIONAL
Source              : S/MIME Mail Security
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Sean Turner <[email-masked]>
Date: Tue, 19 Nov 2019 14:05:15 +0800

There are other protocols that specify a cipher suite for IBEA-CBC (e.g., TLS, IPSec), but they do not use this OID.  Further, I can’t find anyplace where the string “IDEA-CBC” would have been imported (PKCS#1/8/11/12) and I can’t find an example of where they were. So, I reviewed this and believe this errata is correct and should be approved. 

spt

> On Nov 19, 2019, at 11:47, RFC Errata System <[email-masked]> wrote:
> 
> _______________________________________________
> smime mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/smime