Subject: [smime] [Technical Errata Reported] RFC2631 (6302)

From: RFC Errata System <[email-masked]>
Date: Wed, 7 Oct 2020 01:35:21 -0700 (PDT)

The following errata report has been submitted for RFC2631,
"Diffie-Hellman Key Agreement Method".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6302

--------------------------------------
Type: Technical
Reported by: Abdullah Talayhan <[email-masked]>

Section: 2.2.1.1

Original Text
-------------
3. Set N’= L/1024

Corrected Text
--------------
3. Set N = L/1024

Notes
-----
The definition of N' is not used in the document. On line 19 of the algorithm, we have "If counter < (4096 * N) then go to 8.". Hence, either the definition on line 3 has to be N instead of N', or it should be N' instead of N on line 19.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC2631 (draft-ietf-smime-x942-07)
--------------------------------------
Title               : Diffie-Hellman Key Agreement Method
Publication Date    : June 1999
Author(s)           : E. Rescorla
Category            : PROPOSED STANDARD
Source              : S/MIME Mail Security
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Russ Housley <[email-masked]>
Date: Wed, 7 Oct 2020 09:47:49 -0400

This looks correct to me.

Russ

> On Oct 7, 2020, at 4:35 AM, RFC Errata System <[email-masked]> wrote:
> 
> _______________________________________________
> smime mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/smime