Subject: RE: relationship of snmpconf to midcom?

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Sun, 7 Jan 2001 21:50:02 +0100

Comments inline

> ----------
> From: 	Randy Presuhn[SMTP:[email-masked]]
> Reply To: 	[email-masked]
> Sent: 	Saturday, January 06, 2001 1:15 AM
> To: 	[email-masked]
> Subject: 	relationship of snmpconf to midcom?
> 
> Hi -
> 
> Does anyone know how this relates to the snmpconf work?
> 
> > Message-Id: <[email-masked]>
> > From: The IESG <[email-masked]>
> > To: IETF-Announce: ;
> > Subject: WG Review: Middlebox Communication (midcom)
> > Date: Fri, 05 Jan 2001 15:54:08 -0500
> > Sender: [email-masked]
> > Status: RO
> > 
> > A new IETF working group has been proposed in the Transport Area.
> > The IESG has not made any determination as yet. 
> > 
> > The following Description was submitted, and is provided for
> > informational purposes only:
> > 
> > Middlebox Communication (midcom)
> > --------------------------------
> 
<.... snip ...>
> > 
> > The focus of the working group will be the architectural framework and 
> > the requirements for the protocol between the requesting device and the 
> > middle box and the architectural framework for the interface between the
> 
> > middle box and the policy entity.  In both cases we intend to reuse 
> > existing or in process IETF protocols if possible.
> >
at this point it did list examples of IETF protocols.... SNMP was not there
and I suggested that SNMP could be used as well, in addition to probably
quite a few others. So... as to not "direct" the architectural and
requirements
work into a specific direction, we (IESG) changed it to not list any
specific
protocol for this phase of the charter.
<... snip ...>
> > 
> > Discovery of middle boxes is out of scope.
> > 
> > The deliverables will be
> > 
> > o a document specifying the architecture and interfaces on
> > 
> >   . a requesting entity
> > 
> >   . a middle box
> > 
> > o a document the requirements for both the
> >   architecture and the control language
> > 
> > o a document describing the requirements for a policy enity
> > 
> > Once these deliverables are complete, the Area Directors will decide if 
> > the working group should be rechartered.  If rechartered the working 
> > group could undertake protocol development  or development of profiles 
> > of existing protocols.
> ...
> 
And at this point, it might be good for SNMP and/or SNMPCONF folks
to see how we could fit in the architecture and how could meet the
requirements.

Bert (AD hat on)

---

From: Steve Moulton <[email-masked]>
Date: Mon, 08 Jan 2001 10:22:35 -0500

The following message bounced due to an email address change.

------- Forwarded Message

To: [email-masked]
Subject: Re: relationship of snmpconf to midcom? 
From: Jon Saperia <[email-masked]>
In-reply-to: Your message of Fri, 05 Jan 2001 16:15:46 -0800.
             <[email-masked]> 
Date: Sun, 07 Jan 2001 17:18:21 -0500
Sender: [email-masked]

Randy,

Thanks for the note. As near as I can tell it is just another example of
convenient stove pipe engineering. Some of the work looks helpful
(though they probably should talk with the security policy folks), and
some is an unnecessary duplication from what little I know. Any midcom
folks listening that can enlighten us?

Thanks,
/jon
--

Jon Saperia		     [email-masked]
			     Phone: 617-744-1079
			     Fax:   617-249-0874
			     http://www.jdscons.com/

------- End of Forwarded Message