Subject: snmpconf Updated PM MIB draft

From: Steve Waldbusser <[email-masked]>
Date: Thu, 19 Jul 2001 23:51:11 -0700

Here's the next version of the PM ID I'm submitting:

http://www.nextbeacon.com/pmmib/pm.txt

I'll send an email soon describing the changes.

Steve

---

From: Steve Waldbusser <[email-masked]>
Date: Thu, 19 Jul 2001 23:53:41 -0700

Here's the next version of the ID I'm submitting:

Steve

---

From: Steve Waldbusser <[email-masked]>
Date: Tue, 24 Jul 2001 12:58:46 -0700

I continued working on this after my note Thursday and submitted an
updated version. That's available at www.nextbeacon.com/pmmib/pm-07.txt
(the old one is still there as pm.txt if you want to diff).

The changes are:
Thursday-version
Clarified def'n of "address of this element" to include base oid
Clarified confusing uses of the word "context"
clarified derivation of ec() and ev()
Defined no-error return value of subidwrite
Clarified that integer division rounds towards zero
Added relationship to other mibs section
6: Fixed counterRate to have a discontinuity indicator and to work
   with other contexts and off-box
8: Created createRow() function to abstract out createAndWait
   vs. createAndGo RowStatus semantics
15: Added relationships to other MIBs text
18: Deleted capmatch function
18: Replaced capTable with updated table
Changed die() function to fail()
Defined formats of tAddr argument
Added contextEngineID to NonLocalArgs
Noted that createrow only works with integer valued indexes
- Allow integer values to be specified in the form "descriptor(1)" so
  that the code can self-document enumeration values. The descriptor
  text is completely ignored by the function so no MIB knowledge is
  needed.
-   Noted that agents are allowed to terminate a script that exceeds
    a local CPU or memory limitation.
Changed *ProgramIndex object names to *ScriptIndex
Spec'd how to send V1 traps
Updated description of capabilities to correctly describe its reduced
function

Friday version (pm-07.txt)
Used new terminology of "valid", "ready" and "active" and updated text
   throughout with these terms. This allows the text to be more
   accurate while still being readable.
The 0.0 element is now called the "system element"
Deleted pmNotificationRegTable
Policy must now be disabled to change many parameters (such as the
script)
When a policy is re-enabled, all associated scratchpad values will be
  deleted as well as any cached condition return values.
Fixed many typos
Rewrote a few areas of confusing text

Steve