Subject: Re: [Softwires] Softwires configuration via DHCP

From: Francois-Xavier Le Bail <[email-masked]>
Date: Thu, 19 Mar 2009 11:44:22 -0700 (PDT)

--- On Thu, 3/19/09, David W. Hankins <[email-masked]> wrote:

> > The first use case is "Dual-stack lite" but
> the same option can be used for IPv6 in IPv6 tunnels (see
> RFC2473).
> 
> How would a client know which one to configure?  How would
> a server
> know which ones the client supports?
> 
> I think it would work better to have a different option for
> each use
> case scenario ("a different protocol field for every
> OS knob").  The
> client then advertises what configuration values it can use
> (by
> listing any it supports on the Option Request Option).
> 

Agreed.

I suggest to change in the draft the reference from "draft-droms-softwires-snat-01" to the new "draft-ietf-softwire-dual-stack-lite-00".

and to name the option : OPTION_DSLITE.

Francois-Xavier

---

From: "David W. Hankins" <[email-masked]>
Date: Thu, 19 Mar 2009 12:47:01 -0700

> and to name the option : OPTION_DSLITE.

I agree.  I admit I hadn't thought about the name before, but you're
the second person to catch me on the reference mistake, I need to
update that.

Would you object to 'OPTION_DS_LITE'?  I am thinking about this from
how we usually translate RFC option names into configuration parameter
names;

	option dhcp6.dslite foo.example.com;
	option dhcp6.ds-lite foo.example.com;
	option dhcp6.dual-stack-lite foo.example.com;

I'm leaning towards the middle one.

I hope there is no confusion with;

  http://en.wikipedia.org/wiki/Nintendo_DS_Lite

Or perhaps this is an RFC 5241 opportunity?

-- 
David W. Hankins	"If you don't do it right the first time,
Software Engineer		     you'll just have to do it again."
Internet Systems Consortium, Inc.		-- Jack T. Hankins

---

From: Francois-Xavier Le Bail <[email-masked]>
Date: Thu, 19 Mar 2009 13:20:56 -0700 (PDT)

--- On Thu, 3/19/09, David W. Hankins <[email-masked]> wrote:

> Would you object to 'OPTION_DS_LITE'?

This name is OK for me.

Francois-Xavier