Subject: Re: [Softwires] Softwires configuration via DHCP

From: Francois-Xavier Le Bail <[email-masked]>
Date: Thu, 19 Mar 2009 10:34:17 -0700 (PDT)

--- On Thu, 3/19/09, David W. Hankins <[email-masked]> wrote:

> On Thu, Mar 19, 2009 at 01:31:47AM -0700, Francois-Xavier Le
> Bail wrote:
> > I suggest naming the option : OPTION_TUNNEL_ENDPOINT.
> 
> vs OPTION_SOFTWIRES?

Yes.

> Are you suggesting a more open-ended purpose for the
> option?

The first use case is "Dual-stack lite" but the same option can be used for IPv6 in IPv6 tunnels (see RFC2473).

Francois-Xavier

---

From: "David W. Hankins" <[email-masked]>
Date: Thu, 19 Mar 2009 11:10:11 -0700

> The first use case is "Dual-stack lite" but the same option can be used for IPv6 in IPv6 tunnels (see RFC2473).

How would a client know which one to configure?  How would a server
know which ones the client supports?

I think it would work better to have a different option for each use
case scenario ("a different protocol field for every OS knob").  The
client then advertises what configuration values it can use (by
listing any it supports on the Option Request Option).

-- 
David W. Hankins	"If you don't do it right the first time,
Software Engineer		     you'll just have to do it again."
Internet Systems Consortium, Inc.		-- Jack T. Hankins