Subject: [Softwires] [Softwire] Questions on draft-boucadair-dslite-interco-v4v6-03

From: 孙琼 <[email-masked]>
Date: Mon, 22 Mar 2010 22:28:45 +0800

Hi Boucadair,

I'm wondering if I have missed something in this draft. I can understand
that in this extended DS-Lite, ICXF is core stateless and it is quite
scalable for core routers. However,  since CPEs can send both IPv4 packet
and IPv6 packet to AFTR, it will then include double NAT problem if we have
to allocate private IPv4 address to CPEs. Then what is the advantage of this
kind of DS-Lite vs. NAT666 plus dual stack?

Thank you very much.

Best regards

Qiong SUN

---

From: <[email-masked]>
Date: Mon, 22 Mar 2010 19:10:09 +0100

Dear Qiong,

Thank you for reading the ID.

As far as the CPE is concerned, this ID assumes the same behaviour as per DS-Lite architecture documented in draft-ietf-softwire-dual-stack-lite. In particular, no NAT44 is enforced in the CPE and therefore no double NAT would be experienced.

Cheers,
Med

________________________________
De : [email-masked] [mailto:[email-masked]] De la part de ??
Envoyé : lundi 22 mars 2010 15:29
À : [email-masked]
Objet : [Softwires] [Softwire] Questions on draft-boucadair-dslite-interco-v4v6-03

Hi Boucadair,

I'm wondering if I have missed something in this draft. I can understand that in this extended DS-Lite, ICXF is core stateless and it is quite scalable for core routers. However,  since CPEs can send both IPv4 packet and IPv6 packet to AFTR, it will then include double NAT problem if we have to allocate private IPv4 address to CPEs. Then what is the advantage of this kind of DS-Lite vs. NAT666 plus dual stack?

Thank you very much.

Best regards

Qiong SUN

*********************************
This message and any attachments (the "message") are confidential and intended solely for the addressees. 
Any unauthorised use or dissemination is prohibited.
Messages are susceptible to alteration. 
France Telecom Group shall not be liable for the message if altered, changed or falsified.
If you are not the intended addressee of this message, please cancel it immediately and inform the sender.
********************************

---

From: "Lee, Yiu" <[email-masked]>
Date: Mon, 22 Mar 2010 16:03:00 -0400

As Med replied in a different email, the CPE is the B4 in the ds-lite draft
which performs v4-over-v6 tunnel for v4 packets. No NAT-44 will happen in
B4.

On 3/22/10 10:28 AM, "孙琼" <[email-masked]> wrote:

> Hi Boucadair, 
>  
> I'm wondering if I have missed something in this draft. I can understand that
> in this extended DS-Lite, ICXF is core stateless and it is quite scalable for
> core routers. However,  since CPEs can send both IPv4 packet and IPv6 packet
> to AFTR, it will then include double NAT problem if we have to allocate
> private IPv4 address to CPEs. Then what is the advantage of this kind of
> DS-Lite vs. NAT666 plus dual stack?
>  
> Thank you very much.
>  
> Best regards
>  
> Qiong SUN
> 
> 
> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires

---

From: 孙琼 <[email-masked]>
Date: Tue, 23 Mar 2010 09:14:39 +0800

Thank you. I can see that this kind of DS-Lite is good for core network. But
in my consideration, the major problem which might impede the deployment of
DS-Lite is that it has to take control of end-user's CPE. However, in this
case, we not only have to deploy two endpoints, but also the addtional
endpoint of AFTR. And the function of AFTR is a little too complicated,
including double tunnel encapsulation, CGN, CGN-related ALG, etc. So why
does CPE have to locate in IPv6-only environment? Can it possible that CPE
can still send and receive IPv4 packet, while AFTR and ICXF locate in
IPv6-only environment?

Thank you.

Qiong SUN

在 2010年3月23日 上午4:03，Lee, Yiu <[email-masked]>写道：

> scalable for core routers. However, since CPEs can send both IPv4 packet and
> IPv6 packet to AFTR, it will then include double NAT problem if we have to
> allocate private IPv4 address to CPEs. Then what is the advantage of this
> ------------------------------