Subject: [Softwires] Fwd: New Version Notification for draft-arifumi-softwire-dslite-global-addr-00

From: Arifumi Matsumoto <[email-masked]>
Date: Wed, 10 Mar 2010 20:04:15 +0900

Hi,

I submitted a very simple draft.
Any comments are welcome.

http://tools.ietf.org/html/draft-arifumi-softwire-dslite-global-addr-00

Begin forwarded message:

> 差出人: IETF I-D Submission Tool <[email-masked]>
> 日時: 2010年3月2日 09:14:43JST
> 宛先: [email-masked]
> Cc: [email-masked]
> 件名: New Version Notification for draft-arifumi-softwire-dslite-global-addr-00 
> 
> 
> A new version of I-D, draft-arifumi-softwire-dslite-global-addr-00.txt has been successfuly submitted by Arifumi Matsumoto and posted to the IETF repository.
> 
> Filename:	 draft-arifumi-softwire-dslite-global-addr
> Revision:	 00
> Title:		 Global IPv4 Address Configuration Option for DS-Lite
> Creation_date:	 2010-03-02
> WG ID:		 Independent Submission
> Number_of_pages: 6
> 
> Abstract:
> When an ISP tries to deploy IPv6 and take an action for IPv4 address
> depletion, DS-Lite is reasonable approach for solving both of the
> problems.  However, it is troublesome for an ISP to have the existing
> IPv4 service facilities and DS-Lite facilities at the same time for
> not a short period of time.  This document proposes a mechanism to
> assign an IPv4 global address in DS-Lite framework, which makes every
> customer to move to DS-Lite based network, and enables an ISP to
> maintain single facility of the service network.
> 
> 
> 
> The IETF Secretariat.
> 
> 

--
Arifumi Matsumoto
  Secure Communication Project
  NTT Information Sharing Platform Laboratories
  E-mail: [email-masked]

---

From: WashamFan <[email-masked]>
Date: Thu, 11 Mar 2010 15:58:38 +0800

Hi,

Are you sure you are defining a DHCPv4 option? It seems to me
you were intended to define a DHCPv6 option instead.

You said the option defined in the draft could be combined with
options defined in [I-D.ietf-softwire-ds-lite-tunnel-option].
I am not sure how DHCPv4 options combined with DHCPv6 options.

Thanks,
washam

----- Original Message -----
From: Arifumi Matsumoto <[email-masked]>
Date: Wednesday, March 10, 2010 7:04 pm
Subject: [Softwires] Fwd: New Version Notification for draft-arifumi-softwire-dslite-global-addr-00
To: [email-masked]

>  > 件名: New Version Notification for 
> draft-arifumi-softwire-dslite-global-addr-00 
>  > 
>  > 
>  > A new version of I-D, 
> draft-arifumi-softwire-dslite-global-addr-00.txt has been successfuly 
> submitted by Arifumi Matsumoto and posted to the IETF repository.
>  > 
>  _______________________________________________
>  Softwires mailing list
>  [email-masked]
>  https://www.ietf.org/mailman/listinfo/softwires
>

---

From: Arifumi Matsumoto <[email-masked]>
Date: Thu, 11 Mar 2010 18:21:29 +0900

Hi,

> you were intended to define a DHCPv6 option instead.

I think both ways are possible.

If defining DHCPv4 option, the router should request DHCPv4
messages in the configured IPv6 tunnel.

If defining DHCPv6 option, the router should have an global 
IPv4 address as well as IPv6 tunnel endpoint address at the
same time, and should configure IPv6 tunnel and attach IPv4
global address to it.

In the former case, the router has to decide whether it uses
IPv4 global address or not by the reply from the DHCPv4 server
that may not exist in the network. It may bring up implementation
difficulty and also timing issue.

So, as you suggest, it may be better to use DHCPv6.

Kindest regards,

---

From: WashamFan <[email-masked]>
Date: Thu, 11 Mar 2010 17:42:17 +0800

Hi,

>  messages in the configured IPv6 tunnel.

In that way, we can use DHCPv4 as is, no additional options
need inventing.

>  difficulty and also timing issue.

Yes. DS-Lite avoids IPv4 provision in the SP network, so it is hard
for us to assume a DHCPv4 server would be there.
  
>  So, as you suggest, it may be better to use DHCPv6.

;-)

Thanks,
washam

---

From: "Lee, Yiu" <[email-masked]>
Date: Fri, 12 Mar 2010 13:34:09 -0500

Hi Arifumi,

I tried to understand the rationale of this draft. So, are you thinking
there is a scenario where a customer is on a DS-lite access network but the
ISP still want to give him public v4 access? So the AFTR won't need to
perform NAT-44 function for this customer?

Thanks,
Yiu

On 3/10/10 6:04 AM, "Arifumi Matsumoto" <[email-masked]> wrote:

>> A new version of I-D, draft-arifumi-softwire-dslite-global-addr-00.txt has
>> been successfuly submitted by Arifumi Matsumoto and posted to the IETF
>> repository.
>>