Subject: Re: [Softwires] DNS question about DS-lite

From: [email-masked]
Date: Mon, 31 May 2010 10:38:03 +0800

Hi,

Yes, DNS server in the ISP must be able to resolve all the A and AAAA records. Does DS-lite require dual stack DNS server(s), i.e. DNS server(s) with both IPv4 and IPv6 addresses, be deployed in the ISP's network? Dual stack DNS server(s) needs to connect the DNS system in the IPv6-only network and that in the IPv4-only Internet.

Best Regards,
--------------------------------------------------------------------------------
Zhenqiang Li
13911635816
Department of Network Technology
China Mobile Research Institute
2010-05-31

--------------------------------------------------------------------------------

发件人： Lee, Yiu
发送时间： 2010-05-26 22:33:25
收件人： [email-masked]; Durand, Alain; [email-masked]
抄送： 
主题： Re: [Softwires] DNS question about DS-lite

The B4 element contains a DNS proxy that will support DNS over v4 and proxy
the DNS messages to the DNS server over v6 in the ISP network. The DNS
server in the ISP must be able to resolve all the A and AAAA records.

On 5/26/10 5:26 AM, "[email-masked]"
<[email-masked] > wrote:

> Hi Alain,
>     I have one question about DS-lite. Would you please clearify it? Thanks.
>  
>     In your draft, you mention the B4 element  can only get the IPv6 address
> of  a DNS recursive  server, and as such will have to perform  all DNS
> resolution over IPv6. I want to know whether the DNS server can resolve all
> IPv4 nodes over IPv6 successfully. And how? Is it necessary that the type A
> DNS query packet travels through AFTR? Is there any requirement for the DNS
> server in the ISP core network?
>       
> Best Regards,
> ------------------------------------
> Zhenqiang Li
> 13911635816
> Department of Network Technology
> China Mobile Research Institute
> 2010-05-26
> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires

---

From: "Lee, Yiu" <[email-masked]>
Date: Sun, 30 May 2010 22:45:33 -0400

No. DS-lite doesn't require dual-stack DNS server. It needs normal DNS
server running in the IPv6 network, and B4 proxies the v4 request over v6.

I want to echo Med's comment in his previous email. It is not recommended to
use AFTR to reach DNS server over v4 even thought it is possible. This will
increase the AFTR load for obvious reason.

> Hi,

Yes, DNS server in the ISP must be able to resolve all the A and AAAA
> records. Does DS-lite require dual stack DNS server(s), i.e. DNS server(s)
> with both IPv4 and IPv6 addresses, be deployed in the ISP's network? Dual
> stack DNS server(s) needs to connect the DNS system in the IPv6-only network
> and that in the IPv4-only Internet.

Best
> Regards,
---------------------------------------------------------------------
> -----------
Zhenqiang Li
13911635816
China
> Mobile Research 
> Institute
2010-05-31

--------------------------------------------------------
> ------------------------

发件人： Lee, Yiu
收件人：
> [email-masked]; Durand, Alain; [email-masked]
抄送： 
主题： Re:
> [Softwires] DNS question about DS-lite

The B4 element contains a DNS proxy
> that will support DNS over v4 and proxy
the DNS messages to the DNS server
> over v6 in the ISP network. The DNS
server in the ISP must be able to resolve
> all the A and AAAA records.

On 5/26/10 5:26 AM,
> "[email-masked]"
<[email-masked] > wrote:

> Hi
> Alain,
______________________________
> _________________
Softwires mailing
> list
[email-masked]