Subject: [Softwires] I-D Action:draft-ietf-softwire-ipv6-6rd-09.txt

From: [email-masked]
Date: Thu, 6 May 2010 01:30:02 -0700 (PDT)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Softwires Working Group of the IETF.

	Title           : IPv6 via IPv4 Service Provider Networks "6rd"
	Author(s)       : M. Townsley, O. Troan
	Filename        : draft-ietf-softwire-ipv6-6rd-09.txt
	Pages           : 19
	Date            : 2010-05-06

This document specifies an automatic tunneling mechanism tailored to
advance deployment of IPv6 to end users via a Service Provider's IPv4
network infrastructure.  Key aspects include automatic IPv6 prefix
delegation to sites, stateless operation, simple provisioning, and
service which is equivalent to native IPv6 at the sites which are
served by the mechanism.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-softwire-ipv6-6rd-09.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Mark Townsley <[email-masked]>
Date: Thu, 06 May 2010 10:38:32 +0200

FYI: This was an idnits-related update prior to passage to the IESG.

- Mark

On 5/6/10 10:30 AM, [email-masked] wrote:
> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires

---

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 6 May 2010 07:52:14 -0700

Mark,

Not sure whether any changes are necessary, but in terms
of MTU the tunnel should try for more than 1280 if possible.
Otherwise, it may be difficult to configure other tunnels
(VPNs, etc.) over the 6rd tunnel.

Thanks - Fred
[email-masked]

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Mark Townsley
> Sent: Thursday, May 06, 2010 1:39 AM
> To: softwires
> Subject: Re: [Softwires] I-D Action:draft-ietf-softwire-ipv6-6rd-09.txt
> 
>

---

From: Mark Townsley <[email-masked]>
Date: Thu, 06 May 2010 17:29:00 +0200

On 5/6/10 4:52 PM, Templin, Fred L wrote:
> Mark,
> 
> Not sure whether any changes are necessary, 

Great. We have a whole section on MTU.

> but in terms

Yes, that may be a problem with 1280. In general.

- Mrak

---

From: Rémi Després <[email-masked]>
Date: Fri, 7 May 2010 18:20:09 +0200

Hi Fred,

> Not sure whether any changes are necessary,

AKAIKT, ll changes that were agreed in Anaheim are now in the document, so that it can proceed.

> of MTU the tunnel should try for more than 1280 if possible.

Right.
And this is in fact implied by the current text:
 
  "the 6rd Tunnel MTU should be set to the known IPv4
   MTU minus the size of the encapsulating IPv4 header (20 bytes)"

Since ISPs know in general that they support IPv4 MTUs well beyond 1300, they should tunnel MTUs to well beyond 1280.

It is only "Absent of more specific information" that "the 6rd Tunnel MTU SHOULD default to 1280 bytes."

Regards,
RD

---

From: "Templin, Fred L" <[email-masked]>
Date: Fri, 7 May 2010 09:51:32 -0700

Hi Remi,

> From: Rémi Després [mailto:[email-masked]]
> Sent: Friday, May 07, 2010 9:20 AM
> To: Templin, Fred L
> Cc: Mark Townsley; softwires

You tend to cut out important parts of messages. The high
order consideration is the following:

+ Otherwise, it may be difficult to configure other tunnels
+ (VPNs, etc.) over the 6rd tunnel.

This point is in fact the sole reason for my post. Any device
within a 6rd site that would like to configure a VPN or other
tunnel that connects to a device outside the site is dependent
on the 6rd router setting a sufficiently large MTU on its
tunnel interface.

>    MTU minus the size of the encapsulating IPv4 header (20 bytes)"

No problem there.

> It is only "Absent of more specific information" that "the 6rd Tunnel MTU SHOULD default to 1280

If 6rd router implementations take the overly conservative
route suggested above and turn the configuration knob all
the way down to 1280, devices inside the site that wish to
configure tunnels that leave the site will see a path MTU
that would result in either failure to configure the tunnel
or the need for inner IP fragmentation - both undesirable
results.

Fred

---

From: Rémi Després <[email-masked]>
Date: Fri, 7 May 2010 22:12:20 +0200

> + (VPNs, etc.) over the 6rd tunnel.

Please consider that, since I explicitly did agree with what you said, I didn't find it necessary to repeat WHY you said it.

Sorry that read from you that I "tend to tend to cut out important parts of messages".
This is NOT my approach to debates (which I strive to keep useful).

> This point is in fact the sole reason for my post.

I was aware of this, and found it pertinent.

RD

> Any device

---

From: "Templin, Fred L" <[email-masked]>
Date: Fri, 7 May 2010 13:25:24 -0700

Remi,

> Sent: Friday, May 07, 2010 1:12 PM
> To: Templin, Fred L
> Cc: Softwires

Thanks for clarifications. If we are to work together to
help each other's understanding (which is my desire) then
continued open communications will be appreciated.

Fred
 
> >> Since ISPs know in general that they support IPv4 MTUs well beyond 1300, they should tunnel MTUs
> to
> >> well beyond 1280.
> >>