Subject: Re: [Softwires] I-D Action:draft-despres-softwire-sam-00.txt

From: Ruri Hiromi <[email-masked]>
Date: Thu, 13 May 2010 11:42:21 +0900

Hello,

Let me confirm about 2 description.

1) Section 2.5, Fragmentation Considerations

 For "If the exterior locator family of a SAM domain is IPv4" case, you mentioned as "having the "Don't Fragment" bit set to 1 may either be discarded (with appropriate ICMPv6 error message returned to the source).  Is this(ICMPv6 error) correct way?  I suppose this might be ICMP error message and not ICMPv6.

2) Section 3.2.2, Multiple IPv4 Prefixes

 In this section, you described as "Since there are 3 domain exterior prefixes Dn, we have to choose 3 customer interior prefixes P, the lengths of each Cn must be such that k + cn + xn = 48, i.e. cn = 20...". But I suppose P = K[.H] is used here and the "Cn" is replaced for "Hn". Am I missed something?

Regards,

On 2010/03/02, at 3:30, [email-masked] wrote:

> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 	Title           : Stateless Address Mapping (SAM) for Softwire-Lite Solutions
> 	Author(s)       : R. Despres
> 	Filename        : draft-despres-softwire-sam-00.txt
> 	Pages           : 33
> 	Date            : 2010-03-01
> 
> Stateless Address Mapping (SAM) is a generic mechanism which permits,
> in a number of new scenarios, to easily establish tunnels for packets
> of some address family to traverse domains where this family is not
> directly routed (softwires).  It generalizes address mapping
> principles of already deployed technologies such as 6to4, ISATAP, and
> 6rd, where encapsulations of IP over IP are used for point-to-
> multipoint tunnels (mesh softwires).
> 
> Identified use cases of SAM include native IPv6 across IPv4 NATs,
> IPv6 multihoming with provider-aggregatable prefixes, public IPv4
> across IPv6-only domains and, to mitigate consequences of the IPv4
> address shortage, extended IPv4 prefixes for statically shared IPv4
> public addresses.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-despres-softwire-sam-00.txt
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> <メールの添付ファイル>_______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

-------------------------------
Ruri Hiromi
INTEC Systems Institute, Inc. / Keio university
[email-masked] >>>> [email-masked]

---

From: Rémi Després <[email-masked]>
Date: Mon, 17 May 2010 08:59:01 +0200

Hello Ruri,

Le 13 mai 2010 à 04:42, Ruri Hiromi a écrit :
> ...

Right.
Thank you for noting this mistake.

> In this section, you described as "Since there are 3 domain exterior prefixes Dn, we have to choose 3 customer interior prefixes P, the lengths of each Cn must be such that k + cn + xn = 48, i.e. c…

No, you are right.
Thank you again.

The correct text is:
 Since there are 3 domain exterior prefixes Dn, we have to choose 3
 domain-exterior-prefix codes Hn.  Supposing we want to assign /48s as
 customer interior prefixes P, the length of each Hn must be such that
 that k + hn + xn = 48, i.e. hn = 20 - xn, i.e. h1 = 2, h2 = h3 = 3.
 The Hn having to be non-overlapping prefixes, with otherwise
 arbitrary values, we chose binary values H1 = 00, H2 = 010, and H3 =
 011.

Kind regards,
RD