Subject: Re: [Softwires] DNS question about DS-lite

From: "Lee, Yiu" <[email-masked]>
Date: Thu, 27 May 2010 12:30:34 -0400

Agreed that there is no v4 dns server option (probably never will be)  
defined on dhcpv6. If the host doesnt want to statically configure the  
v4 dns server, in theory, the B4 could send a dhcpv4 dns request over  
the tunnel and the AFTR would relay it to a dhcpv4 server. But you can  
see, this is overkilled. The more sensible way is to implement dns  
proxy in B4.

On May 27, 2010, at 11:55 AM, "Jacni Qin" <[email-masked]> wrote:

>
> On Thu, May 27, 2010 at 1:00 AM, Lee, Yiu  
> <[email-masked]> wrote:
>
> If the B4 is in the host, the B4 implementation should be able to  
> proxy the v4 DNS request over v6. Or B4 tunnels the DNS message and  
> sends to a v4 DNS server (less desirable).
>
> -- while as mentioned in the draft, currently there is no option  
> defined for passing the v4 DNS server address to hosts.
> and for the DNS proxy case, do you mean if the OS doesn't support  
> DNS request over v6, we should then provider a patch for this  
> function along with the B4 implementation?
>
> thanks,
>
>
>
> On 5/26/10 12:47 PM, "Jacni Qin" <[email-masked]> wrote:
>
> another question,
>
> for the host scenario(with DS-Lite software installed), what if the  
> operating system can not send DNS query over IPv6?
> i'm sorry if i missed some discussion on this before.
>
> many thanks,
>
> Jacni
>
> On Wed, May 26, 2010 at 10:33 PM, Lee, Yiu  
> <[email-masked]> wrote:
> The B4 element contains a DNS proxy that will support DNS over v4  
> and proxy
> the DNS messages to the DNS server over v6 in the ISP network. The DNS
> server in the ISP must be able to resolve all the A and AAAA records.
>
>
> On 5/26/10 5:26 AM, "[email-masked]"
> <[email-masked]> wrote:
>
> > Hi Alain,
> >     I have one question about DS-lite. Would you please clearify  
> it? Thanks.
> >
> >     In your draft, you mention the B4 element  can only get the  
> IPv6 address
> > of  a DNS recursive  server, and as such will have to perform  all  
> DNS
> > resolution over IPv6. I want to know whether the DNS server can  
> resolve all
> > IPv4 nodes over IPv6 successfully. And how? Is it necessary that  
> the type A
> > DNS query packet travels through AFTR? Is there any requirement  
> for the DNS
> > server in the ISP core network?
> >
> > Best Regards,
> > ------------------------------------
> > Zhenqiang Li
> > 13911635816
> > Department of Network Technology
> > China Mobile Research Institute
> > 2010-05-26
> > _______________________________________________
> > Softwires mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/softwires
>
> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires
>
>
>
>

---

From: Jacni Qin <[email-masked]>
Date: Sun, 30 May 2010 15:57:02 +0800

i agree with you that dns proxy over v6 in B4 should be preferred,

while we should mention this special case in the draft, because this will be
not so special
if many hosts running that kind of OS still exist at the time when we start
to implement DS-Lite.
and the recommendations for dealing with this case may be also included.

regards,
Jacni

On Fri, May 28, 2010 at 12:30 AM, Lee, Yiu <[email-masked]>wrote:

> defined on dhcpv6. If the host doesnt want to statically configure the v4
> dns server, in theory, the B4 could send a dhcpv4 dns request over the
> tunnel and the AFTR would relay it to a dhcpv4 server. But you can see, this
> is overkilled. The more sensible way is to implement dns proxy in B4.
>
>
> On May 27, 2010, at 11:55 AM, "Jacni Qin" < <[email-masked]>
> [email-masked]> wrote:
>
>
> On Thu, May 27, 2010 at 1:00 AM, Lee, Yiu < <[email-masked]><[email-masked]>
> [email-masked]> wrote:
>
>>
>> If the B4 is in the host, the B4 implementation should be able to proxy
>> the v4 DNS request over v6. Or B4 tunnels the DNS message and sends to a v4
>> DNS server (less desirable).
>>
>
> -- while as mentioned in the draft, currently there is no option defined
> for passing the v4 DNS server address to hosts.
> and for the DNS proxy case, do you mean if the OS doesn't support DNS
> request over v6, we should then provider a patch for this function along
> with the B4 implementation?
>
> thanks,
>
>
>>
>>
>> On 5/26/10 12:47 PM, "Jacni Qin" < <http://[email-masked]><[email-masked]>
>> [email-masked]> wrote:
>>
>> another question,
>>
>> On Wed, May 26, 2010 at 10:33 PM, Lee, Yiu <<http://[email-masked]><[email-masked]>
>> [email-masked]> wrote:
>>
>> The B4 element contains a DNS proxy that will support DNS over v4 and
>> proxy
>> On 5/26/10 5:26 AM, " <http://[email-masked]><[email-masked]>
>> [email-masked]"
>> < <http://[email-masked]> <[email-masked]>
>> [email-masked]> wrote:
>>
>> > Hi Alain,
>> >     I have one question about DS-lite. Would you please clearify it?
>> Thanks.
>> >
>> >     In your draft, you mention the B4 element  can only get the IPv6
>> address
>> > of  a DNS recursive  server, and as such will have to perform  all DNS
>> > resolution over IPv6. I want to know whether the DNS server can resolve
>> all
>> > IPv4 nodes over IPv6 successfully. And how? Is it necessary that the
>> type A
>> > DNS query packet travels through AFTR? Is there any requirement for the
>> DNS
>> > <http://[email-masked]> <[email-masked]>[email-masked]
>> > <https://www.ietf.org/mailman/listinfo/softwires><https://www.ietf.org/mailman/listinfo/softwires>
>>  <http://[email-masked]> <[email-masked]>[email-masked]
>>  <https://www.ietf.org/mailman/listinfo/softwires><https://www.ietf.org/mailman/listinfo/softwires>

---

From: "Lee, Yiu" <[email-masked]>
Date: Sun, 30 May 2010 10:50:12 -0400

Ok. We did mention this in the draft, but it seems you found it unclear. I
will work with Alain to clarify the text. Thanks for the comments!

On 5/30/10 3:57 AM, "Jacni Qin" <[email-masked]> wrote:

> if many hosts running that kind of OS still exist at the time when we start to
> implement DS-Lite.
> On Fri, May 28, 2010 at 12:30 AM, Lee, Yiu <[email-masked]> wrote:
>> Agreed that there is no v4 dns server option (probably never will be) defined
>> on dhcpv6. If the host doesnt want to statically configure the v4 dns server,
>> in theory, the B4 could send a dhcpv4 dns request over the tunnel and the
>> AFTR would relay it to a dhcpv4 server. But you can see, this is overkilled.
>> The more sensible way is to implement dns proxy in B4.  
>> 
>> 
>> On May 27, 2010, at 11:55 AM, "Jacni Qin" < <mailto:[email-masked]>
>> [email-masked]> wrote:
>> 
>>> 
>>> On Thu, May 27, 2010 at 1:00 AM, Lee, Yiu <
>>> <mailto:[email-masked]>  <mailto:[email-masked]>
>>>> If the B4 is in the host, the B4 implementation should be able to proxy the
>>>> v4 DNS request over v6. Or B4 tunnels the DNS message and sends to a v4 DNS
>>>> server (less desirable).
>>>  
>>> -- while as mentioned in the draft, currently there is no option defined for
>>> passing the v4 DNS server address to hosts.
>>>> On 5/26/10 12:47 PM, "Jacni Qin" < <http://[email-masked]>
>>>> <mailto:[email-masked]> [email-masked]> wrote:
>>>> 
>>>>> another question,
>>>>> 
>>>>> On Wed, May 26, 2010 at 10:33 PM, Lee, Yiu <
>>>>> <http://[email-masked]>  <mailto:[email-masked]>
>>>>>> On 5/26/10 5:26 AM, " <http://[email-masked]>
>>>>>> <mailto:[email-masked]> [email-masked]"
>>>>>> < <http://[email-masked]>
>>>>>> <mailto:[email-masked]> [email-masked]> wrote:
>>>>>> 
>>>>>>> > Hi Alain,
>>>>>>> > DNS query packet travels through AFTR? Is there any requirement for
>>>>>>> the DNS
>>>>>>> >  <http://[email-masked]>  <mailto:[email-masked]>
>>>>>>> [email-masked]
>>>>>>> >  <https://www.ietf.org/mailman/listinfo/softwires>
>>>>>>> <https://www.ietf.org/mailman/listinfo/softwires>
>>>>>>  <http://[email-masked]>  <mailto:[email-masked]>
>>>>>> [email-masked]
>>>>>>  <https://www.ietf.org/mailman/listinfo/softwires>
>>>>>> <https://www.ietf.org/mailman/listinfo/softwires>

---

From: Jacni Qin <[email-masked]>
Date: Mon, 31 May 2010 01:21:24 +0800

ok,
or just simply add a statement somewhere like, dual stack hosts that can not
send dns query over v6 are
also out of scope.
;-)

On Sun, May 30, 2010 at 10:50 PM, Lee, Yiu <[email-masked]>wrote:

>  Ok. We did mention this in the draft, but it seems you found it unclear.
> I will work with Alain to clarify the text. Thanks for the comments!
>
>
>
> while we should mention this special case in the draft, because this will
> be not so special