Subject: [Softwires] DNS question about DS-lite

From: [email-masked]
Date: Wed, 26 May 2010 17:26:50 +0800

Hi Alain,
    I have one question about DS-lite. Would you please clearify it? Thanks.
 
    In your draft, you mention the B4 element  can only get the IPv6 address of  a DNS recursive  server, and as such will have to perform  all DNS  resolution over IPv6. I want to know whether the DNS server can resolve all IPv4 nodes over IPv6 successfully. And how? Is it necessary that the type A DNS query packet travels through AFTR? Is there any requirement for the DNS server in the ISP core network?
      
Best Regards,
------------------------------------
Zhenqiang Li
13911635816
Department of Network Technology
China Mobile Research Institute
2010-05-26

---

From: "Lee, Yiu" <[email-masked]>
Date: Wed, 26 May 2010 10:33:20 -0400

The B4 element contains a DNS proxy that will support DNS over v4 and proxy
the DNS messages to the DNS server over v6 in the ISP network. The DNS
server in the ISP must be able to resolve all the A and AAAA records.

On 5/26/10 5:26 AM, "[email-masked]"
<[email-masked]> wrote:

>     In your draft, you mention the B4 element  can only get the IPv6 address
> of  a DNS recursive  server, and as such will have to perform  all DNS
> resolution over IPv6. I want to know whether the DNS server can resolve all
> IPv4 nodes over IPv6 successfully. And how? Is it necessary that the type A
> DNS query packet travels through AFTR? Is there any requirement for the DNS
> server in the ISP core network?
>       
> Best Regards,
> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires

---

From: Jacni Qin <[email-masked]>
Date: Thu, 27 May 2010 00:47:20 +0800

another question,

for the host scenario(with DS-Lite software installed), what if the
operating system can not send DNS query over IPv6?
i'm sorry if i missed some discussion on this before.

many thanks,

Jacni

---

From: "Lee, Yiu" <[email-masked]>
Date: Wed, 26 May 2010 13:00:56 -0400

If the B4 is in the host, the B4 implementation should be able to proxy the
v4 DNS request over v6. Or B4 tunnels the DNS message and sends to a v4 DNS
server (less desirable).

On 5/26/10 12:47 PM, "Jacni Qin" <[email-masked]> wrote:

> another question,
> 
> for the host scenario(with DS-Lite software installed), what if the operating
> system can not send DNS query over IPv6?
> On Wed, May 26, 2010 at 10:33 PM, Lee, Yiu <[email-masked]> wrote:

---

From: Jacni Qin <[email-masked]>
Date: Thu, 27 May 2010 23:54:53 +0800

> v4 DNS request over v6. Or B4 tunnels the DNS message and sends to a v4 DNS

-- while as mentioned in the draft, currently there is no option defined for
passing the v4 DNS server address to hosts.
and for the DNS proxy case, do you mean if the OS doesn't support DNS
request over v6, we should then provider a patch for this function along
with the B4 implementation?

thanks,

---

From: <[email-masked]>
Date: Thu, 27 May 2010 19:36:56 +0200

Dear Jacni,

Please see inline.

Cheers,
Med
________________________________________
De : [email-masked] [[email-masked]] de la part de Jacni Qin [[email-masked]]
Date d'envoi : jeudi 27 mai 2010 17:54
À : Lee, Yiu
Cc : Durand, Alain; [email-masked]
Objet : Re: [Softwires] DNS question about DS-lite

On Thu, May 27, 2010 at 1:00 AM, Lee, Yiu <[email-masked]<mailto:[email-masked]>> wrote:

If the B4 is in the host, the B4 implementation should be able to proxy the v4 DNS request over v6. Or B4 tunnels the DNS message and sends to a v4 DNS server (less desirable).

-- while as mentioned in the draft, currently there is no option defined for passing the v4 DNS server address to hosts.

Med: If you really want to provision an IPv4 address of the DNS server, you can inspire from what we proposed for PCP: http://tools.ietf.org/html/draft-bpw-softwire-pcp-dhcp-01#section-3.1 and convey an IP4-mapped IPv6 address (representing the IPv4 address of your DNS server) in the DHCPv6 option. BTW, it is recommended to send DNS queries over IPv6 to avoid crossing the AFTR for various reasons (avoid nating DNS messages, better ports usage in the AFTR since DNS traffic represents an important amount of messages issued by various applications, incremental migration of network services to IPv6: DNS and NTP for instance).
*********************************
This message and any attachments (the "message") are confidential and intended solely for the addressees. 
Any unauthorised use or dissemination is prohibited.
Messages are susceptible to alteration. 
France Telecom Group shall not be liable for the message if altered, changed or falsified.
If you are not the intended addressee of this message, please cancel it immediately and inform the sender.
********************************

---

From: Jacni Qin <[email-masked]>
Date: Sun, 30 May 2010 16:09:11 +0800

thanks Med,

that may be a good idea, we can have a try. and the IPv4-mapped IPv6
addressing plan can be
used for the dns servers in ISP networks.

On Fri, May 28, 2010 at 1:36 AM, <[email-masked]>wrote:

> On Thu, May 27, 2010 at 1:00 AM, Lee, Yiu <[email-masked]
> <mailto:[email-masked]>> wrote:
>
> -- while as mentioned in the draft, currently there is no option defined
> for passing the v4 DNS server address to hosts.
>
>
> Med: If you really want to provision an IPv4 address of the DNS server, you
> can inspire from what we proposed for PCP:
> http://tools.ietf.org/html/draft-bpw-softwire-pcp-dhcp-01#section-3.1 and
> convey an IP4-mapped IPv6 address (representing the IPv4 address of your DNS
> server) in the DHCPv6 option. BTW, it is recommended to send DNS queries
> over IPv6 to avoid crossing the AFTR for various reasons (avoid nating DNS
> messages, better ports usage in the AFTR since DNS traffic represents an
> important amount of messages issued by various applications, incremental
> migration of network services to IPv6: DNS and NTP for instance).