Subject: Re: [Softwires] DNS question about DS-lite

From: Alain Durand <[email-masked]>
Date: Wed, 2 Jun 2010 05:18:51 -0700

Jacni:

The bellow statement only applies to dual-stack hosts implementing the B4 element...
Those behind a home gateway are fine, even if they only resolve over IPv4 transport.
Note: the solutions described in this thread are very similar to what has been suggested to get Windows XP to resolve DNS in an IPv6-only environment.

   - Alain.

On May 30, 2010, at 1:21 PM, Jacni Qin wrote:

ok,
or just simply add a statement somewhere like, dual stack hosts that can not send dns query over v6 are
also out of scope.
;-)

On Sun, May 30, 2010 at 10:50 PM, Lee, Yiu <[email-masked]<mailto:[email-masked]>> wrote:
Ok. We did mention this in the draft, but it seems you found it unclear. I will work with Alain to clarify the text. Thanks for the comments!

On 5/30/10 3:57 AM, "Jacni Qin" <[email-masked]<http://[email-masked]/>> wrote:

i agree with you that dns proxy over v6 in B4 should be preferred,

while we should mention this special case in the draft, because this will be not so special
if many hosts running that kind of OS still exist at the time when we start to implement DS-Lite.
and the recommendations for dealing with this case may be also included.

regards,
Jacni

<ATT00001..txt>

---

From: Jacni Qin <[email-masked]>
Date: Wed, 2 Jun 2010 23:34:57 +0800

exactly,
thank you Alain.

Jacni

On Wed, Jun 2, 2010 at 8:18 PM, Alain Durand <[email-masked]> wrote:

> Note: the solutions described in this thread are very similar to what has
> been suggested to get Windows XP to resolve DNS in an IPv6-only environment.
>
>   - Alain.
>
>
>
>
>
> On Sun, May 30, 2010 at 10:50 PM, Lee, Yiu <[email-masked]
> <mailto:[email-masked]>> wrote:
> Ok. We did mention this in the draft, but it seems you found it unclear. I
> will work with Alain to clarify the text. Thanks for the comments!
>
>
>