Subject: [Softwires] About draft-guo-softwire-6rd-ipv6-config-00

From: xuxiaohu 41208 <[email-masked]>
Date: Fri, 30 Jul 2010 17:46:39 +0800

Hi all,

First, as stated in the DHCPv6 specification [RFC3315], "...The client MUST use a link-local address assigned to the interface for which it is requesting configuration information as the source address in the header of the IP datagram." Since the link-local address can not travel through the 6rd domain, the CPE SHOULD act as a DHCPv6 relay agent. I think nobody will argue against this conclusion.

Second, as I mentioned during the presentation, relaying DHCP request messages to All_DHCP_Servers multicast address by CPEs is not optimal in 6rd scenario. Note that here what I said is "not optimal", rather than "not possible". The CPE as a relay agent, could be upgraded to relay information-request DHCPv6 messages (multicast) towards the 6rd BRs. However, with this approach, the DHCPv6 servers would have to be located in the IPv6 Interne
t, rather than in a 6rd site which is owned by the 6rd SP. In addition, this usage will result in more traffic burden on the 6rd BRs.

Hence, we propose that the CPE as a DHCP relay agent, SHOULD know at least one DHCPv6 server address.

Xiaohu

---

From: Ole Troan <[email-masked]>
Date: Fri, 30 Jul 2010 16:16:29 +0200

Xiaohu,

I think a good start would be to describe the problem you are trying to solve and the limitations with the current solutions.

what configuration information do you need to get to an IPv6 only client?
do you need only "stateless" DHCP options or do you need addresses or prefixes too?

there are other solutions here, e.g the DNS proxy in the CPE.
if we end up on a DHCP solution, then I think we should take that problem on how to make DHCP run over these types of links to the dhc working group.

cheers,
Ole

> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires