Subject: Re: [Softwires] Port mapping - Don't change it at the last minute !

From: Rémi Després <[email-masked]>
Date: Thu, 3 Nov 2011 09:22:15 +0100

Hi Jacni,

Le 3 nov. 2011 à 05:13, Jacni Qin a écrit :
...
>> Saying if you are not happy with port sharing, we give you a full address is relatively straightforward and can be translated into marketing terms. Anything in between is more questionable. This is a question that should be taken back to the working group: how far do we want to go on that route.
> Indeed.

+1

> In addition,
> Although according to the current algorithm, both the "prefix" case and the "exclusive address" case can be inherently supported, I still think, at least to cover the prefix case is debatable, given the so called "residual deployment of IPv4", which is the context of the solution design.
> 
> Furthermore, there is already an approach adopted by the WG for public IPv4 address case,

> if the MAP just covers "shared address with one single sharing ratio for one domain",
> the design will be greatly simplified?

Requiring ISPs to maintain IPv4 routing in their networks, just to serve the few users that need to keep IPv4 prefixes, seems to me a step backward.

Besides, I have serious doubts about "greatly simplified".
In my understanding, the recent unifying design of 4rd-U is, among per-customer-stateless v4/v6 solutions, one that permits a UNIQUE AND SIMPLE standard (possible direct CE-CE routes, transparency to v4 fragmentation, compatibility with v6 O&M-tools). 
All clarification questions are of course welcome. 

Cheers,
RD

---

From: Jacni Qin <[email-masked]>
Date: Thu, 03 Nov 2011 16:50:20 +0800

hi Remi,

> Besides, I have serious doubts about "greatly simplified".
I mean for the design of the address/port mapping algorithm, not the 
transport mechanism.

Cheers,
Jacni

---

From: Ole Troan <[email-masked]>
Date: Thu, 3 Nov 2011 10:04:36 +0100

Remi,

[...]

> Requiring ISPs to maintain IPv4 routing in their networks, just to serve the few users that need to keep IPv4 prefixes, seems to me a step backward.

can you clarify why this? I don't understand why IPv4 routing has to be maintained just because there is a MAP domain with full IPv4 addresses (or a rule for full IPv4 addresses)?

cheers,
Ole

---

From: Rémi Després <[email-masked]>
Date: Thu, 3 Nov 2011 10:04:32 +0100

Le 3 nov. 2011 à 09:50, Jacni Qin a écrit :
> I mean for the design of the address/port mapping algorithm, not the transport mechanism.

Yes, but I don't see the great simplification of the algorithm.
Keeping it general enough to support IPv4 prefixes is AFAIK easy. It doesn't prevent deployments where, IPv4 prefixes being not supported, fields can be at places that may be found more convenient.

Maybe you can be more specific on your concern.

Cheers,
RD

---

From: <[email-masked]>
Date: Thu, 3 Nov 2011 10:14:03 +0100

Hi Rémi, all,

Since there is only an excerpt of e-mails, I lost the context. 

Could you please clarify what is the issue discussed here? Thanks.

Cheers,
Med

> -----Message d'origine-----
> De : Rémi Després [mailto:[email-masked]] 
> Envoyé : jeudi 3 novembre 2011 10:05
> À : Jacni Qin
> Cc : Alain Durand; Ole Troan; BOUCADAIR Mohamed OLNC/NAD/TIP; 
> Satoru Matsushima; Softwires WG
> Objet : Keeping support of CE IPv4 prefixes in the v4/v6 
> address mapping?
> 
> 
> >> Requiring ISPs to maintain IPv4 routing in their networks, 
> just to serve the few users that need to keep IPv4 prefixes, 
> seems to me a step backward.
> >> 
> Keeping it general enough to support IPv4 prefixes is AFAIK 
> easy. It doesn't prevent deployments where, IPv4 prefixes 
> being not supported, fields can be at places that may be 
> found more convenient.
>

---

From: Rémi Després <[email-masked]>
Date: Thu, 3 Nov 2011 10:22:56 +0100

> Could you please clarify what is the issue discussed here? Thanks.

Sure.
Right or wrong, I understood that what Jacni suggested is that the v4/v6 address mapping would be able to assign full IPv4 addresses to CEs, but no longer IPv4 prefixes.

If I misunderstood, end of this subject for me.
Otherwise, I argue that keeping IPv4-prefix support isn't difficult.

Hope it clarifies.
 
Cheers,
RD

---

From: Rémi Després <[email-masked]>
Date: Thu, 3 Nov 2011 10:24:30 +0100

Le 3 nov. 2011 à 10:04, Ole Troan a écrit :
...
> can you clarify why this? I don't understand why IPv4 routing has to be maintained just because there is a MAP domain with full IPv4 addresses (or a rule for full IPv4 addresses)?

I didn't say that.

IF the address mapping can't assign IPv4 prefixes to CEs, AND IF an ISP has to support some users needing IPv4 prefixes, it needs a tool to do it.
I supposed that maintaining IPv4 routing was the easiest way to do it.
If you have a better alternative, what would it be?

As said to Med, if I misunderstood Jacni's idea, this debate can be closed.

Cheers,
RD

---

From: Jacni Qin <[email-masked]>
Date: Fri, 04 Nov 2011 09:40:36 +0800

hi Remi,

> Keeping it general enough to support IPv4 prefixes is AFAIK easy. It doesn't prevent deployments where, IPv4 prefixes being not supported, fields can be at places that may be found more convenient.
Right, and I have already mentioned that in my previous message, the 
prefix case can be inherently supported. I just said that in the context 
of IPv4 address shortage, it may be not reasonable.
If the sharing ratio is unique, then it'll be easily to be calculated, 
some parameter is not required in the MAP Rule. And the simplicity can 
also mean straightforward to implementers and addressing planners, which 
IMHO is important for the solution to be accepted easily in practice.

Cheers,
Jacni

---

From: Jacni Qin <[email-masked]>
Date: Fri, 04 Nov 2011 09:44:32 +0800

hi,

> If you have a better alternative, what would it be?
If the customer is likely to pay that much for a prefix, I guess these 
won't be a problem any more. For example, just setup a dedicated tunnel 
and add a piece of route for them.

Cheers,
Jacni