Subject: [Softwires] Comments on MAP-E draft

From: "Qi Sun" <[email-masked]>
Date: Wed, 29 Feb 2012 17:18:37 +0800

Hi Murakami,
     It's a good draft and makes a nice support for the MAP mechanism. I would like to propose some comments on the draft(sorry if they've been discussed ever). Please check below.
-----------------------------------------------------------------
 Section 5.2 Packet Forwarding Behavior on MAP-E BR
Part (b) BR reception of an IPv6 packet
            BR derives a CE IPv6 address from
            the IPv4 source address or the IPv4 source
            address and the source port in the encapsulated
            IPv4 packet based on the BMR.  If the CE IPv6
            address is eqaul to the IPv6 source address in
            the received IPv6 packet, BR decapsulates the
            IPv4 packet and then forward it via the IPv4
            interface.
I have a few questions here.
1. How can the BR get from an IPv6 packet the IPv4 source address or the IPv4 source address and the source port in the encapsulated IPv4 packet?
2. If the received IPv6 packet is a normal one, instead of an IPv4-encapsulated packet, what will the BR do?  That is, dose the BR can act as a normal router?
3. What can cause the inequality between the derived CE IPv6 address and the IPv6 source address in the received IPv6 packet? And what will BR do with it, discard it ? 

I'm looking forward to your reply~

Best Regards,

Qi Sun
Tsinghua University, Beijing, China

---

From: Tetsuya Murakami <[email-masked]>
Date: Wed, 29 Feb 2012 18:14:04 -0800

Hi Qi,

Thank you for your comments. Please see my comments in line.

On 2012/02/29, at 1:18, Qi Sun wrote:

>  Section 
> 5.2 Packet Forwarding 
> Behavior on MAP-E BR
In case of MAP-E, IPv4 packet is encapsulated in IPv6. The above text is for check the validation of the received packet. In terms of IPv6 packet received at BR, the IPv6 source address should be based on the IPv6 prefix delegated to CE. Also, according to the MAP rule, IPv4 address and port number can be derived from the same delegated IPv6 prefix. So, BR can calculate CE IPv6 address from the IPv4 source address and source port number in IPv4 packet encapsulated in the received IPv6 packet. If the calculation is failed, then the packet could be dropped. If the calculation is succeeded but the calculated CE IPv6 address is not matched to the source IPv6 address in the received IPv6 packet, then the packet could be dropped.

> 2. If the received IPv6 packet is a normal one, instead of an IPv4-encapsulated packet, what will the BR do?  That is, dose the BR can act as a normal router?

In this case, BR should handle this IPv6 packet based on the normal IPv6 routing because the next header is not IPv4 in this case.

> 3. What can cause the inequality between the derived CE IPv6 address and the IPv6 source address in the received IPv6 packet? And what will BR do with it, discard it ?

It might depend on the implementation. But the derived CE IPv6 address must be same as the IPv6 source address in case of MAP-E because the derived CE IPv6 address should be the tunnel end-point address on the CE. So, the received packet should be discarded or not processed as MAP-E packet.

Thanks,
Tetsuya Murakami