Subject: Re: [Softwires] Stateless implementation plan

From: "Lee, Yiu" <[email-masked]>
Date: Wed, 8 Feb 2012 18:39:46 +0000

Hi Remi,

I know this is possible to do, in theory. However my question is more
toward manageability of the network. IMHO, layering one tunnel (or
translation) protocol on another tunnel protocol is asking for trouble.

Cheers,
/Yiu

On 2/8/12 2:13 AM, "Rémi Després" <[email-masked]> wrote:

>6rd can be deployed over Net-10 networks (RFC1918) to deployIPv6.
>Shared public IPv4 addresses can then be offered to customers via this
>IPv6.
>Such a use case, based on the header-mappiong variant of 4rd-U rather
>than on a double MAP encapsulation, is described in
>tools.ietf.org/html/draft-despres-softwire-4rd-u-03#section-5.4.
>
>RD
>

---

From: Jacni Qin <[email-masked]>
Date: Thu, 09 Feb 2012 16:05:28 +0800

Re-,

+1,
IMHO it's unacceptable in practice.

Cheers,
Jacni

On 2/9/2012 2:39 AM, Lee, Yiu wrote:
> On 2/8/12 2:13 AM, "Rémi Després"<[email-masked]>  wrote:
>
> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires
>

---

From: Rémi Després <[email-masked]>
Date: Thu, 9 Feb 2012 09:40:28 +0100

> translation) protocol on another tunnel protocol is asking for trouble.

No obligation to do it, of course.
Noting that it is possible doesn't hurt though.
Personally, I find it legitimate to be careful before pretending to offer more service than before, but I don't see which trouble would result from IPv6 (with IPv4 embedded addresses) encapsulated in IPv4 (with RFC1918 addresses). 

Cheers,
RD