Subject: [Softwires] Tool for Visualizing MAP Rules

From: Mark Townsley <[email-masked]>
Date: Tue, 19 Jun 2012 16:25:11 +0200

Good day all,

I asked a student of mine from Ecole Polytechnique that Cisco hired as an intern for the summer to create a tool to help visualize IPv4 to IPv6 address + port mapping. He's done a great job, and I thought we should begin sharing the results. An Android and iPhone version is in the works, but you'll have to wait a bit longer for that. 

This is of course in "Beta", and comments/suggestions/etc. are welcome. 
Please send feedback to [email-masked], cc'd on this email.

Here's the link:  http://map46.cisco.com/

If its not obvious, the idea is that you can drag the prefix block "borders" left and right to adjust the MAP parameters, while reporting the sharing ratio and such in real time. You can add as many rules as you like, save them in text form or in a link for emailing to your friends, etc. You can even type in your own specific prefix, play around with the "Advanced" mode for more information, or type in an address in "Example" mode to show the precise mapping for a given rule. 

The student's name is Arthur Lacoste, and is on the list above at least until his internship is finished at the end of July. 

Enjoy,

- Mark

---

From: Mark Townsley <[email-masked]>
Date: Thu, 21 Jun 2012 00:56:10 +0200

A video showing the tool in action:

http://www.youtube.com/watch?v=CqHBjO-QbSQ

- Mark