Subject: [Softwires] Fwd: New Version Notification for draft-mdt-softwire-map-deployment-01.txt

From: Maoke <[email-masked]>
Date: Tue, 26 Jun 2012 06:24:09 +0000

hi all,

we have submitted the updated version of the MAP deployment draft. As the
new draft of MAP spec introduces technical uncertainties and hasn't reach
the consensus. we noticed that the 1:1 mode involves different way of
operation, needing to carefully investigate and to understand. Currently we
exclude the 1:1 mode from the scope of MAP deployment.

the major change of this version in comparison to the previous version
includes:
- adding of the new section 4.1: Network Models
  taking the example of home network, explain what is the typical use cases
of MAP
- editorial changes and correction of grammar/wording/spellings.

we are aware that this MAP deployment draft has not reviewed by the working
group, and therefore we update it still as individual draft for the time
being. comments and recommendations are requested.

regards,
maoke

---------- Forwarded message ----------
From: <[email-masked]>
Date: 2012/6/24
Subject: New Version Notification for
draft-mdt-softwire-map-deployment-01.txt
To: [email-masked]
Cc: [email-masked], [email-masked],
[email-masked], [email-masked],
[email-masked]

A new version of I-D, draft-mdt-softwire-map-deployment-01.txt
has been successfully submitted by Qiong Sun and posted to the
IETF repository.

Filename:        draft-mdt-softwire-map-deployment
Revision:        01
Title:           Mapping of Address and Port (MAP) - Deployment
Considerations
Creation date:   2012-06-24
WG ID:           Individual Submission
Number of pages: 32
URL:
http://www.ietf.org/internet-drafts/draft-mdt-softwire-map-deployment-01.txt
Status:
http://datatracker.ietf.org/doc/draft-mdt-softwire-map-deployment
Htmlized:
http://tools.ietf.org/html/draft-mdt-softwire-map-deployment-01
Diff:
http://tools.ietf.org/rfcdiff?url2=draft-mdt-softwire-map-deployment-01

Abstract:
  This document describes when and how an operator uses the technique
  of Mapping of Address and Port (MAP) for the IPv4 residual deployment
  in the IPv6-dominant domain.

The IETF Secretariat

---

From: Wojciech Dec <[email-masked]>
Date: Tue, 26 Jun 2012 11:05:08 +0200

Hi,

comments:

section 4.2 of the draft reads:
" a MAP domain is a set of MAP CEs and BRs connected to the same virtual
link. One MAP domain shares a common BR and has the same set of BMRs, FMRs
and DMR, and it can be further divided into multiple sub-domains when
multiple IPv4 subnets are deployed in one MAP domain.
There might be multiple BMRs in one MAP domain, and CE would pick up its
own BMR by longest prefix matching lookup.

This effectively confirms that multiple MAP domains are an established
characteristics, and logic dictates that if N CEs can be in a given domain,
N can also equal 1.

We look forward to updates to the draft, also in terms of referring to the
specs.

Regards,
Woj.

On 26 June 2012 08:24, Maoke <[email-masked]> wrote:

>   taking the example of home network, explain what is the typical use
> cases of MAP
> we are aware that this MAP deployment draft has not reviewed by the
> working group, and therefore we update it still as individual draft for the
> time being. comments and recommendations are requested.
>
> regards,
> maoke
>
>
> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires
>
>

---

From: Maoke <[email-masked]>
Date: Wed, 27 Jun 2012 13:00:40 +0900

2012/6/26 Wojciech Dec <[email-masked]>

> characteristics, and logic dictates that if N CEs can be in a given domain,

multiple domain is surely an established characteristics. however, the
question is: can N be 1/K (K:int > 1)? ;-)

> We look forward to updates to the draft, also in terms of referring to the

thanks a lot for the comment. and updating the draft with referring to the
specs is definitely the most important task but the first-priority task of
us is clarifying the semantics and impacts of the specs itself.

thanks and regards,
maoke

---

From: Leaf yeh <[email-masked]>
Date: Wed, 27 Jun 2012 04:18:59 +0000

I might have a naive question: why does the Softtwire-WG need a document for deployment other than a document for motivation? 

I guess the answer might be the motivation is for the requirements, and the deployment is for the specified application cases, right? But to me the answer might be as simple as that motivation is the deployment.

Could it possible to merge these 2 document?

Best Regards,
Leaf

From: [email-masked] [mailto:[email-masked]] On Behalf Of Maoke
Sent: Wednesday, June 27, 2012 12:01 PM
To: Wojciech Dec
Cc: Softwires-wg
Subject: Re: [Softwires] Fwd: New Version Notification for draft-mdt-softwire-map-deployment-01.txt

comments:

section 4.2 of the draft reads:
" a MAP domain is a set of MAP CEs and BRs connected to the same virtual link. One MAP domain shares a common BR and has the same set of BMRs, FMRs and DMR, and it can be further divided into multiple sub-domains when multiple IPv4 subnets are deployed in one MAP domain. 
There might be multiple BMRs in one MAP domain, and CE would pick up its own BMR by longest prefix matching lookup. 

This effectively confirms that multiple MAP domains are an established characteristics, and logic dictates that if N CEs can be in a given domain, N can also equal 1.

multiple domain is surely an established characteristics. however, the question is: can N be 1/K (K:int > 1)? ;-)

We look forward to updates to the draft, also in terms of referring to the specs.

thanks a lot for the comment. and updating the draft with referring to the specs is definitely the most important task but the first-priority task of us is clarifying the semantics and impacts of the specs itself. 

thanks and regards,
maoke

Regards,
Woj.

hi all, 

we have submitted the updated version of the MAP deployment draft. As the new draft of MAP spec introduces technical uncertainties and hasn't reach the consensus. we noticed that the 1:1 mode involves different way of operation, needing to carefully investigate and to understand. Currently we exclude the 1:1 mode from the scope of MAP deployment. 

the major change of this version in comparison to the previous version includes: 
- adding of the new section 4.1: Network Models
  taking the example of home network, explain what is the typical use cases of MAP
- editorial changes and correction of grammar/wording/spellings. 

we are aware that this MAP deployment draft has not reviewed by the working group, and therefore we update it still as individual draft for the time being. comments and recommendations are requested. 

regards,
maoke

---------- Forwarded message ----------
From: <[email-masked]>
Date: 2012/6/24
Subject: New Version Notification for draft-mdt-softwire-map-deployment-01.txt
To: [email-masked]
Cc: [email-masked], [email-masked], [email-masked], [email-masked], [email-masked]

Filename:        draft-mdt-softwire-map-deployment
Revision:        01
Title:           Mapping of Address and Port (MAP) - Deployment Considerations
Creation date:   2012-06-24
WG ID:           Individual Submission
Number of pages: 32
URL:             http://www.ietf.org/internet-drafts/draft-mdt-softwire-map-deployment-01.txt
Status:          http://datatracker.ietf.org/doc/draft-mdt-softwire-map-deployment
Htmlized:        http://tools.ietf.org/html/draft-mdt-softwire-map-deployment-01
Diff:            http://tools.ietf.org/rfcdiff?url2=draft-mdt-softwire-map-deployment-01

Abstract:

The IETF Secretariat

---

From: Qiong <[email-masked]>
Date: Wed, 27 Jun 2012 12:56:08 +0800

Hi Leaf,

On Wed, Jun 27, 2012 at 12:18 PM, Leaf yeh <[email-masked]> wrote:

> I might have a naive question: why does the Softtwire-WG need a document
> for deployment other than a document for motivation?
>
Qiong: We already have a motivation draft that clearly demenstrates the
requirements. This is exactly what is documented in charter: "develop a
protocol specification response to the solution motivation document"

>
> I guess the answer might be the motivation is for the requirements, and
> the deployment is for the specified application cases, right? But to me the
> answer might be as simple as that motivation is the deployment.
>
Qiong:  Motivation is why we need it. Specification is what it
is.Deployment is how we use it in operational network.
These three are quite different essentially.

> Could it possible to merge these 2 document?

I don't think so.  See above reasons.

Best wishes
Qiong

-- 
==============================================
Qiong Sun
China Telecom Beijing Research Institude

Open source code:
lightweight 4over6: *http://sourceforge.net/projects/laft6/*
PCP-natcoord:* http://sourceforge.net/projects/pcpportsetdemo/ *
===============================================