Subject: [Softwires] TCP/IPv6 faster than TCP/IPv4/IPv6?

From: Rémi Després <[email-masked]>
Date: Wed, 4 Jul 2012 17:04:29 +0200

Hi all,

There has been discussions, during IETF 83 and after, to warn that, in some circumstances, direct TCP over IPv6 can be significantly faster than TCP/IPv4/IPv6.
A cc is sent to Lorenzo, because he privately reported some direct knowledge of the subject (I personally have none).

Although this is obviously relevant when comparing 4rd or MAP-T to MAP-E, more data should IMHO be available on real facts before posting an issue on the tracker. 
Thanks to anyone who has information about this for sharing it.

Regards,
RD

---

From: Rémi Després <[email-masked]>
Date: Mon, 9 Jul 2012 10:45:24 +0200

The following email, sent by lorenzo to the mailing list didn't reach it because he isn't registered in Softwire.
Upon his request, here is a retransmission.
Regards,
RD

> De : Lorenzo Colitti <[email-masked]>
> Date : 2012-07-06 10:59
> À : Rémi Després <[email-masked]>
> Cc : "[email-masked] WG" <[email-masked]>
> Objet : Rép : TCP/IPv6 faster than TCP/IPv4/IPv6?
> 
>  On Thu, Jul 5, 2012 at 12:04 AM, Rémi Després <[email-masked]> wrote:
> What I know is: some routers only process UDP/IPv6 and/or TCP/IPv6 on the fast path and IPv4/IPv6 on the slow path. I know this because I have one such router at home, and I believe that millions of users in Japan do as well. The devices are used to connect to the NTT East/West closed IPv6 network, which provides 100M or 1G link speeds. Some of these users have IPv6 Internet access over these pipes, and some ISPs are thinking of tunneling IPv4 over IPv6 to take advantage of the fast IPv6 pipe (IPv4 only provides 200M).
> 
> My particular router will do 1Gbps of TCP/IPv6 but only about 300Mbps of TCP/IPv4/IPv6. This particular device is fairly recent, however; I understand that older devices have worse performance (as low as a few Mbps).
> 
> I realize this will very much sound like a first-world problem to most people (my router will only do 300Mbps!), but nevertheless, this is a barrier to adoption because a service that reduces users's bandwidth by 3x to 100x is very hard to for an operator launch.
> 
> Cheers,
> Lorenzo