Subject: [Softwires] DS-Lite address

From: nicholas <[email-masked]>
Date: Sat, 12 Mar 2022 14:54:59 +0000 (UTC)

Hello,

I'm technologically retarded, so please excuse my naivety. My question is why does my phone SIM card have a static ip address of 192.0.0.4?
Incidentally, when I login to a private wifi network, and disconnect my cellular data, a traceroute using the 192.0.0.4 address (which I consider null since I'm no longer using the cellular distributor of that address) still shows 4 to 5 other devices, routers, networks or whatever, on the route to my phone? For a centuryLink network it usually contains Qwest legacy IP's, while comcast uses comcast IP's. Similarly, when my cell phone plan expires (I currently use a trakphone Walmart simple family that is powered by the T-mobile network) my phone status still shows that I have an ip address of 192.0.0.4 and the "4g" data symbol is still visible in the upper corner of my phone with input/output arrows blinking. However, the use of my phone, text and  internet are restricted. Yet, my SIM status shows that I my phone is "connected" and service state is "active"? Another thing that I do not understand and  which really messes with my emotions, is when I search for a national carrier, whether or not known businesses like T-mobile, Verizon, Sprint, etc., show up in my network search, my phone will not accept any of them and instead will automatically connect to the cellular carrier named "HOME". Incidentally, I don't like the look of my default APN, which is also tied to my static 192.0.0.4 IP, as when I fill in different APN settings that I find online my ip address will then become randomized

Thank you so much for your time.
Any information (preferably in layman's terms) would be greatly appreciated!
 Cheers,
Nick James

---

From: [email-masked]
Date: Thu, 17 Mar 2022 17:04:07 +0100

Hi,

Your email got held up the the spam filters. In order to post directly to the email list, you need to register at: https://www.ietf.org/mailman/listinfo/softwires

To your question, I’m not familiar with the specifics of your operator’s network or service, but hopefully the following information will help:

The 192.0.0.4 address is taken from the address range 192.0.0.0./29 which is a "Special Purpose Address" (https://www.iana.org/assignments/iana-ipv4-special-registry/iana-ipv4-special-registry.xhtml <https://www.iana.org/assignments/iana-ipv4-special-registry/iana-ipv4-special-registry.xhtml>). This is a “Globally Reachable False” IPv4 address range (i.e. it is not permitted to appear on the public IPv4 Internet, so you should be able to successfully traceroute to it).

192.0.0.0/29 is defined as the ‘IPv4 Service Continuity Prefix’ (RFC7335). and is used for configuring an v4 address locally on a device which is actually only has an IPv6 connection to the Internet (and no public IPv4 address). This IPv4 address is needed by the IPv4/IPv6 transition technology (in your case, I would guess that 464XLAT is the IPv4/IPv6 transition technology being used here).

With 464XLAT, IPv4 traffic on the device with the source address of 192.0.0.4 (in your case) is translated to a global (public) IPv6 address so it can be sent across the operator’s IPv6 only network. In the operator’s network, there is another device which performs the translation from IPv6 to a public IPv4 address which can be routed on the IPv4 Internet (this might be the ‘randomised’ IPv4 address you are seeing). It’s worth noting that the same 192.0.0.4 address will appear on all devices using this service from this operator, as it never leaves the device.

Regarding setup for different cellular service providers etc., normally the relevant configuration is pushed to a device by the operator, so manual configuration for an APN should not be necessary, but you’d need to talk to your provider about that.

Hope this helps.

Ian

> On 12. Mar 2022, at 15:54, nicholas <civilitant=[email-masked]> wrote:
> 
> Hello,
> 
> Incidentally, when I login to a private wifi network, and disconnect my cellular data, a traceroute using the 192.0.0.4 address (which I consider null since I'm no longer using the cellular distributor of that address) still shows 4 to 5 other devices, routers, networks or whatever, on the route to my phone? For a centuryLink network it usually contains Qwest legacy IP's, while comcast uses comcast IP's. Similarly, when my cell phone plan expires (I currently use a trakphone Walmart simple family that is powered by the T-mobile network) my phone status still shows that I have an ip address of 192.0.0.4 and the "4g" data symbol is still visible in the upper corner of my phone with input/output arrows blinking. However, the use of my phone, text and  internet are restricted. Yet, my SIM status shows that I my phone is "connected" and service state is "active"? Another thing that I do not understand and  which really messes with my emotions, is when I search for a national carrier, whet
> her or not known businesses like T-mobile, Verizon, Sprint, etc., show up in my network search, my phone will not accept any of them and instead will automatically connect to the cellular carrier named "HOME". Incidentally, I don't like the look of my default APN, which is also tied to my static 192.0.0.4 IP, as when I fill in different APN settings that I find online my ip address will then become randomized
> 
> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires