Subject: [lamps] HP Issue: Protection Levels

From: Bernie Hoeneisen <[email-masked]>
Date: Wed, 30 Sep 2020 22:04:53 +0200 (CEST)

Below a summary of the issue on 'Protection Levels'. If anybody wishes 
to discuss this topic further or does not agree with the conclusion, 
please speek up within the next 10 days!

cheers,
  Bernie

Text from slide:

- Specification is targeted for
   - Signature and encryption
   - Signature only

- Variations / corner-cases may pop up at receiving side, e.g.
   - Encryption only
   - Encryption before signature
   - Signature and encryption, but
     - Signature fails to validate
     - Signature validates but the signing certificate revoked
   - Signature only, but
     -  with multiple valid signatures, layered atop each other?

- Which of those and to what extent do we need to document those?

Conclusion at IETF-108 (as I understood):

- For the time being only specify cases (for sending and receiving side):
   - Signature and encryption
   - Signature only

- Decide lateron whether or not to include more guiance on how to deal
   with (some of the) other cases on the receiving side.

---

From: Russ Housley <[email-masked]>
Date: Wed, 30 Sep 2020 17:22:58 -0400

This matches my memory of the discussion.

Russ

> On Sep 30, 2020, at 4:04 PM, Bernie Hoeneisen <[email-masked]> wrote:
> 
> Below a summary of the issue on 'Protection Levels'. If anybody wishes to discuss this topic further or does not agree with the conclusion, please speek up within the next 10 days!
> 
> cheers,
> Bernie
> 
> 
> Text from slide:
> 
> _______________________________________________
> Spasm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spasm