Subject: [lamps] HP Issue - Obfuscation of Header Fields

From: Bernie Hoeneisen <[email-masked]>
Date: Wed, 30 Sep 2020 22:17:33 +0200 (CEST)

Below a summary of the issue on 'Obfuscation of Header Fields'. If anybody 
wishes to discuss this topic further or does not agree with the 
conclusion, please speek up within the next 10 days!

cheers,
  Bernie

Text from slide:
- Should we recommend any specific format for obfuscation?
   e.g.
   - Subject: ...
   - Subject: [...]
   - Date: Thu, 01 Jan 1970 00:00:00 +0000 (UTC)
     - Impact to certificate checking?
   - Date: <set to Monday 9am of the same week>
   - Message-ID: <a new randomly generated Message-ID>
   - From: Obfuscated <[email-masked]>
   - To: Obfuscated <[email-masked]>

- Impact to Spam filtering?

Conclusion at IETF-108 (as I understood):

- Only specify obfuscation if encryption is applied
- Only recommend obfuscation for the Subject HF, but not for
   Date HF, From HF, To HF

We did not discuss about whether or not to recommend a new Message-ID for 
the Outer Message, as the Message-ID often leaves a trace to the 
originator host. Unless there are strong reasons not to do so, I'd be in 
favour of recommending a new randomly generated Messsage-ID. Any opinions 
on this?

---

From: Russ Housley <[email-masked]>
Date: Wed, 30 Sep 2020 17:21:50 -0400

The thing I recall is that we only want to obfuscate the Subject.  I recall someone suggested "Encrypted Message".  Also, the obfuscation should be at the senders discretion.

Russ

> On Sep 30, 2020, at 4:17 PM, Bernie Hoeneisen <[email-masked]> wrote:
> 
> Below a summary of the issue on 'Obfuscation of Header Fields'. If anybody wishes to discuss this topic further or does not agree with the conclusion, please speek up within the next 10 days!
> 
> cheers,
> Bernie
> 
> 
> Text from slide:
> We did not discuss about whether or not to recommend a new Message-ID for the Outer Message, as the Message-ID often leaves a trace to the originator host. Unless there are strong reasons not to do so, I'd be in favour of recommending a new randomly generated Messsage-ID. Any opinions on this?
> 
> _______________________________________________
> Spasm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spasm