Subject: [lamps] draft-ietf-lamps-crmf-update-algs-01

From: Russ Housley <[email-masked]>
Date: Fri, 18 Dec 2020 13:04:25 -0500

This revision addresses all of the outstanding comments.  I believe it is ready for WG Last Call.

Russ

> On Dec 18, 2020, at 1:03 PM, [email-masked] wrote:
> 
> 
> A new version of I-D, draft-ietf-lamps-crmf-update-algs-01.txt
> has been successfully submitted by Russ Housley and posted to the
> IETF repository.
> 
> Name:		draft-ietf-lamps-crmf-update-algs
> Revision:	01
> Title:		Algorithm Requirements Update to the Internet X.509 Public Key Infrastructure Certificate Request Message Format (CRMF)
> Document date:	2020-12-18
> Group:		lamps
> Pages:		8
> URL:            https://www.ietf.org/archive/id/draft-ietf-lamps-crmf-update-algs-01.txt
> Status:         https://datatracker.ietf.org/doc/draft-ietf-lamps-crmf-update-algs/
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-lamps-crmf-update-algs
> Htmlized:       https://tools.ietf.org/html/draft-ietf-lamps-crmf-update-algs-01
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-lamps-crmf-update-algs-01
> 
> Abstract:
>   This document updates the cryptographic algorithm requirements for
>   the Password-Based Message Authentication Code in the Internet X.509
>   Public Key Infrastructure Certificate Request Message Format (CRMF)
>   specified in RFC 4211.

---

From: "Brockhaus, Hendrik" <[email-masked]>
Date: Fri, 18 Dec 2020 18:46:55 +0000

Russ

Sorry for our late response on the iterationCount topic.
Hans and I would like to propose a text, but I could not get hold of Hans this week :-)
I will come back to you next week. 

Hendrik

> -----Ursprüngliche Nachricht-----
> Von: Spasm <[email-masked]> Im Auftrag von Russ Housley
> Gesendet: Freitag, 18. Dezember 2020 19:04
> An: LAMPS <[email-masked]>
> Betreff: [lamps] draft-ietf-lamps-crmf-update-algs-01
> 
> > has been successfully submitted by Russ Housley and posted to the IETF
> > repository.
> >
> > Title:		Algorithm Requirements Update to the Internet X.509 Public
> Key Infrastructure Certificate Request Message Format (CRMF)
> > URL:
> https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww
> .ietf.org%2Farchive%2Fid%2Fdraft-ietf-lamps-crmf-update-algs-
> 01.txt&amp;data=04%7C01%7Chendrik.brockhaus%40siemens.com%7Cd60b
> 8e72a1514c52a39408d8a37f660e%7C38ae3bcd95794fd4addab42e1495d55a%7
> C1%7C0%7C637439115015082517%7CUnknown%7CTWFpbGZsb3d8eyJWIjoi
> MC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C100
> 0&amp;sdata=46KugpRBPoXItrBKtNc%2BNZeHWhZk3SmEKfIbuf4Twzw%3D&
> amp;reserved=0
> > Status:
> https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatat
> racker.ietf.org%2Fdoc%2Fdraft-ietf-lamps-crmf-update-
> algs%2F&amp;data=04%7C01%7Chendrik.brockhaus%40siemens.com%7Cd6
> 0b8e72a1514c52a39408d8a37f660e%7C38ae3bcd95794fd4addab42e1495d55a
> %7C1%7C0%7C637439115015092508%7CUnknown%7CTWFpbGZsb3d8eyJWIj
> oiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1
> 000&amp;sdata=Zfmn0k5pB1H%2BW0EwldtfJPgzhR0eneN7KM8N%2Bq17zU
> U%3D&amp;reserved=0
> > Htmlized:
> https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatat
> racker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-lamps-crmf-update-
> algs&amp;data=04%7C01%7Chendrik.brockhaus%40siemens.com%7Cd60b8e
> 72a1514c52a39408d8a37f660e%7C38ae3bcd95794fd4addab42e1495d55a%7C1
> %7C0%7C637439115015092508%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC
> 4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&
> amp;sdata=FStfeGED7f3fl%2BEvYeVnalAtWU6cIWbdNHeOLoYpC2E%3D&am
> p;reserved=0
> > Htmlized:
> https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.
> ietf.org%2Fhtml%2Fdraft-ietf-lamps-crmf-update-algs-
> 01&amp;data=04%7C01%7Chendrik.brockhaus%40siemens.com%7Cd60b8e7
> 2a1514c52a39408d8a37f660e%7C38ae3bcd95794fd4addab42e1495d55a%7C1
> %7C0%7C637439115015092508%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC
> 4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&
> amp;sdata=8arjo%2Bfmf5hayTxbD%2BWhJMEOEFR1jkQOlIPn5oIrfP8%3D&a
> mp;reserved=0
> > Diff:
> https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww
> .ietf.org%2Frfcdiff%3Furl2%3Ddraft-ietf-lamps-crmf-update-algs-
> 01&amp;data=04%7C01%7Chendrik.brockhaus%40siemens.com%7Cd60b8e7
> 2a1514c52a39408d8a37f660e%7C38ae3bcd95794fd4addab42e1495d55a%7C1
> %7C0%7C637439115015092508%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC
> 4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&
> amp;sdata=At%2BLQYLUpfKWvTCqCM2uhj%2F2x90M8V%2B3ipHAlP7DShw
> %3D&amp;reserved=0
> >
> > Abstract:
> _______________________________________________
> Spasm mailing list
> [email-masked]
> https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww
> .ietf.org%2Fmailman%2Flistinfo%2Fspasm&amp;data=04%7C01%7Chendrik.
> brockhaus%40siemens.com%7Cd60b8e72a1514c52a39408d8a37f660e%7C38a
> e3bcd95794fd4addab42e1495d55a%7C1%7C0%7C637439115015092508%7CU
> nknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI
> 6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=EUn8W8MCpNFPSlQs79J
> Aq%2FMEvVUV%2BfKyw5WiNjoDa7c%3D&amp;reserved=0

---

From: "Brockhaus, Hendrik" <[email-masked]>
Date: Mon, 21 Dec 2020 14:59:48 +0000

Russ

Many thanks for the update. It addresses our concerns and suggestions.

To also address Tomas issues, you could add the following sentence to the section on iterationCount:
"A lower iterationCount can be used, if computer generated shared secrets with a high entropy are used."

We think, using a shared secret with high entropy, the iterationCount of 100 can be absolutely sufficient.

- Hendrik and Hans

---

From: Russ Housley <[email-masked]>
Date: Mon, 21 Dec 2020 10:46:45 -0500

How about:

    A lower iteration count can be used, if automated
    generation produces shared secrets with high entropy.

Russ

> On Dec 21, 2020, at 9:59 AM, Brockhaus, Hendrik <[email-masked]> wrote:
> 
> Russ
> 
> https://www.ietf.org/mailman/listinfo/spasm

---

From: "Brockhaus, Hendrik" <[email-masked]>
Date: Tue, 22 Dec 2020 08:09:25 +0000

Thanks Russ, I like the wording.

Hendrik

> Von: Russ Housley <[email-masked]>
> Gesendet: Montag, 21. Dezember 2020 16:47
> 
> How about:
> 
> .
> ietf.org%2Fmailman%2Flistinfo%2Fspasm&amp;data=04%7C01%7Chendrik.b
> rock
> >
> haus%40siemens.com%7Cd5b41e6e86b9426dc44308d8a5c7a364%7C38ae3bc
> d95794f
> >
> d4addab42e1495d55a%7C1%7C0%7C637441624152431517%7CUnknown%7CT
> WFpbGZsb3
> >
> d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0
> %3D%7
> >
> C1000&amp;sdata=%2FnRwbNXjvkUR%2BCAvWkombUkbqHL2QUP5Z8m9e
> Mo71ak%3D&amp
> > ;reserved=0