Subject: [lamps] Fw: 转发: IETF Liaison Statement to ISO/TC 154 about ISO 14533-4

From: "Jiankang Yao" <[email-masked]>
Date: Thu, 18 Feb 2021 18:05:34 +0800

Hello IAB Chair and all,
    Today is the first business day after  holiday of Spring Festival (Chinese New Year). Mr. Jianfang Zhang has kindly returned email to 
[email-masked]  [email-masked] and [email-masked], and copy to some ISO friends. But the email is bounced back  by these email servers.
Then Mr. Jianfang Zhang  tries again and forwards it to me and [email-masked] [email-masked] and [email-masked].
It seems that only my address gets this email. He just contacts me to tells the news and asks me to relay the email below.
We may need to ask the email server administrator to help to put  [email-masked]  or cnis.ac.cn into the white list.

Mr. Jianfang Zhang  is copied. (Thanks a lot!)

Best Regards

Jiankang Yao

发件人： Jianfang Zhang
发送时间： 2021-02-18 17:16
收件人： [email-masked]; 'Jiankang Yao'; 'IAB'; 'LAMPS'
主题： 转发: IETF Liaison Statement to ISO/TC 154 about ISO 14533-4
_____________________________________________
发件人: Jianfang Zhang <[email-masked]>
发送时间: 2021年2月18日 7:52
收件人: 'IAB Chair' <[email-masked]>; 'Peter Rybár' <[email-masked]>
抄送: [email-masked]' <[email-masked]>; 'IAB' <[email-masked]>; 'LAMPS' <[email-masked]>; 'Roman D. Danyliw' <[email-masked]>; 'Russ Housley' <[email-masked]>; [email-masked]' <[email-masked]>; '茱滴' <[email-masked]>; [email-masked]' <[email-masked]>
主题: 答复: IETF Liaison Statement to ISO/TC 154 about ISO 14533-4
Dear Mr. Mirja Kühlewind (IAB Chair) 
Thank you for your email and for your interest to ISO/TC154.
The IAB has been notified that RFC 8954 may conflict with the way OCSP Nonce extension is used in ISO 14533-4.  We are writing to share that concern.  We understand that ISO 14533-4 places a non-random value in the OCSP Nonce that is larger than 32 octets.  This new size limitation may also impact other work by ISO/TC 154 that we are not aware of.
> Peter is the project leader of ISO 14533-4, and I also add him on the mail list. 
@Peter @Jasmine, could you please dispose the comment on the impact of RFC 8954(updated to RFC 6960) to ISO 14533? Thank you in advance.
We recognize that the IETF does not have a liaison relationship with ISO/TC 154; however, the IETF LAMPS Working Group would like to work with you to resolve this incompatibility in the best possible way.  If the establishment of a liaison relationship between the IETF and ISO/TC 154, then the IAB will coordinate the arrangement.  
> IETF is an external organization to ISO, and the attached form should be filled out by your side as per the clause 1.17 of ISO/IEC directives (https://www.iso.org/sites/directives/current/consolidated/index.xhtml#_idTextAnchor095).
After the formal application form is received, and then the following steps will be taken by ISO side: 
1) A CIB ballot will be initiated for the liaison request, and it requires approval of the application by two-thirds of the P-members voting.
2) With the approval of CIB ballot in TC154, the liaison request will be submitted to ISO/CS to check your organization eligibility. 
3) After checking the eligibility criteria, your organization and experts can be registered in ISO/TC154 as liaison membership. 
If you have any question, please feel free to contact me. Thanks. 
Best regards
Jianfang
ISO/TC 154 committee manager
<<...>> 
-----邮件原件-----
发件人: IAB Chair <[email-masked]> 
发送时间: 2021年2月13日 2:00
收件人: [email-masked]
抄送: [email-masked]; IAB <[email-masked]>; LAMPS <[email-masked]>; Roman D. Danyliw <[email-masked]>; Russ Housley <[email-masked]>; [email-masked]
主题: IETF Liaison Statement to ISO/TC 154 about ISO 14533-4
Dear ISO/TC 154, dear Mr Jianfang Zhang,
The Internet Architecture Board (IAB), which is handling the liaison management of the IETF, would like to make sure that you are aware of the recent work by the at IETF LAMPS Working group (https://datatracker.ietf.org/wg/lamps/about/).  The LAMPS WG is responsible for updates to IETF documents related to public key infrastructure (PKI), including the Online Certificate Status Protocol (OCSP). OCSP is specified in RFC 6960 (https://www.rfc-editor.org/rfc/rfc6960.txt).  As part of the work of the LAMPS Working Group, RFC 8954 (https://www.rfc-editor.org/rfc/rfc8954.txt) was published as an update to RFC 6960, which limits the size of the OCSP Nonce extension to 32 octets to make the OCSP transactions more secure.  The OCSP Nonce is a randomly generated value that cryptographically binds a request and a response to prevent replay attacks.
The IAB has been notified that RFC 8954 may conflict with the way OCSP Nonce extension is used in ISO 14533-4.  We are writing to share that concern.  We understand that ISO 14533-4 places a non-random value in the OCSP Nonce that is larger than 32 octets.  This new size limitation may also impact other work by ISO/TC 154 that we are not aware of.
We had a discussion about the use case in the LAMPS Working Group recently. Based on how the OCSP nonce extension is used in the industry, it was recommended that a new OCSP extension should be used for the purpose of capturing OCSP response for long term validation of the signed documents.
We recognize that the IETF does not have a liaison relationship with ISO/TC 154; however, the IETF LAMPS Working Group would like to work with you to resolve this incompatibility in the best possible way.  If the establishment of a liaison relationship between the IETF and ISO/TC 154, then the IAB will coordinate the arrangement.
Thank you for your attention in this matter.
On behalf of the IAB,
Mirja Kühlewind (IAB Chair)

---

From: Jay Daley <[email-masked]>
Date: Fri, 19 Feb 2021 08:24:03 +1300

Jiankang

> On 18/02/2021, at 11:05 PM, Jiankang Yao <[email-masked]> wrote:
> 
> Hello IAB Chair and all,
> [email-masked] <mailto:[email-masked]>  [email-masked] <mailto:[email-masked]> and [email-masked] <mailto:[email-masked]>, and copy to some ISO friends. But the email is bounced back  by these email servers.
> Then Mr. Jianfang Zhang  tries again and forwards it to me and [email-masked] <mailto:[email-masked]> [email-masked] <mailto:[email-masked]> and [email-masked] <mailto:[email-masked]>.
> We may need to ask the email server administrator to help to put  [email-masked] <mailto:[email-masked]>  or cnis.ac.cn <http://cnis.ac.cn/> into the white list.

When the IETF email servers receive an email from an email address they have never seen before, they respond to that email address asking for the poster to confirm they are genuine.  When the sender confirms, by following the instructions in the email, they are then automatically whitelisted.

kind regards
Jay

> 发件人： Jianfang Zhang <mailto:[email-masked]>
> 发送时间： 2021-02-18 17:16
> 收件人： [email-masked] <mailto:[email-masked]>; 'Jiankang Yao' <mailto:[email-masked]>; 'IAB' <mailto:[email-masked]>; 'LAMPS' <mailto:[email-masked]>
> 发件人: Jianfang Zhang <[email-masked] <mailto:[email-masked]>>
> 发送时间: 2021年2月18日 7:52
> 收件人: 'IAB Chair' <[email-masked] <mailto:[email-masked]>>; 'Peter Rybár' <[email-masked] <mailto:[email-masked]>>
> 抄送: [email-masked] <mailto:[email-masked]>' <[email-masked] <mailto:[email-masked]>>; 'IAB' <[email-masked] <mailto:[email-masked]>>; 'LAMPS' <[email-masked] <mailto:[email-masked]>>; 'Roman D. Danyliw' <[email-masked] <mailto:[email-masked]>>; 'Russ Housley' <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>' <[email-masked] <mailto:[email-masked]>>; '茱滴' <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>' <[email-masked] <mailto:[email-masked]>>
> > IETF is an external organization to ISO, and the attached form should be filled out by your side as per the clause 1.17 of ISO/IEC directives (https://www.iso.org/sites/directives/current/consolidated/index.xhtml#_idTextAnchor095 <https://www.iso.org/sites/directives/current/consolidated/index.xhtml#_idTextAnchor095>).
> 发件人: IAB Chair <[email-masked] <mailto:[email-masked]>> 
> 发送时间: 2021年2月13日 2:00
> 收件人: [email-masked] <mailto:[email-masked]>
> 抄送: [email-masked] <mailto:[email-masked]>; IAB <[email-masked] <mailto:[email-masked]>>; LAMPS <[email-masked] <mailto:[email-masked]>>; Roman D. Danyliw <[email-masked] <mailto:[email-masked]>>; Russ Housley <[email-masked] <mailto:[email-masked]>>;[email-masked] <mailto:[email-masked]>
> The Internet Architecture Board (IAB), which is handling the liaison management of the IETF, would like to make sure that you are aware of the recent work by the at IETF LAMPS Working group (https://datatracker.ietf.org/wg/lamps/about/ <https://datatracker.ietf.org/wg/lamps/about/>).  The LAMPS WG is responsible for updates to IETF documents related to public key infrastructure (PKI), including the Online Certificate Status Protocol (OCSP). OCSP is specified in RFC 6960 (https://www.rfc-editor.org/rfc/rfc6960.txt <https://www.rfc-editor.org/rfc/rfc6960.txt>).  As part of the work of the LAMPS Working Group, RFC 8954 (https://www.rfc-editor.org/rfc/rfc8954.txt <https://www.rfc-editor.org/rfc/rfc8954.txt>) was published as an update to RFC 6960, which limits the size of the OCSP Nonce extension to 32 octets to make the OCSP transactions more secure.  The OCSP Nonce is a randomly generated value that cryptographically binds a request and a response to prevent replay attacks.
> <Form__Application_to_establish_a_liaison_.doc_>

-- 
Jay Daley
IETF Executive Director
[email-masked]