Subject: Re: [lamps] I-D Action: draft-ietf-lamps-cmp-algorithms-08.txt

From: Roman Danyliw <[email-masked]>
Date: Mon, 10 Jan 2022 22:18:01 +0000

Hi Hendrik!

I wanted to confirm that -08 addressed my AD Review.

-09 still has markers of the form "< ToDo: This note must be checked and confirmed by experts.>"  What's the thinking on those reviews?

Regards,
Roman

> -----Original Message-----
> From: Brockhaus, Hendrik <[email-masked]>
> Sent: Wednesday, December 15, 2021 8:52 AM
> To: Roman Danyliw <[email-masked]>; [email-masked]; Russ Housley
> <[email-masked]>
> Cc: [email-masked]
> Subject: AW: [lamps] I-D Action: draft-ietf-lamps-cmp-algorithms-08.txt
> 
> Is there anything I can do about draft-ietf-lamps-cmp-algorithms-08?
> 
> Hendrik
> 
> > Von: Spasm <[email-masked]> Im Auftrag von Brockhaus, Hendrik
> > Gesendet: Mittwoch, 17. November 2021 17:38
> >
> > We just submitted an update of CMP Algorithms draft addressing the
> > comments from Roman's AD review and the discussion at IETF 112.
> >
> > The authors appreciate any review comments, especially on the tables
> > in Section 7 and the Sections on SHAKE and KMAC usage.
> > @Quynh, Thank you for offering your expertise on this.
> >
> >    From version 07 -> 08:
> >
> >    *  Fixing issues from WG and AD review
> >    *  Adding Note to Section 2.2, 3.3, and 6.2.3 regarding usage of
> >       SHAKE and KMAC and added ToDo regarding checking respective notes
> >    *  Added two tables showing algorithms sorted by their strength to
> >       Section 7 and added ToDo regarding checking theses tables
> >    *  Updates the algorithm use profile in Section 7.1
> >    *  Updated and added security consideration on SHAKE,
> >       PasswordBasedMac, KMAC, and symmetric key-based MAC functions and
> >       added ToDo regarding checking the security consideration on
> > SHAKE
> >
> > Hendrik
> >
> > > Von: Spasm <[email-masked]> Im Auftrag von internet-
> > > [email-masked]
> > > Gesendet: Mittwoch, 17. November 2021 17:19
> > >
> > >
> > > A New Internet-Draft is available from the on-line Internet-Drafts
> > directories.
> > > This draft is a work item of the Limited Additional Mechanisms for
> > > PKIX and SMIME WG of the IETF.
> > >
> > >         Title           : Certificate Management Protocol (CMP) Algorithms
> > >         Authors         : Hendrik Brockhaus
> > >                           Hans Aschauer
> > >                           Mike Ounsworth
> > >                           John Gray
> > > 	Filename        : draft-ietf-lamps-cmp-algorithms-08.txt
> > > 	Pages           : 33
> > > 	Date            : 2021-11-17
> > >
> > > Abstract:
> > >    This document updates RFC 4210 describing the conventions for using
> > >    concrete cryptographic algorithms with the Certificate Management
> > >    Protocol (CMP).  CMP is used to enroll and further manage the
> > >    lifecycle of X.509 certificates.
> > >
> > >
> > > The IETF datatracker status page for this draft is:
> > > https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fda
> > > ta
> > > tr
> > > acker.ietf.org%2Fdoc%2Fdraft-ietf-lamps-cmp-
> > >
> > algorithms%2F&amp;data=04%7C01%7Chendrik.brockhaus%40siemens.com
> > >
> >
> %7C5ea8a0eb3dfa4bcf9bc908d9a9e62669%7C38ae3bcd95794fd4addab42e14
> > >
> >
> 95d55a%7C1%7C0%7C637727628230195738%7CUnknown%7CTWFpbGZsb3d
> > >
> >
> 8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D
> > >
> >
> %7C3000&amp;sdata=5He4lH8c%2FAJq6ayV3oREbVnRcOO%2BVXqSnhR6Q6G
> > > iths%3D&amp;reserved=0
> > >
> > > There is also an HTML version available at:
> > >
> > https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.
> > >
> >
> i%2F&amp;data=04%7C01%7Chendrik.brockhaus%40siemens.com%7Ca549af
> > eec5e1
> > >
> >
> 4a21e7df08d9a9e8a7d5%7C38ae3bcd95794fd4addab42e1495d55a%7C1%7C0
> > %7C6377
> > >
> >
> 27638996391296%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLC
> > JQIjoiV2l
> > >
> >
> uMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=PjR2D1U%2B1
> > H24aJ7
> > > ID0NyL9xAluhEQ%2F8dsbDSgf68j1I%3D&amp;reserved=0
> > > etf.org%2Farchive%2Fid%2Fdraft-ietf-lamps-cmp-algorithms-
> > >
> > 08.html&amp;data=04%7C01%7Chendrik.brockhaus%40siemens.com%7C5ea
> > >
> >
> 8a0eb3dfa4bcf9bc908d9a9e62669%7C38ae3bcd95794fd4addab42e1495d55a
> > >
> >
> %7C1%7C0%7C637727628230195738%7CUnknown%7CTWFpbGZsb3d8eyJWIj
> > >
> >
> oiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C30
> > >
> >
> 00&amp;sdata=xiboY9LJwa9SggJQCLw62wanImVr599ykORtaKdANsQ%3D&am
> > > p;reserved=0
> > >
> > > A diff from the previous version is available at:
> > >
> > https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.
> > >
> >
> i%2F&amp;data=04%7C01%7Chendrik.brockhaus%40siemens.com%7Ca549af
> > eec5e1
> > >
> >
> 4a21e7df08d9a9e8a7d5%7C38ae3bcd95794fd4addab42e1495d55a%7C1%7C0
> > %7C6377
> > >
> >
> 27638996401290%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLC
> > JQIjoiV2l
> > >
> >
> uMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=Zooi7TSEyYlzp
> > OvkP
> > > 2E1mKUBI%2BogMYNyoFPhBmKTmpQ%3D&amp;reserved=0
> > > etf.org%2Frfcdiff%3Furl2%3Ddraft-ietf-lamps-cmp-algorithms-
> > >
> > 08&amp;data=04%7C01%7Chendrik.brockhaus%40siemens.com%7C5ea8a0e
> > >
> >
> b3dfa4bcf9bc908d9a9e62669%7C38ae3bcd95794fd4addab42e1495d55a%7C1
> > >
> >
> %7C0%7C637727628230195738%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC
> > >
> >
> 4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&a
> > >
> >
> mp;sdata=RdKY3lRt6uiBQfNp9dYX5cS7xePhxQmjLAj4Oafc%2Brs%3D&amp;res
> > > erved=0
> > >
> > >
> > > Internet-Drafts are also available by anonymous FTP at:
> > > https://eur01.safelinks.protection.outlook.com/?url=ftp%3A%2F%2Fftp.
> > > ie
> > >
> > tf.o%2F&amp;data=04%7C01%7Chendrik.brockhaus%40siemens.com%7Ca54
> > 9afeec
> > >
> >
> 5e14a21e7df08d9a9e8a7d5%7C38ae3bcd95794fd4addab42e1495d55a%7C1%
> > 7C0%7C6
> > >
> >
> 37727638996401290%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMD
> > AiLCJQIjoi
> > >
> >
> V2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=vMTxQS%2
> > F549W%
> > > 2BipLGQJIBd8jFqp0r51iM6gAX56aCF2w%3D&amp;reserved=0
> > > rg%2Finternet-
> > >
> > drafts%2F&amp;data=04%7C01%7Chendrik.brockhaus%40siemens.com%7C5
> > >
> >
> ea8a0eb3dfa4bcf9bc908d9a9e62669%7C38ae3bcd95794fd4addab42e1495d5
> > >
> 5a%7C1%7C0%7C637727628230195738%7CUnknown%7CTWFpbGZsb3d8eyJ
> > >
> >
> WIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C
> > >
> > 3000&amp;sdata=zXSo0IODxSjpyyd7Ex1bTIJa4FyhAFgRodftcPbhQo4%3D&am
> > > p;reserved=0
> > >
> > >
> > > _______________________________________________
> > > Spasm mailing list
> > > [email-masked]
> > >
> > https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.
> > >
> >
> i%2F&amp;data=04%7C01%7Chendrik.brockhaus%40siemens.com%7Ca549af
> > eec5e1
> > >
> >
> 4a21e7df08d9a9e8a7d5%7C38ae3bcd95794fd4addab42e1495d55a%7C1%7C0
> > %7C6377
> > >
> >
> 27638996401290%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLC
> > JQIjoiV2l
> > >
> >
> uMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=Zooi7TSEyYlzp
> > OvkP
> > > 2E1mKUBI%2BogMYNyoFPhBmKTmpQ%3D&amp;reserved=0
> > >
> > etf.org%2Fmailman%2Flistinfo%2Fspasm&amp;data=04%7C01%7Chendrik.br
> > >
> >
> ockhaus%40siemens.com%7C5ea8a0eb3dfa4bcf9bc908d9a9e62669%7C38ae3
> > >
> >
> bcd95794fd4addab42e1495d55a%7C1%7C0%7C637727628230195738%7CUn
> k
> > >
> >
> nown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1
> > >
> >
> haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=L%2BWY9ufwnckvUswk7Gtl0h
> > > hvT%2B86SZXVT3g7%2FjSpIrI%3D&amp;reserved=0
> >
> > _______________________________________________
> > Spasm mailing list
> > [email-masked]
> > https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.
> > i
> etf.org%2Fmailman%2Flistinfo%2Fspasm&amp;data=04%7C01%7Chendrik.br
> >
> ockhaus%40siemens.com%7Ca549afeec5e14a21e7df08d9a9e8a7d5%7C38ae3
> >
> bcd95794fd4addab42e1495d55a%7C1%7C0%7C637727638996401290%7CUn
> k
> >
> nown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1
> > haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=XjOViJ8kLqlF5AojBwsB3Ynicjn
> > A%2BjB9xzeuElQQ4C0%3D&amp;reserved=0

---

From: "Brockhaus, Hendrik" <[email-masked]>
Date: Tue, 11 Jan 2022 07:32:33 +0000

Hello Roman

Thank you very much for your feedback.

The marks refer to the discussion that took place at IETF 112 in the chat about how the use of SHAKE was described. 
>From that discussion, I understand that Quynh offered a review of the I-D that provides the needed changes.
After the meeting, the authors looked more deeply into the use of hash algorithms in CMP and proposed these updates. 
We welcome any review and feedback.

@Quyhn, if I misunderstood you, please accept my apologies.

Hendrik

> Von: Roman Danyliw <[email-masked]>
> Gesendet: Montag, 10. Januar 2022 23:18
> 
> Hi Hendrik!
> 
> -09 still has markers of the form "< ToDo: This note must be checked and
> confirmed by experts.>"  What's the thinking on those reviews?
> 
> Regards,
> Roman
>

---

From: Roman Danyliw <[email-masked]>
Date: Tue, 11 Jan 2022 17:59:55 +0000

Hi Hendrik!

Understood.  We'll wait for the WG review of the edits (per Quyhn) and then a revision minimally to remove the "TODO stubs".

Thanks,
Roman

> Sent: Tuesday, January 11, 2022 2:33 AM
> To: Roman Danyliw <[email-masked]>; [email-masked]
> Cc: [email-masked]; Russ Housley <[email-masked]>
> After the meeting, the authors looked more deeply into the use of hash
> algorithms in CMP and proposed these updates.
> > -09 still has markers of the form "< ToDo: This note must be checked
> > and confirmed by experts.>"  What's the thinking on those reviews?
> >
> > Regards,
> > Roman
> >
> > > > The authors appreciate any review comments, especially on the
> > > > tables in Section 7 and the Sections on SHAKE and KMAC usage.
> > > >       PasswordBasedMac, KMAC, and symmetric key-based MAC
> > > > functions
> > and
> > > > > This draft is a work item of the Limited Additional Mechanisms
> > > > > for PKIX and SMIME WG of the IETF.
> > > > >
> > > > > https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%
> > > > > 2F
> > > > > da
> > > > > ta
> > > > > tr