Subject: [lamps] Fwd: New Version Notification for draft-mtis-lamps-8410-ku-clarifications-00.txt

From: Sean Turner <[email-masked]>
Date: Wed, 12 Jan 2022 14:59:16 -0500

LAMPS,

Hi! While Ito-san and I were working on RFC 8813 (nee draft-ietf-lamps-5480-ku-clarifications, nee draft-turner-5480-ku-clarifications), Daniel McCarney asked whether we should write the same kind of clarifications for RFC 8410 [1] (algorithm identifiers for Ed25519, Ed448, X25519, and X448 in certificates). I had a look and exchanged some emails with Simon and it seems like it would be good to make sure there were the same clarifications for the x25519 and x448 identifiers that we had for the other identifiers … so we produced this I-D.

Note: I am forwarding this I-D to LAMPS for consideration and not curdle knowing that curdle is planning to close. I also alerted the chairs and am cc’ing curdle so nobody is surprised.  As this is basically, a do-over of RFC 8410 I am hoping that adopting/progressing this I-D will be non-controversial.

Cheers,
spt

[1] https://datatracker.ietf.org/doc/rfc8410/

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: New Version Notification for draft-mtis-lamps-8410-ku-clarifications-00.txt
> Date: January 12, 2022 at 01:15:39 EST
> To: "Daniel McCarney" <[email-masked]>, "Sean Turner" <[email-masked]>, "Simon Josefsson" <[email-masked]>, "Tadahiko Ito" <[email-masked]>
> 
> 
> A new version of I-D, draft-mtis-lamps-8410-ku-clarifications-00.txt
> has been successfully submitted by Sean Turner and posted to the
> IETF repository.
> 
> Name:		draft-mtis-lamps-8410-ku-clarifications
> Revision:	00
> Title:		Clarifications for Ed25519, Ed448, X25519, and X448 Algorithm Identifiers
> Document date:	2022-01-12
> Group:		Individual Submission
> Pages:		6
> URL:            https://www.ietf.org/archive/id/draft-mtis-lamps-8410-ku-clarifications-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-mtis-lamps-8410-ku-clarifications/
> Html:           https://www.ietf.org/archive/id/draft-mtis-lamps-8410-ku-clarifications-00.html
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-mtis-lamps-8410-ku-clarifications
> 
> 
> Abstract:
>   This document updates RFC 8410 to clarify existing and specify
>   missing semantics for key usage bits when used in certificates that
>   support the Ed25519, Ed448, X25519, and X448 Elliptic Curve
>   Cryptography algorithms.
> 
> 
> 
> 
> The IETF Secretariat
> 
>

---

From: Russ Housley <[email-masked]>
Date: Wed, 12 Jan 2022 15:55:59 -0500

Sean:

I think that id-Ed25519 or id-Ed448 need to allow keyCertSign as well.  Otherwise, a CA could not use these signature algorithms.

Russ

> On Jan 12, 2022, at 2:59 PM, Sean Turner <[email-masked]> wrote:
> 
> LAMPS,
> 
> [1] https://datatracker.ietf.org/doc/rfc8410/ <https://datatracker.ietf.org/doc/rfc8410/>
> 
>> Begin forwarded message:
>> 
>> From: [email-masked] <mailto:[email-masked]>
>> To: "Daniel McCarney" <[email-masked] <mailto:[email-masked]>>, "Sean Turner" <[email-masked] <mailto:[email-masked]>>, "Simon Josefsson" <[email-masked] <mailto:[email-masked]>>, "Tadahiko Ito" <[email-masked] <mailto:[email-masked]>>
>> 
>> 
>> URL:            https://www.ietf.org/archive/id/draft-mtis-lamps-8410-ku-clarifications-00.txt <https://www.ietf.org/archive/id/draft-mtis-lamps-8410-ku-clarifications-00.txt>
>> Status:         https://datatracker.ietf.org/doc/draft-mtis-lamps-8410-ku-clarifications/ <https://datatracker.ietf.org/doc/draft-mtis-lamps-8410-ku-clarifications/>
>> Html:           https://www.ietf.org/archive/id/draft-mtis-lamps-8410-ku-clarifications-00.html <https://www.ietf.org/archive/id/draft-mtis-lamps-8410-ku-clarifications-00.html>
>> Htmlized:       https://datatracker.ietf.org/doc/html/draft-mtis-lamps-8410-ku-clarifications <https://datatracker.ietf.org/doc/html/draft-mtis-lamps-8410-ku-clarifications>
>> 
>> 
>> Abstract:
> _______________________________________________
> Curdle mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/curdle

---

From: Sean Turner <[email-masked]>
Date: Thu, 13 Jan 2022 23:07:31 -0500

It does, it’s just in the prose before the list:

      If the keyUsage extension is present in a certification authority
      certificate that indicates id-Ed25519 or id-Ed448 in
      SubjectPublicKeyInfo, then the keyUsage extension MUST contain
->   keyCertSign, and zero, or more of the following:

spt

> On Jan 12, 2022, at 15:55, Russ Housley <[email-masked]> wrote:
> 
> Sean:
>

---

From: Sean Turner <[email-masked]>
Date: Fri, 14 Jan 2022 11:34:48 -0500

A couple of people have noted the same thing off list so created the following PR to resolve the issue:
https://github.com/seanturner/draft-mtis-lamps-8410-ku-clarifications/pull/2

spt

> On Jan 13, 2022, at 23:07, Sean Turner <[email-masked]> wrote:
>