Subject: [spb-isis] Spirent SPB testing

From: "Garimella, Pavani" <[email-masked]>
Date: Fri, 24 Jun 2011 15:45:49 -0700

Hello All, 

This week we were successfully able to demonstrate Spirent’s SPB implementation with Huawei and Alcatel Lucent switches in Ottawa and Calabasas respectively. The  topology included 25 simulated nodes behind emulated router  (network diagram attached). The switches established adjacencies and calculated shortest path trees for the nodes.Please find the console output from Huawei switch and the corresponding capture. 

So far from the preliminary tests and results, looks like we are good to go for the interop testing next week. 

Thanks,
Pavani 

<DIV><FONT size="1">

E-mail confidentiality.
--------------------------------
This e-mail contains confidential and / or privileged information belonging to Spirent Communications plc, its affiliates and / or subsidiaries. If you are not the intended recipient, you are hereby notified that any disclosure, copying, distribution and / or the taking of any action based upon reliance on the contents of this transmission is strictly forbidden. If you have received this message in error please notify the sender by return e-mail and delete it from your system.

Spirent Communications plc
Northwood Park, Gatwick Road, Crawley, West Sussex, RH10 9XN, United Kingdom.
Tel No. +44 (0) 1293 767676
Fax No. +44 (0) 1293 767677

Registered in England Number 470893
Registered at Northwood Park, Gatwick Road, Crawley, West Sussex, RH10 9XN, United Kingdom.

Or if within the US,

Spirent Communications,
26750 Agoura Road, Calabasas, CA, 91302, USA.
Tel No. 1-818-676- 2300 

</FONT></DIV>

---

From: Peter Ashwood-Smith <[email-masked]>
Date: Fri, 24 Jun 2011 21:31:51 -0400

Hey Pavani,

Thanks yes, that those forwarding tables and lsdb dumps look correct as far
as I can tell. 

One thing, we (and I think the ERS) will display fib's etc. with the
hostname instead of the sysid where we can for readability. I think you are
advertising the hostname as just an ascii version of the sysid? So our
console displays show the sysid twice .. which makes for harder debugging.
Any chance you could make the sysid's something a bit more informative, i.e.
spirent-1, spirent-2 .. something like that?

Oh, on Monday I'll put up a static IP where you guys can telnet to have a
peek at the cli's of the different devices. I'll send out the address and
telnet userid/password on Monday so those of you not on site should be able
to see the network grow as we plug in and turn on the emulators.

Cheers,

Peter

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Garimella, Pavani
Sent: Friday, June 24, 2011 6:46 PM
To: [email-masked]
Subject: [spb-isis] Spirent SPB testing

Hello All,

This week we were successfully able to demonstrate Spirent's SPB
implementation with Huawei and Alcatel Lucent switches in Ottawa and
Calabasas respectively. The  topology included 25 simulated nodes behind
emulated router  (network diagram attached). The switches established
adjacencies and calculated shortest path trees for the nodes.Please find the
console output from Huawei switch and the corresponding capture.

So far from the preliminary tests and results, looks like we are good to go
for the interop testing next week.

Thanks,
Pavani

E-mail confidentiality.
--------------------------------
This e-mail contains confidential and / or privileged information belonging
to Spirent Communications plc, its affiliates and / or subsidiaries. If you
are not the intended recipient, you are hereby notified that any disclosure,
copying, distribution and / or the taking of any action based upon reliance
on the contents of this transmission is strictly forbidden. If you have
received this message in error please notify the sender by return e-mail and
delete it from your system.

Spirent Communications plc
Northwood Park, Gatwick Road, Crawley, West Sussex, RH10 9XN, United
Kingdom.
Tel No. +44 (0) 1293 767676
Fax No. +44 (0) 1293 767677

Registered in England Number 470893
Registered at Northwood Park, Gatwick Road, Crawley, West Sussex, RH10 9XN,
United Kingdom.

Or if within the US,

Spirent Communications,

---

From: "Garimella, Pavani" <[email-masked]>
Date: Fri, 24 Jun 2011 20:12:54 -0700

From: Peter Ashwood-Smith [mailto:[email-masked]] 
Sent: Friday, June 24, 2011 06:31 PM
To: [email-masked] <[email-masked]> 
Subject: Re: [spb-isis] Spirent SPB testing 

Hey Pavani,

Thanks yes, that those forwarding tables and lsdb dumps look correct as far as I can tell. 

One thing, we (and I think the ERS) will display fib’s etc. with the hostname instead of the sysid where we can for readability. I think you are advertising the hostname as just an ascii version of the sysid? So our console displays show the sysid twice .. which makes for harder debugging. Any chance you could make the sysid’s something a bit more informative, i.e. spirent-1, spirent-2 .. something like that?

Oh, on Monday I’ll put up a static IP where you guys can telnet to have a peek at the cli’s of the different devices. I’ll send out the address and telnet userid/password on Monday so those of you not on site should be able to see the network grow as we plug in and turn on the emulators.

Cheers,

Peter

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of Garimella, Pavani
Sent: Friday, June 24, 2011 6:46 PM
To: [email-masked]
Subject: [spb-isis] Spirent SPB testing

Hello All,

Thanks,
Pavani

E-mail confidentiality.

Or if within the US,

Spirent Communications,

<DIV><FONT size="1">

E-mail confidentiality.

Or if within the US,

Spirent Communications,

</FONT></DIV>

---

From: Peter Ashwood-Smith <[email-masked]>
Date: Mon, 27 Jun 2011 12:45:38 -0400

Avaya switch is in the lab, we are configuring it now.

Solant is in the lab and up properly formed adjacency and showing the 7 node
network on its display.

Spirent will be in shortly.

Peter

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Peter Ashwood-Smith
Sent: Friday, June 24, 2011 9:32 PM
To: [email-masked]
Subject: Re: [spb-isis] Spirent SPB testing

Hey Pavani,

Cheers,

Peter

  _____  

Hello All,

Thanks,
Pavani

E-mail confidentiality.

Or if within the US,

Spirent Communications,

---

From: Peter Ashwood-Smith <[email-masked]>
Date: Mon, 27 Jun 2011 13:56:07 -0400

Avaya switch joined network no problem.

Spirent connect to Huawei no problem.

Testing Avaya to Spirent now.

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Peter Ashwood-Smith
Sent: Monday, June 27, 2011 12:46 PM
To: [email-masked]
Subject: [spb-isis] SPB - interop - status

Peter

  _____  

Hey Pavani,

Cheers,

Peter

  _____  

Hello All,

Thanks,
Pavani

E-mail confidentiality.

Or if within the US,

Spirent Communications,

---

From: Peter Ashwood-Smith <[email-masked]>
Date: Mon, 27 Jun 2011 15:31:45 -0400

Currently seeing 10 physical nodes and 52 emulated nodes.

52 from Spirent, 26 per port.

1  Avaya

1 Solana

8 Huawei 

We have two isids configured with 4 attachment points (or so, I'm loosing
track), unicast and multicast fibs look ok

 and are pinging over the isids without problems.

<ottawa-9303-1>d spb status

SPB Status:

    mode SPBM, nodes 62, links 138, adj 2, ufib 122, mfib 2

    Collision:

Attached is some console port trace. The Solana device drew the topology but
we are having trouble capturing it but will send a picture of the capture.

We are hoping to do a webx on Thursday I imagine and with luck will be able
to share consoles etc.

Will configure the static ip shortly for others to view overnight.

Peter

---

From: Biswajit Nandy <[email-masked]>
Date: Mon, 27 Jun 2011 15:44:01 -0400

Peter,

 From the Solana Management Client,
click on File menu item and select Save as Image.
Choose appropriate directory to save on.

You can copy it on a USB stick.

Thanks.

Bis Nandy

On 6/27/2011 3:31 PM, Peter Ashwood-Smith wrote:
> We have two isids configured with 4 attachment points (or so, I'm 
> loosing track), unicast and multicast fibs look ok
>
> Attached is some console port trace. The Solana device drew the 
> topology but we are having trouble capturing it but will send a 
> picture of the capture.
>
> We are hoping to do a webx on Thursday I imagine and with luck will be 
> able to share consoles etc.
>
> _______________________________________________
> spb-isis mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spb-isis

---

From: Peter Ashwood-Smith <[email-masked]>
Date: Mon, 27 Jun 2011 17:20:02 -0400

WARNING: contains banned part

Subject: RE: [spb-isis] SPB - interop - status - solana smart hawk passive display working
From: Peter Ashwood-Smith <[email-masked]>
To: [email-masked]
Date: Mon, 27 Jun 2011 17:20:02 -0400

We brought down the Spirent, because it needs a laptop to drive it, and
Stephan took his laptop home. ;)

So we fired up the other 802.1aq emulator. Here is the 9 physical (the 10th
physical is the Solana device itself (passive)) + 6 emulated nodes.

The Avaya device ERS is on the lower right.

This is as captured and drawn by the Solana. 

Peter

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Peter Ashwood-Smith
Sent: Monday, June 27, 2011 3:32 PM
To: [email-masked]
Subject: Re: [spb-isis] SPB - interop - status - 62 nodes two console traces
attached

1  Avaya

1 Solana

8 Huawei 

SPB Status:

    Collision:

Peter

---

From: Peter Ashwood-Smith <[email-masked]>
Date: Tue, 28 Jun 2011 14:38:12 -0400

SPB Status:
    mode SPBM, nodes 91, links 212, adj 5, ufib 180, mfib 28

Waiting for ALU .. hopefully tomorrow?

Peter

---

From: Peter Ashwood-Smith <[email-masked]>
Date: Tue, 28 Jun 2011 16:54:59 -0400

Just finishing up for today. Stable at 91 nodes. 
We experimented around with different link metrics and the BridgePriorities
today.

Noted some problems with metric displays and honoring of BridgePriorities

Will send static IP information to those of you doing development so you can
log on to your switches tonight.

Peter

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Peter Ashwood-Smith
Sent: Tuesday, June 28, 2011 2:38 PM
To: [email-masked]
Subject: [spb-isis] SPB interop - 92 nodes 212 links ..

SPB Status:

Peter

---

From: Peter Ashwood-Smith <[email-masked]>
Date: Wed, 29 Jun 2011 16:13:05 -0400

Sorry for the delay getting an update. We were playing how many engineers
does it take to make an RS232 cable to USB serial port adapter ;) We are
embarrased at the answer.

Anyway we now have 186 nodes including the ALU Omniswitch which happily
formed SPB adjacencies with the Avaya and the Huawei and the Spirent while
the Solana passive NNI box is happily displaying the SPB topology. 

We are just configuring the ALU to join an ISID and start looking at the
routing.

Fun fun ..

Peter/John/Stephan and Edgard

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Peter Ashwood-Smith
Sent: Tuesday, June 28, 2011 4:55 PM
To: [email-masked]
Subject: Re: [spb-isis] SPB interop - 92 nodes 212 links ..

Peter

-----Original Message-----

SPB Status:

Peter

---

From: Peter Ashwood-Smith <[email-masked]>
Date: Wed, 29 Jun 2011 21:16:22 -0400

The network should be accessible by telnet about 9:30pm EDT to about 9:00am
EDT at address/userid/password provided previously.

Currently stable at 186 nodes. EG:

<ottawa-s9300-6> d spb status
SPB Status:
    mode SPBM, nodes 187, links 412, adj 6, ufib 372, mfib 45
    Collision:

The ALU switch is in the network called 'omniswitch' and is now advertising
ISIDs correctly and transit unicast and multicast appears correct.

The routing seems ok but its hard to tell with such a big network. Here is a
route crossing three vendor switches.

<ottawa-s9300-6>d spb uroute omniswitch s9303-1 vlan 40
PATH:
  omniswitch -> ERS-6 -> s9303-6 -> s9303-1

Picture attached, ignore red status on links which I think is incorrect. 

Peter/John/Edgard/Stephan

-----Original Message-----

Peter

-----Original Message-----

SPB Status:

Peter

---

From: Peter Ashwood-Smith <[email-masked]>
Date: Thu, 30 Jun 2011 11:35:03 -0400

Topic:  SPB IS-IS Interoperability
Date:   Thursday, June 30, 2011
Time:   3:00 pm, Eastern Daylight Time (New York, GMT-04:00)
Meeting Number: 751 926 328
Meeting Password:       TATA

For audio, please use Passcode # 325 184 7741
Dial-In Numbers
US/CAN Toll free: 1-800-230-5446
Int'l Toll: 1-416-847-3362
 
For Webex
 
To join the online meeting (Now from mobile devices!)
-------------------------------------------------------
1.      Go to
https://tatacommunications.webex.com/tatacommunications/j.php?ED=154877682&U
ID=0&PW=NOTA3Nzc2NDQ0&RT=MiMxMQ%3D%3D
2.      If requested, enter your name and email address.
3.      If a password is required, enter the meeting password: TATA
4.      Click “Join”.
 
To view in other time zones or languages, please click the link:
https://tatacommunications.webex.com/tatacommunications/j.php?ED=154877682&U
ID=0&PW=NOTA3Nzc2NDQ0&ORT=MiMxMQ%3D%3D
 
-------------------------------------------------------
For assistance
-------------------------------------------------------
1.      Go to https://tatacommunications.webex.com/tatacommunications/mc
2.      On the left navigation bar, click “Support”.
 
You can contact me at:
[email-masked]
 
To add this meeting to your calendar program (for example Microsoft
Outlook), click this link:
https://tatacommunications.webex.com/tatacommunications/j.php?ED=154877682&U
ID=1158651797&ICS=MI&LD=1&RD=2&SHA2=-A2M62YzobuzZXCNfIPdzfwMEyTjZtbQGY3D5Go0
ZcY=&ST=1&RT=MiMxMQ%3D%3D
The playback of UCF (Universal Communications Format) rich media files
requires appropriate players. To view this type of rich media files in the
meeting, please check whether you have the players installed on your
computer by going to
https://tatacommunications.webex.com/tatacommunications/systemdiagnosis.php.

http://www.webex.com
We’ve got to start meeting like this™