Subject: [spb-isis] Solana SmartHawk discovers Huawei SPB Switch Topology

From: Biswajit Nandy <[email-masked]>
Date: Mon, 20 Jun 2011 16:28:22 -0400

Hi all,

Here is another step towards successful interoperability
testing. Solana's SmartHawk network monitoring product
is interoperable with Huawei SPB switches. The topology is
discovered and link up/sown is monitored.

It took us only about 30 minutes to setup, configure and create
adjacency with a Huawei SPB switch.

I am attaching two images:

1. A screen-shot of Solana's GUI with Huawei switch topology
2. A topology image with 6 Huawei SPB switches and 3 emulated switches.
     -- red link shows the link down.

We are hoping that it will be interoperable with other vendors as well.

Thanks Peter, for letting us install our appliance to your lab.
Also, your suggestion of "reflecting back" the SPB TLV in Hello worked.

Bis Nandy
Solana Networks

---

From: Peter Ashwood-Smith <[email-masked]>
Date: Mon, 20 Jun 2011 16:48:21 -0400

Hey Bis, 

No problem. Good to see it working in advance of the more elaborate interop
next week. 

One thing I should point out is that you guys reflected back the 143 TLV
contents in the Hello as a very simple way to avoid having to configure
adjacency information. Very nice method for a passive SPB tool to get a
quick and dirty adjacency.

I suggested the same thing to IXIA and Spirent  - i.e. mimic mode.

Look forward to giving your graphics front end a serious work out with a big
network next week!

Peter

  _____  

From: Biswajit Nandy [mailto:[email-masked]] 
Sent: Monday, June 20, 2011 4:28 PM
To: [email-masked]
Cc: Peter Ashwood-Smith; Rup Makkar
Subject: Solana SmartHawk discovers Huawei SPB Switch Topology

Hi all,

Bis Nandy
Solana Networks

---

From: "Vargas, Edgard (Edgard)" <[email-masked]>
Date: Tue, 21 Jun 2011 21:42:44 -0500

Hi Bis,

Do Solana plan to provide visualization of the trees as seen by each of the nodes for the different ECTs to illustrate the paths to reach any of the possible targets?

Are the link events tracked via ISIS updates or via snmp?

How fast the link state propagation happens?

Congrats on the test. Looking forward for the interop validation
Edgard

From: [email-masked] [mailto:[email-masked]] On Behalf Of Biswajit Nandy
Sent: Monday, June 20, 2011 1:28 PM
To: [email-masked]
Subject: [spb-isis] Solana SmartHawk discovers Huawei SPB Switch Topology

Hi all,

Bis Nandy
Solana Networks

---

From: Peter Ashwood-Smith <[email-masked]>
Date: Wed, 22 Jun 2011 08:59:21 -0400

Its actually pretty cool, you plug it into an NNI port and poof it discovers
and draws the network. It tracks link state through the LSPs via the NNI.
Basically it just listens to the link state updates so its as fast as IS-IS.
No SNMP.

I don't think they will have ECT tree drawing for this interop but we were
discussing it in the lab yesterday, once they have the data of course its
not too hard to add lots of useful bells and whistles.

Peter

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Vargas, Edgard (Edgard)
Sent: Tuesday, June 21, 2011 10:43 PM
To: Biswajit Nandy; [email-masked]
Subject: Re: [spb-isis] Solana SmartHawk discovers Huawei SPB Switch
Topology

Hi Bis,

Do Solana plan to provide visualization of the trees as seen by each of the
nodes for the different ECTs to illustrate the paths to reach any of the
possible targets?

Edgard

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Biswajit Nandy
Sent: Monday, June 20, 2011 1:28 PM
To: [email-masked]
Subject: [spb-isis] Solana SmartHawk discovers Huawei SPB Switch Topology

Hi all,

Bis Nandy
Solana Networks

---

From: Biswajit Nandy <[email-masked]>
Date: Wed, 22 Jun 2011 09:05:49 -0400

Edgar,

Currently, we discovers and  visualize switch topology. Also monitor 
each link.
Yes, we plan to bring visualization of trees for different ECTs in future.

All link events are tracked from ISIS updates. The link state propagation
happens as fast as seen by other nodes in the network.

Bis Nandy

On 6/21/2011 10:42 PM, Vargas, Edgard (Edgard) wrote:
>
> Hi Bis,
>
> Do Solana plan to provide visualization of the trees as seen by each 
> of the nodes for the different ECTs to illustrate the paths to reach 
> any of the possible targets?
>
> *From:[email-masked] [mailto:[email-masked]] 
> *On Behalf Of *Biswajit Nandy
> *Sent:* Monday, June 20, 2011 1:28 PM
> *To:* [email-masked]
> *Subject:* [spb-isis] Solana SmartHawk discovers Huawei SPB Switch 
> Topology
>
> Hi all,
>