Subject: Re: [Speechsc] Proposed resolutions for WGLC comments on

From: Scott Bradner <[email-masked]>
Date: Sun, 6 Oct 2002 20:10:52 -0400 (EDT)

humm, should this WG be making requirements for servers or for the protocol
to talk to servers?

   6.2.1  Plain Text
      The TTS Server MUST support the reading of plain text.  For reading
      plain text, the language and voicing MAY be indicated via session
      parameters. For finer control over such properties, use of SSML
      rather than plain text provides the necessary capabilities.

Scott
_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Eric Burger" <[email-masked]>
Date: Thu, 10 Oct 2002 16:37:54 -0400

Part of the problem is we are mixing the definition of what a TTS Server is
with the protocol.

How about:

The protocol MUST support requesting a TTS Server to read plain text.  For
reading plain text, the application MAY indicate language and voicing via
session parameters.  For finer control over such properties, the application
MAY use SSML.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf
> Of Scott Bradner
> Sent: Sunday, October 06, 2002 8:11 PM
> To: [email-masked]
> Subject: Re: [Speechsc] Proposed resolutions for WGLC comments on
>
>
>

---

From: "David R. Oran" <[email-masked]>
Date: Thu, 10 Oct 2002 17:15:31 -0400

--On Thursday, October 10, 2002 4:37 PM -0400 Eric Burger 
<[email-masked]> wrote:

> Part of the problem is we are mixing the definition of what a TTS Server
> is with the protocol.
>
> How about:
>
> session parameters.  For finer control over such properties, the
> application MAY use SSML.
>
I had a slightly different tack on fixing the problem:

"6.2.1 Plain Text

The SPEECHSC framework MAY assume that all TTS servers are capable of 
reading plain text. For reading plain text, framework MUST allow the 
language and voicing to be indicated via session parameters. For finer 
control over such properties, see 6.2.2

6.2.2 SSML

The SPEECHSC framework MUST support TTS servers capable of reading SSML[3] 
text."

For another example fix, here's a shot at the VCR controls:

"The Speechsc framework MUST support VCR controls, and MUST allow for 
servers with varying capabilities to accommodate such controls"

Which formulation to people like better?

Dave.

------------------------
David R. Oran
Cisco Systems
7 Ladyslipper Lane
Acton, MA 01720
Office: +1 978 264 2048
VoIP: +1 408 571 4576
Email: [email-masked]

---

From: Scott Bradner <[email-masked]>
Date: Fri, 11 Oct 2002 01:12:14 -0400 (EDT)

works for me

---

---

From: "Eric Burger" <[email-masked]>
Date: Thu, 10 Oct 2002 16:37:54 -0400

How about:

---

From: Scott Bradner <[email-masked]>
Date: Fri, 11 Oct 2002 01:16:27 -0400 (EDT)

this works for me (also)

---

---

From: "David R. Oran" <[email-masked]>
Date: Thu, 10 Oct 2002 17:15:31 -0400

"6.2.1 Plain Text

6.2.2 SSML

Dave.

------------------------
David R. Oran
Cisco Systems
7 Ladyslipper Lane
Acton, MA 01720
Office: +1 978 264 2048
VoIP: +1 408 571 4576
Email: [email-masked]