Subject: Re: [Speechsc] Regarding SPEECH MARKER

From: Arsen Chaloyan <[email-masked]>
Date: Wed, 16 Jan 2008 23:02:04 -0800 (PST)

Below is the reference from the specification

Section 8.13.
The SPEECH-MARKER event is also generated with a null marker value and output NTP timestamp, when a SPEAK request in Pending-State (i.e. in the queue) changes state to IN-PROGRESS and starts speaking.

However it's not so clear whether event  MUST be generated or  MAY be generated. I'll vote to use the keywords to reduce unambiguity.
HTH,
Arsen.

----- Original Message ----
From: Sharat <[email-masked]>
To: [email-masked]
Sent: Thursday, January 17, 2008 7:36:56 AM
Subject: [Speechsc] Regarding SPEECH MARKER

Hi
all,

Consider
the following scenarios for speechsynth.

1.

C->S:
SPEAK

S->C:
200 PENDING

S->C:
SPEAK-COMPLETE

2.

C->S:
SPEAK

S->C:
200 PENDING

S->C:
SPEECH-MARKER

S->C:
SPEAK-COMPLETE

Are
both the scenarios valid?

Regds,

__Sharat

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc
Supplemental web site:
&lt;http://www.standardstrack.com/ietf/speechsc&gt;

---

From: Sharat <[email-masked]>
Date: Thu, 17 Jan 2008 12:45:59 +0530

Yes, it is not clearly mentioned anywhere in the RFC, whether the event MUST
be generated or SHOULD be generated.

Because of this ambiguity the client doesn't know whether it will receive
SPEECH-MARKER or not from the server since it is dependent on the server
implementation.

As of now some of the mrcpv2 speechsynth servers support it and some
doesn't. So while implementing client could receive either SPEECH-MARKER or
SPEAK-COMPLETE in PENDING state.

The rfc also says 

"The NTP timestamp MUST be synchronized with the RTP timestamp used to
generate the speech stream through standard RTCP machinery."

So the SPEECH-MARKER event is required to clearly demarcate between the RTP
streams of two SPEAKs if queued in the same session.

So I feel the keyword "MUST"  has to be used.

Regards,

__Sharat

  _____  

From: Arsen Chaloyan [mailto:[email-masked]] 
Sent: Thursday, January 17, 2008 12:32 PM
To: [email-masked]
Cc: Sharat
Subject: Re: [Speechsc] Regarding SPEECH MARKER

Section 8.13.
The SPEECH-MARKER event is also generated with a null marker value and
output NTP timestamp, when a SPEAK request in Pending-State (i.e. in the
queue) changes state to IN-PROGRESS and starts speaking.

However it's not so clear whether event  MUST be generated or  MAY be
generated. I'll vote to use the keywords to reduce unambiguity.
HTH,
Arsen.

----- Original Message ----
From: Sharat <[email-masked]>
To: [email-masked]
Sent: Thursday, January 17, 2008 7:36:56 AM
Subject: [Speechsc] Regarding SPEECH MARKER

Hi all,

Consider the following scenarios for speechsynth.

1.

C->S: SPEAK

S->C: 200 PENDING

S->C: SPEAK-COMPLETE

2. 

C->S: SPEAK

S->C: 200 PENDING

S->C: SPEECH-MARKER

S->C: SPEAK-COMPLETE

Are both the scenarios valid?

Regds,

__Sharat