Subject: [Speechsc] Concurrent requests in the same MRCP session scope

From: Arsen Chaloyan <[email-masked]>
Date: Wed, 16 Jan 2008 00:41:56 -0800 (PST)

Can you please identify which from the following statements is true?
1. client MUST wait for a response 
before sending the next request in the same MRCP session scope
or
2. client MAY send the next request without waiting for a response in the same MRCP session scope

For example:
1. C->S: DEFINE-GRAMMAR [1]
    S->C: COMPLETE [1]
    C->S: RECOGNIZE [2]
   
S->C: IN-PROGRESS [2]

or

2. C->S: DEFINE-GRAMMAR [1]
   
C->S: RECOGNIZE [2]

S->C: COMPLETE [1]
    S->C: IN-PROGRESS [2]

Thanks,
Arsen.

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc
Supplemental web site:
&lt;http://www.standardstrack.com/ietf/speechsc&gt;

---

From: Manjunath <[email-masked]>
Date: Wed, 16 Jan 2008 14:22:29 +0530

Second Statement is true..

Regards

Manju

****************************************************************************
***********
This e-mail and attachments contain confidential information from HUAWEI,
which is intended only for the person or entity whose address is listed
above. Any use of the information contained herein in any way (including,
but not limited to, total or partial disclosure, reproduction, or
dissemination) by persons other than the intended recipient's) is
prohibited. If you receive this e-mail in error, please notify the sender by
phone or email immediately and delete it!

  _____  

From: Arsen Chaloyan [mailto:[email-masked]] 
Sent: Wednesday, January 16, 2008 2:12 PM
To: [email-masked]
Subject: [Speechsc] Concurrent requests in the same MRCP session scope

Can you please identify which from the following statements is true?
1. client MUST wait for a response before sending the next request in the
same MRCP session scope
or
2. client MAY send the next request without waiting for a response in the
same MRCP session scope

For example:

or

Thanks,
Arsen.