Subject: [splices] SPLICES IETF-80 meeting minutes and start of ML discussion

From: Simon Pietro Romano <[email-masked]>
Date: Thu, 14 Apr 2011 23:11:11 +0200

Dear all,

I went again through the SPLICES session recording in order to derive a  
"faithful" summary of the things we discussed. You'll find SPLICES 
minutes at the following URL: 
http://www.ietf.org/proceedings/80/minutes/splices.txt

I encourage all of you to go and have a look at them in order to:
1. notify me in case you find something which needs 
revision/re-interpretation;
2. check once more the main lines of discussion we had in Prague.

As decided at the end of the meeting, I am herein also asking you to 
formally express your opinion on the main topic we tackled at the 
meeting and which I am copying below:

"Do people believe that all the burden of this service should be on the 
side implementing the service itself?"

I remind you that the sense of the room at last IETF was clearly in 
favor of this solution, which means that we CANNOT touch the far end of 
the session when designing the SPLICES solution.

This said, I warmly invite all of the people who participated in the 
SPLICES session and who fruitfully contributed to the discussion to 
dedicate some of their cycles to SPLICES. I personally keep on thinking 
that we might do some good work here.
Finally, I encourage the authors of the documents we have been 
discussing so far to raise their voice and explicitly declare: (i) their 
willingness to proceed with the work they proposed; (ii) the main path 
forward they currently envisage in order to let the documents we 
discussed progress.

Let's try and come out of this limbo!

Cheers,

Simon

-- 
                             _\\|//_
                             ( O-O )
    ~~~~~~~~~~~~~~~~~~~~~~o00~~(_)~~00o~~~~~~~~~~~~~~~~~~~~~~~~
                     Simon Pietro Romano
               Universita' di Napoli Federico II
                  Computer Science Department
         Phone: +39 081 7683823 -- Fax: +39 081 7684219
                 e-mail: [email-masked]
           http://www.comics.unina.it/simonpietro.romano

     <<Molti mi dicono che lo scoraggiamento è l'alibi degli
    idioti. Ci rifletto un istante; e mi scoraggio>>. Magritte.
                          oooO
    ~~~~~~~~~~~~~~~~~~~~~~(   )~~ Oooo~~~~~~~~~~~~~~~~~~~~~~~~~
                           \ (    (   )
                            \_)    ) /
                                  (_/

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 14 Apr 2011 17:57:06 -0400

> http://www.ietf.org/proceedings/80/minutes/splices.txt

Wow! You have a promising future as a secretary taking dictation!

> 2. check once more the main lines of discussion we had in Prague.

Yup, its consistent with what I remember.

> side implementing the service itself?"

I think my position is clear: YES

---

From: Salvatore Loreto <[email-masked]>
Date: Fri, 15 Apr 2011 20:02:26 +0200

> side implementing the service itself?"
No,
I am interested in scenarios where both ends may be impacted by the 
implementation
of the new mechanism to be developed;
of course in the case an impact is required, I do think the design 
should consider a fall back for the case the other
peer does not implement it (e.g. a legacy UA)

> the session when designing the SPLICES solution.
yes, that was the sense of the room, but
any decision made at a face-to-face meeting must also gain consensus on 
the WG mailing list.

> forward they currently envisage in order to let the documents we
work of a loosely-coupled coordination scenario,
where no single device needs to remain in the session for its entire 
duration
and no single device needs to act as master...
is still something that I personally find interesting to be investigated

cheers
/Sal

-- 
Salvatore Loreto
www.sloreto.com

---

From: "Shekh-Yusef, Rifaat (Rifaat)" <[email-masked]>
Date: Fri, 15 Apr 2011 15:18:11 -0400

The SIP Action Referral team is committed to this work and planning on keep pushing it forward.
We are planning on creating a new document with a new SIP method, which seems to be the preferred choice for the SPLICES WG members that expressed their opinion on this issue.

I am personally interested in the core work of the SPLICES WG and will try to contribute to that work too.

Regards,
 Rifaat

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Simon Pietro Romano
> Sent: Thursday, April 14, 2011 5:11 PM
> To: [email-masked]
> Subject: [splices] SPLICES IETF-80 meeting minutes and start of ML discussion
> 
> Dear all,
> 
> _______________________________________________
> splices mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/splices

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 15 Apr 2011 20:23:19 -0400

Sal,

On 4/15/2011 2:02 PM, Salvatore Loreto wrote:
...
> peer does not implement it (e.g. a legacy UA)
...
> is still something that I personally find interesting to be investigated

I still don't *get* it.

Can you lay out a scenario/use case/example of what you have in mind?
- describe to moving parts
- what interactions they have to make the case work
- what capabilities each has/expects of others
- if parts of the coordination depend on special behavior of
   *people* rather than automata, explain that too.

Nothing complicated - just very high level.

	Thanks,
	Paul

---

From: Salvatore Loreto <[email-masked]>
Date: Wed, 27 Apr 2011 20:45:23 +0200

> Nothing complicated - just very high level.

what I have in mind is a scenario where
a user can make or answer a Call Using Two or more separate devices;
the devices can happen to be in the same network or in different area 
networks,
however I don't want any of the devices to be a single point of failure 
for the call:
that means that any device, involved in the side of the call
(the one is using different devices to handle the call), can go out of 
coverage, can restart etc.etc.
without having any impact on the call as such.

cheers
/Sal

-- 
Salvatore Loreto
www.sloreto.com

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 27 Apr 2011 18:43:34 -0400

inline

> without having any impact on the call as such.

Well, maybe a little more detail that that :-)

The above seems to be of the "and then magic happens" school.

I presume you have in mind that the *other* party manages two separate 
dialogs and coordinates them.

But who has the intelligence to establish the multi-device call?
- know that more than two devices should be used
- know how to reach the additional device
- know enough about the existing call to splice it in

	Thanks,
	Paul

P.S. I think a variant of the 3pcc approach we are discussing in another 
thread could potentially be used in your scenario too, if the main point 
is to manage where the failure point is.

For instance, if Alice and Bob are talking, and Alice wants to add in a 
local display device, it could send a REFER to the display device, 
asking it to send and INVITE/Join to Bob. This is not so straightforward 
- there are many details to work out. But I find it no less plausible 
than any other yet-to-be-devised scheme.