Subject: [spring] Discuss on draft-lin-sbfd-path-consistency-over-srv6-00

From: linchangwang <[email-masked]>
Date: Tue, 22 Mar 2022 02:28:44 +0000

Hi WG ,Chairs:

https://datatracker.ietf.org/doc/html/draft-lin-sbfd-path-consistency-over-srv6-00

This document describes a method to keep the forward path and
reverse path of S-BFD consistent when detecting SRv6 Policy.

There is no meeting for bfd in IETF-113,  we will present this draft in spring WG:
  March 25, 2022  12:30-14:30 Friday Afternoon session I (UTC+1)
  o S-BFD Path Consistency over SRv6[ 5 minutes ]

S-BFD could be used to monitor SRv6 Policy,  a session associated with a segment list.
Path inconsistency may cause false positive issue.
To the issue, The consistency of forward and reverse path of the same session should be guaranteed.
This draft describes how to realize the bidirectional path consistency of packet when monitoring SRv6 policy by S-BFD.

How to correlate bidirectional path?
1.  Correlating bidirectional path using Path Segment
    2.  Path Segment is defined to identify an SR path in [draft-ietf-spring-srv6-path-segment]
    3.  [draft-ietf-idr-sr-policy-path-segment] extends BGP SR Policy
    4.  Using path segment and reverse path segment to establish a mapping table
       Using the mapping table to get segment list by reverse Path segment

S-BFD Initiator procedure:
    1. Encapsulating the segment list associated with SBFD-session session to SRH
    2. Encapsulating the path segment of segment list in SRH, and set SRH.P-Flag

S-BFD reflector procedure:
    1. If SRH.P-flag is set, extracts the path segment (i.e. SID-Path-A1)of the forward path from SRH
    2.Get segment list of reverse path by the path segment as a reverse path segment from mapping table
    3. Encapsulating response packet with the reverse segment list

Any comments and suggestions are greatly welcome.

Best regards,
Changwang Lin

发件人: linchangwang (RD)
发送时间: 2022年3月2日 23:17
收件人: [email-masked]; chengweiqiang ([email-masked]); lihao (02566, RD); [email-masked]'
主题: Re: I-D Action: draft-lin-sbfd-path-consistency-over-srv6-00.txt

Hi WG,

We have just posted a new draft about sbfd path consistency over SRv6 in BFDWG.
https://datatracker.ietf.org/doc/html/draft-lin-sbfd-path-consistency-over-srv6-00

This document describes a method to keep the forward path and
reverse path of S-BFD consistent when detecting SRv6 Policy.

Any comments and suggestions are greatly welcome.

Best regards,
Changwang Lin

发件人: I-D-Announce [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2022年3月2日 19:33
收件人: [email-masked]
主题: I-D Action: draft-lin-sbfd-path-consistency-over-srv6-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.

        Title           : S-BFD Path Consistency over SRv6
        Authors         : Changwang Lin
                          Weiqiang Cheng
                          Wenying Jiang
Filename        : draft-lin-sbfd-path-consistency-over-srv6-00.txt
Pages           : 12
Date            : 2022-03-02

Abstract:
   Bidirectional Forwarding Detection (BFD) can be used to monitor
   paths between nodes. Seamless BFD (S-BFD) provides a simplified
   mechanism which is suitable for monitoring of paths that are setup
   dynamically and on a large scale network. In SRv6, when a headend
   use S-BFD to monitor the segment list/CPath of SRv6 Policy, the
   forward path of S-BFD packet is indicated by segment list, the
   reverse path of BFD packet is via the shortest path from the
   reflector back to the initiator (headend) as determined by routing.
   The forward path and reverse path of S-BFD packet are likely
   inconsistent going through different intermediate nodes or links.
   This document describes a method to keep the forward path and
   reverse path of S-BFD consistent when detecting SRv6 Policy.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-lin-sbfd-path-consistency-over-srv6/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-lin-sbfd-path-consistency-over-srv6-00

Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
-------------------------------------------------------------------------------------------------------------------------------------
本邮件及其附件含有新华三集团的保密信息，仅限于发送给上面地址中列出
的个人或群组。禁止任何其他人以任何形式使用（包括但不限于全部或部分地泄露、复制、
或散发）本邮件中的信息。如果您错收了本邮件，请您立即电话或邮件通知发件人并删除本
邮件！
This e-mail and its attachments contain confidential information from New H3C, which is
intended only for the person or entity whose address is listed above. Any use of the
information contained herein in any way (including, but not limited to, total or partial
disclosure, reproduction, or dissemination) by persons other than the intended
recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender
by phone or email immediately and delete it!

---

From: Lihao <[email-masked]>
Date: Fri, 25 Mar 2022 01:33:45 +0000

Hi Reshad

   thanks for your comments.

  Yes,  for the decription of S-BFD echo, it's a writing mistake

      We will update the draft to control packet.

Best Wishes

Lihao

From: Rtg-bfd [mailto:[email-masked]] On Behalf Of Reshad Rahman
Sent: Friday, March 25, 2022 9:08 AM
To: [email-masked]; [email-masked]; linchangwang (RD) <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: Discuss on draft-lin-sbfd-path-consistency-over-srv6-00

Hi,

Thank you for keeping the BFD WG in the loop. I don't have any comments on the correlation, will leave that to SPRING.

My only question for now is regarding the use of S-BFD echo packets. RFC7880 recommends to also use S-BFD control packets when using S-BFD echo because a transit node could u-turn the packet. And if the packet is being delivered anyway to the control plane (as per 4.2), control packets should be used instead.

Regards,
Reshad.

On Monday, March 21, 2022, 10:32:00 PM EDT, linchangwang <[email-masked]<mailto:[email-masked]>> wrote:

Hi WG ,Chairs:

Best regards,
Changwang Lin

发件人: linchangwang (RD)
发送时间: 2022年3月2日 23:17
收件人: [email-masked]<mailto:[email-masked]>; chengweiqiang ([email-masked]<mailto:[email-masked]>); lihao (02566, RD); [email-masked]<mailto:[email-masked]>'
主题: Re: I-D Action: draft-lin-sbfd-path-consistency-over-srv6-00.txt

Hi WG,

Best regards,
Changwang Lin

发件人: I-D-Announce [mailto:[email-masked]<mailto:[email-masked]>] 代表 [email-masked]<mailto:[email-masked]>
发送时间: 2022年3月2日 19:33
收件人: [email-masked]<mailto:[email-masked]>
主题: I-D Action: draft-lin-sbfd-path-consistency-over-srv6-00.txt

Abstract:

[email-masked]<mailto:[email-masked]>

---

From: Reshad Rahman <[email-masked]>
Date: Fri, 25 Mar 2022 01:08:08 +0000 (UTC)

Hi,
Thank you for keeping the BFD WG in the loop. I don't have any comments on the correlation, will leave that to SPRING.
My only question for now is regarding the use of S-BFD echo packets. RFC7880 recommends to also use S-BFD control packets when using S-BFD echo because a transit node could u-turn the packet. And if the packet is being delivered anyway to the control plane (as per 4.2), control packets should be used instead.
Regards,Reshad.   
    On Monday, March 21, 2022, 10:32:00 PM EDT, linchangwang <[email-masked]> wrote:  

Hi WG ,Chairs:

Best regards,
Changwang Lin

发件人: linchangwang (RD)
发送时间: 2022年3月2日 23:17

Hi WG,

Best regards,
Changwang Lin

Abstract: