Subject: [spring] WG adoption for draft-boutros-spring-elan-services-over-sr-00

From: "Boutros, Sami" <[email-masked]>
Date: Mon, 14 Mar 2022 17:22:38 +0000

Dear WG Chairs,

The authors would like to request a WG adoption for this draft, the draft was presented at last IETF.

We could present the draft at this IETF too, if you folks like.

Thanks,

Sami

---

From: <[email-masked]>
Date: Wed, 16 Mar 2022 13:40:31 +0000

[+bess chairs]

Dear Sami, authors,

SPRING and BESS chairs believe this work would be better addressed in the BESS WG.

Thanks,
Regards,
--Bruno, Jim, Joel

Orange Restricted
From: Boutros, Sami <[email-masked]>
Sent: Monday, March 14, 2022 6:23 PM
To: DECRAENE Bruno INNOV/NET <[email-masked]>; James Guichard <[email-masked]>; Joel Halpern Direct <[email-masked]>
Cc: [email-masked]
Subject: WG adoption for draft-boutros-spring-elan-services-over-sr-00

Dear WG Chairs,

Thanks,

Sami

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Boutros, Sami" <[email-masked]>
Date: Fri, 25 Mar 2022 12:51:51 +0000

Hi Bruno,

The main salient points in this draft are about:

  *   Defining a service SRGB for services.
  *   Getting rid of overlay convergence and using underlay anycast SID convergence to converge all services riding on this anycast SID.
  *   Use of an underlay node/anycast SID to learn mac against in Dataplane. (Keep in mind we are not proposing any change to data plane MAC learning mechanisms like aging, move, security, etc…) But rather how with the SR encap we will learn the MAC against the source SID under the service SID in the SR encap. NVO3 defining VxLAN, Geneve, etc.. where MAC is learned against Source IP address in the encap didn’t go to discuss this in BESS.

Are you saying we should discuss the above in the BESS working group?

We are not making any relevant changes to the ELAN service, it is true we would need to define a new BGP message to auto-discover the services that will apply to BESS and we will have a draft on that to discuss in BESS.

Thanks,

Sami
From: [email-masked] <[email-masked]>
Date: Wednesday, March 16, 2022 at 2:40 PM
To: Boutros, Sami <[email-masked]>
Cc: [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, James Guichard <[email-masked]>, Joel Halpern Direct <[email-masked]>
Subject: [**EXTERNAL**] RE: WG adoption for draft-boutros-spring-elan-services-over-sr-00
[+bess chairs]

Dear Sami, authors,

Thanks,
Regards,
--Bruno, Jim, Joel

Orange Restricted

Dear WG Chairs,

Thanks,

Sami

Thank you.

---

From: <[email-masked]>
Date: Mon, 28 Mar 2022 10:07:47 +0000

Hi Sami,

< Abstract

   This document proposes a new approach for realizing Ethernet LAN
   (ELAN) services >

BESS : BGP Enabled Services  https://datatracker.ietf.org/doc/charter-ietf-bess/
SPRING : Source Packet Routing in Networking https://datatracker.ietf.org/doc/charter-ietf-spring/

We could also dig a bit more, just looking at the ToC:

4<https://datatracker.ietf.org/doc/html/draft-boutros-spring-elan-services-over-sr-00.txt#section-4>.  Control Plane Behavior  . . . . . . . . . . . . . . . . . . .   5<https://datatracker.ietf.org/doc/html/draft-boutros-spring-elan-services-over-sr-00.txt#page-5>

     4.1<https://datatracker.ietf.org/doc/html/draft-boutros-spring-elan-services-over-sr-00.txt#section-4.1>.  Service discovery . . . . . . . . . . . . . . . . . . . .   5<https://datatracker.ietf.org/doc/html/draft-boutros-spring-elan-services-over-sr-00.txt#page-5>

     4.2<https://datatracker.ietf.org/doc/html/draft-boutros-spring-elan-services-over-sr-00.txt#section-4.2>.  All-Active Service Redundancy . . . . . . . . . . . . . .   6<https://datatracker.ietf.org/doc/html/draft-boutros-spring-elan-services-over-sr-00.txt#page-6>

     4.3<https://datatracker.ietf.org/doc/html/draft-boutros-spring-elan-services-over-sr-00.txt#section-4.3>.  Mass service withdrawal . . . . . . . . . . . . . . . . .   6<https://datatracker.ietf.org/doc/html/draft-boutros-spring-elan-services-over-sr-00.txt#page-6>

     4.4<https://datatracker.ietf.org/doc/html/draft-boutros-spring-elan-services-over-sr-00.txt#section-4.4>.  E-Tree Support  . . . . . . . . . . . . . . . . . . . . .   6<https://datatracker.ietf.org/doc/html/draft-boutros-spring-elan-services-over-sr-00.txt#page-6>

   5<https://datatracker.ietf.org/doc/html/draft-boutros-spring-elan-services-over-sr-00.txt#section-5>.  Data Plane Behavior . . . . . . . . . . . . . . . . . . . . .   6<https://datatracker.ietf.org/doc/html/draft-boutros-spring-elan-services-over-sr-00.txt#page-6>

     5.1<https://datatracker.ietf.org/doc/html/draft-boutros-spring-elan-services-over-sr-00.txt#section-5.1>.  Unicast Traffic . . . . . . . . . . . . . . . . . . . . .   7<https://datatracker.ietf.org/doc/html/draft-boutros-spring-elan-services-over-sr-00.txt#page-7>

     5.2<https://datatracker.ietf.org/doc/html/draft-boutros-spring-elan-services-over-sr-00.txt#section-5.2>.  BUM Traffic . . . . . . . . . . . . . . . . . . . . . . .   8<https://datatracker.ietf.org/doc/html/draft-boutros-spring-elan-services-over-sr-00.txt#page-8>

     5.3<https://datatracker.ietf.org/doc/html/draft-boutros-spring-elan-services-over-sr-00.txt#section-5.3>.  Data Plane MAC learning . . . . . . . . . . . . . . . . .   8<https://datatracker.ietf.org/doc/html/draft-boutros-spring-elan-services-over-sr-00.txt#page-8>

       5.3.1<https://datatracker.ietf.org/doc/html/draft-boutros-spring-elan-services-over-sr-00.txt#section-5.3.1>.  Single Home CE  . . . . . . . . . . . . . . . . . . .   9<https://datatracker.ietf.org/doc/html/draft-boutros-spring-elan-services-over-sr-00.txt#page-9>

       5.3.2<https://datatracker.ietf.org/doc/html/draft-boutros-spring-elan-services-over-sr-00.txt#section-5.3.2>.  Multi-Home CE . . . . . . . . . . . . . . . . . . . .   9<https://datatracker.ietf.org/doc/html/draft-boutros-spring-elan-services-over-sr-00.txt#page-9>

     5.4<https://datatracker.ietf.org/doc/html/draft-boutros-spring-elan-services-over-sr-00.txt#section-5.4>.  ARP suppression . . . . . . . . . . . . . . . . . . . . .  10<https://datatracker.ietf.org/doc/html/draft-boutros-spring-elan-services-over-sr-00.txt#page-10>

     5.5<https://datatracker.ietf.org/doc/html/draft-boutros-spring-elan-services-over-sr-00.txt#section-5.5>.  Distributed Anycast Gateway . . . . . . . . . . . . . . .  10<https://datatracker.ietf.org/doc/html/draft-boutros-spring-elan-services-over-sr-00.txt#page-10>

     5.6<https://datatracker.ietf.org/doc/html/draft-boutros-spring-elan-services-over-sr-00.txt#section-5.6>.  Multi-pathing . . . . . . . . . . . . . . . . . . . . . .  10<https://datatracker.ietf.org/doc/html/draft-boutros-spring-elan-services-over-sr-00.txt#page-10>

     5.7<https://datatracker.ietf.org/doc/html/draft-boutros-spring-elan-services-over-sr-00.txt#section-5.7>.  E-Tree Support  . . . . . . . . . . . . . . . . . . . . .  11<https://datatracker.ietf.org/doc/html/draft-boutros-spring-elan-services-over-sr-00.txt#page-11>

It looks to me that the above is primarily about VPN overlay service, rather than source routing in the underlay.

So yes, to re-iterate, at this point, SPRING and BESS chairs believe this work would be better addressed in the BESS WG.

Thanks,
--Bruno

Orange Restricted
From: Boutros, Sami <[email-masked]>
Sent: Friday, March 25, 2022 1:52 PM
To: DECRAENE Bruno INNOV/NET <[email-masked]>
Cc: [email-masked]; [email-masked]; James Guichard <[email-masked]>; Joel Halpern Direct <[email-masked]>
Subject: Re: WG adoption for draft-boutros-spring-elan-services-over-sr-00

Hi Bruno,

  *   Defining a service SRGB for services.
  *   Getting rid of overlay convergence and using underlay anycast SID convergence to converge all services riding on this anycast SID.
  *   Use of an underlay node/anycast SID to learn mac against in Dataplane. (Keep in mind we are not proposing any change to data plane MAC learning mechanisms like aging, move, security, etc...) But rather how with the SR encap we will learn the MAC against the source SID under the service SID in the SR encap. NVO3 defining VxLAN, Geneve, etc.. where MAC is learned against Source IP address in the encap didn't go to discuss this in BESS.

Thanks,

Sami
From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, March 16, 2022 at 2:40 PM
To: Boutros, Sami <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, James Guichard <[email-masked]<mailto:[email-masked]>>, Joel Halpern Direct <[email-masked]<mailto:[email-masked]>>
Subject: [**EXTERNAL**] RE: WG adoption for draft-boutros-spring-elan-services-over-sr-00
[+bess chairs]

Dear Sami, authors,

Thanks,
Regards,
--Bruno, Jim, Joel

Orange Restricted
From: Boutros, Sami <[email-masked]<mailto:[email-masked]>>
Sent: Monday, March 14, 2022 6:23 PM
To: DECRAENE Bruno INNOV/NET <[email-masked]<mailto:[email-masked]>>; James Guichard <[email-masked]<mailto:[email-masked]>>; Joel Halpern Direct <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: WG adoption for draft-boutros-spring-elan-services-over-sr-00

Dear WG Chairs,

Thanks,

Sami

Thank you.