Subject: Re: [spring] Comments on draft-bocci-mpls-miad-adi-requirements

From: "Bocci, Matthew (Nokia - GB)" <[email-masked]>
Date: Thu, 3 Mar 2022 11:58:43 +0000

Hi Greg

Thank you for your detailed review and comments. We have tried to address these in the updated draft that we just posted.

In answer to your question below about whether the ancillary data needs a common format, I agree that it at least needs a common header format.

Regards

Matthew

From: Greg Mirsky <[email-masked]>
Date: Tuesday, 15 February 2022 at 20:18
To: [email-masked] <[email-masked]>
Cc: mpls <[email-masked]>, spring <[email-masked]>, DetNet WG <[email-masked]>
Subject: Comments on draft-bocci-mpls-miad-adi-requirements
Hi Stewart and Matthew,
thank you for organizing this document in a very clear and concise manner. I enjoyed reading it.
Attached, please find a copy of the draft with my notes, comments, and suggestions. The most important, in my view, the question I have Should we add the requirement to have a common format for ancillary data defined?

Looking forward to your feedback.

Regards,
Greg

---

From: Greg Mirsky <[email-masked]>
Date: Thu, 3 Mar 2022 08:08:04 -0800

Hi Matthew,
thank you for the heads-up. I'll review the updated draft and be back with
my notes.

Regards,
Greg

On Thu, Mar 3, 2022 at 3:58 AM Bocci, Matthew (Nokia - GB) <
[email-masked]> wrote:

> Hi Greg
>
>
>
> Thank you for your detailed review and comments. We have tried to address
> these in the updated draft that we just posted.
>
>
>
> In answer to your question below about whether the ancillary data needs a
> common format, I agree that it at least needs a common header format.
>
>
>
> Regards
>
>
>
> Matthew
>
>
>
>
>
> *From: *Greg Mirsky <[email-masked]>
> *Date: *Tuesday, 15 February 2022 at 20:18
> *To: [email-masked] <
> [email-masked]>
> *Cc: *mpls <[email-masked]>, spring <[email-masked]>, DetNet WG <
> [email-masked]>
> *Subject: *Comments on draft-bocci-mpls-miad-adi-requirements
>
> Hi Stewart and Matthew,
>
> Attached, please find a copy of the draft with my notes, comments, and
> suggestions. The most important, in my view, the question I have Should we
> add the requirement to have a common format for ancillary data defined?
>
>
>

---

From: Greg Mirsky <[email-masked]>
Date: Thu, 3 Mar 2022 16:15:14 -0800

Hi Matthew and Stewart,
thank you for your work addressing my comments; much appreciated. I have
several follow-up questions and comments to the new version of the draft,
mostly to the new Section 3.1.2
<https://datatracker.ietf.org/doc/html/draft-bocci-mpls-miad-adi-requirements#section-3.1.2>
:

   - I may suggest an editorial update to bullet 2

OLD TEXT:
   2.   A common mechanism for ancillary data MUST be defined so that a
        node receiving the ancillary data can determine whether to
        process, ignore or discard it.
NEW TEXT:
   2.   A common mechanism for ancillary data MUST be defined so that a
        node receiving the ancillary data can act according to the local
policies.

   - bullet 4 receives two notes:
      - I think it should be a requirement, not a recommendation
      - I think that an LSR must not be able to insert any ancillary data.
      Only ingress LER inserts data.
   - it would be good if bullet 6 can be split into two
   - RE: bullet 7, I don't think that MPLS is the appropriate layer to
   guarantee in-order delivery. Should that be left to an application?
   - it appears that bullet 8 is specific to the PSD case. If that is the
   case, should it refer to the BoS instead of "as close to the label stack as
   possible"?
   - I think that having a requirement for the use of a common ancillary
   data header will help the discussion.

Couple nits:

   - "an/or" -> "and/or"
   - s/lath/path/

Regards,
Greg